Apply upstream patch to catch up to highlight 4.0 API change. Bump

PKGREVISION.
This commit is contained in:
schmonz 2021-05-14 06:50:16 +00:00
parent ecc7e31be9
commit edc32dcd6b
3 changed files with 25 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.172 2020/12/04 20:45:48 nia Exp $
# $NetBSD: Makefile,v 1.173 2021/05/14 06:50:16 schmonz Exp $
DISTNAME= ikiwiki_3.20200202.3.orig
PKGNAME= ${DISTNAME:S/_/-/:S/.orig//}
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= www textproc
MASTER_SITES= ${MASTER_SITE_DEBIAN:=pool/main/i/ikiwiki/}
EXTRACT_SUFX= .tar.xz

View file

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.137 2020/02/13 19:03:57 schmonz Exp $
$NetBSD: distinfo,v 1.138 2021/05/14 06:50:16 schmonz Exp $
SHA1 (ikiwiki_3.20200202.3.orig.tar.xz) = abbb8ca6611cffe859e5ec323f61bc02377dcb97
RMD160 (ikiwiki_3.20200202.3.orig.tar.xz) = 3062c04b31e0ca6aea30d47405a6d47eb80127dc
SHA512 (ikiwiki_3.20200202.3.orig.tar.xz) = a1d89ccc0d02cddb3ef53c4c4a4a3349139d558fd4eb418263551a48cb635ed29ef430f8276ef6b42486a9232706908752e15e88590e919db6665e1a8844a4e5
Size (ikiwiki_3.20200202.3.orig.tar.xz) = 2689636 bytes
SHA1 (patch-IkiWiki_Plugin_highlight.pm) = 703510899170218bf72af6794fdb10f7f29727cb
SHA1 (patch-Makefile.PL) = 44324917c22ec3cd2aa216439e2ae5a3dc2f9787
SHA1 (patch-ikiwiki-mass-rebuild) = eb03ac0ec83078be593f76968f5a1f9080ea50b9
SHA1 (patch-po_Makefile) = 468b500da41c606c6af6b65c8080d692acb69336

View file

@ -0,0 +1,21 @@
$NetBSD: patch-IkiWiki_Plugin_highlight.pm,v 1.3 2021/05/14 06:50:16 schmonz Exp $
Apply upstream patch 9ea3f9d to catch up to highlight 4.0 API change.
--- IkiWiki/Plugin/highlight.pm.orig 2020-02-02 20:23:50.000000000 +0000
+++ IkiWiki/Plugin/highlight.pm
@@ -54,7 +54,13 @@ sub checkconfig () {
eval q{use highlight};
if (highlight::DataDir->can('new')) {
$data_dir=new highlight::DataDir();
- $data_dir->searchDataDir("");
+ if ( $data_dir->can('initSearchDirectories') ) {
+ # 4.0+
+ $data_dir -> initSearchDirectories("");
+ } else {
+ # pre-4.0
+ $data_dir -> searchDataDir("");
+ }
} else {
$data_dir=undef;
}