py-Pillow: updated to 6.2.1

6.2.1:
- This is the last Pillow release to support Python 2.7
- Add support for Python 3.8
This commit is contained in:
adam 2019-10-22 18:45:02 +00:00
parent 1207c5613d
commit edc5d4c12f
3 changed files with 11 additions and 11 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.46 2019/10/02 07:55:41 adam Exp $
# $NetBSD: Makefile,v 1.47 2019/10/22 18:45:02 adam Exp $
DISTNAME= Pillow-6.2.0
DISTNAME= Pillow-6.2.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_PYPI:=P/Pillow/}

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.39 2019/10/02 07:55:41 adam Exp $
$NetBSD: distinfo,v 1.40 2019/10/22 18:45:02 adam Exp $
SHA1 (Pillow-6.2.0.tar.gz) = 7278bf3e78e5ac3cc1d3d1e47ec610949d6618b3
RMD160 (Pillow-6.2.0.tar.gz) = adadeaf8395fbf08ad534ebe1f8da30892f5e31a
SHA512 (Pillow-6.2.0.tar.gz) = 6eeb51d764c85a9b1f4eb0a59bbff41541852d5e2988c0e32b03acb56010b7d398f5761daaa56731bde278e52a551b44fab5b662988e096e8fd53e5d15d4e083
Size (Pillow-6.2.0.tar.gz) = 37368081 bytes
SHA1 (patch-setup.py) = 0608fa0c0afc4b53320bbc9eb0c8e8428244c1b2
SHA1 (Pillow-6.2.1.tar.gz) = efb43a7be73f13cd300fa30f3f21634cfa3d6056
RMD160 (Pillow-6.2.1.tar.gz) = b6a0743f45072e5000f4d985dc1274d32bb7a40b
SHA512 (Pillow-6.2.1.tar.gz) = 757bfdab2ba418195e96e696d2d111de3b38b6bafe4f6f94012f024f59c9bc8542fdab54f643eaf7b2867a9214db806e72eecbdd636bfceb55b47d3164f643ec
Size (Pillow-6.2.1.tar.gz) = 37673162 bytes
SHA1 (patch-setup.py) = 08af410697c6d0e01cf2c2b4955b8707a1807fdd

View file

@ -1,8 +1,8 @@
$NetBSD: patch-setup.py,v 1.20 2019/10/02 07:55:41 adam Exp $
$NetBSD: patch-setup.py,v 1.21 2019/10/22 18:45:03 adam Exp $
Disable mp_compile hack; it has problems with native parallel building.
--- setup.py.orig 2019-10-01 09:41:46.000000000 +0000
--- setup.py.orig 2019-10-20 09:47:22.000000000 +0000
+++ setup.py
@@ -22,7 +22,6 @@ from setuptools import Extension, setup
@ -10,7 +10,7 @@ Disable mp_compile hack; it has problems with native parallel building.
# comment this out to disable multi threaded builds.
-import mp_compile
if sys.platform == "win32" and sys.version_info >= (3, 8):
if sys.platform == "win32" and sys.version_info >= (3, 9):
warnings.warn(
@@ -332,12 +331,6 @@ class pil_build_ext(build_ext):
if self.debug: