alsa-lib: update to 1.2.11.

Core

    Release v1.2.11
    src/Versions.in: Add guards for pcm and timer syms
    src/Versions.in: Add guards for opt. alisp symbols
    configure.ac: Update AC_OUTPUT() function
    configure: bumb version to 1.2.11pre1 (for aplay/alsa-utils)
    seq: Fix typos in symbol version definitions
    global.h: move __STRING() macro outside !PIC ifdef block
    gitcompile: Add static build

Control API

    control: remap - fix the endless loop in remap_numid_child_new()
    reshuffle included files to include config.h as first - v2
    control.h: Fix ump header file detection

Mixer API

    mixer: simple: Support dB TLVs for CTL_SINGLE controls

Mixer Abstraction API

    headers: avoid c++ keyword

PCM API

    pcm: document interaction of drain silence and sw silence
    pcm: route plugin: allocate temporary array on stack only one time
    pcm: sofvol plugin: fix signed overflow
    pcm: documentation improvement mostly regarding samples and frames
    pcm: handle start_treshold in snd_pcm_write_areas more robustly
    pcm: plug plugin - fast_ops may be changed when sw_params are set
    pcm: fix the documentation for snd_pcm_poll_descriptors again
    pcm: clarify documentation of poll descriptor usage
    pcm: clarify documentation on some hw params related functions
    pcm: Fix incompatible-pointer-type warnings
    pcm: Add MSBITS subformat options
    pcm: Introduce snd_pcm_subformat_value()
    pcm: Fix segfault with 32bit libs

RawMidi API

    reshuffle included files to include config.h as first - v2

Sequencer API

    seq: Add snd_seq_ump_ev_clear()
    seq: Check protocol compatibility with the current version
    seq: Simplify snd_seq_extract_output()
    seq: Clear UMP event flag for legacy apps
    seq: Fix invalid sanity-check in snd_seq_set_input_buffer_size()
    reshuffle included files to include config.h as first - v2

Topology API

    topology: fix Versions file
    add back Versions source file to EXTRA_DIST to fix packaging
    topology: separate Versions linker script

/src/Makefile.am

    add back Versions source file to EXTRA_DIST to fix packaging
    src/Versions.in: Add guards for pcm and timer syms
    src/Versions.in: Add guards for opt. alisp symbols

ALSA Server

    aserver: fix buffer overwriting

Configuration

    conf: pcm: Set C-Media USB 7.1 sound card (ICUSBAUDIO7D) to six_channel for surround40

Filename helpers

    reshuffle included files to include config.h as first - v2

Kernel Headers

    pcm: Add MSBITS subformat options
This commit is contained in:
wiz 2024-02-21 08:58:00 +00:00
parent 5a570364cd
commit eded836ed1
6 changed files with 24 additions and 49 deletions

View File

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.31 2023/11/23 16:15:04 ryoon Exp $
# $NetBSD: Makefile,v 1.32 2024/02/21 08:58:00 wiz Exp $
DISTNAME= alsa-lib-1.2.10
DISTNAME= alsa-lib-1.2.11
CATEGORIES= audio
MASTER_SITES= ftp://ftp.alsa-project.org/pub/lib/
EXTRACT_SUFX= .tar.bz2

View File

@ -1,17 +1,17 @@
$NetBSD: distinfo,v 1.40 2023/12/11 15:41:35 jperkin Exp $
$NetBSD: distinfo,v 1.41 2024/02/21 08:58:00 wiz Exp $
BLAKE2s (alsa-lib-1.2.10.tar.bz2) = 25ee95e555f6dd9f790eefc6da792b0744f123a281327dc70d20cc3cffe5d80b
SHA512 (alsa-lib-1.2.10.tar.bz2) = 4ccbd1dc5a612044571c26290923009e4c3f7959b30a5d0bed47daa68bbefaff9059c4f0fa3bc16f22c1eed2d36f079139369f40243da5921ae4de02a4541939
Size (alsa-lib-1.2.10.tar.bz2) = 1107007 bytes
SHA1 (patch-ad) = 626bee697949f26cdaff2b0bea43d809f4a3c530
SHA1 (patch-ae) = e652f7c0230d6a22042fedd0f7c0189f68dc0984
BLAKE2s (alsa-lib-1.2.11.tar.bz2) = 5069838ba655f6d5b3afd58135aaad70467292df5d6f0f91e90f932efb8a22e3
SHA512 (alsa-lib-1.2.11.tar.bz2) = 7bf2c541dff5262c0302a1c716ca10cdb5105f4e0ad48f3341c3c7e975b0c3ea835a298a05974c3e216a85912c368d8025ba3cdda3ff04a7683133ce5b2a286d
Size (alsa-lib-1.2.11.tar.bz2) = 1107150 bytes
SHA1 (patch-ad) = 0e9bc7848a61b3a6654a9fe25943970404d71052
SHA1 (patch-ae) = f7a0b5b287c93f3dfcd2b47d4880872ae6f0e9a6
SHA1 (patch-af) = 257b06f10616c04c2724e30777b027e5e7e443f9
SHA1 (patch-ah) = 37079a0b99fba9bd16b2318c9a17359d9c4edb54
SHA1 (patch-aq) = 29fc896b2acad44e5fa9619aca1df5dddd76fa5e
SHA1 (patch-bg) = b726769272dd214e67f2407ed5a0199189540557
SHA1 (patch-bi) = 4c60911fe949b858abca9ebecdefc794b008b1c6
SHA1 (patch-bj) = 59f94d9b54386aa7d1a7edd7ec329211184a8c94
SHA1 (patch-configure.ac) = cc034d07eab13caa5ff8748e8eea37ae9dd367f5
SHA1 (patch-configure.ac) = bdeaecdd1f0f603b9ace14d8fff5d57cb0339887
SHA1 (patch-include_error.h) = 9e92d4a51badda1d46305d1e5e36b8197788aa89
SHA1 (patch-include_output.h) = 0a073b53c40293aa7cfa250586c087084002eefe
SHA1 (patch-include_sound_uapi_asound.h) = 06170ff7b39112bae60ef7d39b858ed8068347a4
@ -19,7 +19,7 @@ SHA1 (patch-src_conf.c) = 6f8887c2831de6fb2d58b098e6894278ee145560
SHA1 (patch-src_conf_alsa.conf) = 1a3d2a0ce15b2f903095bc7103c7765fcd6270c0
SHA1 (patch-src_control_control__hw.c) = 07cfe3abe586b32f6b989403cd162599da07e865
SHA1 (patch-src_pcm_pcm__mmap.c) = bf5b59af96110bf8f51269b86bcf60ec0e23a06e
SHA1 (patch-src_seq_seq__midi__event.c) = 0201b01b44d6c91716ad1ce5958badadf0cdb264
SHA1 (patch-src_seq_seq__midi__event.c) = c5a673a14c23aeefc512f04ac550b906fa4f7d30
SHA1 (patch-src_shmarea.c) = 1a3b508fafe3ef7fda76620ed1c06035f32e9096
SHA1 (patch-src_ucm_main.c) = 1e12f2d8734a98aecd7bbea2d9d80d27d45c1173
SHA1 (patch-src_ucm_parser.c) = cf53012d24ff7df16800be4b0e6287ae0c3b0799

View File

@ -1,9 +1,8 @@
$NetBSD: patch-ad,v 1.8 2023/12/11 15:41:35 jperkin Exp $
$NetBSD: patch-ad,v 1.9 2024/02/21 08:58:00 wiz Exp $
SunOS needs alloca.h.
__STRING() is used in more places than just !PIC.
--- include/global.h.orig 2023-09-01 15:35:48.000000000 +0000
--- include/global.h.orig 2024-01-29 16:16:07.000000000 +0000
+++ include/global.h
@@ -30,6 +30,13 @@
@ -19,27 +18,3 @@ __STRING() is used in more places than just !PIC.
#ifdef __cplusplus
extern "C" {
@@ -51,6 +58,11 @@ const char *snd_asoundlib_version(void);
#define ATTRIBUTE_UNUSED __attribute__ ((__unused__))
#endif
+#ifndef __STRING
+/** \brief Return 'x' argument as string */
+#define __STRING(x) #x
+#endif
+
#ifdef PIC /* dynamic build */
/** \hideinitializer \brief Helper macro for #SND_DLSYM_BUILD_VERSION. */
@@ -71,11 +83,6 @@ struct snd_dlsym_link {
extern struct snd_dlsym_link *snd_dlsym_start;
-#ifndef __STRING
-/** \brief Return 'x' argument as string */
-#define __STRING(x) #x
-#endif
-
/** \hideinitializer \brief Helper macro for #SND_DLSYM_BUILD_VERSION. */
#define __SND_DLSYM_VERSION(prefix, name, version) _ ## prefix ## name ## version
/**

View File

@ -1,9 +1,9 @@
$NetBSD: patch-ae,v 1.11 2023/11/23 16:19:41 wiz Exp $
$NetBSD: patch-ae,v 1.12 2024/02/21 08:58:00 wiz Exp $
- Don't assert GNU ld on Solaris, where it might not be true.
- Add endian compat.
--- include/local.h.orig 2023-09-01 15:35:48.000000000 +0000
--- include/local.h.orig 2024-01-29 16:16:07.000000000 +0000
+++ include/local.h
@@ -34,6 +34,15 @@
#include <endian.h>

View File

@ -1,10 +1,10 @@
$NetBSD: patch-configure.ac,v 1.3 2021/05/12 14:12:13 ryoon Exp $
$NetBSD: patch-configure.ac,v 1.4 2024/02/21 08:58:01 wiz Exp $
--- configure.ac.orig 2020-06-29 10:51:08.000000000 +0000
--- configure.ac.orig 2024-01-29 16:16:07.000000000 +0000
+++ configure.ac
@@ -732,6 +732,15 @@ AC_OUTPUT(Makefile doc/Makefile doc/pict
test/Makefile test/lsb/Makefile \
utils/Makefile utils/alsa-lib.spec utils/alsa.pc utils/alsa-topology.pc)
@@ -766,6 +766,15 @@ AC_CONFIG_FILES(Makefile doc/Makefile do
AC_OUTPUT()
+case $host_os in
+ netbsd*|freebsd*|dragonfly*)

View File

@ -1,13 +1,13 @@
$NetBSD: patch-src_seq_seq__midi__event.c,v 1.3 2023/11/23 16:15:04 ryoon Exp $
$NetBSD: patch-src_seq_seq__midi__event.c,v 1.4 2024/02/21 08:58:01 wiz Exp $
--- src/seq/seq_midi_event.c.orig 2023-05-04 07:16:16.000000000 +0000
--- src/seq/seq_midi_event.c.orig 2024-01-29 16:16:07.000000000 +0000
+++ src/seq/seq_midi_event.c
@@ -30,6 +30,8 @@
@@ -31,6 +31,8 @@
#include "local.h"
#if HAVE_MALLOC_H
#include <malloc.h>
+#else
+#include <stdlib.h>
#endif
#include "local.h"
#ifndef DOC_HIDDEN