Update to 4.0.24, which fixes the vulnerability reported in:
http://www.k-otik.com/english/advisories/2005/0252 See http://dev.mysql.com/doc/mysql/en/news-4-0-24.html Bumped BUILDLINK_RECOMMENDED to 4.0.24.
This commit is contained in:
parent
9655dbc5f7
commit
ee1d9c57a0
6 changed files with 12 additions and 131 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile.common,v 1.38 2005/01/20 14:17:15 xtraeme Exp $
|
||||
# $NetBSD: Makefile.common,v 1.39 2005/03/15 15:43:28 xtraeme Exp $
|
||||
|
||||
DISTNAME= mysql-4.0.23a
|
||||
DISTNAME= mysql-4.0.24
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://mirrors.sunsite.dk/mysql/Downloads/MySQL-4.0/ \
|
||||
ftp://sunsite.dk/mirrors/mysql/Downloads/MySQL-4.0/ \
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.11 2005/01/20 14:17:15 xtraeme Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.12 2005/03/15 15:43:28 xtraeme Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
MYSQL_CLIENT_BUILDLINK3_MK:= ${MYSQL_CLIENT_BUILDLINK3_MK}+
|
||||
|
@ -12,7 +12,7 @@ BUILDLINK_PACKAGES+= mysql-client
|
|||
|
||||
.if !empty(MYSQL_CLIENT_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.mysql-client+= mysql-client>=4.0.18nb1
|
||||
BUILDLINK_RECOMMENDED.mysql-client?= mysql-client>=4.0.23a
|
||||
BUILDLINK_RECOMMENDED.mysql-client?= mysql-client>=4.0.24
|
||||
BUILDLINK_PKGSRCDIR.mysql-client?= ../../databases/mysql-client
|
||||
BUILDLINK_LIBDIRS.mysql-client?= lib/mysql
|
||||
.endif # MYSQL_CLIENT_BUILDLINK3_MK
|
||||
|
|
|
@ -1,11 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.17 2005/02/23 16:33:06 agc Exp $
|
||||
$NetBSD: distinfo,v 1.18 2005/03/15 15:43:28 xtraeme Exp $
|
||||
|
||||
SHA1 (mysql-4.0.23a.tar.gz) = b85f6ace8e120da34aef2a8ee26b5751de69b97b
|
||||
RMD160 (mysql-4.0.23a.tar.gz) = 10196d2990fff535a87d7ce68f3abea5d51abaea
|
||||
Size (mysql-4.0.23a.tar.gz) = 16735725 bytes
|
||||
SHA1 (mysql-4.0.24.tar.gz) = 523de9f374d4e8c08d5e6520ced05a32dfa2d35d
|
||||
RMD160 (mysql-4.0.24.tar.gz) = 595a162be1bc4e09eab7bc751c9c02214ba41ed7
|
||||
Size (mysql-4.0.24.tar.gz) = 16885399 bytes
|
||||
SHA1 (patch-af) = 2f3bab4108c002420e243a4ca6c9c0c3d4bdd21b
|
||||
SHA1 (patch-au) = 9183bfa3a6f5b4a9553a6de83448fb684d514a91
|
||||
SHA1 (patch-av) = 684c1e2ff1f96652225045653c25707850fe0ff2
|
||||
SHA1 (patch-aw) = 23d54ceddd0631aa93b32666853965a5fc7bdfab
|
||||
SHA1 (patch-ax) = 0ee6c30cc814d9404625191ac3b248ba9d9e094a
|
||||
SHA1 (patch-az) = 4fdb81d762f5fccf284ea518b1bf2e7d36950a1b
|
||||
|
|
|
@ -1,93 +0,0 @@
|
|||
$NetBSD: patch-az,v 1.1 2005/01/20 14:17:15 xtraeme Exp $
|
||||
|
||||
--- scripts/mysqlaccess.sh.orig 2005-01-16 14:28:38 -08:00
|
||||
+++ scripts/mysqlaccess.sh 2005-01-16 14:28:38 -08:00
|
||||
@@ -2,7 +2,7 @@
|
||||
# ****************************
|
||||
package MySQLaccess;
|
||||
#use strict;
|
||||
-use POSIX qw(tmpnam);
|
||||
+use File::Temp qw(tempfile tmpnam);
|
||||
use Fcntl;
|
||||
|
||||
BEGIN {
|
||||
@@ -32,7 +32,6 @@
|
||||
$ACCESS_U_BCK = 'user_backup';
|
||||
$ACCESS_D_BCK = 'db_backup';
|
||||
$DIFF = '/usr/bin/diff';
|
||||
- $TMP_PATH = '/tmp'; #path to writable tmp-directory
|
||||
$MYSQLDUMP = '@bindir@/mysqldump';
|
||||
#path to mysqldump executable
|
||||
|
||||
@@ -432,7 +431,7 @@
|
||||
# no caching on STDOUT
|
||||
$|=1;
|
||||
|
||||
- $MYSQL_CNF = POSIX::tmpnam();
|
||||
+ $MYSQL_CNF = tmpnam();
|
||||
%MYSQL_CNF = (client => { },
|
||||
mysql => { },
|
||||
mysqldump => { },
|
||||
@@ -577,8 +576,6 @@
|
||||
push(@MySQLaccess::Grant::Error,'not_found_mysql') if !(-x $MYSQL);
|
||||
push(@MySQLaccess::Grant::Error,'not_found_diff') if !(-x $DIFF);
|
||||
push(@MySQLaccess::Grant::Error,'not_found_mysqldump') if !(-x $MYSQLDUMP);
|
||||
-push(@MySQLaccess::Grant::Error,'not_found_tmp') if !(-d $TMP_PATH);
|
||||
-push(@MySQLaccess::Grant::Error,'write_err_tmp') if !(-w $TMP_PATH);
|
||||
if (@MySQLaccess::Grant::Error) {
|
||||
MySQLaccess::Report::Print_Error_Messages() ;
|
||||
exit 0;
|
||||
@@ -1777,17 +1774,15 @@
|
||||
@before = sort(@before);
|
||||
@after = sort(@after);
|
||||
|
||||
- $before = "$MySQLaccess::TMP_PATH/$MySQLaccess::script.before.$$";
|
||||
- $after = "$MySQLaccess::TMP_PATH/$MySQLaccess::script.after.$$";
|
||||
- #$after = "/tmp/t0";
|
||||
- open(BEFORE,"> $before") ||
|
||||
- push(@MySQLaccess::Report::Errors,"Can't open temporary file $before for writing");
|
||||
- open(AFTER,"> $after") ||
|
||||
- push(@MySQLaccess::Report::Errors,"Can't open temporary file $after for writing");
|
||||
- print BEFORE join("\n",@before);
|
||||
- print AFTER join("\n",@after);
|
||||
- close(BEFORE);
|
||||
- close(AFTER);
|
||||
+ ($hb, $before) = tempfile("$MySQLaccess::script.XXXXXX") or
|
||||
+ push(@MySQLaccess::Report::Errors,"Can't create temporary file: $!");
|
||||
+ ($ha, $after) = tempfile("$MySQLaccess::script.XXXXXX") or
|
||||
+ push(@MySQLaccess::Report::Errors,"Can't create temporary file: $!");
|
||||
+
|
||||
+ print $hb join("\n",@before);
|
||||
+ print $ha join("\n",@after);
|
||||
+ close $hb;
|
||||
+ close $ha;
|
||||
|
||||
# ----------------------------------
|
||||
# compute difference
|
||||
@@ -1800,8 +1795,8 @@
|
||||
|
||||
# ----------------------------------
|
||||
# cleanup temp. files
|
||||
- unlink(BEFORE);
|
||||
- unlink(AFTER);
|
||||
+ unlink($before);
|
||||
+ unlink($after);
|
||||
|
||||
return \@diffs;
|
||||
}
|
||||
@@ -2316,14 +2311,6 @@
|
||||
=> "The diff program <$MySQLaccess::DIFF> could not be found.\n"
|
||||
."+ Check your path, or\n"
|
||||
."+ edit the source of this script to point \$DIFF to the diff program.\n"
|
||||
- ,'not_found_tmp'
|
||||
- => "The temporary directory <$MySQLaccess::TMP_PATH> could not be found.\n"
|
||||
- ."+ create this directory (writeable!), or\n"
|
||||
- ."+ edit the source of this script to point \$TMP_PATH to the right directory.\n"
|
||||
- ,'write_err_tmp'
|
||||
- => "The temporary directory <$MySQLaccess::TMP_PATH> is not writable.\n"
|
||||
- ."+ make this directory writeable!, or\n"
|
||||
- ."+ edit the source of this script to point \$TMP_PATH to another directory.\n"
|
||||
,'Unrecognized_option'
|
||||
=> "Sorry,\n"
|
||||
."You are using an old version of the mysql-program,\n"
|
||||
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.29 2005/02/23 16:33:06 agc Exp $
|
||||
$NetBSD: distinfo,v 1.30 2005/03/15 15:43:28 xtraeme Exp $
|
||||
|
||||
SHA1 (mysql-4.0.23a.tar.gz) = b85f6ace8e120da34aef2a8ee26b5751de69b97b
|
||||
RMD160 (mysql-4.0.23a.tar.gz) = 10196d2990fff535a87d7ce68f3abea5d51abaea
|
||||
Size (mysql-4.0.23a.tar.gz) = 16735725 bytes
|
||||
SHA1 (mysql-4.0.24.tar.gz) = 523de9f374d4e8c08d5e6520ced05a32dfa2d35d
|
||||
RMD160 (mysql-4.0.24.tar.gz) = 595a162be1bc4e09eab7bc751c9c02214ba41ed7
|
||||
Size (mysql-4.0.24.tar.gz) = 16885399 bytes
|
||||
SHA1 (patch-aa) = d753d777adfa3d1357a285c0c18dfd0f6fc988b6
|
||||
SHA1 (patch-af) = 038b5d570265e1f821de6502d05f94225eba5672
|
||||
SHA1 (patch-al) = 725a3a6e06d39b26efb706bebbe3ff95da82be96
|
||||
|
@ -12,6 +12,5 @@ SHA1 (patch-ar) = d7c44e5bbed3c58e7516de5e155a82417818a39a
|
|||
SHA1 (patch-as) = d5ee30fad87682d3ed4315e41788c5ae6f68ba6e
|
||||
SHA1 (patch-at) = 62d5ccb0fdb5488b98979f2bb53d6029d0bd3d27
|
||||
SHA1 (patch-au) = 9183bfa3a6f5b4a9553a6de83448fb684d514a91
|
||||
SHA1 (patch-av) = 6ea5b9338d223f1380386288c537f55d4fd7a7d7
|
||||
SHA1 (patch-aw) = c82aa82430b42eaed2b6f4d588306e663e386ce1
|
||||
SHA1 (patch-ax) = 29b3087d240dbbb8a780816a115759994c6f4639
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-av,v 1.4 2004/10/28 01:08:15 xtraeme Exp $
|
||||
|
||||
--- sql/mysqld.cc.orig 2003-12-15 08:23:47.000000000 +1100
|
||||
+++ sql/mysqld.cc
|
||||
@@ -106,7 +106,18 @@ extern "C" { // Because of SCO 3.2V4
|
||||
int allow_severity = LOG_INFO;
|
||||
int deny_severity = LOG_WARNING;
|
||||
|
||||
-#ifdef __STDC__
|
||||
+#ifdef __FreeBSD__
|
||||
+# include <osreldate.h>
|
||||
+# if defined(__STDC__) && __FreeBSD_version < 500000
|
||||
+# define my_fromhost(A) fromhost(A)
|
||||
+# define my_hosts_access(A) hosts_access(A)
|
||||
+# define my_eval_client(A) eval_client(A)
|
||||
+# else
|
||||
+# define my_fromhost(A) fromhost()
|
||||
+# define my_hosts_access(A) hosts_access()
|
||||
+# define my_eval_client(A) eval_client()
|
||||
+# endif
|
||||
+#elif defined(__STDC__)
|
||||
#define my_fromhost(A) fromhost(A)
|
||||
#define my_hosts_access(A) hosts_access(A)
|
||||
#define my_eval_client(A) eval_client(A)
|
Loading…
Reference in a new issue