As per correspondence with Florian Kirsch, the author of OpenCSG, remove a
piece of code that was obviously wrong to him. Fixes rendering problems.
This commit is contained in:
parent
c5256d94ca
commit
ee348d51c0
3 changed files with 23 additions and 4 deletions
|
@ -1,8 +1,9 @@
|
||||||
# $NetBSD: Makefile,v 1.1.1.1 2012/02/26 20:41:04 reinoud Exp $
|
# $NetBSD: Makefile,v 1.2 2012/02/28 10:42:12 reinoud Exp $
|
||||||
#
|
#
|
||||||
|
|
||||||
PKGNAME= opencsg-1.3.2
|
PKGNAME= opencsg-1.3.2
|
||||||
DISTNAME= OpenCSG-1.3.2
|
DISTNAME= OpenCSG-1.3.2
|
||||||
|
PKG_REVISION= 1
|
||||||
CATEGORIES= graphics
|
CATEGORIES= graphics
|
||||||
MASTER_SITES= http://www.opencsg.org/
|
MASTER_SITES= http://www.opencsg.org/
|
||||||
|
|
||||||
|
@ -24,7 +25,6 @@ do-install:
|
||||||
|
|
||||||
.include "../../mk/x11.buildlink3.mk"
|
.include "../../mk/x11.buildlink3.mk"
|
||||||
.include "../../graphics/glew/buildlink3.mk"
|
.include "../../graphics/glew/buildlink3.mk"
|
||||||
.include "../../graphics/glu/buildlink3.mk"
|
.include "../../graphics/glut/buildlink3.mk"
|
||||||
#.include "../../graphics/MesaLib/buildlink3.mk"
|
|
||||||
.include "../../x11/libXmu/buildlink3.mk"
|
.include "../../x11/libXmu/buildlink3.mk"
|
||||||
.include "../../mk/bsd.pkg.mk"
|
.include "../../mk/bsd.pkg.mk"
|
||||||
|
|
|
@ -1,6 +1,7 @@
|
||||||
$NetBSD: distinfo,v 1.1.1.1 2012/02/26 20:41:04 reinoud Exp $
|
$NetBSD: distinfo,v 1.2 2012/02/28 10:42:12 reinoud Exp $
|
||||||
|
|
||||||
SHA1 (OpenCSG-1.3.2.tar.gz) = e2b4abf169ae3e319eb5f6d9ae6136fa96710a05
|
SHA1 (OpenCSG-1.3.2.tar.gz) = e2b4abf169ae3e319eb5f6d9ae6136fa96710a05
|
||||||
RMD160 (OpenCSG-1.3.2.tar.gz) = 4480778c310a3d5f84933c1b35508dd94adf2332
|
RMD160 (OpenCSG-1.3.2.tar.gz) = 4480778c310a3d5f84933c1b35508dd94adf2332
|
||||||
Size (OpenCSG-1.3.2.tar.gz) = 744712 bytes
|
Size (OpenCSG-1.3.2.tar.gz) = 744712 bytes
|
||||||
SHA1 (patch-Makefile) = 13c3cc669156b04b5d09af9587f76d1055629518
|
SHA1 (patch-Makefile) = 13c3cc669156b04b5d09af9587f76d1055629518
|
||||||
|
SHA1 (patch-RenderTexture.cpp) = 9d65c9928b4f42fde109b5497912e6654b188c69
|
||||||
|
|
18
graphics/opencsg/patches/patch-RenderTexture.cpp
Normal file
18
graphics/opencsg/patches/patch-RenderTexture.cpp
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
$NetBSD: patch-RenderTexture.cpp,v 1.1 2012/02/28 10:42:13 reinoud Exp $
|
||||||
|
|
||||||
|
--- RenderTexture/RenderTexture.cpp.orig 2011-12-01 21:25:12.000000000 +0000
|
||||||
|
+++ RenderTexture/RenderTexture.cpp
|
||||||
|
@@ -414,11 +414,13 @@ bool RenderTexture::Initialize(int width
|
||||||
|
GLXFBConfigSGIX *fbConfigs;
|
||||||
|
int nConfigs;
|
||||||
|
|
||||||
|
+#if 0
|
||||||
|
// [Andrew Wood]
|
||||||
|
//Add in pbufferAttribs. Needed to choose pixel format. (Especially for floating point)
|
||||||
|
_pixelFormatAttribs.insert(_pixelFormatAttribs.begin(),
|
||||||
|
_pbufferAttribs.begin(),_pbufferAttribs.end());
|
||||||
|
// [/Andrew Wood]
|
||||||
|
+#endif
|
||||||
|
|
||||||
|
fbConfigs = glXChooseFBConfigSGIX(_pDisplay, screen,
|
||||||
|
&_pixelFormatAttribs[0], &nConfigs);
|
Loading…
Reference in a new issue