py-macs2: fix dependency pattern in setup.py

Fixes configure
This commit is contained in:
wiz 2023-02-10 14:19:45 +00:00
parent ece867da84
commit ee96d1294b
2 changed files with 9 additions and 4 deletions

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1 2023/01/22 23:30:11 bacon Exp $
$NetBSD: distinfo,v 1.2 2023/02/10 14:19:45 wiz Exp $
BLAKE2s (MACS2-2.2.7.1.tar.gz) = 9018fcf83634355b625d8cbf6f67071c78d469bb35732318115470b7b7d30f8a
SHA512 (MACS2-2.2.7.1.tar.gz) = 2591ff3258124b1d577b0f417838e13ca6151b011590dbb769fd500d7ee5c7969349a7e40d11c3d8cbe75555786f3b76d3950586d7ed144e6e7679018c32d5c5
Size (MACS2-2.2.7.1.tar.gz) = 134872405 bytes
SHA1 (patch-setup.py) = 9b17fd669b1d67aeb1e7ab8d8fc2b93624755f47
SHA1 (patch-setup.py) = 2dd7f9996f93db596b4670c3231c818aaee03c87

View file

@ -1,10 +1,15 @@
$NetBSD: patch-setup.py,v 1.1 2023/01/22 23:30:11 bacon Exp $
$NetBSD: patch-setup.py,v 1.2 2023/02/10 14:19:45 wiz Exp $
# Remove lexical version check and pip requirement
--- setup.py.orig 2020-04-12 00:00:15.000000000 +0000
+++ setup.py
@@ -20,28 +20,8 @@ numpy_requires = '>=1.17'
@@ -16,32 +16,12 @@ from setuptools import setup, Extension
from distutils.version import LooseVersion
import subprocess
-numpy_requires = '>=1.17'
+numpy_requires = '1.17'
install_requires = [f"numpy>={numpy_requires}",]
def main():