Revbump and patches to compile with ocaml 4.01.
This commit is contained in:
parent
2a12144144
commit
eecdc5867b
4 changed files with 35 additions and 2 deletions
|
@ -1,8 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.12 2013/04/03 12:31:49 jaapb Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2013/11/01 10:50:03 jaapb Exp $
|
||||
#
|
||||
|
||||
DISTNAME= lwt-2.4.3
|
||||
PKGNAME= ocaml-${DISTNAME}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.ocsigen.org/download/
|
||||
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.6 2013/04/03 12:31:49 jaapb Exp $
|
||||
$NetBSD: distinfo,v 1.7 2013/11/01 10:50:03 jaapb Exp $
|
||||
|
||||
SHA1 (lwt-2.4.3.tar.gz) = 12503d6eb52ce0d5360096baf8bb846b140cf6bc
|
||||
RMD160 (lwt-2.4.3.tar.gz) = f159152df1cdbbfaf3b54600e43dccbed944550e
|
||||
Size (lwt-2.4.3.tar.gz) = 504000 bytes
|
||||
SHA1 (patch-src_unix_lwt_unix.ml) = 2ee202fa191a3d1101a573240025cea070d8c3b7
|
||||
SHA1 (patch-src_unix_lwt_unix.mli) = 8866ac18f024b79dd6aeddecf790fdb71bb2e8a8
|
||||
|
|
15
devel/ocaml-lwt/patches/patch-src_unix_lwt_unix.ml
Normal file
15
devel/ocaml-lwt/patches/patch-src_unix_lwt_unix.ml
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_unix_lwt_unix.ml,v 1.1 2013/11/01 10:50:03 jaapb Exp $
|
||||
|
||||
Patch (from upstream git) to compile with ocaml 4.01
|
||||
--- src/unix/lwt_unix.ml.orig 2012-12-27 12:29:57.000000000 +0000
|
||||
+++ src/unix/lwt_unix.ml
|
||||
@@ -596,6 +596,9 @@ type open_flag =
|
||||
#if ocaml_version >= (3, 13)
|
||||
| O_SHARE_DELETE
|
||||
#endif
|
||||
+#if ocaml_version >= (4, 01)
|
||||
+ | O_CLOEXEC
|
||||
+#endif
|
||||
|
||||
#if windows
|
||||
|
15
devel/ocaml-lwt/patches/patch-src_unix_lwt_unix.mli
Normal file
15
devel/ocaml-lwt/patches/patch-src_unix_lwt_unix.mli
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_unix_lwt_unix.mli,v 1.1 2013/11/01 10:50:03 jaapb Exp $
|
||||
|
||||
Patch (from upstream git) to compile with ocaml 4.01
|
||||
--- src/unix/lwt_unix.mli.orig 2012-12-27 12:29:57.000000000 +0000
|
||||
+++ src/unix/lwt_unix.mli
|
||||
@@ -315,6 +315,9 @@ type open_flag =
|
||||
#if ocaml_version >= (3, 13)
|
||||
| O_SHARE_DELETE
|
||||
#endif
|
||||
+#if ocaml_version >= (4, 01)
|
||||
+ | O_CLOEXEC
|
||||
+#endif
|
||||
|
||||
val openfile : string -> open_flag list -> file_perm -> file_descr Lwt.t
|
||||
(** Wrapper for [Unix.openfile]. *)
|
Loading…
Reference in a new issue