musicpd: Remove useless patch

pkgsrc changes:
---------------
  * Remove patch for which the issue has been fixed upstream:
    https://github.com/MusicPlayerDaemon/MPD/commit/32bddfa
  * Bump revision
This commit is contained in:
triaxx 2022-12-21 17:08:39 +00:00
parent d1749f10a0
commit ef505f315a
3 changed files with 3 additions and 24 deletions

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.282 2022/12/06 19:37:49 wiz Exp $
# $NetBSD: Makefile,v 1.283 2022/12/21 17:08:39 triaxx Exp $
DISTNAME= mpd-0.23.11
PKGREVISION= 1
PKGNAME= ${DISTNAME:S/mpd/musicpd/}
CATEGORIES= audio
MASTER_SITES= https://www.musicpd.org/download/mpd/${PKGVERSION_NOREV:R}/

View file

@ -1,10 +1,9 @@
$NetBSD: distinfo,v 1.143 2022/12/06 19:37:49 wiz Exp $
$NetBSD: distinfo,v 1.144 2022/12/21 17:08:39 triaxx Exp $
BLAKE2s (mpd-0.23.11.tar.xz) = e6bbf596f1bd6e4a5e9475d3f48e821b6c5f07801965a5e15e62449dbb1e45d7
SHA512 (mpd-0.23.11.tar.xz) = 971ae6b8ee5bf963a0f2408194fa01089713b606b3a2423081621b80a25e1b480f0e80a6d155ac8c2083960d99681c90f4bf00bf0baffa1f977259f1687c4ceb
Size (mpd-0.23.11.tar.xz) = 774592 bytes
SHA1 (patch-doc_mpd.conf.5.rst) = ee22092564075cdf7917e4e66687f6ab98b5817c
SHA1 (patch-src_archive_plugins_meson.build) = a37ed926b2321aa948158f0b77a4422565c146ca
SHA1 (patch-src_decoder_plugins_meson.build) = 8033d6e19da05f472f14f3562a5dfc2f410da98b
SHA1 (patch-src_net_IPv6Address.hxx) = f89b838ad5e946c5db8d95a6dd560e02bdccae29
SHA1 (patch-src_util_WStringAPI.hxx) = 92f39096770943c26d8aaae8a7581d4daca2d233

View file

@ -1,21 +0,0 @@
$NetBSD: patch-src_archive_plugins_meson.build,v 1.2 2022/12/06 19:37:49 wiz Exp $
Fix building on MacOS when bzip2 and zziplib are disabled. The libarchive
plugin cannot be created since ar doesn't seem to want to create empty library.
Patch submitted upstream: https://github.com/MusicPlayerDaemon/MPD/issues/1650
--- src/archive/plugins/meson.build.orig 2022-11-28 15:55:46.000000000 +0000
+++ src/archive/plugins/meson.build
@@ -26,6 +26,7 @@ if not found_archive_plugin
subdir_done()
endif
+if libiso9660_dep.found() or libbz2_dep.found() or libzzip_dep.found()
archive_plugins = static_library(
'archive_plugins',
archive_plugins_sources,
@@ -44,3 +45,4 @@ archive_plugins_dep = declare_dependency
input_glue_dep,
],
)
+endif