gnucash: disable -Werror to fix build with latest boost
Idea from adam@, thanks!
This commit is contained in:
parent
d351426aac
commit
ef7373bbc5
2 changed files with 22 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
||||||
$NetBSD: distinfo,v 1.87 2018/06/25 08:02:36 wiz Exp $
|
$NetBSD: distinfo,v 1.88 2018/08/20 11:43:41 wiz Exp $
|
||||||
|
|
||||||
SHA1 (gnucash-3.2.tar.bz2) = 91a2dbed3e08026e6d2765851361d698e377e4d3
|
SHA1 (gnucash-3.2.tar.bz2) = 91a2dbed3e08026e6d2765851361d698e377e4d3
|
||||||
RMD160 (gnucash-3.2.tar.bz2) = 9cd51ace65afb30a65aabd28ffd32b0703161a46
|
RMD160 (gnucash-3.2.tar.bz2) = 9cd51ace65afb30a65aabd28ffd32b0703161a46
|
||||||
SHA512 (gnucash-3.2.tar.bz2) = 2283f7cc3426b012297f654376a369021cce0f2de2354350d05cbd6a8610f512d418e4fedab15c811e11841d01bd47c5a1458c05dd14eaad3bfc0bafd7ed7cb0
|
SHA512 (gnucash-3.2.tar.bz2) = 2283f7cc3426b012297f654376a369021cce0f2de2354350d05cbd6a8610f512d418e4fedab15c811e11841d01bd47c5a1458c05dd14eaad3bfc0bafd7ed7cb0
|
||||||
Size (gnucash-3.2.tar.bz2) = 13384008 bytes
|
Size (gnucash-3.2.tar.bz2) = 13384008 bytes
|
||||||
|
SHA1 (patch-CMakeLists.txt) = 299b1daa2599a873385d2c8b1432e03c6fdba590
|
||||||
|
|
20
finance/gnucash/patches/patch-CMakeLists.txt
Normal file
20
finance/gnucash/patches/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
$NetBSD: patch-CMakeLists.txt,v 1.1 2018/08/20 11:43:42 wiz Exp $
|
||||||
|
|
||||||
|
Disable -Werror due to boost issues.
|
||||||
|
|
||||||
|
--- CMakeLists.txt.orig 2018-06-24 21:43:51.000000000 +0000
|
||||||
|
+++ CMakeLists.txt
|
||||||
|
@@ -560,10 +560,10 @@ set(CMAKE_CXX_FLAGS "-std=gnu++11 ${CMAK
|
||||||
|
|
||||||
|
|
||||||
|
if (UNIX)
|
||||||
|
- set( CMAKE_C_FLAGS "-Werror -Wdeclaration-after-statement -Wno-pointer-sign -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-unused ${CMAKE_C_FLAGS}")
|
||||||
|
- set( CMAKE_CXX_FLAGS "-Werror -Wall -Wmissing-declarations -Wno-unused -Wno-error=parentheses ${CMAKE_CXX_FLAGS}")
|
||||||
|
+ set( CMAKE_C_FLAGS "-Wdeclaration-after-statement -Wno-pointer-sign -Wall -Wmissing-prototypes -Wmissing-declarations -Wno-unused ${CMAKE_C_FLAGS}")
|
||||||
|
+ set( CMAKE_CXX_FLAGS "-Wall -Wmissing-declarations -Wno-unused -Wno-error=parentheses ${CMAKE_CXX_FLAGS}")
|
||||||
|
set( CMAKE_C_FLAGS "-Wno-deprecated-declarations -std=gnu11 -Wno-error=parentheses ${CMAKE_C_FLAGS}")
|
||||||
|
- set( CMAKE_C_FLAGS_RELEASE "-O3 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 ${CMAKE_C_FLAGS}")
|
||||||
|
+ set( CMAKE_C_FLAGS_RELEASE "-U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 ${CMAKE_C_FLAGS}")
|
||||||
|
endif (UNIX)
|
||||||
|
if (MINGW)
|
||||||
|
set( CMAKE_C_FLAGS "-Werror -Wdeclaration-after-statement -Wno-pointer-sign -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -Wno-unused -Wno-error=deprecated-declarations -std=gnu11 ${CMAKE_C_FLAGS}")
|
Loading…
Reference in a new issue