take notice of the 'inet6' package option,
by default, inet6 support is built in, but it can be disabled for systems that do not have inet6 capability.
This commit is contained in:
parent
cac8bfb964
commit
ef975405dc
4 changed files with 44 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.57 2007/07/28 08:39:34 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.58 2007/08/18 09:59:48 plunky Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ORBit2-2.14.8
|
||||
|
@ -25,6 +25,17 @@ GNU_CONFIGURE= YES
|
|||
|
||||
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR:Q}
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.ORBit2
|
||||
PKG_SUPPORTED_OPTIONS= inet6
|
||||
PKG_SUGGESTED_OPTIONS= inet6
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
.if !empty(PKG_OPTIONS:Minet6)
|
||||
CPPFLAGS+= -DINET6
|
||||
.endif
|
||||
|
||||
PKGCONFIG_OVERRIDE= ORBit-2.0.pc.in
|
||||
PKGCONFIG_OVERRIDE+= ORBit-CosNaming-2.0.pc.in
|
||||
PKGCONFIG_OVERRIDE+= ORBit-imodule-2.0.pc.in
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.35 2007/08/05 20:48:47 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.36 2007/08/18 09:59:49 plunky Exp $
|
||||
|
||||
SHA1 (ORBit2-2.14.8.tar.bz2) = 9f9c99a356045debcdb2286a65d25790de184415
|
||||
RMD160 (ORBit2-2.14.8.tar.bz2) = 512259accfcc939873046d04ae2d482f145e71ec
|
||||
Size (ORBit2-2.14.8.tar.bz2) = 742448 bytes
|
||||
SHA1 (patch-aa) = 6e87e28e3634908f35c219f81a47d0353cfaf551
|
||||
SHA1 (patch-ab) = 1661eaaa0119895a860e0c667990ea71b80e8ace
|
||||
SHA1 (patch-ac) = 075a11883b9d0a3ec7d5d93b37007ba64e1baf41
|
||||
SHA1 (patch-ad) = 0688c1156a373a3edf7388164bfa6d7fc3e99989
|
||||
|
|
15
net/ORBit2/patches/patch-ac
Normal file
15
net/ORBit2/patches/patch-ac
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ac,v 1.3 2007/08/18 09:59:49 plunky Exp $
|
||||
|
||||
--- linc2/src/linc-compat.h.orig 2007-07-29 18:12:41.000000000 +0100
|
||||
+++ linc2/src/linc-compat.h
|
||||
@@ -108,6 +108,10 @@
|
||||
# define INADDR_NONE (-1)
|
||||
#endif
|
||||
|
||||
+#if defined(AF_INET6) && !defined (INET6)
|
||||
+# undef AF_INET6
|
||||
+#endif
|
||||
+
|
||||
#if !defined (UNIX_PATH_MAX)
|
||||
/* UNP: 14.2 - Posix.1g at least 100 bytes */
|
||||
# define LINK_UNIX_PATH_MAX 100
|
14
net/ORBit2/patches/patch-ad
Normal file
14
net/ORBit2/patches/patch-ad
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ad,v 1.1 2007/08/18 09:59:49 plunky Exp $
|
||||
|
||||
--- linc2/src/linc-connection.c.orig 2007-07-29 19:21:53.000000000 +0100
|
||||
+++ linc2/src/linc-connection.c
|
||||
@@ -444,7 +444,9 @@ link_connection_from_fd_T (LinkConnectio
|
||||
|
||||
switch (cnx->proto->family) {
|
||||
case AF_INET:
|
||||
+#ifdef AF_INET6
|
||||
case AF_INET6:
|
||||
+#endif
|
||||
if (_link_timeout && !cnx->timeout_msec) /* this should'nt happen twice but I'm always paranoid... */
|
||||
cnx->timeout_msec = _link_timeout;
|
||||
break;
|
Loading…
Reference in a new issue