Update to 1.0.21:
Version 1.0.21 (2009-12-13) * Add a couple of new binary programs to programs/ dir. * Remove sndfile-jackplay (now in sndfile-tools package). * Add windows only function sf_wchar_open(). * Bunch of minor bug fixes. (The last entry sums up at least the DOS patches we had in pkgsrc.)
This commit is contained in:
parent
5c6fc7e0ea
commit
efa2c4d960
9 changed files with 16 additions and 170 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.55 2009/12/03 13:06:51 asau Exp $
|
||||
# $NetBSD: Makefile,v 1.56 2009/12/15 11:08:38 wiz Exp $
|
||||
|
||||
DISTNAME= libsndfile-1.0.20
|
||||
PKGREVISION= 2
|
||||
DISTNAME= libsndfile-1.0.21
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://www.mega-nerd.com/libsndfile/
|
||||
MASTER_SITES= http://www.mega-nerd.com/libsndfile/files/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.mega-nerd.com/libsndfile/
|
||||
|
@ -15,7 +14,7 @@ PKG_INSTALLATION_TYPES= overwrite pkgviews
|
|||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
PKGCONFIG_OVERRIDE= sndfile.pc.in
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
|
|
|
@ -1,8 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.16 2009/06/14 17:32:15 joerg Exp $
|
||||
@comment $NetBSD: PLIST,v 1.17 2009/12/15 11:08:38 wiz Exp $
|
||||
bin/sndfile-cmp
|
||||
bin/sndfile-concat
|
||||
bin/sndfile-convert
|
||||
bin/sndfile-deinterleave
|
||||
bin/sndfile-info
|
||||
bin/sndfile-jackplay
|
||||
bin/sndfile-interleave
|
||||
bin/sndfile-metadata-get
|
||||
bin/sndfile-metadata-set
|
||||
bin/sndfile-play
|
||||
|
@ -11,8 +13,12 @@ include/sndfile.h
|
|||
include/sndfile.hh
|
||||
lib/libsndfile.la
|
||||
lib/pkgconfig/sndfile.pc
|
||||
man/man1/sndfile-cmp.1
|
||||
man/man1/sndfile-concat.1
|
||||
man/man1/sndfile-convert.1
|
||||
man/man1/sndfile-info.1
|
||||
man/man1/sndfile-metadata-get.1
|
||||
man/man1/sndfile-metadata-set.1
|
||||
man/man1/sndfile-play.1
|
||||
share/doc/libsndfile1-dev/html/FAQ.html
|
||||
share/doc/libsndfile1-dev/html/api.html
|
||||
|
|
|
@ -1,11 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.29 2009/06/08 09:30:17 tron Exp $
|
||||
$NetBSD: distinfo,v 1.30 2009/12/15 11:08:38 wiz Exp $
|
||||
|
||||
SHA1 (libsndfile-1.0.20.tar.gz) = d4f88b919c644f54dd4038c4cf4fb2e7b0d32f7b
|
||||
RMD160 (libsndfile-1.0.20.tar.gz) = 873802efaa3f1e3303167fe1b7302fe2ab4cbd59
|
||||
Size (libsndfile-1.0.20.tar.gz) = 927422 bytes
|
||||
SHA1 (patch-aa) = fe12f9e3f8621d11c57b079534259465bb70ff42
|
||||
SHA1 (patch-ab) = 28299ed8bebe27f5f8ebbf36a129458ef05d8cd0
|
||||
SHA1 (patch-ac) = bc3cb0c0334df3c1c40201eb032a980a1270108f
|
||||
SHA1 (patch-ad) = dcdc4aebfb1da508e590220c1c2da7e9bb02678a
|
||||
SHA1 (patch-ae) = 8b0c4ae7ba9559bf5bc3d12d59e049f93889d09e
|
||||
SHA1 (patch-af) = b4fd14515b944164af0ecbd2da4a8deed43be28b
|
||||
SHA1 (libsndfile-1.0.21.tar.gz) = 136845a8bb5679e033f8f53fb98ddeb5ee8f1d97
|
||||
RMD160 (libsndfile-1.0.21.tar.gz) = 3f4d3472aebf24b02c2ce3f370023f50096c1fbd
|
||||
Size (libsndfile-1.0.21.tar.gz) = 1014722 bytes
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.15 2009/06/08 09:30:17 tron Exp $
|
||||
|
||||
Upstream fix for DoS vulnerability taken from here:
|
||||
|
||||
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530831
|
||||
|
||||
--- src/alaw.c.orig 2009-03-22 19:17:13.000000000 +0000
|
||||
+++ src/alaw.c 2009-06-08 10:03:02.000000000 +0100
|
||||
@@ -69,7 +69,7 @@
|
||||
else
|
||||
psf->datalength = 0 ;
|
||||
|
||||
- psf->sf.frames = psf->datalength / psf->blockwidth ;
|
||||
+ psf->sf.frames = psf->blockwidth > 0 ? psf->datalength / psf->blockwidth : 0 ;
|
||||
|
||||
return 0 ;
|
||||
} /* alaw_init */
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.9 2009/06/08 09:30:17 tron Exp $
|
||||
|
||||
Upstream fix for DoS vulnerability taken from here:
|
||||
|
||||
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530831
|
||||
|
||||
--- src/float32.c.orig 2009-03-25 02:59:47.000000000 +0000
|
||||
+++ src/float32.c 2009-06-08 10:03:02.000000000 +0100
|
||||
@@ -241,7 +241,7 @@
|
||||
else
|
||||
psf->datalength = 0 ;
|
||||
|
||||
- psf->sf.frames = psf->datalength / psf->blockwidth ;
|
||||
+ psf->sf.frames = psf->blockwidth > 0 ? psf->datalength / psf->blockwidth : 0 ;
|
||||
|
||||
return 0 ;
|
||||
} /* float32_init */
|
|
@ -1,29 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.11 2009/06/08 09:30:17 tron Exp $
|
||||
|
||||
Upstream fix for DoS vulnerability taken from here:
|
||||
|
||||
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530831
|
||||
|
||||
--- src/htk.c.orig 2009-03-22 19:17:14.000000000 +0000
|
||||
+++ src/htk.c 2009-06-08 10:03:02.000000000 +0100
|
||||
@@ -195,10 +195,17 @@
|
||||
return SFE_HTK_NOT_WAVEFORM ;
|
||||
|
||||
psf->sf.channels = 1 ;
|
||||
- psf->sf.samplerate = 10000000 / sample_period ;
|
||||
|
||||
- psf_log_printf (psf, "HTK Waveform file\n Sample Count : %d\n Sample Period : %d => %d Hz\n",
|
||||
- sample_count, sample_period, psf->sf.samplerate) ;
|
||||
+ if (sample_period > 0)
|
||||
+ { psf->sf.samplerate = 10000000 / sample_period ;
|
||||
+ psf_log_printf (psf, "HTK Waveform file\n Sample Count : %d\n Sample Period : %d => %d Hz\n",
|
||||
+ sample_count, sample_period, psf->sf.samplerate) ;
|
||||
+ }
|
||||
+ else
|
||||
+ { psf->sf.samplerate = 16000 ;
|
||||
+ psf_log_printf (psf, "HTK Waveform file\n Sample Count : %d\n Sample Period : %d (should be > 0) => Guessed sample rate %d Hz\n",
|
||||
+ sample_count, sample_period, psf->sf.samplerate) ;
|
||||
+ } ;
|
||||
|
||||
psf->sf.format = SF_FORMAT_HTK | SF_FORMAT_PCM_16 ;
|
||||
psf->bytewidth = 2 ;
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.12 2009/06/08 09:30:17 tron Exp $
|
||||
|
||||
Upstream fix for DoS vulnerability taken from here:
|
||||
|
||||
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530831
|
||||
|
||||
--- src/pcm.c.orig 2009-03-22 19:17:14.000000000 +0000
|
||||
+++ src/pcm.c 2009-06-08 10:03:02.000000000 +0100
|
||||
@@ -271,7 +271,7 @@
|
||||
else
|
||||
psf->datalength = 0 ;
|
||||
|
||||
- psf->sf.frames = psf->datalength / psf->blockwidth ;
|
||||
+ psf->sf.frames = psf->blockwidth > 0 ? psf->datalength / psf->blockwidth : 0 ;
|
||||
|
||||
return 0 ;
|
||||
} /* pcm_init */
|
|
@ -1,56 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.7 2009/06/08 09:30:17 tron Exp $
|
||||
|
||||
Upstream fix for DoS vulnerability taken from here:
|
||||
|
||||
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530831
|
||||
|
||||
--- src/sds.c.orig 2009-03-22 19:17:14.000000000 +0000
|
||||
+++ src/sds.c 2009-06-08 10:03:02.000000000 +0100
|
||||
@@ -219,21 +219,40 @@
|
||||
if (marker != 0xF07E || byte != 0x01)
|
||||
return SFE_SDS_NOT_SDS ;
|
||||
|
||||
- psf_log_printf (psf, "Midi Sample Dump Standard (.sds)\nF07E\n Midi Channel : %d\n", channel) ;
|
||||
+ bytesread += psf_binheader_readf (psf, "e2", &sample_no) ;
|
||||
+ sample_no = SDS_3BYTE_TO_INT_DECODE (sample_no) ;
|
||||
|
||||
- bytesread += psf_binheader_readf (psf, "e213", &sample_no, &bitwidth, &samp_period) ;
|
||||
+ psf_log_printf (psf, "Midi Sample Dump Standard (.sds)\nF07E\n"
|
||||
+ " Midi Channel : %d\n Sample Number : %d\n",
|
||||
+ channel, sample_no) ;
|
||||
+
|
||||
+ bytesread += psf_binheader_readf (psf, "e13", &bitwidth, &samp_period) ;
|
||||
|
||||
- sample_no = SDS_3BYTE_TO_INT_DECODE (sample_no) ;
|
||||
samp_period = SDS_3BYTE_TO_INT_DECODE (samp_period) ;
|
||||
|
||||
psds->bitwidth = bitwidth ;
|
||||
|
||||
- psf->sf.samplerate = 1000000000 / samp_period ;
|
||||
+ if (psds->bitwidth > 1)
|
||||
+ psf_log_printf (psf, " Bit Width : %d\n", psds->bitwidth) ;
|
||||
+ else
|
||||
+ { psf_log_printf (psf, " Bit Width : %d (should be > 1)\n", psds->bitwidth) ;
|
||||
+ return SFE_SDS_BAD_BIT_WIDTH ;
|
||||
+ } ;
|
||||
+
|
||||
+ if (samp_period > 0)
|
||||
+ { psf->sf.samplerate = 1000000000 / samp_period ;
|
||||
|
||||
- psf_log_printf (psf, " Sample Number : %d\n"
|
||||
- " Bit Width : %d\n"
|
||||
+ psf_log_printf (psf, " Sample Period : %d\n"
|
||||
" Sample Rate : %d\n",
|
||||
- sample_no, psds->bitwidth, psf->sf.samplerate) ;
|
||||
+ samp_period, psf->sf.samplerate) ;
|
||||
+ }
|
||||
+ else
|
||||
+ { psf->sf.samplerate = 16000 ;
|
||||
+
|
||||
+ psf_log_printf (psf, " Sample Period : %d (should be > 0)\n"
|
||||
+ " Sample Rate : %d (guessed)\n",
|
||||
+ samp_period, psf->sf.samplerate) ;
|
||||
+ } ;
|
||||
|
||||
bytesread += psf_binheader_readf (psf, "e3331", &data_length, &sustain_loop_start, &sustain_loop_end, &loop_type) ;
|
||||
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.7 2009/06/08 09:30:17 tron Exp $
|
||||
|
||||
Upstream fix for DoS vulnerability taken from here:
|
||||
|
||||
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=530831
|
||||
|
||||
--- src/ulaw.c.orig 2009-03-22 19:17:14.000000000 +0000
|
||||
+++ src/ulaw.c 2009-06-08 10:03:02.000000000 +0100
|
||||
@@ -59,7 +59,7 @@
|
||||
else
|
||||
psf->datalength = 0 ;
|
||||
|
||||
- psf->sf.frames = psf->datalength / psf->blockwidth ;
|
||||
+ psf->sf.frames = psf->blockwidth > 0 ? psf->datalength / psf->blockwidth : 0 ;
|
||||
|
||||
return 0 ;
|
||||
} /* ulaw_init */
|
Loading…
Reference in a new issue