Update libpgf to version 7.21.7

Pkgsrc changes:
Don't need dos2unix, the line endings have been fixed in this version.
Removed doc/Makefile.am patch, it has been applied upstream.
This version builds on compilers defaulting to C++17.
BUILDLINK_API_DEPENDS has been bumped to the new version since nothing
in pkgsrc depends on libpgf.


Changelog from readme:

Version 7.21.7, (Thu, 18 Feb 2021)
------------------------------------

1. The new version is a minor bug fix of versions 7.15.25 to 7.21.2.

2. This bug fix for ROI decoding only. This bug fix is necessary if
   several Read() and ResetStreamPos() operations are called with
   the same PGFimage object after a single Open() call.


Version 7.21.2, (Sun, 17 Jan 2021)
------------------------------------

1. The new version is a documentation and build tool update of
   version 7.19.3.


Version 7.19.3, (Tue, 15 Jan 2019)
------------------------------------

1. The new version is a minor update of version 7.15.25.

2. This version fixes a compilation bug seen when ROI support is
   disabled.


Version 7.15.32, (Thu, 6 Aug 2015)
------------------------------------

1. The new version is a minor update of version 7.15.25.

2. This version improves the reuse of CPGFImage objects for several
   decoding operations. It clarifies the usage of CPGFImage::Close()
   and CPGFImage::Destroy() by deletion of Close(). Several reading
   operations can be performed in the following way:
   Open(), Read(), GetBitmap(), ResetStreamPos(), Read(),
   GetBitmap(), ResetStreamPos(), ...
   Calling Destroy() frees all allocated ressources and reinitializes
   the object to the same state as the constructor does. This allows
   the reuse of the CPGFImage object for encoding and decoding:
   SetHeader(), ImportBitmap(), Write(), ResetStreamPos(), Destroy(),
   Open(), Read(), GetBitmap()

3. Caching or skipping of user data (meta data) while opening a PGF
   image can be controlled by a new UserdataPolicy in
   ConfigureDecoder().


Version 7.15.25, (Sat, 20 June 2015)
------------------------------------

1. This new version is a replacement of version 6.14.12.
   In case you use the ROI decoding, we strongly encourage using
   version 6.15.25 instead of an older version.

2. This version fixes some decoder bugs only seen in ROI decoding.
   ROI decoding is now also supported for Bitmap and RGB12 image modes.

3. This version introduces a new and more efficient data format for
   binary images (bitmaps).
   The new format allows ROI decoding.
   The decoder supports both the old and the new format, but ROI
   decoding works only with the new format.

4. The two reserverd bytes in PGFHeader are now used for a more
   detailled PGF version number.

5. The Visual Studio project files are in the VS12 format.
This commit is contained in:
nros 2023-09-29 18:29:29 +00:00
parent 07944fd323
commit efabdae924
8 changed files with 98 additions and 57 deletions

View File

@ -1,30 +1,24 @@
# $NetBSD: Makefile,v 1.4 2023/06/06 12:41:34 riastradh Exp $
# $NetBSD: Makefile,v 1.5 2023/09/29 18:29:29 nros Exp $
DISTNAME= libpgf-src-6.14.12
PKGNAME= ${DISTNAME:S/-src//}
DISTNAME= libpgf
PKGNAME= libpgf-7.21.7
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=libpgf/}
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=libpgf/libpgf/${PKGVERSION_NOREV}/}
DIST_SUBDIR= ${PKGNAME_NOREV}
EXTRACT_SUFX= .zip
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.libpgf.org/
COMMENT= Progressive Graphics File (PGF) library
LICENSE= gnu-lgpl-v2.1
WRKSRC= ${WRKDIR}/libpgf
GNU_CONFIGURE= yes
USE_TOOLS+= aclocal autoconf automake
USE_LANGUAGES= c c++
USE_LIBTOOL= yes
# https://sourceforge.net/p/libpgf/bugs/7/
TOOL_DEPENDS+= dos2unix-[0-9]*:../../converters/dos2unix
pre-patch:
${CP} ${WRKSRC}/configure.ac ${WRKSRC}/configure.ac.orig
${CAT} ${WRKSRC}/configure.ac.orig | dos2unix >${WRKSRC}/configure.ac
pre-configure:
${RUN} cd ${WRKSRC} && ./autogen.sh
${RUN} cd ${WRKSRC} && ${TOUCH} README && ${SH} autogen.sh
PKGCONFIG_OVERRIDE+= libpgf.pc.in

View File

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2014/07/22 17:36:49 wiz Exp $
@comment $NetBSD: PLIST,v 1.2 2023/09/29 18:29:29 nros Exp $
include/libpgf/PGFimage.h
include/libpgf/PGFplatform.h
include/libpgf/PGFstream.h
@ -26,6 +26,7 @@ ${PLIST.doc}man/man3/PGFMagicVersion.3
${PLIST.doc}man/man3/PGFPostHeader.3
${PLIST.doc}man/man3/PGFPreHeader.3
${PLIST.doc}man/man3/PGFRect.3
${PLIST.doc}man/man3/PGFVersionNumber.3
${PLIST.doc}man/man3/PGFimage.cpp.3
${PLIST.doc}man/man3/PGFimage.h.3
${PLIST.doc}man/man3/PGFplatform.h.3
@ -70,7 +71,10 @@ ${PLIST.doc}share/doc/${PKGNAME}/html/WaveletTransform_8cpp_source.html
${PLIST.doc}share/doc/${PKGNAME}/html/WaveletTransform_8h.html
${PLIST.doc}share/doc/${PKGNAME}/html/WaveletTransform_8h_source.html
${PLIST.doc}share/doc/${PKGNAME}/html/annotated.html
${PLIST.doc}share/doc/${PKGNAME}/html/arrowdown.png
${PLIST.doc}share/doc/${PKGNAME}/html/arrowright.png
${PLIST.doc}share/doc/${PKGNAME}/html/bc_s.png
${PLIST.doc}share/doc/${PKGNAME}/html/bc_sd.png
${PLIST.doc}share/doc/${PKGNAME}/html/bdwn.png
${PLIST.doc}share/doc/${PKGNAME}/html/classCDecoder-members.html
${PLIST.doc}share/doc/${PKGNAME}/html/classCDecoder.html
@ -101,21 +105,13 @@ ${PLIST.doc}share/doc/${PKGNAME}/html/config_8h.html
${PLIST.doc}share/doc/${PKGNAME}/html/config_8h_source.html
${PLIST.doc}share/doc/${PKGNAME}/html/dir_000000.html
${PLIST.doc}share/doc/${PKGNAME}/html/dir_000001.html
${PLIST.doc}share/doc/${PKGNAME}/html/dir_68267d1309a1af8e8297ef4c3efbcdba.html
${PLIST.doc}share/doc/${PKGNAME}/html/dir_d44c64559bbebec7f509842c48db8b23.html
${PLIST.doc}share/doc/${PKGNAME}/html/doc.png
${PLIST.doc}share/doc/${PKGNAME}/html/doxygen.png
${PLIST.doc}share/doc/${PKGNAME}/html/files.html
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2blank.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2doc.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2folderclosed.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2folderopen.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2lastnode.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2link.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2mlastnode.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2mnode.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2node.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2plastnode.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2pnode.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2splitbar.png
${PLIST.doc}share/doc/${PKGNAME}/html/ftv2vertline.png
${PLIST.doc}share/doc/${PKGNAME}/html/folderclosed.png
${PLIST.doc}share/doc/${PKGNAME}/html/folderopen.png
${PLIST.doc}share/doc/${PKGNAME}/html/functions.html
${PLIST.doc}share/doc/${PKGNAME}/html/functions_b.html
${PLIST.doc}share/doc/${PKGNAME}/html/functions_c.html
@ -140,6 +136,7 @@ ${PLIST.doc}share/doc/${PKGNAME}/html/functions_u.html
${PLIST.doc}share/doc/${PKGNAME}/html/functions_v.html
${PLIST.doc}share/doc/${PKGNAME}/html/functions_vars.html
${PLIST.doc}share/doc/${PKGNAME}/html/functions_w.html
${PLIST.doc}share/doc/${PKGNAME}/html/functions_y.html
${PLIST.doc}share/doc/${PKGNAME}/html/functions_~.html
${PLIST.doc}share/doc/${PKGNAME}/html/globals.html
${PLIST.doc}share/doc/${PKGNAME}/html/globals_defs.html
@ -151,9 +148,13 @@ ${PLIST.doc}share/doc/${PKGNAME}/html/globals_vars.html
${PLIST.doc}share/doc/${PKGNAME}/html/hierarchy.html
${PLIST.doc}share/doc/${PKGNAME}/html/index.html
${PLIST.doc}share/doc/${PKGNAME}/html/nav_f.png
${PLIST.doc}share/doc/${PKGNAME}/html/nav_fd.png
${PLIST.doc}share/doc/${PKGNAME}/html/nav_g.png
${PLIST.doc}share/doc/${PKGNAME}/html/nav_h.png
${PLIST.doc}share/doc/${PKGNAME}/html/nav_hd.png
${PLIST.doc}share/doc/${PKGNAME}/html/open.png
${PLIST.doc}share/doc/${PKGNAME}/html/splitbar.png
${PLIST.doc}share/doc/${PKGNAME}/html/splitbard.png
${PLIST.doc}share/doc/${PKGNAME}/html/structIOException-members.html
${PLIST.doc}share/doc/${PKGNAME}/html/structIOException.html
${PLIST.doc}share/doc/${PKGNAME}/html/structPGFHeader-members.html
@ -168,13 +169,19 @@ ${PLIST.doc}share/doc/${PKGNAME}/html/structPGFPreHeader.html
${PLIST.doc}share/doc/${PKGNAME}/html/structPGFPreHeader.png
${PLIST.doc}share/doc/${PKGNAME}/html/structPGFRect-members.html
${PLIST.doc}share/doc/${PKGNAME}/html/structPGFRect.html
${PLIST.doc}share/doc/${PKGNAME}/html/structPGFVersionNumber-members.html
${PLIST.doc}share/doc/${PKGNAME}/html/structPGFVersionNumber.html
${PLIST.doc}share/doc/${PKGNAME}/html/structROIBlockHeader_1_1RBH-members.html
${PLIST.doc}share/doc/${PKGNAME}/html/structROIBlockHeader_1_1RBH.html
${PLIST.doc}share/doc/${PKGNAME}/html/sync_off.png
${PLIST.doc}share/doc/${PKGNAME}/html/sync_on.png
${PLIST.doc}share/doc/${PKGNAME}/html/tab_a.png
${PLIST.doc}share/doc/${PKGNAME}/html/tab_ad.png
${PLIST.doc}share/doc/${PKGNAME}/html/tab_b.png
${PLIST.doc}share/doc/${PKGNAME}/html/tab_bd.png
${PLIST.doc}share/doc/${PKGNAME}/html/tab_h.png
${PLIST.doc}share/doc/${PKGNAME}/html/tab_hd.png
${PLIST.doc}share/doc/${PKGNAME}/html/tab_s.png
${PLIST.doc}share/doc/${PKGNAME}/html/tab_sd.png
${PLIST.doc}share/doc/${PKGNAME}/html/unionROIBlockHeader-members.html
${PLIST.doc}share/doc/${PKGNAME}/html/unionROIBlockHeader.html

View File

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.1 2014/07/22 17:36:49 wiz Exp $
# $NetBSD: buildlink3.mk,v 1.2 2023/09/29 18:29:29 nros Exp $
BUILDLINK_TREE+= libpgf
.if !defined(LIBPGF_BUILDLINK3_MK)
LIBPGF_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.libpgf+= libpgf>=6.14.12
BUILDLINK_API_DEPENDS.libpgf+= libpgf>=7.21.7
BUILDLINK_PKGSRCDIR.libpgf?= ../../graphics/libpgf
.endif # LIBPGF_BUILDLINK3_MK

View File

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.4 2021/10/26 10:46:28 nia Exp $
$NetBSD: distinfo,v 1.5 2023/09/29 18:29:29 nros Exp $
BLAKE2s (libpgf-src-6.14.12.tar.gz) = 5aae267435c464f9fd86e0284fb3a1d1f8bba9efa7790b8c0332893dbe656909
SHA512 (libpgf-src-6.14.12.tar.gz) = 1fb2377deb86cea65ab28704a5c438a6e8586c37fb73a208800341214c0b09c9ae61c30a70e839b0238223b31da9825db2aeb2275e06c7a3ff6ff5b43cf72972
Size (libpgf-src-6.14.12.tar.gz) = 91154 bytes
SHA1 (patch-configure.ac) = a3965803c80bf6160eca1b9c0562620fdd8f213f
SHA1 (patch-doc_Makefile.am) = 28e0ebf8d83bd15ac6456967c572322943262f34
BLAKE2s (libpgf-7.21.7/libpgf.zip) = 39fe793416adad3a962d4f976374cf7a3e5a0a592642aee166d474f779280e4f
SHA512 (libpgf-7.21.7/libpgf.zip) = dbc17d9dce1afbeffb272df0d573059914d2ac79d652d1d43e67c49509fd6e643be8594bbd1a3058a5aa3a9d30db100c6dcf641051345049cf8f9375d49e2799
Size (libpgf-7.21.7/libpgf.zip) = 2075722 bytes
SHA1 (patch-configure.ac) = 4281c5d85931f6cff577f419e11f6cbed3967d99
SHA1 (patch-include_PGFplatform.h) = 1ef19ef4570bc8e5b1b11de769eb8e84c595004c
SHA1 (patch-libpgf.pc.in) = 3709fe3393b536cb84cda03fd00bb6bf26914b8d

View File

@ -1,11 +1,28 @@
$NetBSD: patch-configure.ac,v 1.1 2014/07/22 17:36:49 wiz Exp $
$NetBSD: patch-configure.ac,v 1.2 2023/09/29 18:29:29 nros Exp $
* Use newer autoconf macros
* set right version number
* add --enable-doc option
https://sourceforge.net/p/libpgf/patches/8/
--- configure.ac.orig 2014-06-18 08:16:27.000000000 +0000
--- configure.ac.orig 2021-02-12 19:54:36.000000000 +0000
+++ configure.ac
@@ -30,8 +30,11 @@ AC_CONFIG_HEADERS( config.h )
@@ -1,4 +1,4 @@
-AC_INIT([libpgf], [7.15.32])
+AC_INIT([libpgf],[7.21.7])
AC_CONFIG_SRCDIR([src/PGFimage.cpp])
@@ -27,22 +27,26 @@ PACKAGE_RELEASE=2
AC_SUBST(PACKAGE_RELEASE)
AM_INIT_AUTOMAKE
-AC_PROG_LIBTOOL
+LT_INIT
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS( [config.h] )
AC_PROG_CXX
dnl Check for doxygen support
@ -17,3 +34,14 @@ https://sourceforge.net/p/libpgf/patches/8/
AM_CONDITIONAL(HAS_DOXYGEN, test $DOXYGEN && $DOT)
# Generate output
-AC_OUTPUT(Makefile
+AC_CONFIG_FILES([Makefile
src/Makefile
include/Makefile
doc/Makefile
doc/Doxyfile
libpgf.spec
libpgf.pc
-)
+])
+AC_OUTPUT

View File

@ -1,19 +0,0 @@
$NetBSD: patch-doc_Makefile.am,v 1.1 2014/07/22 17:36:49 wiz Exp $
* install manpages in mandir
https://sourceforge.net/p/libpgf/patches/9/
* do not install _usr_...3 manpage files
https://sourceforge.net/p/libpgf/patches/10/
--- doc/Makefile.am.orig 2013-10-25 11:24:17.000000000 +0000
+++ doc/Makefile.am
@@ -11,6 +11,6 @@ html/index.html: Doxyfile
install-data-local: html/index.html
$(mkinstalldirs) $(DOC_DIR)/html
- $(mkinstalldirs) $(DESTDIR)$(datadir)/man/man3
+ $(mkinstalldirs) $(DESTDIR)$(mandir)/man3
-(cd html && for f in *.html *.png; do $(INSTALL) -m 644 "$$f" "$(DOC_DIR)/html/$$f"; done)
- -(cd man/man3; for f in *.3; do $(INSTALL) -m 644 "$$f" "$(DESTDIR)$(datadir)/man/man3/$$f"; done)
+ -(cd man/man3; for f in [!_]*.3; do $(INSTALL) -m 644 "$$f" "$(DESTDIR)$(mandir)/man3/$$f"; done)

View File

@ -0,0 +1,15 @@
$NetBSD: patch-include_PGFplatform.h,v 1.1 2023/09/29 18:29:29 nros Exp $
* Add DragonflyBSD and Haiku support
--- include/PGFplatform.h.orig 2023-09-29 18:29:20.586933088 +0000
+++ include/PGFplatform.h
@@ -336,7 +336,7 @@ inline OSError SetFPos(HANDLE hFile, int
//-------------------------------------------------------------------------------
// *BSD
//-------------------------------------------------------------------------------
-#if defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
+#if defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__DragonFly__) || defined(__HAIKU__)
#ifndef __POSIX__
#define __POSIX__
#endif

View File

@ -0,0 +1,15 @@
$NetBSD: patch-libpgf.pc.in,v 1.1 2023/09/29 18:29:29 nros Exp $
* don't hardcode includedir but depend on ${prefix}
--- libpgf.pc.in.orig 2021-02-12 19:54:36.000000000 +0000
+++ libpgf.pc.in
@@ -1,7 +1,7 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
libdir=@libdir@
-includedir=@prefix@/include/@PACKAGE@
+includedir=@includedir@/@PACKAGE@
Name: @PACKAGE@
Description: libpgf - Progressive Graphics File (PGF) library