Add -lintl for SunOS. Add patch to fix unportable cfmakeraw() for SunOS.

This commit is contained in:
rodent 2014-01-19 00:49:06 +00:00
parent 87898f8e6f
commit efd3a0f08d
6 changed files with 17 additions and 16 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.6 2014/01/10 02:32:50 rodent Exp $
# $NetBSD: Makefile,v 1.7 2014/01/19 00:49:06 rodent Exp $
#
DISTNAME= ucommon-6.1.0
@ -21,7 +21,7 @@ PKGCONFIG_OVERRIDE+= ucommon.pc.in
.include "options.mk"
LDFLAGS.SunOS+= -lsocket -lnsl
LDFLAGS.SunOS+= -lsocket -lnsl -lintl
.include "../../mk/dlopen.buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"

View file

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.7 2014/01/10 02:32:50 rodent Exp $
$NetBSD: distinfo,v 1.8 2014/01/19 00:49:06 rodent Exp $
SHA1 (ucommon-6.1.0.tar.gz) = c20dc9c5ec53131284cbc523148302b6e135a9ac
RMD160 (ucommon-6.1.0.tar.gz) = 93e175c0970e335acb2df2b8ee2433720ba69fdd
Size (ucommon-6.1.0.tar.gz) = 826742 bytes
SHA1 (patch-CMakeLists.txt) = 4d4c11a89111161bc8d8fe3715f643290ecb6149
SHA1 (patch-commoncpp_address.cpp) = 13fc4a7073b6c2de6329a90269045fc3dbb0e389
SHA1 (patch-commoncpp_udp.cpp) = 17d61b4f3a885d897b222b179b714dc5a8b1e906
SHA1 (patch-inc_ucommon_string.h) = e878aefcf3a6e0b21eecdcef1f561c7f68c7a6c5
SHA1 (patch-CMakeLists.txt) = 53e9ffad15d45a89eb1b992da3d6a965a46d0447
SHA1 (patch-commoncpp_address.cpp) = 64cbb5ae5f43b994a36d65d893cf58309e7324df
SHA1 (patch-commoncpp_udp.cpp) = 6950168df08702bb5aed023682e8a73e73b6f965
SHA1 (patch-inc_ucommon_string.h) = 334e9a71dfbf94f81ced34e0af7074c67f65b8da
SHA1 (patch-utils_keywait.cpp) = 7f5a595b080f3e61097cf99680602d8fcc84bafa

View file

@ -1,10 +1,10 @@
$NetBSD: patch-CMakeLists.txt,v 1.1 2013/04/17 00:51:20 rodent Exp $
$NetBSD: patch-CMakeLists.txt,v 1.2 2014/01/19 00:49:06 rodent Exp $
Fix INSTALL_MANDIR overwriting itself.
--- CMakeLists.txt.orig 2011-11-12 15:24:39.000000000 +0000
--- CMakeLists.txt.orig 2014-01-04 17:15:36.000000000 +0000
+++ CMakeLists.txt
@@ -36,15 +36,7 @@ if(WIN32)
@@ -42,15 +42,7 @@ if(WIN32)
set(SYSCONFDIR "etc" CACHE PATH "config directory")
set(STATEDIR "var" CACHE PATH "state directory")
else()

View file

@ -1,9 +1,9 @@
$NetBSD: patch-commoncpp_address.cpp,v 1.2 2013/06/27 01:36:25 rodent Exp $
$NetBSD: patch-commoncpp_address.cpp,v 1.3 2014/01/19 00:49:06 rodent Exp $
Be explicit that the local version of bitset is wanted, not the STL
version in std for C++11 libraries.
--- commoncpp/address.cpp.orig 2013-04-28 14:29:48.000000000 +0000
--- commoncpp/address.cpp.orig 2014-01-04 17:32:41.000000000 +0000
+++ commoncpp/address.cpp
@@ -1062,7 +1062,7 @@ void IPV4Cidr::set(const char *cp)
#endif

View file

@ -1,6 +1,6 @@
$NetBSD: patch-commoncpp_udp.cpp,v 1.1 2013/11/08 21:14:37 joerg Exp $
$NetBSD: patch-commoncpp_udp.cpp,v 1.2 2014/01/19 00:49:06 rodent Exp $
--- commoncpp/udp.cpp.orig 2013-11-07 12:53:49.000000000 +0000
--- commoncpp/udp.cpp.orig 2014-01-04 17:32:41.000000000 +0000
+++ commoncpp/udp.cpp
@@ -409,7 +409,7 @@ Socket::Error UDPSocket::join(const IPV4
setsockopt(so, IPPROTO_IP, IP_ADD_MEMBERSHIP, (char *)&group, sizeof(group));

View file

@ -1,6 +1,6 @@
$NetBSD: patch-inc_ucommon_string.h,v 1.1 2013/07/13 19:22:27 joerg Exp $
$NetBSD: patch-inc_ucommon_string.h,v 1.2 2014/01/19 00:49:06 rodent Exp $
--- inc/ucommon/string.h.orig 2013-07-12 14:12:23.000000000 +0000
--- inc/ucommon/string.h.orig 2014-01-04 17:30:39.000000000 +0000
+++ inc/ucommon/string.h
@@ -1627,7 +1627,7 @@ public:
* @param string2 to compare.