audio/din: Updates to 52

Changes since 51.1:

DIN Is Noise 52:

  \ walked back some changes introduced in DIN 51
    \ the drone tracked by gravity does not change when the selection changes
  \ renamed drone arrow parameter called Head to Neck

  /* new gravity size modulation for DIN 52

      change the size (aka strength/magnitude) of gravity vector over bpm:
        on the gravity widget, turn on Modulate
          bpm = speed of gravity size modulation
          depth = how far to 0 gravity drops
            depth = 1, goes all the way to 0 and back in 1 beat
            depth = 0.5, goes from starting size to half size and back in 1 beat
            depth = 0, no size modulation ie size does not change at all
            default depth = 1

          set an initial size using gravity presets or click on Change Size
          and move the mouse up or down. keep Modulate off when doing this.

          click Edit to edit the size modulation curve for interesting fx.
  /*

  + press q to toggle drone wanding when Menu > Drone Tools > Wand is selected
    ! was always in Add drone mode until DIN 51.x
  + optional tracking of drones when connecting them with Menu > Drone Tools > Connect
    + enable / disable @ Menu > Drone Tools > Track
    + if enabled on connection: drone 1 points to drone 2 points to drone 3 and so on
    + if disabled on disconnection: selected drones stop tracking any other drone
  + select drone on creation
    + Menu > Drone Params > Defaults > Select on Creation
    + drone is not selected by default
    + useful for looking at pitch/volume info of launched drones as they fly past
  + white = noise interpolator curve
    @ Menu > Editors > Noise Interpolator
  + white = drone that makes noise
    \ was grayscale in DIN 51.x
  + color of velocity vector of drone = color of drone
    \ was green in DIN51.x
  + constrain magnitude of drone velocity +/ acceleration to be > 0
    + click on 0 checkbutton on the Menu > Drone Params > Motion > Velocity or Acceleration to toggle
      + if enabled, magnitude of velocity +/ acceleration will always be > 0
      + if disabled, magnitude of velocity +/ acceleration can go < 0 ie will reverse movement or
        orbiting
  + browsed drone marker color is color of the browsed drone
    \ was green in DIN51.x
  * improved drone arrow drawing
  * improved note/frequency labeling on microtonal ranges
  * improved 'with left/center/right fixed' menu item on Menu > Ranges
  * new default volume distribution curve to have value increase (linearly)
    after 100% instead of staying at 100%. upto 200% now.
  * improved drone > < noise progress display
  <> moved (and renamed) Menu > Drone Params > Move under Gravity to Menu > Drone Tools > Balloon
      still does the same thing:
        releases (like gas balloons :) anchored drones
          these are now launched drones and die at the end of their lifetimes.
  <> moved Snap drones to notes / Position affects velocity from Menu > Drone Params > Motion to
     Menu > Drone Tools
  <> moved Bounces, rebound Speed% and drone bounce behaviour from Menu > Drone Params > Motion to
     Menu > Drone Params > Defaults as they apply equally to all launched drones
  * replaced drone Rise Time Min and Max spinners with a Rise time spinner
    + turn on ~ to generate a random rise time (default is 50% to 100% of Rise time) on drone creation
      + change range of randomness by editing %~ field
  * replaced drone Fall Time Min and Max spinners with a Fall time spinner
    + turn on ~ to generate a random fall time (default is 50% to 100% of Fall time) on drone removal
      + change range of randomness by editing %~ field
  + drones can bounce ahead, back or ahead/back
  + can select drones while voice phrasor plays
  + reinstated (from din-5.2.1 release!) a form of indian notation for notes
    + from Settings screen, choose notation = indian
  + a launched drone lifetime = lifetime of launcher or if ~ is active on Menu > Drone Params > Defaults > Lifetime
    a randomisation based on ~% of the lifetime of the launcher

  ! fixed bug when setting snap left/right values
  ! fixed mouse wheel scrolling of UI when hovering over label widget
  ! gravity continues tracking drone as its moved around or when scrolling microtonal keyboard
This commit is contained in:
fox 2021-12-12 23:26:01 +00:00
parent 51ff47fdc0
commit efeaf2ee4f
5 changed files with 20 additions and 19 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.34 2021/09/29 19:00:17 adam Exp $
# $NetBSD: Makefile,v 1.35 2021/12/12 23:26:01 fox Exp $
DISTNAME= din-51.1.1
PKGREVISION= 2
DISTNAME= din-52
CATEGORIES= audio
MASTER_SITES= https://archive.org/download/dinisnoise_source_code/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2021/07/12 14:58:35 fox Exp $
@comment $NetBSD: PLIST,v 1.9 2021/12/12 23:26:01 fox Exp $
bin/din
share/applications/din.desktop
share/din/factory/2600
@ -357,6 +357,8 @@ share/din/factory/get-selection.help.tcl
share/din/factory/get-style.help.tcl
share/din/factory/get-var.help.tcl
share/din/factory/globals
share/din/factory/gravmod.crv
share/din/factory/gravmod.ed
share/din/factory/harmonics
share/din/factory/harmonics.help.tcl
share/din/factory/harmonics.patch.tcl

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.25 2021/10/26 09:58:52 nia Exp $
$NetBSD: distinfo,v 1.26 2021/12/12 23:26:01 fox Exp $
BLAKE2s (din-51.1.1.tar.gz) = 511a6cedf1d904d333891263952c44e5d60b582ea82400233682dcc56a666df9
SHA512 (din-51.1.1.tar.gz) = ea5e1ab79cbc24abb80a9fd25d8304f36ab2345505ee98132196685cda73b31dd7db3f62cb1821cbdc9694703d3454bd58d733833710d492ecebffee23732a0f
Size (din-51.1.1.tar.gz) = 3700797 bytes
SHA1 (patch-src_Makefile.am) = 42f2f712db4092bc89793f4db6dda915a708ee20
SHA1 (patch-src_Makefile.in) = e4f93496379202ac25ae1909351fea6532989078
BLAKE2s (din-52.tar.gz) = 02740e8e2c7bb458e02bedb3eb9f87d39230183e29f7e77c02e1535504da602a
SHA512 (din-52.tar.gz) = c2ec779746d07ad6579aeebadff45e218fd29715ac446f00840b513d3f9c8d1ef79f556a1f5c7d931adb3451b547f58fb58d6da699170755ae62f25d70b95158
Size (din-52.tar.gz) = 3706694 bytes
SHA1 (patch-src_Makefile.am) = 522d3378ebae332e0eaedee8eb60d3cd091653c0
SHA1 (patch-src_Makefile.in) = 3135bd8315cfdd65e7d885fc80f4baa89b7d94dc

View file

@ -1,17 +1,17 @@
$NetBSD: patch-src_Makefile.am,v 1.11 2021/07/12 14:58:35 fox Exp $
$NetBSD: patch-src_Makefile.am,v 1.12 2021/12/12 23:26:01 fox Exp $
Removed tcl8.6, asound and jack flags, this is now handled in the pkgsrc
script.
--- src/Makefile.am.orig 2021-07-12 01:15:59.000000000 +0000
--- src/Makefile.am.orig 2021-12-04 02:58:55.000000000 +0000
+++ src/Makefile.am
@@ -1,7 +1,7 @@
#dinincludedir = $(pkgsrcdir)
-AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -D __BOOST_TIME__ -DPREFIX=\"@prefix@\"
-AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
-LIBS += -ltcl8.6 -lSDL -lGL -lpthread -lasound
+AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -D __BOOST_TIME__ -DPREFIX=\"@prefix@\"
+LIBS += -lSDL -lGL -lpthread -lasound
+AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
+LIBS += -lSDL -lGL -lpthread
bin_PROGRAMS = din
din_SOURCES = alarm.cc arrow_button.cc audio.cc authors_note.cc ball.cc ball_ops.cc basic_editor.cc beat2value.cc binaural_drone.cc binaural_drones.cc bit_display.cc box_selector.cc button.cc capturer.cc checkbutton.cc chrono.cc circler.cc command.cc compressor.cc console.cc console_iterator.cc countries.cc cross_button.cc curve.cc curve_display.cc curve_editor.cc curve_library.cc curve_mixer.cc curve_picker.cc curve_samples.cc custom_periodic.cc delay.cc din.cc din_info.cc drawrrow.cc drone.cc eval.cc fader.cc fft.cc field.cc filled_button.cc font.cc font_editor.cc fractaliser.cc globals.cc glyph.cc gravity.cc hit.cc help.cc item_list.cc keyboard_keyboard.cc label.cc levels.cc line.cc lissajous.cc listeners.cc main.cc menu.cc mesh.cc midi_in.cc minus_button.cc mocap.cc modulator.cc mondrian.cc morpher.cc morse_code.cc mouse_slider.cc multi_curve.cc note.cc noiser.cc number.cc oscilloscope.cc phrasor.cc play.cc plugin.cc plugin_browser.cc plus_button.cc point_modulator.cc range.cc recorder.cc rect.cc rose_milker.cc scale_info.cc scale_notes.cc scalelist.cc separator.cc settings.cc sine_mixer.cc slit.cc solver.cc spiraler.cc starrer.cc superformula.cc tap_bpm.cc tcl_interp.cc textboard.cc tokenizer.cc trail.cc triggered_note.cc ui.cc ui_sin_cos_radius.cc viewwin.cc warper.cc widget.cc kiss_fft.c RtAudio.cpp RtMidi.cpp
din_SOURCES = alarm.cc arrow_button.cc audio.cc authors_note.cc autoflip.cc autorotator.cc ball.cc ball_ops.cc basic_editor.cc beat2value.cc binaural_drone.cc binaural_drones.cc bit_display.cc box_selector.cc button.cc capturer.cc checkbutton.cc chrono.cc circler.cc command.cc compressor.cc console.cc console_iterator.cc countries.cc cross_button.cc curve.cc curve_display.cc curve_editor.cc curve_library.cc curve_mixer.cc curve_picker.cc curve_samples.cc custom_periodic.cc defvelaccel.cc delay.cc din.cc din_info.cc drawrrow.cc drone.cc eval.cc fader.cc fft.cc field.cc filled_button.cc font.cc font_editor.cc fractaliser.cc globals.cc glyph.cc gravity.cc hit.cc help.cc item_list.cc keyboard_keyboard.cc label.cc levels.cc line.cc lissajous.cc listeners.cc main.cc menu.cc mesh.cc midi_in.cc minus_button.cc mocap.cc modulator.cc mondrian.cc morpher.cc morse_code.cc mouse_slider.cc multi_curve.cc note.cc noiser.cc number.cc oscilloscope.cc phrasor.cc play.cc plugin.cc plugin_browser.cc plus_button.cc point_modulator.cc range.cc recorder.cc rect.cc rose_milker.cc scale_info.cc scale_notes.cc scalelist.cc separator.cc settings.cc sine_mixer.cc slit.cc solver.cc spiraler.cc starrer.cc superformula.cc tap_bpm.cc tcl_interp.cc textboard.cc tokenizer.cc trail.cc triggered_note.cc ui.cc ui_sin_cos_radius.cc viewwin.cc warper.cc widget.cc kiss_fft.c RtAudio.cpp RtMidi.cpp

View file

@ -1,10 +1,10 @@
$NetBSD: patch-src_Makefile.in,v 1.2 2019/09/14 16:08:32 fox Exp $
$NetBSD: patch-src_Makefile.in,v 1.3 2021/12/12 23:26:01 fox Exp $
Removed linker flags, it is now handled by the pkgsrc script.
--- src/Makefile.in.orig 2019-09-13 03:30:58.000000000 +0000
--- src/Makefile.in.orig 2021-12-12 12:44:12.475294365 +0000
+++ src/Makefile.in
@@ -236,7 +236,7 @@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
@@ -242,7 +242,7 @@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
LDFLAGS = @LDFLAGS@
LIBOBJS = @LIBOBJS@