Updated to 0.8.1.

Gauche-0.8.1 is a maintainance release of Gauche-0.8.
Gauche-0.8 release announce is cited here:

* *New Features*

    o Auxiliary scripts: Gauche now installs a few scripts
      that help to build and install extension packages. The
      gauche-package script handles download, unpacking,
      configuration, building and installation in one command
      invocation. See the description of "Using extension
      packages" section of the manual. (NB: this feature is
      still new and may have problems, but hey, let's give a
      try.) A couple of auxiliary scripts, gauche-cesconv and
      gauche-install can be called from Makefile. They don't
      have documentation yet, but try --help option for these
      scripts.

    o Module util.match: Andrew Wright's match macro is
      bundled. It is modified to handle Gauche's object system.

* *Improvements*

    o A couple of performance tuning were done for I/O and
      loading Scheme files.

    o Now you can subclass <error> class as well as
      <exception> class to define your own error type. A new
      built-in macro guard, which is SRFI-34 compliant, can be
      used to handle errors selectively. Eventually the errors
      from built-in procedures will have more structured
      exception hierarchy.

    o New built-in system procedures: sys-lchown, sys-realpath.

    o Built-in sort routines now have stable versions,
      stable-sort and stable-sort!.

    o New built-in macro: let/cc.

    o New built-in keyword procedures: delete-keyword, delete-keyword!.

    o New built-in regexp procedure: rxmatch-num-matches.

    o Module file.util: new procedures: file-is-symlink?,
      file->string, file->string-list, file->list, file->sexp-list.

    o Module gauche.net: documented the previously
      experimental procedures: socket-send, socket-sendto,
      socket-recv, socket-recvfrom, socket-getpeername,
      socket-getsockname. Now these are official procedures.

    o Module gauche.process: process-command wasn't exported,
      even though it was documented.

    o Module gauche.test: you can control whether the error in
      the test procedure is reported or not by an envioronment
      variable GAUCHE_TEST_REPORT_ERROR and a global variable
      *test-report-error*. Useful to find a problem during testing.

    o Module www.cgi: new procedure cgi-get-metavariables;
      allows the user routine to take metavariables via
      cgi-metavariables parameter, so that cgi scripts can be
      easily modularized.

    o Module gauche.parseopt: support of "optional
      option-argument" is added.

    o Module gauche.array: homogeneous numeric array types are added.

    o Module text.html-lite: added frame-related tags.

* *Bug Fixes*
 [snip]
This commit is contained in:
minoura 2004-08-08 07:05:38 +00:00
parent 2777d84d16
commit f007cb24a7
5 changed files with 37 additions and 6900 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.22 2004/07/18 10:49:49 recht Exp $
# $NetBSD: Makefile,v 1.23 2004/08/08 07:05:38 minoura Exp $
#
DISTNAME= Gauche-0.7.4.2
PKGREVISION= 1
DISTNAME= Gauche-0.8.1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gauche/}
EXTRACT_SUFX= .tgz
@ -28,6 +27,7 @@ GNU_CONFIGURE= yes
USE_BUILDLINK3= yes
CONFIGURE_ARGS+= --with-slib=${PREFIX}/share/slib
CONFIGURE_ARGS+= --with-iconv=${BUILDLINK_PREFIX.iconv}
CONFIGURE_ARGS+= --enable-threads=none # must match w/ boehm-gc
CONFIGURE_ENV+= AS="${CC} -x assembler-with-cpp -c"
_WITH_ICONV_LIB= ${BUILDLINK_LIBICONV_LDADD:M-l*:C/-l//}

View file

@ -1,10 +1,16 @@
@comment $NetBSD: PLIST,v 1.8 2004/03/29 09:34:26 kei Exp $
@comment $NetBSD: PLIST,v 1.9 2004/08/08 07:05:38 minoura Exp $
bin/gauche-cesconv
bin/gauche-config
bin/gauche-install
bin/gauche-package
bin/gosh
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/auxsys.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/binary.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/fcntl.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/gauche-cesconv
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/gauche-config
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/gauche-install
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/gauche-package
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/gosh
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/libcharconv.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/libgauche-uvector.so
@ -19,6 +25,7 @@ lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/termios.so
lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}/threads.so
lib/gauche/${PKGVERSION}/include/gauche.h
lib/gauche/${PKGVERSION}/include/gauche/arch.h
lib/gauche/${PKGVERSION}/include/gauche/builtin-syms.h
lib/gauche/${PKGVERSION}/include/gauche/char_euc_jp.h
lib/gauche/${PKGVERSION}/include/gauche/char_none.h
lib/gauche/${PKGVERSION}/include/gauche/char_sjis.h
@ -35,7 +42,8 @@ lib/gauche/${PKGVERSION}/include/gauche/uthread.h
lib/gauche/${PKGVERSION}/include/gauche/uvector.h
lib/gauche/${PKGVERSION}/include/gauche/vm.h
lib/gauche/${PKGVERSION}/include/gauche/vminsn.h
@exec ${MKDIR} %D/lib/gauche/site/${PKGVERSION}/${MACHINE_GNU_PLATFORM}
lib/libgauche.so.${PKGVERSION}
lib/libgauche.so.0
lib/libgauche.so
man/man1/gauche-config.1
man/man1/gosh.1
@ -67,7 +75,6 @@ share/gauche/${PKGVERSION}/lib/gauche/hook.scm
share/gauche/${PKGVERSION}/lib/gauche/interactive.scm
share/gauche/${PKGVERSION}/lib/gauche/interactive/info.scm
share/gauche/${PKGVERSION}/lib/gauche/interpolate.scm
share/gauche/${PKGVERSION}/lib/gauche/ioutil.scm
share/gauche/${PKGVERSION}/lib/gauche/let-opt.scm
share/gauche/${PKGVERSION}/lib/gauche/libutil.scm
share/gauche/${PKGVERSION}/lib/gauche/listener.scm
@ -75,6 +82,7 @@ share/gauche/${PKGVERSION}/lib/gauche/listutil.scm
share/gauche/${PKGVERSION}/lib/gauche/logger.scm
share/gauche/${PKGVERSION}/lib/gauche/logical.scm
share/gauche/${PKGVERSION}/lib/gauche/macroutil.scm
share/gauche/${PKGVERSION}/lib/gauche/matrix.scm
share/gauche/${PKGVERSION}/lib/gauche/modutil.scm
share/gauche/${PKGVERSION}/lib/gauche/mop/instance-pool.scm
share/gauche/${PKGVERSION}/lib/gauche/mop/propagate.scm
@ -83,6 +91,10 @@ share/gauche/${PKGVERSION}/lib/gauche/mop/validator.scm
share/gauche/${PKGVERSION}/lib/gauche/net.scm
share/gauche/${PKGVERSION}/lib/gauche/numerical.scm
share/gauche/${PKGVERSION}/lib/gauche/object.scm
share/gauche/${PKGVERSION}/lib/gauche/package.scm
share/gauche/${PKGVERSION}/lib/gauche/package/build.scm
share/gauche/${PKGVERSION}/lib/gauche/package/fetch.scm
share/gauche/${PKGVERSION}/lib/gauche/package/util.scm
share/gauche/${PKGVERSION}/lib/gauche/parameter.scm
share/gauche/${PKGVERSION}/lib/gauche/parseopt.scm
share/gauche/${PKGVERSION}/lib/gauche/portutil.scm
@ -193,16 +205,18 @@ share/gauche/${PKGVERSION}/lib/util/digest.scm
share/gauche/${PKGVERSION}/lib/util/isomorph.scm
share/gauche/${PKGVERSION}/lib/util/lcs.scm
share/gauche/${PKGVERSION}/lib/util/list.scm
share/gauche/${PKGVERSION}/lib/util/match.scm
share/gauche/${PKGVERSION}/lib/util/queue.scm
share/gauche/${PKGVERSION}/lib/util/record.scm
share/gauche/${PKGVERSION}/lib/util/toposort.scm
share/gauche/${PKGVERSION}/lib/util/tree.scm
share/gauche/${PKGVERSION}/lib/www/cgi-test.scm
share/gauche/${PKGVERSION}/lib/www/cgi.scm
@exec ${MKDIR} %D/share/gauche/site
@exec ${MKDIR} %D/share/gauche/site/lib
@dirrm share/gauche/site/lib
@dirrm share/gauche/site
@exec ${MKDIR} %D/lib/gauche/site 2>/dev/null || ${TRUE}
@exec ${MKDIR} %D/lib/gauche/site/${PKGVERSION} 2>/dev/null || ${TRUE}
@exec ${MKDIR} %D/lib/gauche/site/${PKGVERSION}/${MACHINE_GNU_PLATFORM} 2>/dev/null || ${TRUE}
@exec ${MKDIR} %D/share/gauche/site 2>/dev/null || ${TRUE}
@exec ${MKDIR} %D/share/gauche/site/lib 2>/dev/null || ${TRUE}
@dirrm share/gauche/${PKGVERSION}/lib/www
@dirrm share/gauche/${PKGVERSION}/lib/util
@dirrm share/gauche/${PKGVERSION}/lib/text
@ -216,6 +230,7 @@ share/gauche/${PKGVERSION}/lib/www/cgi.scm
@dirrm share/gauche/${PKGVERSION}/lib/math
@dirrm share/gauche/${PKGVERSION}/lib/gauche/vm
@dirrm share/gauche/${PKGVERSION}/lib/gauche/serializer
@dirrm share/gauche/${PKGVERSION}/lib/gauche/package
@dirrm share/gauche/${PKGVERSION}/lib/gauche/mop
@dirrm share/gauche/${PKGVERSION}/lib/gauche/interactive
@dirrm share/gauche/${PKGVERSION}/lib/gauche
@ -225,13 +240,15 @@ share/gauche/${PKGVERSION}/lib/www/cgi.scm
@dirrm share/gauche/${PKGVERSION}/lib/binary
@dirrm share/gauche/${PKGVERSION}/lib
@dirrm share/gauche/${PKGVERSION}
@dirrm share/gauche
@unexec ${RMDIR} %D/share/aclocal 2>/dev/null || ${TRUE}
@dirrm lib/gauche/site/${PKGVERSION}/${MACHINE_GNU_PLATFORM}
@dirrm lib/gauche/site/${PKGVERSION}
@dirrm lib/gauche/site
@dirrm lib/gauche/${PKGVERSION}/include/gauche
@dirrm lib/gauche/${PKGVERSION}/include
@dirrm lib/gauche/${PKGVERSION}/i386--netbsdelf
@dirrm lib/gauche/${PKGVERSION}/${MACHINE_GNU_PLATFORM}
@dirrm lib/gauche/${PKGVERSION}
@dirrm lib/gauche
@unexec ${RMDIR} %D/share/gauche/site/lib 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/share/gauche/site 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/share/gauche 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/share/aclocal 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/lib/gauche/site/${PKGVERSION}/${MACHINE_GNU_PLATFORM} 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/lib/gauche/site/${PKGVERSION} 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/lib/gauche/site 2>/dev/null || ${TRUE}
@unexec ${RMDIR} %D/lib/gauche 2>/dev/null || ${TRUE}

View file

@ -1,9 +1,7 @@
$NetBSD: distinfo,v 1.12 2004/06/02 13:57:33 minoura Exp $
$NetBSD: distinfo,v 1.13 2004/08/08 07:05:38 minoura Exp $
SHA1 (Gauche-0.7.4.2.tgz) = 87a48aa152ff1bda149453a2320e73e792db6cff
Size (Gauche-0.7.4.2.tgz) = 2401071 bytes
SHA1 (Gauche-0.8.1.tgz) = 5ea6742fabcef9eecacece67a07c94e05fffad3a
Size (Gauche-0.8.1.tgz) = 2595068 bytes
SHA1 (patch-aa) = 81a351b08cbd957242f88eb43d26c65ba95fe2f2
SHA1 (patch-ab) = c08f8b9fbed9d9f41cddfddb386a756e8bd322cc
SHA1 (patch-ac) = ba544ffef3b59d824033ada5c1fb050066613db7
SHA1 (patch-ad) = 57fcc3d5acd2ba619c68c58b988d8c7cd720356f
SHA1 (patch-ae) = eeb04ddbe45d2c06ba185e4f48dc77095819c8dc

File diff suppressed because it is too large Load diff

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ae,v 1.8 2004/06/02 13:56:56 minoura Exp $
Patch already submitted to the author.
--- doc/extract.orig 2004-01-19 22:28:35.000000000 +0000
+++ doc/extract 2004-05-24 08:47:17.000000000 +0000
@@ -67,7 +67,7 @@
(process-header cmd header) (in (read-line)))
(#/^\* ([^:]+)::(.*)?/ (#f node desc)
(process-menu node #f desc) (in (read-line)))
- (#/^\* ([^:]+):\s+([^.]+)\.(.*)?/ (#f tag node desc)
+ (#/^\* ([^:]+):\s+([^)]+\))\.(.*)?/ (#f tag node desc)
(process-menu node tag desc) (in (read-line)))
(else (display
(regexp-replace-all #/@VERSION@/