Reorder the linker tests in the configure script so that we test for
C libraries *before* we throw the AC_LANG([C++]) switch. This makes the generated configure script use the C compiler/linker instead of the C++ compiler/linker when running tests. This avoids errors like these based on not correctly getting the function signature correct: conftest.cc:36: error: nonnull argument with out-of-range operand number (arg 1, operand 2) This error was causing the configure script to not detect *gettext() routines and not building and installing the *.mo files. This fixes the error noted in the bulk build results: http://mail-index.netbsd.org/pkgsrc-bulk/2006/06/20/0000.html
This commit is contained in:
parent
36c6544bba
commit
f025f43fc4
15 changed files with 20715 additions and 26 deletions
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.4 2006/06/14 20:14:21 adam Exp $
|
||||
$NetBSD: distinfo,v 1.5 2006/06/22 18:52:00 jlam Exp $
|
||||
|
||||
SHA1 (qalculate-bases-0.9.4.tar.gz) = 71f4071bfd6217eb30788c41e95c531cca55b610
|
||||
RMD160 (qalculate-bases-0.9.4.tar.gz) = be0c2e11eaca3dfce064b751903249486264f857
|
||||
Size (qalculate-bases-0.9.4.tar.gz) = 368685 bytes
|
||||
SHA1 (patch-aa) = 8bafc00b8daa26fe72c88f7415f8dceaf748b3e1
|
||||
SHA1 (patch-ab) = f162586746600d18621068ca6af94c9f00f559dd
|
||||
|
|
3957
math/qalculate-bases/patches/patch-aa
Normal file
3957
math/qalculate-bases/patches/patch-aa
Normal file
File diff suppressed because it is too large
Load diff
72
math/qalculate-bases/patches/patch-ab
Normal file
72
math/qalculate-bases/patches/patch-ab
Normal file
|
@ -0,0 +1,72 @@
|
|||
$NetBSD: patch-ab,v 1.1 2006/06/22 18:52:00 jlam Exp $
|
||||
|
||||
--- configure.in.orig 2006-04-18 03:13:35.000000000 -0400
|
||||
+++ configure.in
|
||||
@@ -54,7 +54,33 @@ if test "x$GCC" = "xyes"; then
|
||||
fi
|
||||
changequote([,])dnl
|
||||
|
||||
+dnl -------------------------------------
|
||||
+dnl | internationalization (i18n) support |------------------------------------
|
||||
+dnl -------------------------------------
|
||||
+
|
||||
+GETTEXT_PACKAGE=qalculate-bases
|
||||
+AC_SUBST(GETTEXT_PACKAGE)
|
||||
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
|
||||
|
||||
+dnl Please keep this in alphabetical order
|
||||
+ALL_LINGUAS="nl sv"
|
||||
+AM_GLIB_GNU_GETTEXT
|
||||
+
|
||||
+dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
|
||||
+AC_MSG_CHECKING(locale directory)
|
||||
+if test "x$prefix" = "xNONE"; then
|
||||
+ PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
|
||||
+else
|
||||
+ PACKAGE_LOCALE_DIR=$prefix/share/locale
|
||||
+fi
|
||||
+
|
||||
+AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
|
||||
+ [The directory in which qalculate's locale data will be stored])
|
||||
+ AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
|
||||
+
|
||||
+INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
|
||||
+AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
|
||||
+
|
||||
dnl --------------------------------
|
||||
dnl | check for neccessary libraries |-----------------------------------------
|
||||
dnl --------------------------------
|
||||
@@ -89,33 +115,6 @@ PKG_CHECK_MODULES(QALCULATE, [
|
||||
AC_SUBST(QALCULATE_CFLAGS)
|
||||
AC_SUBST(QALCULATE_LIBS)
|
||||
|
||||
-dnl -------------------------------------
|
||||
-dnl | internationalization (i18n) support |------------------------------------
|
||||
-dnl -------------------------------------
|
||||
-
|
||||
-GETTEXT_PACKAGE=qalculate-bases
|
||||
-AC_SUBST(GETTEXT_PACKAGE)
|
||||
-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
|
||||
-
|
||||
-dnl Please keep this in alphabetical order
|
||||
-ALL_LINGUAS="nl sv"
|
||||
-AM_GLIB_GNU_GETTEXT
|
||||
-
|
||||
-dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
|
||||
-AC_MSG_CHECKING(locale directory)
|
||||
-if test "x$prefix" = "xNONE"; then
|
||||
- PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
|
||||
-else
|
||||
- PACKAGE_LOCALE_DIR=$prefix/share/locale
|
||||
-fi
|
||||
-
|
||||
-AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
|
||||
- [The directory in which qalculate's locale data will be stored])
|
||||
- AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
|
||||
-
|
||||
-INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
|
||||
-AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
|
||||
-
|
||||
dnl --------
|
||||
dnl | output |-----------------------------------------------------------------
|
||||
dnl --------
|
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.4 2006/06/14 20:14:21 adam Exp $
|
||||
$NetBSD: distinfo,v 1.5 2006/06/22 18:52:00 jlam Exp $
|
||||
|
||||
SHA1 (qalculate-currency-0.9.4.tar.gz) = 8352fd1bc8434299e4c3a1111f1b6b275246ee0f
|
||||
RMD160 (qalculate-currency-0.9.4.tar.gz) = fa7a52c922ed0c01494e43b6a9c971124a9856cb
|
||||
Size (qalculate-currency-0.9.4.tar.gz) = 370506 bytes
|
||||
SHA1 (patch-aa) = 40d2dcb92b1affa6df71679cfce4027291fcd894
|
||||
SHA1 (patch-ab) = 06824dc714d112ce6ed422f550939ae802e2452b
|
||||
|
|
3972
math/qalculate-currency/patches/patch-aa
Normal file
3972
math/qalculate-currency/patches/patch-aa
Normal file
File diff suppressed because it is too large
Load diff
72
math/qalculate-currency/patches/patch-ab
Normal file
72
math/qalculate-currency/patches/patch-ab
Normal file
|
@ -0,0 +1,72 @@
|
|||
$NetBSD: patch-ab,v 1.1 2006/06/22 18:52:00 jlam Exp $
|
||||
|
||||
--- configure.in.orig 2006-04-18 03:13:20.000000000 -0400
|
||||
+++ configure.in
|
||||
@@ -55,6 +55,33 @@ fi
|
||||
changequote([,])dnl
|
||||
|
||||
|
||||
+dnl -------------------------------------
|
||||
+dnl | internationalization (i18n) support |------------------------------------
|
||||
+dnl -------------------------------------
|
||||
+
|
||||
+GETTEXT_PACKAGE=qalculate-currency
|
||||
+AC_SUBST(GETTEXT_PACKAGE)
|
||||
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
|
||||
+
|
||||
+dnl Please keep this in alphabetical order
|
||||
+ALL_LINGUAS="nl sv"
|
||||
+AM_GLIB_GNU_GETTEXT
|
||||
+
|
||||
+dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
|
||||
+AC_MSG_CHECKING(locale directory)
|
||||
+if test "x$prefix" = "xNONE"; then
|
||||
+ PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
|
||||
+else
|
||||
+ PACKAGE_LOCALE_DIR=$prefix/share/locale
|
||||
+fi
|
||||
+
|
||||
+AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
|
||||
+ [The directory in which qalculate's locale data will be stored])
|
||||
+ AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
|
||||
+
|
||||
+INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
|
||||
+AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
|
||||
+
|
||||
dnl --------------------------------
|
||||
dnl | check for neccessary libraries |-----------------------------------------
|
||||
dnl --------------------------------
|
||||
@@ -89,33 +116,6 @@ PKG_CHECK_MODULES(QALCULATE, [
|
||||
AC_SUBST(QALCULATE_CFLAGS)
|
||||
AC_SUBST(QALCULATE_LIBS)
|
||||
|
||||
-dnl -------------------------------------
|
||||
-dnl | internationalization (i18n) support |------------------------------------
|
||||
-dnl -------------------------------------
|
||||
-
|
||||
-GETTEXT_PACKAGE=qalculate-currency
|
||||
-AC_SUBST(GETTEXT_PACKAGE)
|
||||
-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
|
||||
-
|
||||
-dnl Please keep this in alphabetical order
|
||||
-ALL_LINGUAS="nl sv"
|
||||
-AM_GLIB_GNU_GETTEXT
|
||||
-
|
||||
-dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
|
||||
-AC_MSG_CHECKING(locale directory)
|
||||
-if test "x$prefix" = "xNONE"; then
|
||||
- PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
|
||||
-else
|
||||
- PACKAGE_LOCALE_DIR=$prefix/share/locale
|
||||
-fi
|
||||
-
|
||||
-AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
|
||||
- [The directory in which qalculate's locale data will be stored])
|
||||
- AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
|
||||
-
|
||||
-INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
|
||||
-AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
|
||||
-
|
||||
dnl --------
|
||||
dnl | output |-----------------------------------------------------------------
|
||||
dnl --------
|
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.6 2006/06/14 20:14:21 adam Exp $
|
||||
$NetBSD: distinfo,v 1.7 2006/06/22 18:52:00 jlam Exp $
|
||||
|
||||
SHA1 (qalculate-gtk-0.9.4.tar.gz) = 1cf5219d7f5c5375468e521a0784eb186ebe1253
|
||||
RMD160 (qalculate-gtk-0.9.4.tar.gz) = 3cf72bc37e04548f7174909648dcee43c1c18dff
|
||||
Size (qalculate-gtk-0.9.4.tar.gz) = 1546220 bytes
|
||||
SHA1 (patch-aa) = a8f186eb76a16d6f2b6329da50a2bbd07994414c
|
||||
SHA1 (patch-ab) = 0c814667e326b0660f98dcceea6e569ccd182084
|
||||
SHA1 (patch-ac) = a28ab9767be4e7a46ac32a284c1040ee9cdaf695
|
||||
|
|
4437
math/qalculate-gtk/patches/patch-ab
Normal file
4437
math/qalculate-gtk/patches/patch-ab
Normal file
File diff suppressed because it is too large
Load diff
76
math/qalculate-gtk/patches/patch-ac
Normal file
76
math/qalculate-gtk/patches/patch-ac
Normal file
|
@ -0,0 +1,76 @@
|
|||
$NetBSD: patch-ac,v 1.1 2006/06/22 18:52:00 jlam Exp $
|
||||
|
||||
--- configure.in.orig 2006-04-13 06:27:37.000000000 -0400
|
||||
+++ configure.in
|
||||
@@ -55,6 +55,35 @@ fi
|
||||
changequote([,])dnl
|
||||
|
||||
|
||||
+dnl -------------------------------------
|
||||
+dnl | internationalization (i18n) support |------------------------------------
|
||||
+dnl -------------------------------------
|
||||
+
|
||||
+GETTEXT_PACKAGE=qalculate-gtk
|
||||
+AC_SUBST(GETTEXT_PACKAGE)
|
||||
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
|
||||
+
|
||||
+dnl Please keep this in alphabetical order
|
||||
+ALL_LINGUAS="nl sv"
|
||||
+AM_GLIB_GNU_GETTEXT
|
||||
+
|
||||
+dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
|
||||
+AC_MSG_CHECKING(locale directory)
|
||||
+if test "x$prefix" = "xNONE"; then
|
||||
+ PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
|
||||
+else
|
||||
+ PACKAGE_LOCALE_DIR=$prefix/share/locale
|
||||
+fi
|
||||
+
|
||||
+AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
|
||||
+ [The directory in which qalculate's locale data will be stored])
|
||||
+ AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
|
||||
+
|
||||
+
|
||||
+
|
||||
+INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
|
||||
+AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
|
||||
+
|
||||
dnl --------------------------------
|
||||
dnl | check for neccessary libraries |-----------------------------------------
|
||||
dnl --------------------------------
|
||||
@@ -123,35 +152,6 @@ AC_SUBST(QALCULATE_GTK)
|
||||
|
||||
AC_SUBST(LN_QALCULATE)
|
||||
|
||||
-dnl -------------------------------------
|
||||
-dnl | internationalization (i18n) support |------------------------------------
|
||||
-dnl -------------------------------------
|
||||
-
|
||||
-GETTEXT_PACKAGE=qalculate-gtk
|
||||
-AC_SUBST(GETTEXT_PACKAGE)
|
||||
-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
|
||||
-
|
||||
-dnl Please keep this in alphabetical order
|
||||
-ALL_LINGUAS="nl sv"
|
||||
-AM_GLIB_GNU_GETTEXT
|
||||
-
|
||||
-dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
|
||||
-AC_MSG_CHECKING(locale directory)
|
||||
-if test "x$prefix" = "xNONE"; then
|
||||
- PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
|
||||
-else
|
||||
- PACKAGE_LOCALE_DIR=$prefix/share/locale
|
||||
-fi
|
||||
-
|
||||
-AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
|
||||
- [The directory in which qalculate's locale data will be stored])
|
||||
- AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
|
||||
-
|
||||
-
|
||||
-
|
||||
-INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
|
||||
-AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
|
||||
-
|
||||
dnl --------
|
||||
dnl | output |-----------------------------------------------------------------
|
||||
dnl --------
|
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.4 2006/06/14 20:14:21 adam Exp $
|
||||
$NetBSD: distinfo,v 1.5 2006/06/22 18:52:00 jlam Exp $
|
||||
|
||||
SHA1 (qalculate-units-0.9.4.tar.gz) = 1a6c124e572671973be9d249aba682e745f01f91
|
||||
RMD160 (qalculate-units-0.9.4.tar.gz) = 621636ecc487b71a85f7e6f9785e275ed2ac2e17
|
||||
Size (qalculate-units-0.9.4.tar.gz) = 375642 bytes
|
||||
SHA1 (patch-aa) = b345c2bfdee5c3000ae23f6f77b7ef7e491fa385
|
||||
SHA1 (patch-ab) = a5500e60ffd51c40ed266ae7c26faf7b6e441234
|
||||
|
|
3972
math/qalculate-units/patches/patch-aa
Normal file
3972
math/qalculate-units/patches/patch-aa
Normal file
File diff suppressed because it is too large
Load diff
72
math/qalculate-units/patches/patch-ab
Normal file
72
math/qalculate-units/patches/patch-ab
Normal file
|
@ -0,0 +1,72 @@
|
|||
$NetBSD: patch-ab,v 1.1 2006/06/22 18:52:01 jlam Exp $
|
||||
|
||||
--- configure.in.orig 2006-04-18 03:13:12.000000000 -0400
|
||||
+++ configure.in
|
||||
@@ -55,6 +55,33 @@ fi
|
||||
changequote([,])dnl
|
||||
|
||||
|
||||
+dnl -------------------------------------
|
||||
+dnl | internationalization (i18n) support |------------------------------------
|
||||
+dnl -------------------------------------
|
||||
+
|
||||
+GETTEXT_PACKAGE=qalculate-units
|
||||
+AC_SUBST(GETTEXT_PACKAGE)
|
||||
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
|
||||
+
|
||||
+dnl Please keep this in alphabetical order
|
||||
+ALL_LINGUAS="nl sv"
|
||||
+AM_GLIB_GNU_GETTEXT
|
||||
+
|
||||
+dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
|
||||
+AC_MSG_CHECKING(locale directory)
|
||||
+if test "x$prefix" = "xNONE"; then
|
||||
+ PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
|
||||
+else
|
||||
+ PACKAGE_LOCALE_DIR=$prefix/share/locale
|
||||
+fi
|
||||
+
|
||||
+AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
|
||||
+ [The directory in which qalculate's locale data will be stored])
|
||||
+ AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
|
||||
+
|
||||
+INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
|
||||
+AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
|
||||
+
|
||||
dnl --------------------------------
|
||||
dnl | check for neccessary libraries |-----------------------------------------
|
||||
dnl --------------------------------
|
||||
@@ -89,33 +116,6 @@ PKG_CHECK_MODULES(QALCULATE, [
|
||||
AC_SUBST(QALCULATE_CFLAGS)
|
||||
AC_SUBST(QALCULATE_LIBS)
|
||||
|
||||
-dnl -------------------------------------
|
||||
-dnl | internationalization (i18n) support |------------------------------------
|
||||
-dnl -------------------------------------
|
||||
-
|
||||
-GETTEXT_PACKAGE=qalculate-units
|
||||
-AC_SUBST(GETTEXT_PACKAGE)
|
||||
-AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[The package name for gettext])
|
||||
-
|
||||
-dnl Please keep this in alphabetical order
|
||||
-ALL_LINGUAS="nl sv"
|
||||
-AM_GLIB_GNU_GETTEXT
|
||||
-
|
||||
-dnl AM_GLIB_GNU_GETTEXT sets $DATADIRNAME
|
||||
-AC_MSG_CHECKING(locale directory)
|
||||
-if test "x$prefix" = "xNONE"; then
|
||||
- PACKAGE_LOCALE_DIR=$ac_default_prefix/share/locale
|
||||
-else
|
||||
- PACKAGE_LOCALE_DIR=$prefix/share/locale
|
||||
-fi
|
||||
-
|
||||
-AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "$PACKAGE_LOCALE_DIR",
|
||||
- [The directory in which qalculate's locale data will be stored])
|
||||
- AC_MSG_RESULT("$PACKAGE_LOCALE_DIR")
|
||||
-
|
||||
-INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
|
||||
-AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
|
||||
-
|
||||
dnl --------
|
||||
dnl | output |-----------------------------------------------------------------
|
||||
dnl --------
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.12 2006/06/14 20:14:21 adam Exp $
|
||||
$NetBSD: distinfo,v 1.13 2006/06/22 18:52:00 jlam Exp $
|
||||
|
||||
SHA1 (libqalculate-0.9.4.tar.gz) = 78468f5a0329b01e146a71ff8d1b9b823ed52262
|
||||
RMD160 (libqalculate-0.9.4.tar.gz) = 8d14a0ac6790eeab0d8fe2d7b8f87381d1ad223c
|
||||
Size (libqalculate-0.9.4.tar.gz) = 1055947 bytes
|
||||
SHA1 (patch-aa) = fda2983150bbbdecc1578e747d8a6aa7ef965f3f
|
||||
SHA1 (patch-ab) = bdc1a55f186ce7ab8c9ccb470d6d02f5ab10e483
|
||||
SHA1 (patch-ab) = 9888beca031650259fcb4f194e2ead39c73a9a70
|
||||
SHA1 (patch-ac) = 98e817d60fc4cd521e7d227ecd330364ec072ecd
|
||||
SHA1 (patch-ad) = 192adfe4ca7c0752109e02cce3ce74a385554176
|
||||
|
|
File diff suppressed because it is too large
Load diff
62
math/qalculate/patches/patch-ad
Normal file
62
math/qalculate/patches/patch-ad
Normal file
|
@ -0,0 +1,62 @@
|
|||
$NetBSD: patch-ad,v 1.1 2006/06/22 18:52:00 jlam Exp $
|
||||
|
||||
--- configure.in.orig 2006-04-13 06:24:58.000000000 -0400
|
||||
+++ configure.in
|
||||
@@ -84,28 +84,6 @@ AC_SUBST(QALCULATE_AGE)
|
||||
|
||||
|
||||
dnl --------------------------------
|
||||
-dnl | check for neccessary libraries |-----------------------------------------
|
||||
-dnl --------------------------------
|
||||
-
|
||||
-AC_CHECK_LIB(pthread, pthread_create, [LIBS="$LIBS -lpthread"])
|
||||
-
|
||||
-AC_LANG([C++])
|
||||
-
|
||||
-AC_PATH_CLN(1.1.0, [
|
||||
- LIBS="$LIBS $CLN_LIBS"
|
||||
- CPPFLAGS="$CPPFLAGS $CLN_CPPFLAGS"
|
||||
- AC_DEFINE(HAVE_LIBCLN,1,[If CLN can be used])
|
||||
-], AC_MSG_ERROR([No suitable installed version of CLN could be found.]))
|
||||
-
|
||||
-
|
||||
-PKG_CHECK_MODULES(GLIB, [
|
||||
- glib-2.0
|
||||
- libxml-2.0 >= 2.3.8
|
||||
- ])
|
||||
-AC_SUBST(GLIB_CFLAGS)
|
||||
-AC_SUBST(GLIB_LIBS)
|
||||
-
|
||||
-dnl --------------------------------
|
||||
dnl | check for readline |-----------------------------------------
|
||||
dnl --------------------------------
|
||||
|
||||
@@ -230,6 +208,28 @@ AC_DEFINE_UNQUOTED(PACKAGE_LOCALE_DIR, "
|
||||
INTLTOOL_QALCULATE_DEFINITIONS_RULE='%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po-defs/*.po) ; LC_ALL=C $(INTLTOOL_MERGE) -x -u -c $(top_builddir)/po-defs/.intltool-merge-cache $(top_srcdir)/po-defs $< [$]@'
|
||||
AC_SUBST(INTLTOOL_QALCULATE_DEFINITIONS_RULE)
|
||||
|
||||
+dnl --------------------------------
|
||||
+dnl | check for neccessary libraries |-----------------------------------------
|
||||
+dnl --------------------------------
|
||||
+
|
||||
+AC_CHECK_LIB(pthread, pthread_create, [LIBS="$LIBS -lpthread"])
|
||||
+
|
||||
+AC_LANG([C++])
|
||||
+
|
||||
+AC_PATH_CLN(1.1.0, [
|
||||
+ LIBS="$LIBS $CLN_LIBS"
|
||||
+ CPPFLAGS="$CPPFLAGS $CLN_CPPFLAGS"
|
||||
+ AC_DEFINE(HAVE_LIBCLN,1,[If CLN can be used])
|
||||
+], AC_MSG_ERROR([No suitable installed version of CLN could be found.]))
|
||||
+
|
||||
+
|
||||
+PKG_CHECK_MODULES(GLIB, [
|
||||
+ glib-2.0
|
||||
+ libxml-2.0 >= 2.3.8
|
||||
+ ])
|
||||
+AC_SUBST(GLIB_CFLAGS)
|
||||
+AC_SUBST(GLIB_LIBS)
|
||||
+
|
||||
dnl --------
|
||||
dnl | output |-----------------------------------------------------------------
|
||||
dnl --------
|
Loading…
Reference in a new issue