Mixing _XOPEN_SOURCE=500 and _XOPEN_SOURCE=600 in the same package

is asking for trouble. On solaris these options are mutually exclusive
because 600 needs C99 and 500 is not allowed to use C99.

I lowered the requirement to _XOPEN_SOURCE=500 and the build succeeded.

While here I'll note that PR pkg/42897 (netbpm link error on Solaris 10)
should now be fixed by libpng-1.2.41nb1.
This commit is contained in:
tnn 2010-03-04 11:01:01 +00:00
parent 7e67628a81
commit f02a9d99f4
3 changed files with 15 additions and 13 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.72 2010/02/19 18:25:44 drochner Exp $
$NetBSD: distinfo,v 1.73 2010/03/04 11:01:01 tnn Exp $
SHA1 (netpbm-10.35.73.tgz) = e498fcedbc88c618e69163cdb9fa782178a1645e
RMD160 (netpbm-10.35.73.tgz) = b4507ac7897227bf0fb8addceb9a14c9f4601ee8
@ -13,8 +13,8 @@ SHA1 (patch-aw) = bd890324e95fa7bb893d9d5cdab9d5a33dcff777
SHA1 (patch-ax) = d50e56191192b4caf423ed081581868bb1a63de8
SHA1 (patch-ay) = 60ab532de6d6ec498ada140f795bba327a562e13
SHA1 (patch-cb) = b1be33ae6acfe57bf2f407cd48a6b140c3ddea85
SHA1 (patch-da) = 5580d9cf0336b6a28010d1448e2749db9ea2ff5d
SHA1 (patch-db) = e087de63043bbae5f45afd17c742fa603188cae4
SHA1 (patch-da) = 8ae329469bf0bd55b671dffeb4253b8d14621f5c
SHA1 (patch-db) = 23a05e54043ee84a0b7ec507a383d5cd8adfcca5
SHA1 (patch-dc) = 8ed1365dccf5abb0e158a4f7a65749ff5b244ef3
SHA1 (patch-dd) = 2acbcffeef96fd8b0419e60fa44a1eaf9f4b291b
SHA1 (patch-eb) = 5c3dfac08038fce372fabc7c526081bb8051e908

View file

@ -1,15 +1,16 @@
$NetBSD: patch-da,v 1.2 2010/02/19 18:25:44 drochner Exp $
$NetBSD: patch-da,v 1.3 2010/03/04 11:01:01 tnn Exp $
--- converter/other/jpeg2000/pamtojpeg2k.c.orig 2007-12-27 22:32:59.000000000 +0000
+++ converter/other/jpeg2000/pamtojpeg2k.c
--- converter/other/jpeg2000/jpeg2ktopam.c.orig 2007-12-27 22:32:59.000000000 +0000
+++ converter/other/jpeg2000/jpeg2ktopam.c
@@ -10,7 +10,11 @@
#define _BSD_SOURCE 1 /* Make sure strdup() is in string.h */
#define _BSD_SOURCE 1 /* Make sure strdup() is in string.h */
/* Make sure strdup() is in string.h and int_fast32_t is in inttypes.h */
-#define _XOPEN_SOURCE 600
+#ifdef __osf__
+#define _OSF_SOURCE
+#else
#define _XOPEN_SOURCE 600
+#define _XOPEN_SOURCE 500
+#endif /* __osf__ */
#include <string.h>

View file

@ -1,15 +1,16 @@
$NetBSD: patch-db,v 1.2 2010/02/19 18:25:44 drochner Exp $
$NetBSD: patch-db,v 1.3 2010/03/04 11:01:01 tnn Exp $
--- converter/other/jpeg2000/jpeg2ktopam.c.orig 2007-12-27 22:32:59.000000000 +0000
+++ converter/other/jpeg2000/jpeg2ktopam.c
--- converter/other/jpeg2000/pamtojpeg2k.c.orig 2007-12-27 22:32:59.000000000 +0000
+++ converter/other/jpeg2000/pamtojpeg2k.c
@@ -10,7 +10,11 @@
#define _BSD_SOURCE 1 /* Make sure strdup() is in string.h */
#define _BSD_SOURCE 1 /* Make sure strdup() is in string.h */
/* Make sure strdup() is in string.h and int_fast32_t is in inttypes.h */
-#define _XOPEN_SOURCE 600
+#ifdef __osf__
+#define _OSF_SOURCE
+#else
#define _XOPEN_SOURCE 600
+#define _XOPEN_SOURCE 500
+#endif /* __osf__ */
#include <string.h>