Update to 1.4.1:
Included hunspell upgraded to 1.2.2, pkgsrc patches integrated.
This commit is contained in:
parent
ab1b7cb653
commit
f02e2dd337
4 changed files with 7 additions and 75 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.25 2008/04/17 21:07:18 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.26 2008/04/22 19:32:18 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= enchant-1.4.0
|
||||
PKGREVISION= 2
|
||||
DISTNAME= enchant-1.4.1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www.abisource.com/downloads/enchant/1.4.0/
|
||||
MASTER_SITES= http://www.abisource.com/downloads/enchant/1.4.1/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.abisource.com/projects/enchant/
|
||||
|
@ -22,9 +21,6 @@ CFLAGS.SunOS+= -D__EXTENSIONS__
|
|||
|
||||
CONFIGURE_ARGS+= --with-myspell-dir=${BUILDLINK_PREFIX.hunspell}/share/hunspell
|
||||
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && autoconf
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.11 2008/04/17 21:07:18 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.12 2008/04/22 19:32:18 wiz Exp $
|
||||
|
||||
SHA1 (enchant-1.4.0.tar.gz) = 1a3c140c96769d3268a7f1faf7d9400016985537
|
||||
RMD160 (enchant-1.4.0.tar.gz) = 84a253e665f71ba5b3277ad95a403ea386d42ba4
|
||||
Size (enchant-1.4.0.tar.gz) = 601930 bytes
|
||||
SHA1 (patch-aa) = 56ca983fdd6de171aba956b46c673299dcb7549e
|
||||
SHA1 (patch-ab) = fd2319dd225493d643facb8fbe7f88dee810b1db
|
||||
SHA1 (enchant-1.4.1.tar.gz) = 73a194faae887e3d2e62fb45b9f1089c0c37e840
|
||||
RMD160 (enchant-1.4.1.tar.gz) = 7ee91e8971fd5a6691aa2d7a94b06e5f6845cf8a
|
||||
Size (enchant-1.4.1.tar.gz) = 605550 bytes
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2008/04/17 14:29:58 wiz Exp $
|
||||
|
||||
http://bugzilla.abisource.com/show_bug.cgi?id=11551
|
||||
|
||||
--- configure.in.orig 2008-03-31 19:47:43.000000000 +0200
|
||||
+++ configure.in
|
||||
@@ -75,18 +75,18 @@ AC_DEFUN([ENCHANT_CXX_TRY_FLAG], [
|
||||
AC_MSG_CHECKING([whether $CXX supports $1])
|
||||
|
||||
AC_LANG_PUSH(C++)
|
||||
- enchant_save_CFLAGS="$CFLAGS"
|
||||
- CFLAGS="$CFLAGS $1"
|
||||
+ enchant_save_CXXFLAGS="$CXXFLAGS"
|
||||
+ CXXFLAGS="$CXXFLAGS $1"
|
||||
|
||||
- AC_COMPILE_IFELSE([ ], [enchant_cc_flag=yes], [enchant_cc_flag=no])
|
||||
- CFLAGS="$enchant_save_CFLAGS"
|
||||
+ AC_COMPILE_IFELSE([ ], [enchant_cxx_flag=yes], [enchant_cxx_flag=no])
|
||||
+ CXXFLAGS="$enchant_save_CXXFLAGS"
|
||||
|
||||
- if test "x$enchant_cc_flag" = "xyes"; then
|
||||
+ if test "x$enchant_cxx_flag" = "xyes"; then
|
||||
ifelse([$2], , :, [$2])
|
||||
else
|
||||
ifelse([$3], , :, [$3])
|
||||
fi
|
||||
- AC_MSG_RESULT([$enchant_cc_flag])
|
||||
+ AC_MSG_RESULT([$enchant_cxx_flag])
|
||||
AC_LANG_POP(C++)
|
||||
])
|
||||
|
||||
@@ -169,7 +169,7 @@ AC_CACHE_CHECK([for supported C++ warnin
|
||||
done
|
||||
|
||||
enchant_cxx_cv_warn_cflags=$CXX_WARN_CFLAGS
|
||||
- enchant_cxx_cv_warn_cflags=$CXX_MAYBE_WARN
|
||||
+ enchant_cxx_cv_warn_maybe=$CXX_MAYBE_WARN
|
||||
|
||||
AC_MSG_CHECKING([which C++ warning flags were supported])])
|
||||
CXX_WARN_CFLAGS="$enchant_cxx_cv_warn_cflags"
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2008/04/17 21:07:18 wiz Exp $
|
||||
|
||||
--- src/myspell/myspell_checker.cpp.orig 2008-03-21 02:45:24.000000000 +0100
|
||||
+++ src/myspell/myspell_checker.cpp
|
||||
@@ -39,7 +39,7 @@
|
||||
#include "enchant-provider.h"
|
||||
|
||||
/* built against hunspell 1.1.5 on 2007-03-19 */
|
||||
-#include "hunspell.hxx"
|
||||
+#include <hunspell/hunspell.hxx>
|
||||
|
||||
ENCHANT_PLUGIN_DECLARE("Myspell")
|
||||
|
||||
@@ -353,7 +353,7 @@ MySpellChecker::requestDictionary(const
|
||||
strcpy(aff+len_dic-3, "aff");
|
||||
if (g_file_test(aff, G_FILE_TEST_EXISTS))
|
||||
{
|
||||
- myspell = new Hunspell(aff, dic);
|
||||
+ myspell = new Hunspell(aff, dic, NULL);
|
||||
}
|
||||
g_free(dic);
|
||||
g_free(aff);
|
Loading…
Reference in a new issue