Update to 5.1:

v5.1  The bitmap graphics from the US Macintosh release of Lancelot
        now display correctly.

  v5.0  V1 games are also now supported.
        The input logic now correctly handles commas and full stops
        in the user's input for v3 or later games.
        The input logic now allows hyphens and apostrophes to be
        input, which is needed for some v2 games.
        The dictionary listing for v2 games no longer has junk on the
        end.
        The graphics detection algorithm has been improved, so that it
        now correctly finds graphics in all known games.
        A difference in the logic between the v2 and v3 line-drawn
        graphics has been implemented, which corrects the scaling for
        some v2 graphics.
        Added #seed and #play meta commands.

  v4.1  Corrected a bug that made Lancelot unplayable.
        BBC B bitmaps are now shown as they appeared on the original
        computer.
This commit is contained in:
wiz 2013-10-13 10:19:22 +00:00
parent 3099b2b8eb
commit f032225eee
3 changed files with 26 additions and 18 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.17 2013/10/10 17:27:56 roy Exp $
# $NetBSD: Makefile,v 1.18 2013/10/13 10:19:22 wiz Exp $
DISTNAME= Level9_4.0_Source
PKGNAME= level9-4.0
PKGREVISION= 2
DISTNAME= Level9_5.1_Source
PKGNAME= level9-5.1
CATEGORIES= games
MASTER_SITES= http://www.ifarchive.org/if-archive/level9/interpreters/level9/
EXTRACT_SUFX= .zip
@ -10,13 +9,14 @@ EXTRACT_SUFX= .zip
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.ifarchive.org/if-archive/level9/interpreters/level9/
COMMENT= Curses port of the Level 9 text adventure interpreter
LICENSE= gnu-gpl-v2
WRKSRC= ${WRKDIR}/Unix
# uses halfkey (present since 1.6M)
INCOMPAT_CURSES+= NetBSD-1.4[Y-Z]*-* NetBSD-1.5*-* NetBSD-1.6-*
INCOMPAT_CURSES+= NetBSD-1.6.*-* NetBSD-1.6[A-L]*-*
INSTALLATION_DIRS= bin
INSTALLATION_DIRS= bin share/doc/level9
LDADD+= ${BUILDLINK_LDADD.termcap}
LDADD+= ${BUILDLINK_LDADD.curses}
@ -27,7 +27,6 @@ post-extract:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/level9 ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/level9
${INSTALL_DATA} ${WRKDIR}/level9.txt \
${DESTDIR}${PREFIX}/share/doc/level9

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.7 2013/10/10 17:27:56 roy Exp $
$NetBSD: distinfo,v 1.8 2013/10/13 10:19:22 wiz Exp $
SHA1 (Level9_4.0_Source.zip) = 7bbd0a675aa66067745b2d850d07eaa2b08fd452
RMD160 (Level9_4.0_Source.zip) = 224b2b3414da53e8dd7c3a253468b078c09a0e4f
Size (Level9_4.0_Source.zip) = 294428 bytes
SHA1 (Level9_5.1_Source.zip) = 764078fb9f1ed2cc86cecb34fdcc6f053a27672b
RMD160 (Level9_5.1_Source.zip) = 1d8d9763a2a22dac203c8249efb6d302e1a37cf7
Size (Level9_5.1_Source.zip) = 323660 bytes
SHA1 (patch-Makefile) = aaf6966e4b62f92003f8ce2e162d9a6a6bbccab0
SHA1 (patch-aa) = 2fda19e85676e7eadf94d109a1ba0e02a17e9d84
SHA1 (patch-aa) = f34eff28db4b1dbb34b8618799dbe17beaf0fc60

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.2 2003/10/01 20:21:40 dillo Exp $
$NetBSD: patch-aa,v 1.3 2013/10/13 10:19:22 wiz Exp $
--- unix-curses.c.orig Sun Apr 21 21:37:00 2002
--- unix-curses.c.orig 2011-05-29 07:39:50.000000000 +0000
+++ unix-curses.c
@@ -10,11 +10,6 @@
@@ -9,11 +9,6 @@
*
* A few notes on this port:
*
@ -14,7 +14,7 @@ $NetBSD: patch-aa,v 1.2 2003/10/01 20:21:40 dillo Exp $
* If you don't specify a path, level9 Linux will look first in the directory
* $LEVEL9DIR, if defined, and then in the current directory.
*
@@ -39,11 +34,6 @@
@@ -38,11 +33,6 @@
#define FILE_DELIM '/'
/*
@ -26,7 +26,16 @@ $NetBSD: patch-aa,v 1.2 2003/10/01 20:21:40 dillo Exp $
* Define this as 1 to get the Emacs-type key bindings
* Ctrl-A (go to beginning of line)
* Ctrl-B (back one character)
@@ -741,25 +731,11 @@ int main (int argc, char *argv [])
@@ -88,7 +78,7 @@ extern FILE* scriptfile;
/*
* You might have to change this if not using ncurses
*/
-#include <ncurses/curses.h>
+#include <curses.h>
#define CTRL_A '\x01'
@@ -773,25 +763,11 @@ int main (int argc, char *argv [])
char gamename [256];
char *envbuf;
L9BOOL gotgame;
@ -53,7 +62,7 @@ $NetBSD: patch-aa,v 1.2 2003/10/01 20:21:40 dillo Exp $
if (argc != 2)
{
@@ -786,8 +762,9 @@ int main (int argc, char *argv [])
@@ -820,8 +796,9 @@ int main (int argc, char *argv [])
/*
* Get the terminal characteristics for line width and More prompt
*/
@ -64,7 +73,7 @@ $NetBSD: patch-aa,v 1.2 2003/10/01 20:21:40 dillo Exp $
{
fprintf (stderr, "Couldn't get terminal width---falling back on good old"
" 80 columns\n\n");
@@ -795,7 +772,7 @@ int main (int argc, char *argv [])
@@ -829,7 +806,7 @@ int main (int argc, char *argv [])
}
More_lines = tgetnum ("li");