build fix for jdk-zero-vm option

This commit is contained in:
tnn 2015-06-13 23:57:25 +00:00
parent 5255c1b873
commit f03fdf6b1d
2 changed files with 23 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.19 2015/06/13 14:55:52 tnn Exp $
$NetBSD: distinfo,v 1.20 2015/06/13 23:57:25 tnn Exp $
SHA1 (openjdk7/bootstrap-jdk-1.7.76-freebsd-10-amd64-20150301.tar.xz) = 7408f52d3bbe35c2b14bbd3215cbf60f1335d334
RMD160 (openjdk7/bootstrap-jdk-1.7.76-freebsd-10-amd64-20150301.tar.xz) = 24f1577b5fc86d137f070aedb4610c8c89e45815
@ -57,6 +57,7 @@ SHA1 (patch-hotspot_src_os__cpu_bsd__zero_vm_orderAccess__bsd__zero.inline.hpp)
SHA1 (patch-hotspot_src_os__cpu_bsd__zero_vm_os__bsd__zero.cpp) = 4fa018be66fad39aa0a922dfb86c79661a7379f2
SHA1 (patch-hotspot_src_os_posix_vm_os__posix.cpp) = 69a4ff639488bec525cb5bbccaca10dae0d7dc4d
SHA1 (patch-hotspot_src_share_vm_ci_ciTypeFlow.cpp) = 2d827ade6fcf0ba08fcd0390472cda17772bc0c5
SHA1 (patch-hotspot_src_share_vm_interpreter_interpreterRuntime.cpp) = d2eaaae414810ab460ced512fdfc07385d60f4b8
SHA1 (patch-hotspot_src_share_vm_opto_node.cpp) = aacb4e03f62f1a6f9b38de39a966c318b70b1293
SHA1 (patch-hotspot_src_share_vm_utilities_globalDefinitions__gcc.hpp) = cab48bc272fc67f3326e663dc6feb94fe56ec79f
SHA1 (patch-jdk_make_CompileLaunchers.gmk) = 76bae0aab5528a6c020d2fdd5ba7c1ffa132aca2

View file

@ -0,0 +1,21 @@
$NetBSD: patch-hotspot_src_share_vm_interpreter_interpreterRuntime.cpp,v 1.1 2015/06/13 23:57:25 tnn Exp $
Fix build with jdk-zero-vm option:
interpreterRuntime.cpp:412:25: error: no member named 'remove_activation_entry' in 'Interpreter'
return Interpreter::remove_activation_entry();
--- hotspot/src/share/vm/interpreter/interpreterRuntime.cpp.orig 2015-06-10 10:31:51.000000000 +0000
+++ hotspot/src/share/vm/interpreter/interpreterRuntime.cpp
@@ -407,7 +407,11 @@ IRT_ENTRY(address, InterpreterRuntime::e
// during deoptimization so the interpreter needs to skip it when
// the frame is popped.
thread->set_do_not_unlock_if_synchronized(true);
+#ifdef CC_INTERP
+ return (address) -1;
+#else
return Interpreter::remove_activation_entry();
+#endif
}
// Need to do this check first since when _do_not_unlock_if_synchronized