Version 1.2.0

(21 May 2005, from /branches/1.2.x)
http://svn.collab.net/repos/svn/tags/1.2.0

See the 1.2 release notes for a more verbose overview of the changes since
the 1.1 release:  http://subversion.tigris.org/svn_1.2_releasenotes.html

 User-visible-changes:
  - Client:
    * add peg-rev syntax to co/blame/cat/ls/pget/plist/export (issue #1093)
    * 'svn info' now works on URLs (r13123, 13144)
    * 'svn* --version' now shows available repository back-ends (r13761)
    * new fixed-length keywords (for placement in binary files) (issue #2095)
    * on Windows, disk-cached passwords are now encrypted (r13888)
    * performance improvements:
       - 'svn status' does much less disk parsing (r11677, 11704)
       - 'svn st -u' no longer asks server to generate textdeltas (issue #2259)
       - 'svn revert -R' doing much less work (r13883)
       - utf8<->native conversions are faster now (issue #2016)
    * new switches added:
       - 'svn log --limit N'               - show only first N log messages
       - 'svn info --revision'             - show info on older object (r13265)
       - 'svn list --xml'                  - output listing in XML
       - 'svn propset --force'             - allow unusual propsets (#2065)
       - 'svn diff --force'                - show diffs on binary files (#2099)
       - 'svn co/up/st --ignore-externals' - skip over externals (#2189)
       - 'svn export --non-recursive'      - don't export subdirs (issue #2228)
       - 'svnversion --help'               - show help (r13128)
    * fixed: 'svn merge' fails to add symlinks or expand keywords (issue #2064)
    * fixed: 'svn merge --dry-run' shows spurious 'skip' messages (issue #1943)
    * fixed: 'svn merge' file-not-found' error (issue #1673)
    * fixed: 'svn merge' of propchanges into deleted file (issue #2132)
    * fixed: 'svn merge' on implicit target with space (r13010)
    * fixed: 'svn merge/diff URL URL' can cause httpd timeout (issue #2048)
    * fixed: 'svn switch/update' failure might corrupt wc (issue #1825)
    * fixed: 'svn up' should rm before add, helps case-insensitivity (r12616)
    * fixed: 'svn up -rX' causes file to be unrestorable (issue #2250)
    * fixed: 'svn copy wc wc' should keep .svn/ hidden (issue #1739)
    * fixed: 'svn copy wc wc' of deleted=true doesn't delete (issue #2101)
    * fixed: 'svn copy' shouldn't copy into schedule-delete area (issue #2020)
    * fixed: 'svn copy dir dir' infinite recursion (issue #2224)
    * fixed: 'svn log' throws error on unversioned target (issue #1551)
    * fixed: 'svn log' in r0 working copy shows r1 log msg (issue #1950)
    * fixed: 'svn export' bugs on deleted dirs or nonexistents (#2226, r13226)
    * fixed: 'svn export' on single file from working copy (issue #1708)
    * fixed: 'svn import' creating an empty revision (r14293)
    * fixed: 'svn commit' ignores --encoding when editing externally (#2244)
    * fixed: 'svn commit' log message lost if utf8-conversion failure (r13230)
    * fixed: 'svn diff' output encoding bug (r11461)
    * fixed: 'svn diff' showing prop-diffs on repos root dir (r13381-2)
    * fixed: 'svn diff' label reversal (issue #2033)
    * fixed: 'svn propget' prints extra newline in --strict mode (r14505)
    * fixed: 'svn propset' should skip unversioned files (#2030)
    * fixed: 'svn rm URL1 URL2 URL3...' huge memory usage (issue #2218)
    * fixed: 'svn mkdir' cleanup after failure (r11883)
    * fixed: 'svn status -u' crash in non-recursive wc's (issue #2122)
    * fixed: 'svn revert' should skip unversioned items (issues #2030, 2133)
    * fixed: 'svn revert' should suggest --recursive (issue #2114)
    * fixed: 'svn add/import' better detects invalid paths (issue #1954)
    * fixed: 'svn cleanup' should repair timestamps (r12012)
    * fixed: 'svn cat -rBASE' contacts repository (issue #1361)
    * fixed: fuzzily escape control-characters when sending over dav (#2147)
    * fixed: prevent client from manipulating svn🚾* properties (r12523)
    * fixed: xml-escaping bugs over dav (r11090)
    * fixed: store symlinks as utf8, always work in non-utf8 locale (r11358-9)
    * fixed: bug in special-file detranslation (r11441)
    * fixed: show paths in local-style where we weren't (issue #1538)
    * fixed: detect invalid propnames better (issue #1832)
    * fixed: entire error stack not being printed (issue #1822)
    * fixed: improper utf8 conversion of revision strings (issue #1999)
    * fixed: use-commit-times timestamp bug (r12906)
    * fixed: don't comment out section-names in default config file (r11771)
    * more support for user-cancellation (r13083-4, 13086)
    * improved error messages (r12920, 11392, 11599, 11913, #2154, #2214)

   - Server:
    * mod_dav_svn autoversioning feature now complete (see release notes)
    * 'svnadmin create' now creates FSFS repositories by default (r13624)
    * new pre/post-revprop hook argument to describe propchange (r12162)
    * mod_authz_svn groups can now contain other groups (issue #2085)
    * 'svnadmin recover' now creates default svnserve passwd file (r11589)
    * increase default BDB cache size in DB_CONFIG (r13030)
    * new switches added:
       - 'svnlook diff --no-diff-added'        - suppress added files (#2180)
       - 'svnlook propget/proplist --revprop'  - show revision props (#2181)
       - 'svnadmin load --use-pre-commit-hook'
         'svnadmin load --use-post-commit-hook'- invoke hooks when loading
    * fixed: FSFS race condition on posix platforms (issue #2265)
    * fixed: change FSFS revprops atomically and safely (issue #2193)
    * fixed: FSFS should verify checksums (issue #2253)
    * fixed: 'svnadmin create' should clean up when it fails (r13200)
    * fixed: 'svnadmin load' compatibility on pre-0.14 dumpfiles (r12075)
    * fixed: 'svnadmin load' crashes on contentful rev 0 (issue #1674)
    * fixed: 'svnadmin dump' should write in console encoding (issue #1997)
    * fixed: check for null-streams in dump/load code (r10510)
    * fixed: hook script ignored when symlink is broken (issue #1700)
    * fixed: hook script may inherit server's stdin stream (r12155)
    * fixed: potential svnserve segfault (r13199)
    * fixed: svnserve handling mutually-exclusive options (issue #2251)
    * fixed: mod_authz_svn should log errors to httpd errorlog (issue #2182)
    * fixed: 'svnadmin hotcopy' failed to copy format files (r14678, r14683)
    * mailer.py: add win32 compatibility, plus other bugfixes

   - Both:
    * new 'locking' feature (issue #1478, see release notes for details):
        - new: 'svn lock/unlock', 'svnadmin lslocks/rmlocks', 'svnlook lock'
        - new: 'svn:needs-lock' property to enable communication
        - 'svn st [-u]' shows local or remote lock overview
        - 'svn info wc | URL'  shows local or remote lock details
        - 'svn commit' sends locks, 'svn up' removes stale locks
        - new hook scripts: pre-lock, pre-unlock, post-lock, post-unlock
    * speedups for 'svn blame' and other commands (see xdelta in release notes)
    * fixed: make both svnserve and svn:// urls work with IPv6 (r13235-6)
    * continued improvement of localized message translations:
        - German, Spanish, Polish, Brazilian Portuguese, Norwegian Bokmål,
          Swedish, Traditional Chinese, Simplified Chinese, Korean, Japanese
        - more localized messages in all svn-related binaries

 Developer-visible changes:
 * binary diff algorithm now defaults to xdelta instead of vdelta
 * huge number of new APIs:
     - new locking APIs in svn_client.h, svn_ra.h, svn_repos.h, svn_fs.h
     - new 'flattened' svn_ra.h API, which imitates svn_fs.h  (issue #1931)
     - new notification API in svn_client.h, svn_wc.h
     - http://svn.haxx.se/dev/archive-2005-04/0319.shtml has all API changes
 * fs now has its own 'format' file, independent of repos 'format' (r13387)
 * improve efficiency of delta combining algorithm (r13016, r13063)
 * make all BDB apis take explicit pool parameters (r13198, r13205)
 * remove libsvn_fs_base caching of node revisions (r13299)
 * libsvn_repos commit editor can now take incoming txn (r13733)
 * fixed: mod_dav_svn sending illegal editor-drive (issue #2258)
 * pool usage improvements (r12954, 12852, r13386, issue #1310)
 * SWIG bindings:  better API coverage overall.
    - new ruby bindings!
    - remove bitrotting swig-java bindings
    - perl and python bindings:  numerous improvements, see their own logs.
    - bindings tests now within svntest framework
 * javahl bindings:   numerous improvements, see its own logs.
 * many improvements to mailer.py and commit-email.pl
 * rewrite/improvements to gen-make build system, including VS.NET support
 * many improvements to the automated python testsuite (issue #2257)
 * book moved to separate repository (http://svn.red-bean.com/svnbook)

pkgsrc changes:
 * New package devel/ruby-subversion.
 * Switch to devel/swig13, which we no longer need at runtime.
 * Provide TEST_TARGET for p5-subversion.
This commit is contained in:
epg 2005-05-23 22:58:26 +00:00
parent 73e8ad2e42
commit f0d52560af
15 changed files with 1057 additions and 590 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.19 2005/05/22 05:35:32 jlam Exp $ # $NetBSD: Makefile,v 1.20 2005/05/23 22:58:26 epg Exp $
PKGNAME= p5-subversion-${SVNVER} PKGNAME= p5-subversion-${SVNVER}
COMMENT= Perl bindings for Subversion COMMENT= Perl bindings for Subversion
@ -15,12 +15,13 @@ PERL5_CONFIGURE= NO
#PERL5_CONFIGURE_DIRS= ${PERL_DIR} #PERL5_CONFIGURE_DIRS= ${PERL_DIR}
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/SVN/_Core/.packlist PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/SVN/_Core/.packlist
TEST_TARGET= check-swig-pl
post-patch: post-patch:
${RM} ${WRKSRC}/build-outputs.mk ${RM} ${WRKSRC}/build-outputs.mk
${CP} ${FILESDIR}/build-outputs.mk ${WRKSRC}/build-outputs.mk ${CP} ${FILESDIR}/build-outputs.mk ${WRKSRC}/build-outputs.mk
.include "../../devel/subversion/buildlink3.mk" .include "../../devel/subversion/buildlink3.mk"
.include "../../devel/swig-build/buildlink3.mk" .include "../../devel/swig13/buildlink3.mk"
.include "../../devel/swig-perl/buildlink3.mk"
.include "../../lang/perl5/module.mk" .include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk" .include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.14 2005/04/26 00:17:48 epg Exp $ # $NetBSD: Makefile,v 1.15 2005/05/23 22:58:26 epg Exp $
PKGNAME= ${PYPKGPREFIX}-subversion-${SVNVER} PKGNAME= ${PYPKGPREFIX}-subversion-${SVNVER}
COMMENT= Python bindings and tools for Subversion COMMENT= Python bindings and tools for Subversion
@ -17,7 +17,7 @@ BUILD_TARGET= swig-py-lib swig-py
INSTALL_TARGET= install-swig-py INSTALL_TARGET= install-swig-py
MAKE_ENV+= EXTRA_CPPFLAGS="${BUILDLINK_CPPFLAGS}" MAKE_ENV+= EXTRA_CPPFLAGS="${BUILDLINK_CPPFLAGS}"
MAKEFLAGS+= swig_pydir=${LOCALBASE}/${PYSITELIB}/libsvn \ MAKE_FLAGS+= swig_pydir=${LOCALBASE}/${PYSITELIB}/libsvn \
swig_pydir_extra=${LOCALBASE}/${PYSITELIB}/svn swig_pydir_extra=${LOCALBASE}/${PYSITELIB}/svn
TEST_TARGET= all check TEST_TARGET= all check
@ -36,8 +36,7 @@ post-install:
${SVNEXAMPLES}/hook-scripts ${SVNEXAMPLES}/hook-scripts
.include "../../devel/subversion/buildlink3.mk" .include "../../devel/subversion/buildlink3.mk"
.include "../../devel/swig-build/buildlink3.mk" .include "../../devel/swig13/buildlink3.mk"
.include "../../devel/swig-python/buildlink3.mk"
.include "../../lang/python/application.mk" .include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk" .include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk" .include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2005/04/26 00:17:48 epg Exp $ @comment $NetBSD: PLIST,v 1.5 2005/05/23 22:58:26 epg Exp $
lib/libsvn_swig_py-1.la lib/libsvn_swig_py-1.la
${PYSITELIB}/libsvn/__init__.py ${PYSITELIB}/libsvn/__init__.py
${PYSITELIB}/libsvn/__init__.pyc ${PYSITELIB}/libsvn/__init__.pyc
@ -37,8 +37,6 @@ ${PYSITELIB}/svn/ra.py
${PYSITELIB}/svn/ra.pyc ${PYSITELIB}/svn/ra.pyc
${PYSITELIB}/svn/repos.py ${PYSITELIB}/svn/repos.py
${PYSITELIB}/svn/repos.pyc ${PYSITELIB}/svn/repos.pyc
${PYSITELIB}/svn/util.py
${PYSITELIB}/svn/util.pyc
${PYSITELIB}/svn/wc.py ${PYSITELIB}/svn/wc.py
${PYSITELIB}/svn/wc.pyc ${PYSITELIB}/svn/wc.pyc
share/examples/subversion/hook-scripts/mailer.conf.example share/examples/subversion/hook-scripts/mailer.conf.example

View file

@ -0,0 +1,5 @@
The goal of the Subversion project is to build a version control system that
is a compelling replacement for CVS in the open source community. The software
is released under an Apache/BSD-style open source license.
This package contains the Ruby bindings to the Subversion libraries.

View file

@ -0,0 +1,32 @@
# $NetBSD: Makefile,v 1.1 2005/05/23 22:58:26 epg Exp $
PKGNAME= ${RUBY_PKGPREFIX}-subversion-${SVNVER}
COMMENT= Ruby bindings for Subversion
.include "../../devel/subversion/Makefile.common"
RUBY_DIST_SUBDIR=
RUBY_VERSION_SUPPORTED= 18
REPLACE_RUBY_DIRS= ${WRKSRC}/tools
CONFIGURE_ENV+= RUBY=${RUBY}
BUILD_TARGET= swig-rb-lib swig-rb
INSTALL_TARGET= install-swig-rb
TEST_TARGET= check-swig-rb
post-patch:
${RM} ${WRKSRC}/build-outputs.mk
${CP} ${FILESDIR}/build-outputs.mk ${WRKSRC}/build-outputs.mk
post-install:
${RM} ${RUBY_SITEARCHLIBDIR}/svn/ext/*.a
${RM} ${RUBY_SITEARCHLIBDIR}/svn/ext/*.la
${INSTALL_DATA_DIR} ${SVNEXAMPLES}/ruby
${INSTALL_DATA} ${WRKSRC}/tools/*/*.rb ${SVNEXAMPLES}/ruby
.include "../../devel/subversion/buildlink3.mk"
.include "../../devel/swig13/buildlink3.mk"
.include "../../lang/ruby/modules.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,26 @@
@comment $NetBSD: PLIST,v 1.1 2005/05/23 22:58:26 epg Exp $
lib/libsvn_swig_ruby-1.la
${RUBY_SITEARCHLIBDIR}/svn/ext/client.${RUBY_DLEXT}
${RUBY_SITEARCHLIBDIR}/svn/ext/core.${RUBY_DLEXT}
${RUBY_SITEARCHLIBDIR}/svn/ext/delta.${RUBY_DLEXT}
${RUBY_SITEARCHLIBDIR}/svn/ext/fs.${RUBY_DLEXT}
${RUBY_SITEARCHLIBDIR}/svn/ext/ra.${RUBY_DLEXT}
${RUBY_SITEARCHLIBDIR}/svn/ext/repos.${RUBY_DLEXT}
${RUBY_SITEARCHLIBDIR}/svn/ext/wc.${RUBY_DLEXT}
${RUBY_SITELIBDIR}/svn/client.rb
${RUBY_SITELIBDIR}/svn/core.rb
${RUBY_SITELIBDIR}/svn/delta.rb
${RUBY_SITELIBDIR}/svn/error.rb
${RUBY_SITELIBDIR}/svn/fs.rb
${RUBY_SITELIBDIR}/svn/info.rb
${RUBY_SITELIBDIR}/svn/ra.rb
${RUBY_SITELIBDIR}/svn/repos.rb
${RUBY_SITELIBDIR}/svn/util.rb
${RUBY_SITELIBDIR}/svn/wc.rb
share/examples/subversion/ruby/commit-email.rb
share/examples/subversion/ruby/svnlook.rb
share/examples/subversion/ruby/svnshell.rb
@dirrm share/examples/subversion/ruby
@dirrm ${RUBY_SITELIBDIR}/svn
@dirrm ${RUBY_SITEARCHLIBDIR}/svn/ext
@dirrm ${RUBY_SITEARCHLIBDIR}/svn

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2004/11/24 15:52:05 jlam Exp $ @comment $NetBSD: PLIST,v 1.9 2005/05/23 22:58:27 epg Exp $
bin/svn bin/svn
bin/svnadmin bin/svnadmin
bin/svndumpfilter bin/svndumpfilter
@ -12,6 +12,7 @@ include/subversion-1/svn_base64.h
include/subversion-1/svn_client.h include/subversion-1/svn_client.h
include/subversion-1/svn_cmdline.h include/subversion-1/svn_cmdline.h
include/subversion-1/svn_config.h include/subversion-1/svn_config.h
include/subversion-1/svn_ctype.h
include/subversion-1/svn_dav.h include/subversion-1/svn_dav.h
include/subversion-1/svn_delta.h include/subversion-1/svn_delta.h
include/subversion-1/svn_diff.h include/subversion-1/svn_diff.h
@ -67,7 +68,9 @@ share/examples/subversion/hook-scripts/svnperms.conf.example
share/examples/subversion/hook-scripts/svnperms.py share/examples/subversion/hook-scripts/svnperms.py
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/subversion.mo ${PKGLOCALEDIR}/locale/de/LC_MESSAGES/subversion.mo
${PKGLOCALEDIR}/locale/es/LC_MESSAGES/subversion.mo ${PKGLOCALEDIR}/locale/es/LC_MESSAGES/subversion.mo
${PKGLOCALEDIR}/locale/it/LC_MESSAGES/subversion.mo
${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/subversion.mo ${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/subversion.mo
${PKGLOCALEDIR}/locale/ko/LC_MESSAGES/subversion.mo
${PKGLOCALEDIR}/locale/nb/LC_MESSAGES/subversion.mo ${PKGLOCALEDIR}/locale/nb/LC_MESSAGES/subversion.mo
${PKGLOCALEDIR}/locale/pl/LC_MESSAGES/subversion.mo ${PKGLOCALEDIR}/locale/pl/LC_MESSAGES/subversion.mo
${PKGLOCALEDIR}/locale/pt_BR/LC_MESSAGES/subversion.mo ${PKGLOCALEDIR}/locale/pt_BR/LC_MESSAGES/subversion.mo

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.23 2005/04/11 21:45:38 tv Exp $ # $NetBSD: Makefile,v 1.24 2005/05/23 22:58:26 epg Exp $
PKGNAME= subversion-${SVNVER} PKGNAME= subversion-${SVNVER}
COMMENT= Version control system, meta-package COMMENT= Version control system, meta-package
@ -7,6 +7,7 @@ DEPENDS+= subversion-base-${SVNVER}{,nb[0-9]*}:../../devel/subversion-base
DEPENDS+= p5-subversion-${SVNVER}{,nb[0-9]*}:../../devel/p5-subversion DEPENDS+= p5-subversion-${SVNVER}{,nb[0-9]*}:../../devel/p5-subversion
DEPENDS+= ap2-subversion-${SVNVER}{,nb[0-9]*}:../../www/ap2-subversion DEPENDS+= ap2-subversion-${SVNVER}{,nb[0-9]*}:../../www/ap2-subversion
DEPENDS+= ${PYPKGPREFIX}-subversion-${SVNVER}{,nb[0-9]*}:../../devel/py-subversion DEPENDS+= ${PYPKGPREFIX}-subversion-${SVNVER}{,nb[0-9]*}:../../devel/py-subversion
DEPENDS+= ${RUBY_PKGPREFIX}-subversion-${SVNVER}{,nb[0-9]*}:../../devel/ruby-subversion
.include "Makefile.common" .include "Makefile.common"
@ -17,6 +18,7 @@ NO_BUILD= YES
NO_MTREE= YES NO_MTREE= YES
.include "../../lang/python/pyversion.mk" .include "../../lang/python/pyversion.mk"
.include "../../lang/ruby/rubyversion.mk"
# The NO_PATCH macro is gone so we have to do this to prevent the # The NO_PATCH macro is gone so we have to do this to prevent the
# patches from being applied: # patches from being applied:

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.19 2005/05/22 05:37:44 jlam Exp $ # $NetBSD: Makefile.common,v 1.20 2005/05/23 22:58:26 epg Exp $
DISTNAME= subversion-${SVNVER} DISTNAME= subversion-${SVNVER}
CATEGORIES= devel CATEGORIES= devel
@ -25,6 +25,8 @@ CONFIGURE_ARGS+= --with-apr-util=${BUILDLINK_PREFIX.apr}
CONFIGURE_ARGS+= --with-neon=${BUILDLINK_PREFIX.neon} CONFIGURE_ARGS+= --with-neon=${BUILDLINK_PREFIX.neon}
CONFIGURE_ARGS+= --with-ssl CONFIGURE_ARGS+= --with-ssl
MAKE_FLAGS+= SWIG_LIBSWIG_DIR=${BUILDLINK_DIR}/share/swig/1.3
BUILDLINK_DEPENDS.subversion-base= subversion-base>=${SVNVER} BUILDLINK_DEPENDS.subversion-base= subversion-base>=${SVNVER}
.include "../../devel/gettext-lib/buildlink3.mk" .include "../../devel/gettext-lib/buildlink3.mk"

View file

@ -1,5 +1,5 @@
# $NetBSD: Makefile.version,v 1.28 2005/04/05 01:58:05 epg Exp $ # $NetBSD: Makefile.version,v 1.29 2005/05/23 22:58:26 epg Exp $
.if !defined(SVNVER) .if !defined(SVNVER)
SVNVER= 1.1.4 SVNVER= 1.2.0
.endif .endif

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.43 2005/04/05 01:58:05 epg Exp $ $NetBSD: distinfo,v 1.44 2005/05/23 22:58:26 epg Exp $
SHA1 (subversion-1.1.4.tar.gz) = 24af67171e79e2715eb07f89c50a800efb419b37 SHA1 (subversion-1.2.0.tar.gz) = bee1021a1dd9fedc6aae4f59395dca8610b6830a
RMD160 (subversion-1.1.4.tar.gz) = a68a6177ed5def666a32e012f6efa398ee3b8936 RMD160 (subversion-1.2.0.tar.gz) = e5f2e46aa8f48012514653125de6f8a87b7b44a2
Size (subversion-1.1.4.tar.gz) = 8177634 bytes Size (subversion-1.2.0.tar.gz) = 8620677 bytes
SHA1 (patch-ad) = 4b3551b4f24823690f1e75eea9d62f1db78b6dc5 SHA1 (patch-ad) = b2975d9b9aebd045cc7db22f79e03b2efbbbe285
SHA1 (patch-ag) = faa890d811ca2d5d0240647fac6d115e714dc2a3 SHA1 (patch-ag) = faa890d811ca2d5d0240647fac6d115e714dc2a3
SHA1 (patch-ah) = 95347e442d72516d74258254892712fa3387d5c9 SHA1 (patch-ah) = 195aeabc711b229cb402312357cad143c19d7b53
SHA1 (patch-ai) = 4515b108ca67f6100cf89eb42def2c3c234c63a4 SHA1 (patch-ai) = 9b209d2d436a5ed3ac2ca02a2dac80c8cad0e98c

File diff suppressed because it is too large Load diff

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.9 2004/11/27 02:35:53 epg Exp $ $NetBSD: patch-ad,v 1.10 2005/05/23 22:58:26 epg Exp $
--- Makefile.in.orig 2004-09-11 11:45:29.000000000 -0400 --- Makefile.in.orig 2005-04-11 08:57:22.000000000 -0400
+++ Makefile.in +++ Makefile.in
@@ -573,7 +573,7 @@ install-info: doc-all-info @@ -577,7 +577,7 @@ install-swig-rb: install-swig-rb-lib
$(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL $(SWIG_PL_DIR)/native/Makefile: $(SWIG_PL_DIR)/native/Makefile.PL
cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL cd $(SWIG_PL_DIR)/native; $(PERL) Makefile.PL

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ah,v 1.1 2004/11/27 02:35:53 epg Exp $ $NetBSD: patch-ah,v 1.2 2005/05/23 22:58:26 epg Exp $
--- build/generator/gen_make.py.orig 2004-08-09 18:30:31.000000000 -0400 --- build/generator/gen_make.py.orig 2005-03-22 10:08:25.000000000 -0500
+++ build/generator/gen_make.py +++ build/generator/gen_make.py
@@ -5,6 +5,7 @@ @@ -5,6 +5,7 @@
import os import os
@ -10,7 +10,7 @@ $NetBSD: patch-ah,v 1.1 2004/11/27 02:35:53 epg Exp $
import gen_base import gen_base
@@ -27,6 +28,13 @@ class Generator(gen_base.GeneratorBase): @@ -39,6 +40,13 @@ class Generator(gen_base.GeneratorBase):
install_deps = self.graph.get_deps(gen_base.DT_INSTALL) install_deps = self.graph.get_deps(gen_base.DT_INSTALL)
install_sources = self.graph.get_all_sources(gen_base.DT_INSTALL) install_sources = self.graph.get_all_sources(gen_base.DT_INSTALL)
@ -24,25 +24,7 @@ $NetBSD: patch-ah,v 1.1 2004/11/27 02:35:53 epg Exp $
# ensure consistency between runs # ensure consistency between runs
install_deps.sort() install_deps.sort()
install_sources.sort(lambda s1, s2: cmp(s1.name, s2.name)) install_sources.sort(lambda s1, s2: cmp(s1.name, s2.name))
@@ -68,6 +76,8 @@ class Generator(gen_base.GeneratorBase): @@ -54,11 +62,17 @@ class Generator(gen_base.GeneratorBase):
elif isinstance(source, gen_base.TargetLinked):
if source.external_lib:
libs.append(source.external_lib)
+ elif source.name in self.installed_libs:
+ libs.append('-l%s-%s' % (source.name[3:], self.cfg.version))
else:
# append the output of the target to our stated dependencies
deps.append(source.filename)
@@ -184,6 +194,8 @@ class Generator(gen_base.GeneratorBase):
for target in inst_targets:
for target_dep in self.graph.get_sources(gen_base.DT_LINK, target.name,
gen_base.TargetLib):
+ if target_dep.name in self.installed_libs:
+ continue
if target_dep.install and target_dep.install != area:
install_deps['install-%s' % target_dep.install] = None
install_deps = install_deps.keys()
@@ -356,11 +368,18 @@ class Generator(gen_base.GeneratorBase):
# construct a list of the other .la libs to link against # construct a list of the other .la libs to link against
retreat = build_path_retreat(target.path) retreat = build_path_retreat(target.path)
@ -50,16 +32,24 @@ $NetBSD: patch-ah,v 1.1 2004/11/27 02:35:53 epg Exp $
- link = [ build_path_join(retreat, target.filename) ] - link = [ build_path_join(retreat, target.filename) ]
+ if target.name in self.installed_libs: + if target.name in self.installed_libs:
+ deps = [] + deps = []
+ link = [ '-l%s-%s' % (target.name[3:], self.cfg.version) ] + link = [ '-l%s-%s' % (target.name[3:], self.version) ]
+ else: + else:
+ deps = [ target.filename ] + deps = [ target.filename ]
+ link = [ build_path_join(retreat, target.filename) ] + link = [ build_path_join(retreat, target.filename) ]
for source in self.graph.get_sources(gen_base.DT_LINK, target.name): for source in self.graph.get_sources(gen_base.DT_LINK, target.name):
if not isinstance(source, gen_base.TargetLib) or source.external_lib: if not isinstance(source, gen_base.TargetLib) or source.external_lib:
continue continue
+ if source.name in self.installed_libs: + elif source.name in self.installed_libs:
+ link.append('-l%s-%s' % (source.name[3:], self.cfg.version))
+ continue + continue
deps.append(source.filename) deps.append(source.filename)
link.append(build_path_join(retreat, source.filename)) link.append(build_path_join(retreat, source.filename))
@@ -136,6 +150,8 @@ class Generator(gen_base.GeneratorBase):
elif isinstance(link_dep, gen_base.TargetLinked):
if link_dep.external_lib:
libs.append(link_dep.external_lib)
+ elif link_dep.name in self.installed_libs:
+ libs.append('-l%s-%s' % (link_dep.name[3:], self.version))
else:
# append the output of the target to our stated dependencies
deps.append(link_dep.filename)

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ai,v 1.1 2004/11/27 02:35:53 epg Exp $ $NetBSD: patch-ai,v 1.2 2005/05/23 22:58:26 epg Exp $
--- gen-make.py.orig 2004-08-10 13:26:26.000000000 -0400 --- gen-make.py.orig 2005-01-31 07:11:57.000000000 -0500
+++ gen-make.py +++ gen-make.py
@@ -62,6 +62,13 @@ def _usage_exit(): @@ -81,6 +81,13 @@ def _usage_exit():
print print
print " The default generator type is 'make'" print " The default generator type is 'make'"
print print
@ -16,12 +16,10 @@ $NetBSD: patch-ai,v 1.1 2004/11/27 02:35:53 epg Exp $
print " Windows-specific options:" print " Windows-specific options:"
print print
print " --with-apr=DIR" print " --with-apr=DIR"
@@ -140,7 +147,8 @@ if __name__ == '__main__': @@ -176,6 +183,7 @@ if __name__ == '__main__':
'enable-purify',
'enable-quantify',
'enable-nls', 'enable-nls',
- 'enable-bdb-in-apr-util' 'enable-bdb-in-apr-util',
+ 'enable-bdb-in-apr-util', 'vsnet-version=',
+ 'installed-libs=', + 'installed-libs=',
]) ])
if len(args) > 1: if len(args) > 1: