Fix GCC build.

I will revisit clang build later.
This commit is contained in:
ryoon 2014-10-24 03:09:35 +00:00
parent eeebcae8ae
commit f0f5f54514
2 changed files with 1 additions and 49 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.26 2014/10/22 21:37:12 ryoon Exp $
$NetBSD: distinfo,v 1.27 2014/10/24 03:09:35 ryoon Exp $
SHA1 (libreoffice/0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz) = 452eba922e4f41603539c9dc39947d2271e47093
RMD160 (libreoffice/0168229624cfac409e766913506961a8-ucpp-1.3.2.tar.gz) = dbeb7a7f8c89961ca2e544b810345d025561866b
@ -153,7 +153,6 @@ Size (libreoffice/libreoffice-help-4.3.2.2.tar.xz) = 1851688 bytes
SHA1 (libreoffice/libreoffice-translations-4.3.2.2.tar.xz) = 3ad09b28613781f7a563c2546ba605bee1b69392
RMD160 (libreoffice/libreoffice-translations-4.3.2.2.tar.xz) = d2ecead38db96b0a39aba728e307a0b971e009d3
Size (libreoffice/libreoffice-translations-4.3.2.2.tar.xz) = 126301100 bytes
SHA1 (patch-bridges_source_cpp__uno_gcc3__linux__x86-64_share.hxx) = c3ba3d646be015ff679380c677ee1dad4f3f34f8
SHA1 (patch-bridges_source_cpp__uno_gcc3__linux__x86-64_uno2cpp.cxx) = 5022ad96533aa1681e6fab323cadf803281a6c17
SHA1 (patch-configure.ac) = 2eb5f6d45dab049362ff2638f7e5d413e19be0a8
SHA1 (patch-external_coinmp_ExternalProject__coinmp.mk) = e43f77575f8096b2d94070140aae14fd638f4298

View file

@ -1,47 +0,0 @@
$NetBSD: patch-bridges_source_cpp__uno_gcc3__linux__x86-64_share.hxx,v 1.7 2014/10/15 22:07:46 joerg Exp $
--- bridges/source/cpp_uno/gcc3_linux_x86-64/share.hxx.orig 2014-09-16 20:10:41.000000000 +0000
+++ bridges/source/cpp_uno/gcc3_linux_x86-64/share.hxx
@@ -31,6 +31,25 @@
#include "config_gcc.h"
#include "uno/mapping.h"
+#ifdef _LIBCPP_VERSION
+
+namespace __cxxabiv1
+{
+ struct __class_type_info : public std::type_info
+ {
+ explicit __class_type_info( const char *__n ) : type_info( __n ) { }
+ virtual ~__class_type_info();
+ };
+
+ struct __si_class_type_info : public __class_type_info
+ {
+ explicit __si_class_type_info( const char *__n, const __class_type_info *__b ) :
+ __class_type_info( __n ), __base_type( __b ) { }
+ virtual ~__si_class_type_info();
+ const __class_type_info *__base_type;
+ };
+}
+#else
namespace CPPU_CURRENT_NAMESPACE
{
@@ -72,6 +91,7 @@ struct __cxa_eh_globals
};
}
+#endif
// __cxa_get_globals is exported from libstdc++ since GCC 3.4.0 (CXXABI_1.3),
// but it is only declared in cxxabi.h (in namespace __cxxabiv1) since
@@ -109,7 +129,7 @@ void raiseException(
uno_Any * pUnoExc, uno_Mapping * pUno2Cpp );
void fillUnoException(
- __cxa_exception * header, uno_Any *, uno_Mapping * pCpp2Uno );
+ __cxxabiv1::__cxa_exception * header, uno_Any *, uno_Mapping * pCpp2Uno );
}
/* vim:set shiftwidth=4 softtabstop=4 expandtab: */