Imported avenger.

Mail Avenger is a highly-configurable, MTA-independent SMTP server
daemon. It lets users run messages through filters like ClamAV and
SpamAssassin during SMTP transactions, so the server can reject mail
before assuming responsibility for its delivery. Other unique features
include TCP SYN fingerprint and network route recording, verification of
sender addresses through SMTP callbacks, SPF (sender policy framework)
as a general policy language, qmail-style control over both SMTP-level
behavior and local delivery of extension addresses, mail-bomb
protection, integration with kernel firewalls, and more.
This commit is contained in:
rillig 2006-10-25 14:05:31 +00:00
parent 926f5c78df
commit f0fffdff52
6 changed files with 111 additions and 0 deletions

9
mail/avenger/DESCR Normal file
View file

@ -0,0 +1,9 @@
Mail Avenger is a highly-configurable, MTA-independent SMTP server
daemon. It lets users run messages through filters like ClamAV and
SpamAssassin during SMTP transactions, so the server can reject mail
before assuming responsibility for its delivery. Other unique features
include TCP SYN fingerprint and network route recording, verification of
sender addresses through SMTP callbacks, SPF (sender policy framework)
as a general policy language, qmail-style control over both SMTP-level
behavior and local delivery of extension addresses, mail-bomb
protection, integration with kernel firewalls, and more.

23
mail/avenger/Makefile Normal file
View file

@ -0,0 +1,23 @@
# $NetBSD: Makefile,v 1.1.1.1 2006/10/25 14:05:31 rillig Exp $
#
DISTNAME= avenger-0.7.7
CATEGORIES= mail
MASTER_SITES= http://www.mailavenger.org/dist/
MAINTAINER= rillig@NetBSD.org
HOMEPAGE= http://www.mailavenger.org/dist/
COMMENT= SMTP server with filtering capabilities
PKG_SYSCONFSUBDIR= avenger
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-db=${BUILDLINK_PREFIX.db4}
CONFIGURE_ARGS+= --with-etcdir=${PKG_SYSCONFDIR}
USE_LIBTOOL= yes
USE_LANGUAGES= c c++
USE_TOOLS+= perl
.include "options.mk"
.include "../../databases/db4/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

40
mail/avenger/PLIST Normal file
View file

@ -0,0 +1,40 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2006/10/25 14:05:31 rillig Exp $
bin/aliascheck
bin/dbutil
bin/deliver
bin/dotlock
bin/edinplace
bin/escape
bin/macutil
bin/mailexec
bin/match
bin/sendmac
bin/smtpdcheck
bin/synos
libexec/avenger
libexec/avenger.local
man/man1/aliascheck.1
man/man1/avenger.1
man/man1/dbutil.1
man/man1/deliver.1
man/man1/dotlock.1
man/man1/edinplace.1
man/man1/escape.1
man/man1/macutil.1
man/man1/mailexec.1
man/man1/match.1
man/man1/smtpdcheck.1
man/man1/synos.1
man/man5/asmtpd.conf.5
man/man8/asmtpd.8
man/man8/avenger.local.8
sbin/asmtpd
share/avenger/INSTALL
share/avenger/INSTALL.html
share/avenger/asmtpd.conf
share/avenger/avsendmail.m4
share/avenger/smtp-filter.iptables
share/avenger/smtp-filter.pf
share/avenger/unknown
share/pf.os
@dirrm share/avenger

6
mail/avenger/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2006/10/25 14:05:31 rillig Exp $
SHA1 (avenger-0.7.7.tar.gz) = 2ba44c82be8b78cf31758a25a79c8366ee6626b8
RMD160 (avenger-0.7.7.tar.gz) = f01eebb2f41224e8e8ad655ca15afa2d1ee06ce2
Size (avenger-0.7.7.tar.gz) = 824862 bytes
SHA1 (patch-aa) = 7df2d9ac15feaf69bbc93e33de59ca25891c4223

15
mail/avenger/options.mk Normal file
View file

@ -0,0 +1,15 @@
# $NetBSD: options.mk,v 1.1.1.1 2006/10/25 14:05:31 rillig Exp $
#
PKG_SUPPORTED_OPTIONS= sasl
PKG_SUGGESTED_OPTIONS= # none
PKG_OPTIONS_VAR= PKG_OPTIONS.avenger
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Msasl)
.include "../../security/cyrus-sasl/buildlink3.mk"
CONFIGURE_ARGS+= --enable-sasl
.else
CONFIGURE_ARGS+= --disable-sasl
.endif

View file

@ -0,0 +1,18 @@
$NetBSD: patch-aa,v 1.1.1.1 2006/10/25 14:05:31 rillig Exp $
--- configure.orig 2006-10-23 13:49:50.000000000 +0200
+++ configure 2006-10-23 13:57:09.000000000 +0200
@@ -27069,9 +27069,10 @@ test -z "${with_db+set}" && with_db=yes
echo "$as_me:$LINENO: checking for BerkeleyDB library" >&5
echo $ECHO_N "checking for BerkeleyDB library... $ECHO_C" >&6
-if test "$DB_DIR" -a "$with_db" = yes; then
- CPPFLAGS="$CPPFLAGS "'-I$(top_builddir)/'"$DB_DIR/dist"
- DB_LIB='$(top_builddir)/'"$DB_DIR/dist/.libs/libdb-*.a"
+if true; then
+ # let's cheat a bit -- the detection is much too complicated.
+ DB_DIR="${prefix}"
+ DB_LIB="-ldb4"
echo "$as_me:$LINENO: result: using distribution in $DB_DIR subdirectory" >&5
echo "${ECHO_T}using distribution in $DB_DIR subdirectory" >&6
elif test x"$with_db" != xno; then