Import ez-ipupdate from pkgsrc-wip. Ok by wiz.

ez-ipupdate is a small utility for updating your host name for the any
of the dynamic DNS service offered at:

* http://www.ez-ip.net
* http://www.justlinux.com
* http://www.dhs.org
* http://www.dyndns.org
* http://www.ods.org
* http://gnudip.cheapnet.net (GNUDip)
* http://www.dyn.ca (GNUDip)
* http://www.tzo.com
* http://www.easydns.com
* http://www.dyns.cx
* http://www.hn.org
* http://www.zoneedit.com

The key features are: support for multiple service types, daemon mode
that monitors your IP address and only sends updates when your IP
address changes.
This commit is contained in:
ghen 2005-12-28 15:50:35 +00:00
parent 5449285f4e
commit f140aa1701
10 changed files with 199 additions and 0 deletions

19
net/ez-ipupdate/DESCR Normal file
View file

@ -0,0 +1,19 @@
ez-ipupdate is a small utility for updating your host name for the any
of the dynamic DNS service offered at:
* http://www.ez-ip.net
* http://www.justlinux.com
* http://www.dhs.org
* http://www.dyndns.org
* http://www.ods.org
* http://gnudip.cheapnet.net (GNUDip)
* http://www.dyn.ca (GNUDip)
* http://www.tzo.com
* http://www.easydns.com
* http://www.dyns.cx
* http://www.hn.org
* http://www.zoneedit.com
The key features are: support for multiple service types, daemon mode
that monitors your IP address and only sends updates when your IP
address changes.

7
net/ez-ipupdate/MESSAGE Normal file
View file

@ -0,0 +1,7 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2005/12/28 15:50:35 ghen Exp $
Due to restrictions on the naming of environment variables (they cannot
contain dashes), the rc.d script for this package is called ez_ipupdate,
and the according rc.conf variables are ez_ipupdate and ez_ipupdate_flags.
===========================================================================

29
net/ez-ipupdate/Makefile Normal file
View file

@ -0,0 +1,29 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/12/28 15:50:35 ghen Exp $
DISTNAME= ez-ipupdate-3.0.11b7
CATEGORIES= net
MASTER_SITES= http://www.ez-ipupdate.com/dist/
MAINTAINER= ghen@NetBSD.org
HOMEPAGE= http://www.ez-ipupdate.com/
COMMENT= Client to update dynamic DNS entries
GNU_CONFIGURE= yes
USE_PKGINSTALL= yes
EGDIR= ${PREFIX}/share/examples/ez-ipupdate
RCD_SCRIPTS= ez-ipupdate
SUBST_CLASSES+= path
SUBST_STAGE.path= post-patch
SUBST_MESSAGE.path= "Correcting paths in example scripts."
SUBST_FILES.path= example-*.conf example.conf
SUBST_SED.path= -e "s|/usr/local|${PREFIX}|g"
SUBST_SED.path+= -e "s|cache-file=/etc/|cache-file=${PKG_SYSCONFDIR}/|g"
post-install:
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/example.conf ${EGDIR}/ez-ipupdate.conf
${INSTALL_DATA} ${WRKSRC}/example-*.conf ${EGDIR}/
.include "../../mk/bsd.pkg.mk"

15
net/ez-ipupdate/PLIST Normal file
View file

@ -0,0 +1,15 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/12/28 15:50:35 ghen Exp $
bin/ez-ipupdate
share/examples/ez-ipupdate/example-dhs.conf
share/examples/ez-ipupdate/example-dyndns.conf
share/examples/ez-ipupdate/example-dyns.conf
share/examples/ez-ipupdate/example-easydns.conf
share/examples/ez-ipupdate/example-gnudip.conf
share/examples/ez-ipupdate/example-heipv6tb.conf
share/examples/ez-ipupdate/example-justlinux.conf
share/examples/ez-ipupdate/example-ods.conf
share/examples/ez-ipupdate/example-pgpow.conf
share/examples/ez-ipupdate/example-tzo.conf
share/examples/ez-ipupdate/ez-ipupdate.conf
share/examples/rc.d/ez-ipupdate
@dirrm share/examples/ez-ipupdate

9
net/ez-ipupdate/distinfo Normal file
View file

@ -0,0 +1,9 @@
$NetBSD: distinfo,v 1.1.1.1 2005/12/28 15:50:35 ghen Exp $
SHA1 (ez-ipupdate-3.0.11b7.tar.gz) = a2754a5e1ff4b252ee7e3878f5c89d4a9bf7a084
RMD160 (ez-ipupdate-3.0.11b7.tar.gz) = fdb0c0cec776690cd57b12d18d3733a1b61ad72a
Size (ez-ipupdate-3.0.11b7.tar.gz) = 82481 bytes
SHA1 (patch-aa) = df2eeb9d987910826fe09943c632be5451f1eb20
SHA1 (patch-ab) = e98e7d4af30866f86382da03fd5e70e5f0f16362
SHA1 (patch-ac) = 41ff359e7c5dd8fcee4ee13c998acd7f962b5239
SHA1 (patch-ad) = e58f8582f45bc179f52e6811b3153fcba90fad22

View file

@ -0,0 +1,21 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: ez-ipupdate.sh,v 1.1.1.1 2005/12/28 15:50:35 ghen Exp $
#
# PROVIDE: ez_ipupdate
# REQUIRE: DAEMON syslogd
. /etc/rc.subr
name="ez_ipupdate"
rcvar="${name}"
progname="ez-ipupdate"
command="@PREFIX@/bin/${progname}"
conf_file="@PKG_SYSCONFDIR@/${progname}.conf"
required_files="${conf_file}"
command_args="-d -c ${conf_file}"
sig_stop=QUIT
extra_commands="reload"
load_rc_config $name
run_rc_command "$1"

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/12/28 15:50:35 ghen Exp $
--- ez-ipupdate.c.orig
+++ ez-ipupdate.c
@@ -798,7 +798,7 @@
sprintf(buf, "message incomplete because your OS sucks: %s\n", fmt);
#endif
- syslog(LOG_NOTICE, buf);
+ syslog(LOG_NOTICE, "%s", buf);
}
else
{

View file

@ -0,0 +1,19 @@
$NetBSD: patch-ab,v 1.1.1.1 2005/12/28 15:50:35 ghen Exp $
--- error.h.orig 2000-11-24 23:46:37.000000000 +0100
+++ error.h
@@ -1,12 +1,12 @@
#ifndef _ERROR_H
#define _ERROR_H
+#include <errno.h>
+
#if HAVE_STRERROR
-extern int errno;
# define error_string strerror(errno)
#elif HAVE_SYS_ERRLIST
extern const char *const sys_errlist[];
-extern int errno;
# define error_string (sys_errlist[errno])
#else
# define error_string "error message not found"

View file

@ -0,0 +1,43 @@
$NetBSD: patch-ac,v 1.1.1.1 2005/12/28 15:50:35 ghen Exp $
--- cache_file.c.orig 2001-04-04 19:12:02.000000000 +0200
+++ cache_file.c
@@ -29,6 +29,7 @@
# include <config.h>
#endif
+#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
@@ -36,18 +37,13 @@
#if HAVE_SYS_STAT_H
# include <sys/stat.h>
#endif
-#if HAVE_ERRNO_H
-# include <errno.h>
-#endif
#include <cache_file.h>
#if HAVE_STRERROR
-extern int errno;
# define error_string strerror(errno)
#elif HAVE_SYS_ERRLIST
extern const char *const sys_errlist[];
-extern int errno;
# define error_string (sys_errlist[errno])
#else
# define error_string "error message not found"
@@ -63,11 +59,9 @@ extern int errno;
# define dprintf(x)
#endif
#if HAVE_STRERROR
-extern int errno;
# define error_string strerror(errno)
#elif HAVE_SYS_ERRLIST
extern const char *const sys_errlist[];
-extern int errno;
# define error_string (sys_errlist[errno])
#else
# define error_string "error message not found"

View file

@ -0,0 +1,24 @@
$NetBSD: patch-ad,v 1.1.1.1 2005/12/28 15:50:35 ghen Exp $
--- conf_file.c.orig 2005-12-15 14:47:05.000000000 +0000
+++ conf_file.c
@@ -31,6 +31,7 @@
# include <config.h>
#endif
+#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
@@ -38,11 +39,9 @@
#include <conf_file.h>
#if HAVE_STRERROR
-extern int errno;
# define error_string strerror(errno)
#elif HAVE_SYS_ERRLIST
extern const char *const sys_errlist[];
-extern int errno;
# define error_string (sys_errlist[errno])
#else
# define error_string "error message not found"