Make this compile on Linux and IRIX and increase odds of working on

other non-NetBSD platforms as well (though they may need ALL_TARGET
tweaking):
- apparently some versions of Linux/gcc combinations require
  the header file errno.h included in each file in order for
  it to link (otherwise, it will compile (!?) but bail out
  when linking)
- set ALL_TARGET to LOWER_OPSYS
  this works for netbsd and linux, and should work for the other bsds
  at least.
- set ALL_TARGET differently for IRIX
- use CFLAGS instead of hard-coded ABI flags for IRIX 6
- some install-sh/install can not handle multiple files/directories at
  once.  Newer bootstrapped versions can, but for systems that still
  have the older one we may as well split this for better compatibility.
This commit is contained in:
jschauma 2004-06-10 22:42:42 +00:00
parent 9c1d103865
commit f1468f69f5
5 changed files with 54 additions and 10 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.17 2004/04/11 20:42:28 snj Exp $
# $NetBSD: Makefile,v 1.18 2004/06/10 22:42:42 jschauma Exp $
DISTNAME= plan-1.8.4
CATEGORIES= x11 time
@ -11,7 +11,13 @@ COMMENT= Schedule planner based on X/Motif
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_BUILDLINK3= YES
USE_X11BASE= YES
ALL_TARGET= netbsd
ALL_TARGET= ${LOWER_OPSYS}
.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == "IRIX"
ALL_TARGET= ${LOWER_VENDOR}${OS_VERSION:C/.[0-9]//}
.endif
.include "../../mk/compiler.mk"
@ -21,10 +27,13 @@ post-configure:
.endif
pre-install:
${INSTALL_DATA_DIR} ${PREFIX}/libexec/plan ${PREFIX}/share/plan \
${PREFIX}/share/plan/holiday
${INSTALL_DATA_DIR} ${PREFIX}/libexec/plan
${INSTALL_DATA_DIR} ${PREFIX}/share/plan
${INSTALL_DATA_DIR} ${PREFIX}/share/plan/holiday
${RM} -f ${WRKDIR}/${DISTNAME}/holiday/holiday_*.orig
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/holiday/holiday_* ${PREFIX}/share/plan/holiday
for f in ${WRKDIR}/${DISTNAME}/holiday/holiday_*; do \
${INSTALL_DATA} $$f ${PREFIX}/share/plan/holiday/; \
done
for f in HISTORY README; do \
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/$$f ${PREFIX}/share/plan; \
done

View file

@ -1,8 +1,10 @@
$NetBSD: distinfo,v 1.4 2001/07/24 09:27:57 jlam Exp $
$NetBSD: distinfo,v 1.5 2004/06/10 22:42:42 jschauma Exp $
SHA1 (plan-1.8.4.tar.gz) = 0b4c5f2d078d3ad48f734c89a316258a56a5749a
Size (plan-1.8.4.tar.gz) = 422458 bytes
SHA1 (patch-aa) = 8e1ff57d70df86b641c51dd16e74a0a75437beea
SHA1 (patch-aa) = 6159fa85cfe7ad8416e03e33ddb0cf3754cde6b9
SHA1 (patch-ab) = 6670c398271e5ee6d32194c0b69850f381b5cc5c
SHA1 (patch-ac) = 3e78546544e2b55e296068be4de31f6366cab2b0
SHA1 (patch-ad) = f50e8e46e1ed503bf6f16c6cd31dd935e9251772
SHA1 (patch-ae) = 7d0fa64ada11940169d0bfa076e25b65ff1f1d15
SHA1 (patch-af) = f1eb1428667fb27bafe8aaca5bc6741b1a29d0fe

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aa,v 1.3 2001/07/24 09:27:58 jlam Exp $
$NetBSD: patch-aa,v 1.4 2004/06/10 22:42:42 jschauma Exp $
--- Makefile.orig Mon Jul 17 13:07:03 2000
+++ Makefile
--- Makefile.orig 2000-07-17 16:07:03.000000000 -0400
+++ Makefile 2004-06-10 18:02:25.000000000 -0400
@@ -8,19 +8,19 @@
# after "=", this is parsed and rewritten by the configure script.
#
@ -54,6 +54,15 @@ $NetBSD: patch-aa,v 1.3 2001/07/24 09:27:58 jlam Exp $
#------------------------- end of configuration section ----------------------
OPT=$(DEBUG) $(PLANRULE) -DPLANLOCK=\"$(PLANLOCK)\" -DPLANDLOCK=\"$(PLANDLOCK)\"
@@ -102,7 +102,7 @@
SGI4_C =
SGI5_C = -DSYSV -DSVR4 -DDESKTOP
-SGI6_C = -n32 -mips3 -woff 1110,1167,1185 -DSYSV -DSVR4 -DDESKTOP -D_BSD_SIGNALS
+SGI6_C = ${CFLAGS} -woff 1110,1167,1185 -DSYSV -DSVR4 -DDESKTOP -D_BSD_SIGNALS
HP8_C = -Aa -I/usr/include/Motif1.1 -I/usr/include/X11R4 -I/usr/include\
-D_INCLUDE_HPUX_SOURCE -D_INCLUDE_POSIX_SOURCE\
-D_INCLUDE_XOPEN_SOURCE -DNOREGEX -DFIXMBAR -DRABBITS
@@ -140,8 +140,7 @@
USL_C = -DNOKILL0 -I/usr/X/include
BSDI_C = -DBSD -DRABBITS -I/usr/X11/include -DFLOCK -DNOREGEX -Dbsdi

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ae,v 1.1 2004/06/10 22:42:43 jschauma Exp $
--- g_dbfile.c.orig 2004-06-11 18:17:47.000000000 -0400
+++ g_dbfile.c 2004-06-11 18:18:13.000000000 -0400
@@ -6,6 +6,7 @@
*/
#include <X11/Xos.h>
+#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
#include <time.h>

View file

@ -0,0 +1,12 @@
$NetBSD: patch-af,v 1.1 2004/06/10 22:42:43 jschauma Exp $
--- netplan.c.orig 2004-06-11 18:18:30.000000000 -0400
+++ netplan.c 2004-06-11 18:18:43.000000000 -0400
@@ -4,6 +4,7 @@
typedef void *Widget; /* dummy for prototype declarations in config.h */
+#include <errno.h>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>