In xmmswrapper.cpp, include stddef.h first to get a proper NULL.
For some reason, a (char *)0 gets defined somewhere on DragonFly and breaks C++ horribly. Add USE_LIBTOOL to workaround libtool breakage (unability to find library `').
This commit is contained in:
parent
d6d32da4b7
commit
f15b0fa555
3 changed files with 17 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.18 2005/11/16 01:40:15 seb Exp $
|
||||
# $NetBSD: Makefile,v 1.19 2005/11/17 16:45:52 joerg Exp $
|
||||
|
||||
DISTNAME= amarok-1.3.6
|
||||
CATEGORIES= audio kde
|
||||
|
@ -13,6 +13,7 @@ USE_DIRS+= xdg-1.1
|
|||
USE_TOOLS+= gmake pkg-config
|
||||
USE_LANGUAGES= c c++
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
|
||||
CONFIGURE_ARGS+= --without-nmm
|
||||
CONFIGURE_ARGS+= --without-mas
|
||||
|
|
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.13 2005/11/16 01:40:15 seb Exp $
|
||||
$NetBSD: distinfo,v 1.14 2005/11/17 16:45:52 joerg Exp $
|
||||
|
||||
SHA1 (amarok-1.3.6.tar.bz2) = b8029aef728a0caa7c3e789afd295782ee53fd27
|
||||
RMD160 (amarok-1.3.6.tar.bz2) = 05daeb82401b5d312a91c2f125d58f2f9589cf6e
|
||||
Size (amarok-1.3.6.tar.bz2) = 8649808 bytes
|
||||
SHA1 (patch-aa) = 32ae1ed331a36951739651f380363b71cc0b04e8
|
||||
|
|
13
audio/amarok/patches/patch-aa
Normal file
13
audio/amarok/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.8 2005/11/17 16:45:52 joerg Exp $
|
||||
|
||||
--- amarok/src/vis/xmmswrapper/xmmswrapper.cpp.orig 2005-11-17 16:04:50.000000000 +0000
|
||||
+++ amarok/src/vis/xmmswrapper/xmmswrapper.cpp
|
||||
@@ -3,6 +3,8 @@
|
||||
|
||||
#include <config.h>
|
||||
|
||||
+#include <stddef.h> /* NULL */
|
||||
+
|
||||
#include <xmms/configfile.h> //visplugins use this stuff, see extern "C" block
|
||||
|
||||
#include <dirent.h>
|
Loading…
Reference in a new issue