Update to 1.23.0
* Disable Solaris/SunOS suppprt for a while Changelog: # What's in 1.23.0 stable New year, new Rust! For our first improvement today, we now avoid some unnecessary copies in certain situations. We've seen memory usage of using rustc to drop 5-10% with this change; it may be different with your programs. The documentation team has been on a long journey to move rustdoc to use CommonMark. Previously, rustdoc never guaranteed which markdown rendering engine it used, but we're finally committing to CommonMark. As part of this release, we render the documentation with our previous renderer, Hoedown, but also render it with a CommonMark compliant renderer, and warn if there are any differences. There should be a way for you to modify the syntax you use to render correctly under both; we're not aware of any situations where this is impossible. Docs team member Guillaume Gomez has written a blog post showing some common differences and how to solve them. In a future release, we will switch to using the CommonMark renderer by default. This warning landed in nightly in May of last year, and has been on by default since October of last year, so many crates have already fixed any issues that they've found. In other documentation news, historically, Cargo's docs have been a bit strange. Rather than being on doc.rust-lang.org, they've been at doc.crates.io. With this release, that's changing. You can now find Cargo's docs at doc.rust-lang.org/cargo. Additionally, they've been converted to the same format as our other long-form documentation. We'll be adding a redirect from doc.crates.io to this page, and you can expect to see more improvements and updates to Cargo's docs throughout the year. See the detailed release notes for more. ## Library stabilizations As of Rust 1.0, a trait named AsciiExt existed to provide ASCII related functionality on u8, char, [u8], and str. To use it, you'd write code like this: use std::ascii::AsciiExt; let ascii = 'a'; let non_ascii = '❤'; let int_ascii = 97; assert!(ascii.is_ascii()); assert!(!non_ascii.is_ascii()); assert!(int_ascii.is_ascii()); In Rust 1.23, these methods are now defined directly on those types, and so you no longer need to import the trait. Thanks to our stability guarantees, this trait still exists, so if you'd like to still support Rust versions before Rust 1.23, you can do this: #[allow(unused_imports)] use std::ascii::AsciiExt; ...to suppress the related warning. Once you drop support for older Rusts, you can remove both lines, and everything will continue to work. Additionally, a few new APIs were stabilized this release: The various std::sync::atomic types now implement From their non-atomic types. For example, let x = AtomicBool::from(true);. () now implements FromIterator<()>; check the PR for a neat use-case. RwLock<T> has had its Send restriction lifted See the detailed release notes for more. ## Cargo features cargo check can now check your unit tests. cargo uninstall can now uninstall more than one package in one command.
This commit is contained in:
parent
427e4995b3
commit
f166e97b4c
6 changed files with 72 additions and 111 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.26 2018/01/04 15:18:50 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.27 2018/01/08 09:33:58 ryoon Exp $
|
||||
|
||||
DISTNAME= rustc-1.22.1-src
|
||||
DISTNAME= rustc-1.23.0-src
|
||||
PKGNAME= ${DISTNAME:S/rustc/rust/:S/-src//}
|
||||
PKGREVISION= 3
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= http://static.rust-lang.org/dist/
|
||||
|
||||
|
@ -75,7 +74,7 @@ CONFIGURE_ARGS+= --disable-jemalloc
|
|||
# own bootstrap. See the stage0-bootstrap below for more details.
|
||||
#
|
||||
DISTFILES:= ${DEFAULT_DISTFILES}
|
||||
RUST_STAGE0_VER= 1.21.0
|
||||
RUST_STAGE0_VER= 1.22.1
|
||||
#
|
||||
.if !empty(MACHINE_PLATFORM:MDarwin-*-i386) || make(distinfo) || make (makesum) || make(mdi)
|
||||
RUST_ARCH:= i686-apple-darwin
|
||||
|
@ -101,13 +100,13 @@ RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
|
|||
RUST_STD_STAGE0:= rust-std-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
|
||||
DISTFILES:= ${DISTFILES} ${RUST_STAGE0} ${RUST_STD_STAGE0}
|
||||
.endif
|
||||
.if !empty(MACHINE_PLATFORM:MSunOS-*-x86_64) || make(distinfo) || make (makesum) || make(mdi)
|
||||
RUST_ARCH:= x86_64-sun-solaris
|
||||
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
|
||||
SITES.${RUST_STAGE0}= https://us-east.manta.joyent.com/pkgsrc/public/pkg-bootstraps/
|
||||
DISTFILES:= ${DISTFILES} ${RUST_STAGE0}
|
||||
RUST_BOOTSTRAP_PATH?= ${WRKDIR}/rust-${RUST_STAGE0_VER}-${RUST_ARCH}
|
||||
.endif
|
||||
#.if !empty(MACHINE_PLATFORM:MSunOS-*-x86_64) || make(distinfo) || make (makesum) || make(mdi)
|
||||
#RUST_ARCH:= x86_64-sun-solaris
|
||||
#RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
|
||||
#SITES.${RUST_STAGE0}= https://us-east.manta.joyent.com/pkgsrc/public/pkg-bootstraps/
|
||||
#DISTFILES:= ${DISTFILES} ${RUST_STAGE0}
|
||||
#RUST_BOOTSTRAP_PATH?= ${WRKDIR}/rust-${RUST_STAGE0_VER}-${RUST_ARCH}
|
||||
#.endif
|
||||
.if !empty(MACHINE_PLATFORM:MNetBSD-*-i386) || make(distinfo) || make (makesum) || make(mdi)
|
||||
RUST_ARCH= i686-unknown-netbsd
|
||||
RUST_STAGE0:= rust-${RUST_STAGE0_VER}-${RUST_ARCH}.tar.gz
|
||||
|
|
|
@ -1,66 +1,60 @@
|
|||
$NetBSD: distinfo,v 1.15 2018/01/04 15:18:50 jperkin Exp $
|
||||
$NetBSD: distinfo,v 1.16 2018/01/08 09:33:58 ryoon Exp $
|
||||
|
||||
SHA1 (rust-1.21.0-i686-apple-darwin.tar.gz) = 9e01c8800419db1de2c31dee06494194ab843b7d
|
||||
RMD160 (rust-1.21.0-i686-apple-darwin.tar.gz) = 0f5f73fb5dfca510afd9acaf755893901a3180ca
|
||||
SHA512 (rust-1.21.0-i686-apple-darwin.tar.gz) = 48bd390722aeb6bd692db123026f05bbc6d23cf86cfd75b38aff6dae8b9b8eb492ad05c3f4f917eee86236b5620f75b298608588a17d0e9cd38bc15e8505b651
|
||||
Size (rust-1.21.0-i686-apple-darwin.tar.gz) = 131082514 bytes
|
||||
SHA1 (rust-1.21.0-i686-unknown-linux-gnu.tar.gz) = 75e07d06342e4c612c2a98d9a7e6eb38acfd296a
|
||||
RMD160 (rust-1.21.0-i686-unknown-linux-gnu.tar.gz) = d39a098d532f0526c51e83ce8d44bfbc641c9893
|
||||
SHA512 (rust-1.21.0-i686-unknown-linux-gnu.tar.gz) = 63ab8e34869b79b4c203f481937c35cca0afdb18dda19116cc6d7082de360dede30b200ace831857b9ce7b3bc83e2ceea134e87de46cf28fb79211520ea3d227
|
||||
Size (rust-1.21.0-i686-unknown-linux-gnu.tar.gz) = 152141942 bytes
|
||||
SHA1 (rust-1.21.0-i686-unknown-netbsd.tar.gz) = 63c633c7561040d8e7b9578be714e1224ae3da7d
|
||||
RMD160 (rust-1.21.0-i686-unknown-netbsd.tar.gz) = ffac35745ceb01c7bb2a1caa9867c6bc1aa25d4d
|
||||
SHA512 (rust-1.21.0-i686-unknown-netbsd.tar.gz) = 2319bee6a5b4bb854567505240a13976f3117e9073c0f8181d923226c9fd3d97792160bdff99d8715a1ee5d0c19d232a5f7548f331ad186a195d784f2ebb77bc
|
||||
Size (rust-1.21.0-i686-unknown-netbsd.tar.gz) = 171539464 bytes
|
||||
SHA1 (rust-1.21.0-x86_64-apple-darwin.tar.gz) = a605caf3f2f15259291fcc101c964d17b2f2d426
|
||||
RMD160 (rust-1.21.0-x86_64-apple-darwin.tar.gz) = c1fb237215d34059041065c0508308eea767f7b3
|
||||
SHA512 (rust-1.21.0-x86_64-apple-darwin.tar.gz) = dd19ec67b22c43d219ee88319312ab82964d40d0996931eb1c7df12defebc17827fbdbb4f7096aff6cee6772c8f6b6f1614a487b8b2a0ab3b5f3cb66417aaf8a
|
||||
Size (rust-1.21.0-x86_64-apple-darwin.tar.gz) = 133932530 bytes
|
||||
SHA1 (rust-1.21.0-x86_64-sun-solaris.tar.gz) = 5da64aa97e4aba82d02f7547dbdd44a9305005fc
|
||||
RMD160 (rust-1.21.0-x86_64-sun-solaris.tar.gz) = b0c1aa3734faf03d2b02fa301562b79ec145aa66
|
||||
SHA512 (rust-1.21.0-x86_64-sun-solaris.tar.gz) = 952280e446c86091340202caa206ea7f31295d82cc65da95a4e78fa691bdf837ded587d916ff3226adc639f7483db8ab12a99ef7e233cdac46c33e9edcc738ad
|
||||
Size (rust-1.21.0-x86_64-sun-solaris.tar.gz) = 146676219 bytes
|
||||
SHA1 (rust-1.21.0-x86_64-unknown-linux-gnu.tar.gz) = a725a3cdaf937b30788d55363f962a1da1a6e2e2
|
||||
RMD160 (rust-1.21.0-x86_64-unknown-linux-gnu.tar.gz) = 5d4feca3675ec279868e52b7bdb84349be9c9e83
|
||||
SHA512 (rust-1.21.0-x86_64-unknown-linux-gnu.tar.gz) = 8ffee69e895eba1564eecff769a105c8069cc66ce85f4ae6d1316eef5483185d8b4180595a1d67b2f08802b74e349c7677398203d89e3b131b56b2ea7ce0e980
|
||||
Size (rust-1.21.0-x86_64-unknown-linux-gnu.tar.gz) = 161008260 bytes
|
||||
SHA1 (rust-1.21.0-x86_64-unknown-netbsd.tar.gz) = a06aaf281a9d02678d1472bda1f1f75c7fa32fd7
|
||||
RMD160 (rust-1.21.0-x86_64-unknown-netbsd.tar.gz) = af75dde0002af7ceca6e1f44fbf0850180b1dcca
|
||||
SHA512 (rust-1.21.0-x86_64-unknown-netbsd.tar.gz) = 32bcc10180314eec08dd70cd914ab9083ba172ae91a1d08266f51e5eaac482459d695b17120496dba265f656882d0280db614a1c4e891bac576290810081b259
|
||||
Size (rust-1.21.0-x86_64-unknown-netbsd.tar.gz) = 142044953 bytes
|
||||
SHA1 (rust-std-1.21.0-i686-apple-darwin.tar.gz) = 37f6dbf18ab4b2ecd3b871764e03d45cc2b8a677
|
||||
RMD160 (rust-std-1.21.0-i686-apple-darwin.tar.gz) = dd2eac226f7226bf805b09d39a83289054107031
|
||||
SHA512 (rust-std-1.21.0-i686-apple-darwin.tar.gz) = 32badbdb52bf06aebae506efff2251001b2912126a540bc7324b81d75bd83fffc19ae7f729294d7941b7ee283e991d381a98d97293d3d541a6dad06c8882fe8b
|
||||
Size (rust-std-1.21.0-i686-apple-darwin.tar.gz) = 62398751 bytes
|
||||
SHA1 (rust-std-1.21.0-i686-unknown-linux-gnu.tar.gz) = 34b71a0b3e537d041936527d0a697c2079160b6f
|
||||
RMD160 (rust-std-1.21.0-i686-unknown-linux-gnu.tar.gz) = a1269384082a05cd88b809f437e8e8376e37a51a
|
||||
SHA512 (rust-std-1.21.0-i686-unknown-linux-gnu.tar.gz) = 51e96a4b2e01dab6da3881a9e5b8aa40498d489917d98497428b6c97d73f1f0cb7eaee56040451d5a747ada4e8560b50ffc96fc39dfaf6104e2cf453192dd2b5
|
||||
Size (rust-std-1.21.0-i686-unknown-linux-gnu.tar.gz) = 73026434 bytes
|
||||
SHA1 (rust-std-1.21.0-i686-unknown-netbsd.tar.gz) = 2ff0ce748287e6ebcee41025a1468bf7554d88d4
|
||||
RMD160 (rust-std-1.21.0-i686-unknown-netbsd.tar.gz) = b8a2762eaefa295d3f0e1c8d0097736045d312b3
|
||||
SHA512 (rust-std-1.21.0-i686-unknown-netbsd.tar.gz) = 2eb0e2737f75207b0592981c0a4b24e035b8467690d1a8884514df49c61425f3c399fcd40edcf537ec44ffa0e03b9f008a9e533b01ee4b668faecb536e39ff6c
|
||||
Size (rust-std-1.21.0-i686-unknown-netbsd.tar.gz) = 76481494 bytes
|
||||
SHA1 (rust-std-1.21.0-x86_64-apple-darwin.tar.gz) = 92d33211e2601113aa5b3a526303f4acb08bb87f
|
||||
RMD160 (rust-std-1.21.0-x86_64-apple-darwin.tar.gz) = 5464f0dc69416cbba28c6ab65fb196820f8849f3
|
||||
SHA512 (rust-std-1.21.0-x86_64-apple-darwin.tar.gz) = c3faad4a16ec1d428ededa251409b5f6402b0f6abb04329a9bb239f3fbba444832f3f9ca31d32a694a57b0b12c535bba0992204f46e014ea549820b7f0292249
|
||||
Size (rust-std-1.21.0-x86_64-apple-darwin.tar.gz) = 63566693 bytes
|
||||
SHA1 (rust-std-1.21.0-x86_64-unknown-linux-gnu.tar.gz) = 2c5a3450df5071962c8ca519f7416bca661fc3cc
|
||||
RMD160 (rust-std-1.21.0-x86_64-unknown-linux-gnu.tar.gz) = f0ae6dbec6a733cf6e6ebce7b7dafd8b56ae0b50
|
||||
SHA512 (rust-std-1.21.0-x86_64-unknown-linux-gnu.tar.gz) = 635373c3e08b3570e296e98607110b4c79b3196dd34ec075fa705cf939f9946db8594b5646d1862ecc4927d6bb5181442d8d329592cf97f880cb912fc7174bbc
|
||||
Size (rust-std-1.21.0-x86_64-unknown-linux-gnu.tar.gz) = 83489993 bytes
|
||||
SHA1 (rust-std-1.21.0-x86_64-unknown-netbsd.tar.gz) = 6aae65c3120f0d949adf567504bacfc6cc0087d4
|
||||
RMD160 (rust-std-1.21.0-x86_64-unknown-netbsd.tar.gz) = 7206b29b6c9283d06cdf2def4af65bf9ab97c346
|
||||
SHA512 (rust-std-1.21.0-x86_64-unknown-netbsd.tar.gz) = 6f4c4c1b27c7ffa191c73e766371fccb67684fb24bf99bbf149b71ecb4eadb650dfc9afd9bc722689d84bd53626c23f5f42e61ea8c79f91432ead661873673be
|
||||
Size (rust-std-1.21.0-x86_64-unknown-netbsd.tar.gz) = 68316257 bytes
|
||||
SHA1 (rustc-1.22.1-src.tar.gz) = 05e5d569ba3737e4b596bef4f4d0cb69f888e69d
|
||||
RMD160 (rustc-1.22.1-src.tar.gz) = 1b2a36e53f70bb643e86a275d5f6652efc536de7
|
||||
SHA512 (rustc-1.22.1-src.tar.gz) = cb1f0f5643c5244225255030bef974eb8d642c9a9f04d3a1ba44157b3848ca2ee0c1b96160c19e6e0e110d0065836f99936f00678690840aa8f34e22ecece874
|
||||
Size (rustc-1.22.1-src.tar.gz) = 54935620 bytes
|
||||
SHA1 (patch-src_bootstrap_bin_rustc.rs) = 617cc7ae52d92fdf80af0aff169c17a9cec4d67c
|
||||
SHA1 (patch-src_bootstrap_lib.rs) = b69068545d489b448705c79f854e2f73bda53b1e
|
||||
SHA1 (rust-1.22.1-i686-apple-darwin.tar.gz) = 9e846c124ea8d94234bed3bf96abba6d405898c3
|
||||
RMD160 (rust-1.22.1-i686-apple-darwin.tar.gz) = d873e7d9f98f700a281beeabbf4e70df4b2d1949
|
||||
SHA512 (rust-1.22.1-i686-apple-darwin.tar.gz) = 92a8a1bb2a7f87ef893343bfc878948984a485da929abcfea67fd4e7c1f260bb1bbf273e2d8e14b9c5efeef6092bed0668db3a39064abbf209f0817c6403a61f
|
||||
Size (rust-1.22.1-i686-apple-darwin.tar.gz) = 128186253 bytes
|
||||
SHA1 (rust-1.22.1-i686-unknown-linux-gnu.tar.gz) = b0f9049be84d682006a067e92e3a824ef88de41e
|
||||
RMD160 (rust-1.22.1-i686-unknown-linux-gnu.tar.gz) = dba349de91fb173d9607f7fee10fbbee0e26059c
|
||||
SHA512 (rust-1.22.1-i686-unknown-linux-gnu.tar.gz) = 5e24f021cc31f3998209cdca180cba8a51ab368991dbd74743e5402213ace87d289b0be095e54ce83c6b10753bac5a53dfa05116bb1d9fd283b9ec602bdfcfb9
|
||||
Size (rust-1.22.1-i686-unknown-linux-gnu.tar.gz) = 151926292 bytes
|
||||
SHA1 (rust-1.22.1-i686-unknown-netbsd.tar.gz) = 4d794ff2e789487a55ea03af9a85cc776e23c735
|
||||
RMD160 (rust-1.22.1-i686-unknown-netbsd.tar.gz) = 765987d2ce25eb726f6818b3dbe5d660810284f1
|
||||
SHA512 (rust-1.22.1-i686-unknown-netbsd.tar.gz) = e4566d76c7f9030b450ade689199dde93253d3503942a480ff226b5f3a3d40a41e0cd7985bd6a8dbbbc32a563ade509ddf1d2365de7c7530a1ca68f3768046b5
|
||||
Size (rust-1.22.1-i686-unknown-netbsd.tar.gz) = 154203732 bytes
|
||||
SHA1 (rust-1.22.1-x86_64-apple-darwin.tar.gz) = 0f373805daf012aa1559afc23600405823879ae6
|
||||
RMD160 (rust-1.22.1-x86_64-apple-darwin.tar.gz) = 00119085a763d0bd112669167f8aa71fcf9c44dc
|
||||
SHA512 (rust-1.22.1-x86_64-apple-darwin.tar.gz) = 75818fdf4b76844dcb04d9a5061b192c014d796090b9ccef91db6d4c9368951c6bb2e2752e85d38e9081a8abe2b237f6b0502e02409a2b6004a58d01ced8a14e
|
||||
Size (rust-1.22.1-x86_64-apple-darwin.tar.gz) = 131157151 bytes
|
||||
SHA1 (rust-1.22.1-x86_64-unknown-linux-gnu.tar.gz) = a1a5dd3650fb8393e7201280d2bba3bcd9d9194f
|
||||
RMD160 (rust-1.22.1-x86_64-unknown-linux-gnu.tar.gz) = e4c1626b864a819778584ecb51667c168f0ec271
|
||||
SHA512 (rust-1.22.1-x86_64-unknown-linux-gnu.tar.gz) = 0fd3776a7fd38cbcbffe8a257836f9f5c0d04762af3107b93b8860b98b6d92b0912b4668c973d9f647a7a74b4855a5680cab042c3389c6158efee1b4640a60de
|
||||
Size (rust-1.22.1-x86_64-unknown-linux-gnu.tar.gz) = 160434198 bytes
|
||||
SHA1 (rust-1.22.1-x86_64-unknown-netbsd.tar.gz) = ecf48d776a4b1f7ddb39c51f30376f53bdbfc11d
|
||||
RMD160 (rust-1.22.1-x86_64-unknown-netbsd.tar.gz) = 5cac3c44ec455532d4466ed0f57c904ca9f77733
|
||||
SHA512 (rust-1.22.1-x86_64-unknown-netbsd.tar.gz) = 0e80041c2f732da56a614862413bf97a218f92f7d858be8c62961fae45690de763f5bdd25aa66a7583c2136d3631f6a97b7f309d84652e6dc6ec37e681ecd283
|
||||
Size (rust-1.22.1-x86_64-unknown-netbsd.tar.gz) = 141364677 bytes
|
||||
SHA1 (rust-std-1.22.1-i686-apple-darwin.tar.gz) = 3fbd0f74e8a59f3e074b254f55fe84c388488faa
|
||||
RMD160 (rust-std-1.22.1-i686-apple-darwin.tar.gz) = c37621c86f7e8e15fa90ed881303e772841e3a5e
|
||||
SHA512 (rust-std-1.22.1-i686-apple-darwin.tar.gz) = 0a35db3514a06663c15a5a6c1544057853a954fdc29db48e23ac98fa5b248bea479363eb6bbbeeb9ce56ea2c8506f0f5819d2a0f6668c8d2c208117ba1711794
|
||||
Size (rust-std-1.22.1-i686-apple-darwin.tar.gz) = 60227393 bytes
|
||||
SHA1 (rust-std-1.22.1-i686-unknown-linux-gnu.tar.gz) = 1d0265e4d5a3e09650b99c1142886cd0e4151572
|
||||
RMD160 (rust-std-1.22.1-i686-unknown-linux-gnu.tar.gz) = fa1e751a6c6a80d2853c36f8d585c6333f4f68ee
|
||||
SHA512 (rust-std-1.22.1-i686-unknown-linux-gnu.tar.gz) = 867a4ad11041f978f28e0ccd119f0ef19603cf56b43e9d2b6d527c88b9c86e26ccf40172b484f5dfd5c52654e7266872c25c1b48e5a403c532c30e1d2b54c386
|
||||
Size (rust-std-1.22.1-i686-unknown-linux-gnu.tar.gz) = 70983153 bytes
|
||||
SHA1 (rust-std-1.22.1-i686-unknown-netbsd.tar.gz) = 94fed3116a71f06bc1630900bc34064ce12f1a0d
|
||||
RMD160 (rust-std-1.22.1-i686-unknown-netbsd.tar.gz) = 78f0f24d308006a292888d5cfcae0afe11d577ed
|
||||
SHA512 (rust-std-1.22.1-i686-unknown-netbsd.tar.gz) = 7b52305d7d5f2381daf419fa2fbd0a1756400d4227965fea78622cf5d033e462813cb329a8d4e3a6c71f7e4f3675278eb64b62df87f53368fa27198ed1128ac9
|
||||
Size (rust-std-1.22.1-i686-unknown-netbsd.tar.gz) = 80286408 bytes
|
||||
SHA1 (rust-std-1.22.1-x86_64-apple-darwin.tar.gz) = 0d34bd70369cacf31ca3f113855435a48de67431
|
||||
RMD160 (rust-std-1.22.1-x86_64-apple-darwin.tar.gz) = 49a78f586fb2560bcbc36003a273ad364b8df8aa
|
||||
SHA512 (rust-std-1.22.1-x86_64-apple-darwin.tar.gz) = adcf063cdd59fcc17853353f303091fe2c24b68632b788968ea7bbd0f0034470831c388eff3d52838d409b458300dca482ce701a99fef665be785ec50dd49416
|
||||
Size (rust-std-1.22.1-x86_64-apple-darwin.tar.gz) = 61451295 bytes
|
||||
SHA1 (rust-std-1.22.1-x86_64-unknown-linux-gnu.tar.gz) = 0211229c5f65e287b6c2741945fe1def2392235e
|
||||
RMD160 (rust-std-1.22.1-x86_64-unknown-linux-gnu.tar.gz) = b064f709cc165ed7e7c1d702c7e609aa71848f95
|
||||
SHA512 (rust-std-1.22.1-x86_64-unknown-linux-gnu.tar.gz) = ba4ad86b328d135ccd7735cc280889c1526128b1bbc85041c2b9cced47bb6697352d16852db76111868b2b10fd42e5198c11f6fe6d3c4009972627ccd6b874dd
|
||||
Size (rust-std-1.22.1-x86_64-unknown-linux-gnu.tar.gz) = 81372873 bytes
|
||||
SHA1 (rust-std-1.22.1-x86_64-unknown-netbsd.tar.gz) = aa825d7c39f285dea39f93bcf610775c14e53789
|
||||
RMD160 (rust-std-1.22.1-x86_64-unknown-netbsd.tar.gz) = 83281e839c0950711ad2e2dc3605ad3ff696470a
|
||||
SHA512 (rust-std-1.22.1-x86_64-unknown-netbsd.tar.gz) = 4e095960dbb4fe2d83aa99b7c03793c03c9aa9d68f66bd8ed1508b0005438515856fd09a8ec8f28a50d419ceb97f2c3d0f1a1b6f612325d18819151a7896358c
|
||||
Size (rust-std-1.22.1-x86_64-unknown-netbsd.tar.gz) = 66149679 bytes
|
||||
SHA1 (rustc-1.23.0-src.tar.gz) = e21a85ecdc9adbb2b3cbe0f07282e6e59bc50ef1
|
||||
RMD160 (rustc-1.23.0-src.tar.gz) = f8dc31e9fbe1e2071d2307be5a38c73da8a637ee
|
||||
SHA512 (rustc-1.23.0-src.tar.gz) = a1dbb1a625c6d8dfe9708e1cf478a49154b1eb0aba5ba67ac85518a8c7d1c70d2d86ac4d441156e9bfd0fd77ca241fb5491a2bd68aefcf0b3c2e164c3cc29e4e
|
||||
Size (rustc-1.23.0-src.tar.gz) = 60010149 bytes
|
||||
SHA1 (patch-src_bootstrap_bin_rustc.rs) = e4baa9e42a8d1e55fdf8317f833d5b645dd6e1c2
|
||||
SHA1 (patch-src_bootstrap_lib.rs) = 1c290a1e0f251c99cdb4fa8639f8680f9c7953ff
|
||||
SHA1 (patch-src_libbacktrace_configure) = b2c1e9b93a99408aad42ab9f1af27704cc81bdd8
|
||||
SHA1 (patch-src_libstd_build.rs) = 32dad8a474300f9f37bce8b92acca762cf8cc4ab
|
||||
SHA1 (patch-src_llvm_cmake_modules_AddLLVM.cmake) = 282d97cce8d01cfefe565185d4999c2db9ccc13f
|
||||
SHA1 (patch-src_llvm_lib_CodeGen_MachineDominanceFrontier.cpp) = 2899771b1a23be840b9305eff7e5e5f957239ccb
|
||||
SHA1 (patch-src_vendor_filetime_.cargo-checksum.json) = 7cdd486b65ad780c3a472bc1846d55270dcbcdeb
|
||||
SHA1 (patch-src_vendor_filetime_src_unix.rs) = e31011cdc146897b6530c51d76929b8ac194f6a2
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-src_bootstrap_bin_rustc.rs,v 1.1 2017/09/30 04:42:43 ryoon Exp $
|
||||
$NetBSD: patch-src_bootstrap_bin_rustc.rs,v 1.2 2018/01/08 09:33:58 ryoon Exp $
|
||||
|
||||
* Set RPATH for pkgsrc wrapper
|
||||
|
||||
--- src/bootstrap/bin/rustc.rs.orig 2017-08-27 18:26:05.000000000 +0000
|
||||
--- src/bootstrap/bin/rustc.rs.orig 2018-01-01 21:50:13.000000000 +0000
|
||||
+++ src/bootstrap/bin/rustc.rs
|
||||
@@ -225,7 +225,7 @@ fn main() {
|
||||
@@ -224,7 +224,7 @@ fn main() {
|
||||
cmd.arg("-Z").arg("osx-rpath-install-name");
|
||||
Some("-Wl,-rpath,@loader_path/../lib")
|
||||
} else if !target.contains("windows") {
|
||||
|
|
|
@ -1,12 +1,12 @@
|
|||
$NetBSD: patch-src_bootstrap_lib.rs,v 1.1 2017/12/07 12:12:44 maya Exp $
|
||||
$NetBSD: patch-src_bootstrap_lib.rs,v 1.2 2018/01/08 09:33:58 ryoon Exp $
|
||||
|
||||
Don't filter out optimization flags.
|
||||
|
||||
--- src/bootstrap/lib.rs.orig 2017-11-22 21:33:00.000000000 +0000
|
||||
--- src/bootstrap/lib.rs.orig 2018-01-01 21:50:13.000000000 +0000
|
||||
+++ src/bootstrap/lib.rs
|
||||
@@ -622,7 +622,6 @@ impl Build {
|
||||
@@ -636,7 +636,6 @@ impl Build {
|
||||
// cc-rs because the build scripts will determine that for themselves.
|
||||
let mut base = self.cc[&target].0.args().iter()
|
||||
let mut base = self.cc[&target].args().iter()
|
||||
.map(|s| s.to_string_lossy().into_owned())
|
||||
- .filter(|s| !s.starts_with("-O") && !s.starts_with("/O"))
|
||||
.collect::<Vec<_>>();
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
$NetBSD: patch-src_vendor_filetime_.cargo-checksum.json,v 1.1 2018/01/04 15:18:51 jperkin Exp $
|
||||
|
||||
Update checksum for src/unix.rs patch.
|
||||
|
||||
--- src/vendor/filetime/.cargo-checksum.json.orig 2017-11-22 23:37:31.000000000 +0000
|
||||
+++ src/vendor/filetime/.cargo-checksum.json
|
||||
@@ -1 +1 @@
|
||||
-{"files":{".cargo-ok":"e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855",".gitignore":"f9b1ca6ae27d1c18215265024629a8960c31379f206d9ed20f64e0b2dcf79805",".travis.yml":"fed0342a81e321ed9d4189905a9987d60d5b83b3c097dd3dc62d81461c8b65d8","Cargo.toml":"34c5b16ec63d0079f74203650c1766d928384f16801472f0e19912dee8e3fd9e","Cargo.toml.orig":"6ed10b4b57d08fa891d9c8d8579509107b2046965db9c76145b6ede345c9a570","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"378f5840b258e2779c39418f3f2d7b2ba96f1c7917dd6be0713f88305dbda397","README.md":"fef1998633eb2f460e6b12bc1133a21f5674e0b53ae5914ba1e53f1b63a185c3","appveyor.yml":"3a74394c3e3ef3b2c7d9458f526e47587977e98d026b63f00be29479075ff597","src/lib.rs":"12dff581c45905398c5eab919cda969d811d1e56a486aee13b12027d7840a5f7","src/redox.rs":"7b6376069ea06e6593058699af40fa780c3d621c010d31bfa6c1bfae18de28f4","src/unix.rs":"943587ee42bfcb684cb0abf8567d478dc21006e01f96fb86c76e5d0e2b7932dd","src/windows.rs":"37dd08863698a5c32c103374ad1ed776405b75038c88bc48b7db28ad9c5bf86b"},"package":"6ab199bf38537c6f38792669e081e0bb278b9b7405bba2642e4e5d15bf732c0e"}
|
||||
\ No newline at end of file
|
||||
+{"files":{".cargo-ok":"e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855",".gitignore":"f9b1ca6ae27d1c18215265024629a8960c31379f206d9ed20f64e0b2dcf79805",".travis.yml":"fed0342a81e321ed9d4189905a9987d60d5b83b3c097dd3dc62d81461c8b65d8","Cargo.toml":"34c5b16ec63d0079f74203650c1766d928384f16801472f0e19912dee8e3fd9e","Cargo.toml.orig":"6ed10b4b57d08fa891d9c8d8579509107b2046965db9c76145b6ede345c9a570","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"378f5840b258e2779c39418f3f2d7b2ba96f1c7917dd6be0713f88305dbda397","README.md":"fef1998633eb2f460e6b12bc1133a21f5674e0b53ae5914ba1e53f1b63a185c3","appveyor.yml":"3a74394c3e3ef3b2c7d9458f526e47587977e98d026b63f00be29479075ff597","src/lib.rs":"12dff581c45905398c5eab919cda969d811d1e56a486aee13b12027d7840a5f7","src/redox.rs":"7b6376069ea06e6593058699af40fa780c3d621c010d31bfa6c1bfae18de28f4","src/unix.rs":"24e6c14adb4b66879f4f616d7617e948f9fc4ab497b77c008825daef59e45456","src/windows.rs":"37dd08863698a5c32c103374ad1ed776405b75038c88bc48b7db28ad9c5bf86b"},"package":"6ab199bf38537c6f38792669e081e0bb278b9b7405bba2642e4e5d15bf732c0e"}
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-src_vendor_filetime_src_unix.rs,v 1.1 2018/01/04 15:18:51 jperkin Exp $
|
||||
|
||||
SunOS does not have lutimes.
|
||||
|
||||
--- src/vendor/filetime/src/unix.rs.orig 2017-11-22 23:37:31.000000000 +0000
|
||||
+++ src/vendor/filetime/src/unix.rs
|
||||
@@ -14,12 +14,12 @@ pub fn set_file_times(p: &Path, atime: F
|
||||
set_file_times_u(p, atime, mtime, libc::utimes)
|
||||
}
|
||||
|
||||
-#[cfg(target_os = "android")]
|
||||
+#[cfg(any(target_os = "android", target_os = "solaris"))]
|
||||
pub fn set_symlink_file_times(_p: &Path, _atime: FileTime, _mtime: FileTime) -> io::Result<()> {
|
||||
- Err(io::Error::new(io::ErrorKind::Other, "not supported on Android"))
|
||||
+ Err(io::Error::new(io::ErrorKind::Other, "not supported"))
|
||||
}
|
||||
|
||||
-#[cfg(not(target_os = "android"))]
|
||||
+#[cfg(not(any(target_os = "android", target_os = "solaris")))]
|
||||
pub fn set_symlink_file_times(p: &Path, atime: FileTime, mtime: FileTime) -> io::Result<()> {
|
||||
set_file_times_u(p, atime, mtime, libc::lutimes)
|
||||
}
|
Loading…
Reference in a new issue