Update to 0.2.3. Remove patch-ac, all the header files it added are now

included by default.

*******************
* GUPnP IGD 0.2.3 *
*******************

- Emit errors as boxed types
- Various build improvements
- Make tests less racy
This commit is contained in:
wiz 2014-02-12 15:15:20 +00:00
parent dc3e73c2dc
commit f184842bf8
4 changed files with 9 additions and 28 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.25 2014/01/25 10:30:16 wiz Exp $
# $NetBSD: Makefile,v 1.26 2014/02/12 15:15:20 wiz Exp $
DISTNAME= gupnp-igd-0.2.2
PKGREVISION= 5
DISTNAME= gupnp-igd-0.2.3
CATEGORIES= net devel
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gupnp-igd/0.2/}
EXTRACT_SUFX= .tar.xz
@ -12,12 +11,13 @@ COMMENT= Library to handle UPnP IGD port mapping
LICENSE= gnu-lgpl-v2.1
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-python
USE_LIBTOOL= yes
USE_TOOLS+= gmake pkg-config
PKGCONFIG_OVERRIDE+= gupnp-igd-1.0.pc.in
PY_PATCHPLIST= yes
PYTHON_VERSIONS_INCOMPATIBLE= 33 # not yet ported as of 0.2.2
PYTHON_VERSIONS_INCOMPATIBLE= 33 # py-gobject; not yet ported as of 0.2.2
CONFIGURE_ENV+= PYTHON=${PYTHONBIN:Q}

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2012/10/06 08:18:53 ryoon Exp $
@comment $NetBSD: PLIST,v 1.5 2014/02/12 15:15:20 wiz Exp $
include/gupnp-igd-1.0/libgupnp-igd/gupnp-simple-igd-thread.h
include/gupnp-igd-1.0/libgupnp-igd/gupnp-simple-igd.h
lib/libgupnp-igd-1.0.la

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.8 2013/03/15 18:13:46 drochner Exp $
$NetBSD: distinfo,v 1.9 2014/02/12 15:15:20 wiz Exp $
SHA1 (gupnp-igd-0.2.2.tar.xz) = bd24e98b224b3a233b0ab6714638ed4c6bf64b47
RMD160 (gupnp-igd-0.2.2.tar.xz) = 215f21e85dd902c729c3aff9981bff42c4b20d3c
Size (gupnp-igd-0.2.2.tar.xz) = 262216 bytes
SHA1 (patch-ac) = 76cae0ce8589f1f2b8edbffdbeaf4ab668d21691
SHA1 (gupnp-igd-0.2.3.tar.xz) = a319fbe75f748b830519d86f6f4898fb176abbf1
RMD160 (gupnp-igd-0.2.3.tar.xz) = be9b68f7f5916a7e4c8b26f8c2f3c4ac7337dc5d
Size (gupnp-igd-0.2.3.tar.xz) = 269920 bytes

View file

@ -1,18 +0,0 @@
$NetBSD: patch-ac,v 1.1 2010/12/25 06:33:11 obache Exp $
* DragonFly require additional headers for inet_pton(3).
--- libgupnp-igd/gupnp-simple-igd.c.orig 2010-04-05 17:54:17.000000000 +0000
+++ libgupnp-igd/gupnp-simple-igd.c
@@ -36,6 +36,11 @@
#include "gupnp-simple-igd-marshal.h"
#include <string.h>
+#ifdef __DragonFly__
+#include <sys/types.h>
+#include <sys/socket.h>
+#include <netinet/in.h>
+#endif
#include <arpa/inet.h>
#include <libgupnp/gupnp.h>