Import lua-socket-2.0.2 as net/lua-socket.
Lua extension library that is composed by two parts: a C core that provides support for the TCP and UDP transport layers, and a set of Lua modules that add support for functionality commonly needed by applications that deal with the Internet. (Based on wip/luasocket.)
This commit is contained in:
parent
08ff784184
commit
f195db004f
5 changed files with 66 additions and 0 deletions
4
net/lua-socket/DESCR
Normal file
4
net/lua-socket/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Lua extension library that is composed by two parts: a C core that provides
|
||||
support for the TCP and UDP transport layers, and a set of Lua modules that
|
||||
add support for functionality commonly needed by applications that deal
|
||||
with the Internet.
|
25
net/lua-socket/Makefile
Normal file
25
net/lua-socket/Makefile
Normal file
|
@ -0,0 +1,25 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2010/09/21 10:08:48 fhajny Exp $
|
||||
#
|
||||
|
||||
DISTNAME= luasocket-2.0.2
|
||||
PKGNAME= ${LUA_PKGPREFIX}-${DISTNAME:S/lua//}
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://luaforge.net/frs/download.php/2664/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://w3.impa.br/~diego/software/luasocket/
|
||||
COMMENT= Network support for the Lua language
|
||||
LICENSE= mit
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
MAKE_FILE= makefile
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
LDFLAGS.SunOS= -lrt -lresolv
|
||||
|
||||
INSTALL_MAKE_FLAGS+= INSTALL_TOP_SHARE=${DESTDIR}${PREFIX}/${LUA_LDIR}
|
||||
INSTALL_MAKE_FLAGS+= INSTALL_TOP_LIB=${DESTDIR}${PREFIX}/${LUA_CDIR}
|
||||
|
||||
.include "../../lang/lua/module.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
11
net/lua-socket/PLIST
Normal file
11
net/lua-socket/PLIST
Normal file
|
@ -0,0 +1,11 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2010/09/21 10:08:48 fhajny Exp $
|
||||
lib/lua/5.1/mime/core.so
|
||||
lib/lua/5.1/socket/core.so
|
||||
share/lua/5.1/ltn12.lua
|
||||
share/lua/5.1/mime.lua
|
||||
share/lua/5.1/socket.lua
|
||||
share/lua/5.1/socket/ftp.lua
|
||||
share/lua/5.1/socket/http.lua
|
||||
share/lua/5.1/socket/smtp.lua
|
||||
share/lua/5.1/socket/tp.lua
|
||||
share/lua/5.1/socket/url.lua
|
6
net/lua-socket/distinfo
Normal file
6
net/lua-socket/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2010/09/21 10:08:48 fhajny Exp $
|
||||
|
||||
SHA1 (luasocket-2.0.2.tar.gz) = 5ce521fc5c6efb7c1eba7f36dfeafa9e4d745464
|
||||
RMD160 (luasocket-2.0.2.tar.gz) = 24d7e4fb1c9cf0c3d94f8b36e82d494ae922e268
|
||||
Size (luasocket-2.0.2.tar.gz) = 115443 bytes
|
||||
SHA1 (patch-aa) = f4e4af32fea1b12f39aba9fe92989cfe57f8d039
|
20
net/lua-socket/patches/patch-aa
Normal file
20
net/lua-socket/patches/patch-aa
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2010/09/21 10:08:48 fhajny Exp $
|
||||
|
||||
Let CFLAGS/LDFLAGS merge with pkgsrc's ones
|
||||
|
||||
--- config.orig 2007-10-15 04:21:05.000000000 +0000
|
||||
+++ config
|
||||
@@ -49,10 +49,10 @@ INSTALL_EXEC=cp
|
||||
#------
|
||||
# Compiler and linker settings
|
||||
# for Linux
|
||||
-CC=gcc
|
||||
+CC?=gcc
|
||||
DEF=-DLUASOCKET_DEBUG
|
||||
-CFLAGS= $(LUAINC) $(DEF) -pedantic -Wall -O2 -fpic
|
||||
-LDFLAGS=-O -shared -fpic
|
||||
+CFLAGS+= $(LUAINC) $(DEF) -pedantic -Wall -O2 -fpic
|
||||
+LDFLAGS+=-O -shared -fpic
|
||||
LD=gcc
|
||||
|
||||
#------
|
Loading…
Reference in a new issue