Update mail/isync to 1.0.4
Changelog contains mostly bugfixes. Add path-af to handle 64bits time_t
This commit is contained in:
parent
e18f5bd0af
commit
f1b61f89d0
3 changed files with 39 additions and 10 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.24 2008/09/06 20:54:33 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.25 2009/07/12 20:26:59 tonio Exp $
|
||||
#
|
||||
|
||||
DISTNAME= isync-1.0.3
|
||||
PKGREVISION= 5
|
||||
DISTNAME= isync-1.0.4
|
||||
CATEGORIES= mail net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=isync/}
|
||||
|
||||
|
@ -10,8 +9,11 @@ MAINTAINER= tonio@NetBSD.org
|
|||
HOMEPAGE= http://isync.sourceforge.net/
|
||||
COMMENT= Synchronize a maildir with an imap server
|
||||
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
INSTALLATION_DIRS+= share/examples/isync
|
||||
INSTALLATION_DIRS+= share/examples/isync
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
|
@ -23,8 +25,8 @@ LDFLAGS+= -lcrypto
|
|||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/src/mbsyncrc.sample \
|
||||
${PREFIX}/share/examples/isync/mbsyncrc.sample
|
||||
${DESTDIR}${PREFIX}/share/examples/isync/mbsyncrc.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/src/compat/isyncrc.sample \
|
||||
${PREFIX}/share/examples/isync/isyncrc.sample
|
||||
${DESTDIR}${PREFIX}/share/examples/isync/isyncrc.sample
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.8 2007/01/18 18:26:21 tonio Exp $
|
||||
$NetBSD: distinfo,v 1.9 2009/07/12 20:26:59 tonio Exp $
|
||||
|
||||
SHA1 (isync-1.0.3.tar.gz) = 21500bb486ea0b8e9eae680f835a5a58ffe6a0d3
|
||||
RMD160 (isync-1.0.3.tar.gz) = c1ed6e3691eebbe97a57247102afb6794556bdb2
|
||||
Size (isync-1.0.3.tar.gz) = 169840 bytes
|
||||
SHA1 (isync-1.0.4.tar.gz) = a327cc5b81946c7ccb3a26ddd971933e2e006ed3
|
||||
RMD160 (isync-1.0.4.tar.gz) = 23475533ff9848c38b95911eae6191ca03132185
|
||||
Size (isync-1.0.4.tar.gz) = 170264 bytes
|
||||
SHA1 (patch-aa) = 5ac207f7d7b634673e60ce34cc9a921846d205da
|
||||
SHA1 (patch-ab) = bee5b091f89a670b584b73ef58774ae992bb6637
|
||||
SHA1 (patch-ac) = d06d1444f66eaeab1fdf22e1aa2f1b9184abccfa
|
||||
SHA1 (patch-ad) = c4a86de19b3004752dc51da9453b702945fe6578
|
||||
SHA1 (patch-ae) = 2fddc575e8824ecbbb4b8c51a56193840b43d647
|
||||
SHA1 (patch-af) = 12fc0ec1b2292c422e7c3347b37167438866728d
|
||||
|
|
26
mail/isync/patches/patch-af
Normal file
26
mail/isync/patches/patch-af
Normal file
|
@ -0,0 +1,26 @@
|
|||
$NetBSD: patch-af,v 1.4 2009/07/12 20:26:59 tonio Exp $
|
||||
|
||||
time_t may be 64bits
|
||||
|
||||
--- src/drv_maildir.c.orig 2008-02-23 10:02:21.000000000 +0100
|
||||
+++ src/drv_maildir.c
|
||||
@@ -936,7 +936,7 @@ maildir_store_msg( store_t *gctx, msg_da
|
||||
int ret, fd, bl;
|
||||
char buf[_POSIX_PATH_MAX], nbuf[_POSIX_PATH_MAX], fbuf[NUM_FLAGS + 3], base[128];
|
||||
|
||||
- bl = nfsnprintf( base, sizeof(base), "%ld.%d_%d.%s", time( 0 ), Pid, ++MaildirCount, Hostname );
|
||||
+ bl = nfsnprintf( base, sizeof(base), "%lld.%d_%d.%s", (long long int) time( 0 ), Pid, ++MaildirCount, Hostname );
|
||||
if (uid) {
|
||||
#ifdef USE_DB
|
||||
if (ctx->db) {
|
||||
@@ -1086,8 +1086,8 @@ maildir_trash_msg( store_t *gctx, messag
|
||||
for (;;) {
|
||||
nfsnprintf( buf, sizeof(buf), "%s/%s/%s", gctx->path, subdirs[gmsg->status & M_RECENT], msg->base );
|
||||
s = strstr( msg->base, ":2," );
|
||||
- nfsnprintf( nbuf, sizeof(nbuf), "%s%s/%s/%ld.%d_%d.%s%s", gctx->conf->path, gctx->conf->trash,
|
||||
- subdirs[gmsg->status & M_RECENT], time( 0 ), Pid, ++MaildirCount, Hostname, s ? s : "" );
|
||||
+ nfsnprintf( nbuf, sizeof(nbuf), "%s%s/%s/%lld.%d_%d.%s%s", gctx->conf->path, gctx->conf->trash,
|
||||
+ subdirs[gmsg->status & M_RECENT], (long long int) time( 0 ), Pid, ++MaildirCount, Hostname, s ? s : "" );
|
||||
if (!rename( buf, nbuf ))
|
||||
break;
|
||||
if (!stat( buf, &st )) {
|
Loading…
Reference in a new issue