Initial import of xnc-4.4.5

X Northern Captain is a X Window file manager that allows to create, copy,
move, rename, delete, view and edit files in a Virtual File System (VFS).
VFS consists from a normal disk space and a Archive File System (AFS).
All file operations in AFS can be done exactly as in normal file system.

The IVES - file viewer and editor for X Window included, provides a
comprehensive way to view and edit images in many different formats: GIF,
JPEG, PCX, BMP, XBM, XPM, TIFF, TGA, PCD, PNG.

Package provided by Rui-Xiang Guo <xg@ms25.url.com.tw> in PR pkg/13835
This commit is contained in:
zuntum 2001-09-17 05:40:06 +00:00
parent 40e2679bcb
commit f1bc802a0f
14 changed files with 300 additions and 0 deletions

24
sysutils/xnc/Makefile Normal file
View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
DISTNAME= xnc-4.4.5.src
PKGNAME= xnc-4.4.5
CATEGORIES= sysutils x11
MASTER_SITES= http://www.xnc.dubna.su/src/
MAINTAINER= rxg@ms25.url.com.tw
HOMEPAGE= http://xnc.dubna.su/
COMMENT= File manager for X Window
WRKSRC= ${WRKDIR}/${PKGNAME}
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/xnc
${INSTALL_DATA} ${WRKSRC}/Docs/* ${PREFIX}/share/doc/xnc
.include "../../graphics/jpeg/buildlink.mk"
.include "../../graphics/png/buildlink.mk"
.include "../../mk/x11.buildlink.mk"
.include "../../mk/bsd.pkg.mk"

13
sysutils/xnc/distinfo Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: distinfo,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
SHA1 (xnc-4.4.5.src.tar.gz) = da94c0bec207863b33f09e9fd773510045723c4a
Size (xnc-4.4.5.src.tar.gz) = 1620903 bytes
SHA1 (patch-aa) = 1bdbb1a794048ba72c406dc2fc88dd943bae8bc9
SHA1 (patch-ab) = 3310dd3412bb8e72d2c66012be59d08bc65bf60a
SHA1 (patch-ac) = 8a0a07b17264cc7eac9705be596763ce64a2bab3
SHA1 (patch-ad) = 416ed4180b48507a9767bbc62203b700a669dd28
SHA1 (patch-ae) = 4e518462595ca661a9be6549266afb684d5dab43
SHA1 (patch-af) = 863d90f7b7863d8a3e6a45778bf9ce4e7f56ef98
SHA1 (patch-ag) = 167857bdff959d18695525febe2f53a016254e83
SHA1 (patch-ah) = 12fc839079ea7adeb71080d8cf9718cdf24ed538
SHA1 (patch-ai) = 569438fe88fbdaa1817566d2f52e9413b7cb8028

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
--- filedir/makefile.in.orig Wed Apr 25 20:11:20 2001
+++ filedir/makefile.in Wed Apr 25 20:11:28 2001
@@ -34,7 +34,7 @@
@MCOMMON@
VERSION = 3.20.1
-MAGIC = /usr/share/magic
+MAGIC = /usr/share/misc/magic
#MAGIC = /usr/local/etc/magic
MAGDEFS = -DMAGIC='"$(MAGIC)"' -DMAGIC_FOR_XNC $(DEFS)# -Dvoid=int

View file

@ -0,0 +1,48 @@
$NetBSD: patch-ab,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
--- Makefile.in.orig Mon Jun 25 15:50:51 2001
+++ Makefile.in
@@ -190,28 +190,30 @@
install: install-$(PLUGINS)
#Installing X Northern Captain...
- $(INS) ./users.xnc $(INSTDIR)
- $(INS) ./groups.xnc $(INSTDIR)
+ $(INSTALL_PROGRAM) ./users.xnc $(INSTDIR)
+ $(INSTALL_PROGRAM) ./groups.xnc $(INSTDIR)
$(INS) ./rpm.xnc $(INSTDIR)
- $(INS) ./zips.xnc $(INSTDIR)
+ $(INSTALL_PROGRAM) ./zips.xnc $(INSTDIR)
$(INS) ./gzip.xnc $(INSTDIR)
$(INS) ./bzip.xnc $(INSTDIR)
- $(INS) ./nc $(INSTDIR)/xnc
+ $(INSTALL_PROGRAM) ./nc $(INSTDIR)/xnc
$(INSM) ./yo-man/*.1 $(INSTMAN)/man1
- $(INS) ./ives/ives $(INSTDIR)
- $(INS) ./ives/es $(INSTDIR)
- $(INS) ./ives/vs $(INSTDIR)
- $(INS) ./xsetup/xncsetup $(INSTDIR)
- $(INS) ./xjroot/xjpegroot $(INSTDIR)
- $(INS) ./launch/xnlaunch $(INSTDIR)
- /bin/sh ./replace.script
+ $(INSTALL_PROGRAM) ./ives/ives $(INSTDIR)
+ $(INSTALL_PROGRAM) ./ives/es $(INSTDIR)
+ $(INSTALL_PROGRAM) ./ives/vs $(INSTDIR)
+ $(INSTALL_PROGRAM) ./xsetup/xncsetup $(INSTDIR)
+ $(INSTALL_PROGRAM) ./xjroot/xjpegroot $(INSTDIR)
+ $(INSTALL_PROGRAM) ./launch/xnlaunch $(INSTDIR)
+# /bin/sh ./replace.script
@echo "Don't foget run 'xncsetup' before starting XNC"
install-plugins:
mkdir -p $(INSTPLUG)
- $(INS) ./plugins/five/libxncfive.so $(INSTPLUG)
- $(INS) ./plugins/aqua/libxncaqua.so $(INSTPLUG)
+# $(INS) ./plugins/five/libxncfive.so $(INSTPLUG)
+# $(INS) ./plugins/aqua/libxncaqua.so $(INSTPLUG)
+ cd ./plugins/five && make install
+ cd ./plugins/aqua && make install
install-:
@echo "Skipping..."

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
--- ives/makefile.in.orig Thu Aug 30 15:27:39 2001
+++ ives/makefile.in
@@ -31,7 +31,7 @@
STYLE=-DOLD_STYLE
CXXOPT=-DIVES $(NO_ALT) $(STYLE) $(DEB) $(DEFS) $(CFLAGS)
- LOCAL_LIBRARIES=$(TLIB) $(XLIBS) -L../image -L/usr/lib $(PNGLIB) $(ZLIB) $(LIBS)
+ LOCAL_LIBRARIES=$(TLIB) $(XLIBS) -L../image -L/usr/lib $(PNGLIB) $(ZLIB) $(LIBS) $(LDFLAGS)
PROGRAM =ives es vs $(IMAGEOBJS) $(JDEP)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
--- xsetup/makefile.in.orig Thu Aug 30 15:39:30 2001
+++ xsetup/makefile.in
@@ -25,7 +25,7 @@
../commonfuncs.o ../image/imload.o ../xdndclass.o ../xncdebug.o
CXXINCLUDES=$(XINC) -I../xbitmaps
CXXOPT=$(DEFS) $(DEB) $(CFLAGS)
- LOCAL_LIBRARIES=$(IMAGEOBJS) $(JLIB) $(TLIB) $(XLIBS) -L../image $(PNGLIB) $(ZLIB) $(LIBS)
+ LOCAL_LIBRARIES=$(IMAGEOBJS) $(JLIB) $(TLIB) $(XLIBS) -L../image $(PNGLIB) $(ZLIB) $(LIBS) $(LDFLAGS)
PROGRAM =xncsetup

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
--- xjroot/makefile.in.orig Thu Aug 30 15:43:09 2001
+++ xjroot/makefile.in
@@ -20,7 +20,7 @@
IOBJS =xjpegroot.o
CXXINCLUDES=$(XINC) $(JINC)
CXXOPT=$(DEFS) $(CFLAGS)
- LOCAL_LIBRARIES=../image/libie.a $(JLIB) $(TLIB) $(XLIBS) -L../image $(PNGLIB) $(ZLIB) $(LIBS)
+ LOCAL_LIBRARIES=../image/libie.a $(JLIB) $(TLIB) $(XLIBS) -L../image $(PNGLIB) $(ZLIB) $(LIBS) $(LDFLAGS)
PROGRAM =xjpegroot $(IMAGENGINE)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
--- launch/makefile.in.orig Thu Aug 30 15:46:12 2001
+++ launch/makefile.in
@@ -28,7 +28,7 @@
STYLE=-DOLD_STYLE
CXXOPT=$(DEFS) $(CFLAGS)
- LOCAL_LIBRARIES=$(TLIB) $(XLIBS) -L../image $(PNGLIB) $(ZLIB) $(LIBS)
+ LOCAL_LIBRARIES=$(TLIB) $(XLIBS) -L../image $(PNGLIB) $(ZLIB) $(LIBS) $(LDFLAGS)
PROGRAM =xnlaunch $(IMAGEOBJS) $(JDEP)

View file

@ -0,0 +1,41 @@
$NetBSD: patch-ag,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
--- plugins/five/makefile.in.orig Tue Mar 13 19:05:52 2001
+++ plugins/five/makefile.in
@@ -18,6 +18,11 @@
@MCOMMON@
+CXX = $(LIBTOOL) --mode=compile $(CC)
+
+.c.o:
+ $(CXX) -c $(CXXINCLUDES) $(INCLUDES) $(CXXOPT) $<
+
PLUGINFLAGS=$(SHAREFLAGS)
IOBJS =fiveplugin.o fivegeom.o fivefuncs.o fiveskin.o fivegui.o \
@@ -25,9 +30,12 @@
CXXINCLUDES=$(XINC) -I../../image -I../../xbitmaps -I../.. -I../common -I../../ftplib
CXXOPT=$(DEFS) $(DEB) $(CFLAGS)
-PROGRAM =libxncfive.so
+#PROGRAM =libxncfive.so
+PROGRAM = libxncfive.a
-all:: $(PROGRAM)
+#all:: $(PROGRAM)
+all: $(IOBJS)
+ $(LIBTOOL) $(CC) -module -avoid-version -o $(PROGRAM:.a=.la) $(IOBJS:.o=.lo) -rpath $(INSTPLUG)
../gui.o: ../gui.cxx
@@ -87,7 +95,8 @@
install:
- ./xncsetup
+# ./xncsetup
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) $(PROGRAM:.a=.la) $(INSTPLUG)
uninstall:
#Uninstalling IVES..

View file

@ -0,0 +1,41 @@
$NetBSD: patch-ah,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
--- plugins/aqua/makefile.in.orig Tue Mar 13 19:05:49 2001
+++ plugins/aqua/makefile.in
@@ -18,6 +18,11 @@
@MCOMMON@
+CXX = $(LIBTOOL) --mode=compile $(CC)
+
+.c.o:
+ $(CXX) -c $(CXXINCLUDES) $(INCLUDES) $(CXXOPT) $<
+
PLUGINFLAGS=$(SHAREFLAGS)
IOBJS =aquaplugin.o aquagui.o aquafuncs.o aquageom.o aquapanel.o\
@@ -25,9 +30,12 @@
CXXINCLUDES=$(XINC) -I../../image -I../../xbitmaps -I../.. -I../common -I../../ftplib
CXXOPT=$(DEFS) $(DEB) $(CFLAGS)
-PROGRAM =libxncaqua.so
+#PROGRAM =libxncaqua.so
+PROGRAM = libxncaqua.a
-all:: $(PROGRAM)
+#all:: $(PROGRAM)
+all: $(IOBJS)
+ $(LIBTOOL) $(CC) -module -avoid-version -o $(PROGRAM:.a=.la) $(IOBJS:.o=.lo) -rpath $(INSTPLUG)
../gui.o: ../gui.cxx
@@ -86,7 +94,8 @@
install:
- ./xncsetup
+# ./xncsetup
+ $(LIBTOOL) --mode=install $(INSTALL_DATA) $(PROGRAM:.a=.la) $(INSTPLUG)
uninstall:
$(RM) -f $(PROGRAM)

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ai,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
--- plugins/common/makefile.in.orig Thu Aug 30 21:30:56 2001
+++ plugins/common/makefile.in
@@ -18,6 +18,11 @@
@MCOMMON@
+CXX = $(LIBTOOL) --mode=compile $(CC)
+
+.c.o:
+ $(CXX) -c $(CXXINCLUDES) $(INCLUDES) $(CXXOPT) $<
+
CXXINCLUDES=$(XINC) -I../xbitmaps
CXXOPT=$(DEFS) $(DEB) $(CFLAGS)

8
sysutils/xnc/pkg/DESCR Normal file
View file

@ -0,0 +1,8 @@
X Northern Captain is a X Window file manager that allows to create, copy,
move, rename, delete, view and edit files in a Virtual File System (VFS).
VFS consists from a normal disk space and a Archive File System (AFS).
All file operations in AFS can be done exactly as in normal file system.
The IVES - file viewer and editor for X Window included, provides a
comprehensive way to view and edit images in many different formats: GIF,
JPEG, PCX, BMP, XBM, XPM, TIFF, TGA, PCD, PNG.

7
sysutils/xnc/pkg/MESSAGE Normal file
View file

@ -0,0 +1,7 @@
======================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
Each user who wants to use xnc should first execute xncsetup
from X11 to configure his/her own profile.
======================================================================

37
sysutils/xnc/pkg/PLIST Normal file
View file

@ -0,0 +1,37 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2001/09/17 05:40:06 zuntum Exp $
bin/bzip.xnc
bin/es
bin/groups.xnc
bin/gzip.xnc
bin/ives
bin/rpm.xnc
bin/users.xnc
bin/vs
bin/xjpegroot
bin/xnc
bin/xncsetup
bin/xnlaunch
bin/zips.xnc
lib/xnc/libxncaqua.a
lib/xnc/libxncaqua.la
lib/xnc/libxncaqua.so
lib/xnc/libxncfive.a
lib/xnc/libxncfive.la
lib/xnc/libxncfive.so
man/man1/es.1
man/man1/ives.1
man/man1/vs.1
man/man1/xjpegroot.1
man/man1/xnc.1
man/man1/xnlaunch.1
share/doc/xnc/doc1.html
share/doc/xnc/doc2.html
share/doc/xnc/doc3.html
share/doc/xnc/doc4.html
share/doc/xnc/doc5.html
share/doc/xnc/doc6.html
share/doc/xnc/doc7.html
share/doc/xnc/doc8.html
share/doc/xnc/index.html
@dirrm share/doc/xnc
@dirrm lib/xnc