lang/algol68g: update to version 3.1.4.

From the NEWS file:

Version 3.1.1-3.1.4, January/March 2023
* Fix configuration bug preventing building on Cygwin.
* Fix undefined errno upon succesful relpath call on some systems.
* Distribution update.
* Minor bug fixes.
This commit is contained in:
rhialto 2023-03-29 10:11:12 +00:00
parent b65e5150fd
commit f1dda2ce5b
5 changed files with 13 additions and 35 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.23 2023/01/16 05:00:57 dholland Exp $
# $NetBSD: Makefile,v 1.24 2023/03/29 10:11:12 rhialto Exp $
DISTNAME= algol68g-3.1.2
DISTNAME= algol68g-3.1.4
CATEGORIES= lang
MASTER_SITES= http://jmvdveer.home.xs4all.nl/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2023/01/16 05:00:57 dholland Exp $
@comment $NetBSD: PLIST,v 1.5 2023/03/29 10:11:12 rhialto Exp $
bin/a68g
include/algol68g/a68g-common.h
include/algol68g/a68g-compiler.h
@ -32,6 +32,7 @@ include/algol68g/a68g-prelude-mathlib.h
include/algol68g/a68g-prelude.h
include/algol68g/a68g-stack.h
include/algol68g/a68g-stddef.h
include/algol68g/a68g-torrix.h
include/algol68g/a68g-transput.h
include/algol68g/a68g-types.h
include/algol68g/a68g.h

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.15 2023/01/16 05:00:57 dholland Exp $
$NetBSD: distinfo,v 1.16 2023/03/29 10:11:12 rhialto Exp $
BLAKE2s (algol68g-3.1.2.tar.gz) = 71fea9f77119a90c928475cb6f4465a1af5350871c16b572eca76db7d810566b
SHA512 (algol68g-3.1.2.tar.gz) = 12ce45c24412be3f5de1a3dec1b8b5ea8c6caaac30bd7e7ba26442139988ea05fa7c593dc961d73a2ad9b0b965d1df61aedf8265be9f2ea86ff4f2ad6f5368c9
Size (algol68g-3.1.2.tar.gz) = 615054 bytes
SHA1 (patch-src_a68g_a68g.c) = 3dcee4e2343dc6305b000933bea685820d7cacdc
SHA1 (patch-src_a68g_options.c) = 35d53f40b5874f0169a49641e73cbcc71dd143a0
BLAKE2s (algol68g-3.1.4.tar.gz) = 1812f1ebdaf6562aaafa6bc5671dbeeab68a1003be81528306fc23f63baf9697
SHA512 (algol68g-3.1.4.tar.gz) = 3d8522edc5ed721c7b4fc5534fc3db350ca5a33cbbd8aa6b8c6a4840cd90ba415ca01ba0e6d6573a4cedfd9f72a294bbe56252b161b97fcc9596386692cc9170
Size (algol68g-3.1.4.tar.gz) = 618962 bytes
SHA1 (patch-src_a68g_a68g-options.c) = bd659a155d0a6ee835e42868a0eaac9c4a7d9824

View file

@ -1,10 +1,10 @@
$NetBSD: patch-src_a68g_options.c,v 1.2 2022/12/04 17:11:13 rhialto Exp $
$NetBSD: patch-src_a68g_a68g-options.c,v 1.1 2023/03/29 10:11:13 rhialto Exp $
* Enable compiler for *BSD.
--- src/a68g/options.c.orig 2022-02-01 20:45:41.000000000 +0000
+++ src/a68g/options.c
@@ -548,7 +548,7 @@ BOOL_T set_options (OPTION_LIST_T * i, B
--- src/a68g/a68g-options.c.orig 2023-03-19 20:10:12.000000000 +0000
+++ src/a68g/a68g-options.c
@@ -552,7 +552,7 @@ BOOL_T set_options (OPTION_LIST_T * i, B
#endif
}
if (eq (q, "linux")) {

View file

@ -1,22 +0,0 @@
$NetBSD: patch-src_a68g_a68g.c,v 1.3 2022/12/04 18:30:39 rhialto Exp $
* Use an explicit directory name to store (and later dlopen) the .so file,
so that --compile works. Otherwise, you get errors like
test-set$ a68g --compile 20-quicksort.a68
[20-quicksort.a68]
test-set$ ./20-quicksort
[.a68g.tmp.20-quicksort]
a68g: exiting: ./src/a68g/a68g.c: 497: cannot resolve symbol, /usr/pkg/bin/a68g: Shared object ".a68g.tmp.20-quicksort.so" not found
--- src/a68g/a68g.c.orig 2022-11-06 16:02:39.000000000 +0000
+++ src/a68g/a68g.c
@@ -480,7 +480,7 @@ void compiler_interpreter (void)
struct stat srcstat, objstat;
int ret;
announce_phase ("dynamic linker");
- ASSERT (snprintf (libname, SNPRINTF_SIZE, "%s", FILE_LIBRARY_NAME (&A68_JOB)) >= 0);
+ ASSERT (snprintf (libname, SNPRINTF_SIZE, "./%s", FILE_LIBRARY_NAME (&A68_JOB)) >= 0);
// Check whether we are doing something rash.
ret = stat (FILE_SOURCE_NAME (&A68_JOB), &srcstat);
ABEND (ret != 0, ERROR_ACTION, FILE_SOURCE_NAME (&A68_JOB));