import yaz-2.0
YAZ is a C/C++ library for information retrieval applications using the Z39.50/SRW protocols for information retrieval. Properties of YAZ: * Complete Z39.50 version 3 support. Amendments and Z39.50-2002 revision is supported. * Supports SRW version 1.0 (over HTTP and HTTPS). * Includes BER encoders/decoders for the ISO ILL protocol. * Supports the following transports: BER over TCP/IP (RFC1729), BER over unix local socket, and HTTP 1.1. * Secure Socket Layer support using OpenSSL. If enabled, YAZ uses HTTPS transport (for SOAP) or "Secure BER" (for Z39.50). * Offers ZOOM C API implementing both Z39.50 and SRW. * The YAZ library offers a set of useful utilities related to the protocols, such as MARC (ISO2709) parser, CCL (ISO8777) parser, CQL parser, memory management routines, character set conversion. * Portable code. YAZ compiles out-of-the box on most Unixes and on Windows using Microsoft Visual C++. * Fast operation. The C based BER encoders/decoders as well as the server component of YAZ is very fast. * Liberal license that allows for commercial use of YAZ.
This commit is contained in:
parent
197b332fc8
commit
f1ddcf79ac
5 changed files with 348 additions and 0 deletions
22
net/yaz/DESCR
Normal file
22
net/yaz/DESCR
Normal file
|
@ -0,0 +1,22 @@
|
|||
YAZ is a C/C++ library for information retrieval applications using
|
||||
the Z39.50/SRW protocols for information retrieval.
|
||||
|
||||
Properties of YAZ:
|
||||
|
||||
* Complete Z39.50 version 3 support. Amendments and Z39.50-2002
|
||||
revision is supported.
|
||||
* Supports SRW version 1.0 (over HTTP and HTTPS).
|
||||
* Includes BER encoders/decoders for the ISO ILL protocol.
|
||||
* Supports the following transports: BER over TCP/IP (RFC1729), BER
|
||||
over unix local socket, and HTTP 1.1.
|
||||
* Secure Socket Layer support using OpenSSL. If enabled, YAZ uses
|
||||
HTTPS transport (for SOAP) or "Secure BER" (for Z39.50).
|
||||
* Offers ZOOM C API implementing both Z39.50 and SRW.
|
||||
* The YAZ library offers a set of useful utilities related to the
|
||||
protocols, such as MARC (ISO2709) parser, CCL (ISO8777) parser,
|
||||
CQL parser, memory management routines, character set conversion.
|
||||
* Portable code. YAZ compiles out-of-the box on most Unixes and on
|
||||
Windows using Microsoft Visual C++.
|
||||
* Fast operation. The C based BER encoders/decoders as well as the
|
||||
server component of YAZ is very fast.
|
||||
* Liberal license that allows for commercial use of YAZ.
|
17
net/yaz/Makefile
Normal file
17
net/yaz/Makefile
Normal file
|
@ -0,0 +1,17 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2003/05/16 12:17:25 dmcmahill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= yaz-2.0
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://ftp.indexdata.dk/pub/yaz/
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://indexdata.dk/yaz
|
||||
COMMENT= C/C++ toolkit for the development of Z39.50v3/SRW clients and servers
|
||||
|
||||
USE_BUILDLINK2= YES
|
||||
USE_LIBTOOL= YES
|
||||
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
|
||||
GNU_CONFIGURE= YES
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
160
net/yaz/PLIST
Normal file
160
net/yaz/PLIST
Normal file
|
@ -0,0 +1,160 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2003/05/16 12:17:26 dmcmahill Exp $
|
||||
bin/yaz-client
|
||||
bin/yaz-comp
|
||||
bin/yaz-config
|
||||
bin/yaz-ztest
|
||||
bin/zoomsh
|
||||
include/yaz/backend.h
|
||||
include/yaz/ccl.h
|
||||
include/yaz/charneg.h
|
||||
include/yaz/comstack.h
|
||||
include/yaz/cql.h
|
||||
include/yaz/diagbib1.h
|
||||
include/yaz/ill-core.h
|
||||
include/yaz/ill.h
|
||||
include/yaz/item-req.h
|
||||
include/yaz/log.h
|
||||
include/yaz/logrpn.h
|
||||
include/yaz/marcdisp.h
|
||||
include/yaz/nmem.h
|
||||
include/yaz/odr.h
|
||||
include/yaz/oid.h
|
||||
include/yaz/options.h
|
||||
include/yaz/otherinfo.h
|
||||
include/yaz/pquery.h
|
||||
include/yaz/proto.h
|
||||
include/yaz/prt-ext.h
|
||||
include/yaz/readconf.h
|
||||
include/yaz/soap.h
|
||||
include/yaz/sortspec.h
|
||||
include/yaz/srw.h
|
||||
include/yaz/statserv.h
|
||||
include/yaz/tcpip.h
|
||||
include/yaz/tpath.h
|
||||
include/yaz/unix.h
|
||||
include/yaz/wrbuf.h
|
||||
include/yaz/xmalloc.h
|
||||
include/yaz/yaz-ccl.h
|
||||
include/yaz/yaz-iconv.h
|
||||
include/yaz/yaz-util.h
|
||||
include/yaz/yaz-version.h
|
||||
include/yaz/yconfig.h
|
||||
include/yaz/z-accdes1.h
|
||||
include/yaz/z-accform1.h
|
||||
include/yaz/z-acckrb1.h
|
||||
include/yaz/z-charneg.h
|
||||
include/yaz/z-core.h
|
||||
include/yaz/z-date.h
|
||||
include/yaz/z-diag1.h
|
||||
include/yaz/z-espec1.h
|
||||
include/yaz/z-estask.h
|
||||
include/yaz/z-exp.h
|
||||
include/yaz/z-grs.h
|
||||
include/yaz/z-mterm2.h
|
||||
include/yaz/z-opac.h
|
||||
include/yaz/z-rrf1.h
|
||||
include/yaz/z-rrf2.h
|
||||
include/yaz/z-sum.h
|
||||
include/yaz/z-sutrs.h
|
||||
include/yaz/z-uifr1.h
|
||||
include/yaz/z-univ.h
|
||||
include/yaz/zes-admin.h
|
||||
include/yaz/zes-expi.h
|
||||
include/yaz/zes-exps.h
|
||||
include/yaz/zes-order.h
|
||||
include/yaz/zes-pquery.h
|
||||
include/yaz/zes-psched.h
|
||||
include/yaz/zes-pset.h
|
||||
include/yaz/zes-update.h
|
||||
include/yaz/zes-update0.h
|
||||
include/yaz/zgdu.h
|
||||
include/yaz/zoom.h
|
||||
lib/libyaz.a
|
||||
lib/libyaz.la
|
||||
lib/libyaz.so
|
||||
lib/libyaz.so.2
|
||||
lib/libyaz.so.${PKGVERSION}
|
||||
lib/libyazmalloc.a
|
||||
lib/libyazmalloc.la
|
||||
lib/libyazmalloc.so
|
||||
lib/libyazmalloc.so.2
|
||||
lib/libyazmalloc.so.${PKGVERSION}
|
||||
man/man1/yaz-client-ssl.1
|
||||
man/man1/yaz-client.1
|
||||
man/man1/yaz-config.1
|
||||
man/man1/zoomsh.1
|
||||
man/man7/yaz.7
|
||||
man/man8/yaz-ztest-ssl.8
|
||||
man/man8/yaz-ztest.8
|
||||
share/aclocal/yaz.m4
|
||||
share/doc/yaz/apilayer.png
|
||||
share/doc/yaz/asn.external.html
|
||||
share/doc/yaz/asn.html
|
||||
share/doc/yaz/asn.oid.html
|
||||
share/doc/yaz/asn.pdu.html
|
||||
share/doc/yaz/asn.preparing.html
|
||||
share/doc/yaz/client.commands.html
|
||||
share/doc/yaz/client.html
|
||||
share/doc/yaz/client.invoking.html
|
||||
share/doc/yaz/client.searching.html
|
||||
share/doc/yaz/comstack.addresses.html
|
||||
share/doc/yaz/comstack.client.html
|
||||
share/doc/yaz/comstack.common.html
|
||||
share/doc/yaz/comstack.diagnostics.html
|
||||
share/doc/yaz/comstack.html
|
||||
share/doc/yaz/comstack.introduction.html
|
||||
share/doc/yaz/comstack.server.html
|
||||
share/doc/yaz/comstack.summary.html
|
||||
share/doc/yaz/credits.html
|
||||
share/doc/yaz/future.html
|
||||
share/doc/yaz/id.png
|
||||
share/doc/yaz/indexdata.html
|
||||
share/doc/yaz/installation.html
|
||||
share/doc/yaz/installation.unix.html
|
||||
share/doc/yaz/installation.win32.html
|
||||
share/doc/yaz/introduction.api.html
|
||||
share/doc/yaz/introduction.html
|
||||
share/doc/yaz/license.html
|
||||
share/doc/yaz/license.other.html
|
||||
share/doc/yaz/odr.debugging.html
|
||||
share/doc/yaz/odr.html
|
||||
share/doc/yaz/odr.programming.html
|
||||
share/doc/yaz/odr.use.html
|
||||
share/doc/yaz/server.backend.html
|
||||
share/doc/yaz/server.backendfunctions.html
|
||||
share/doc/yaz/server.frontend.html
|
||||
share/doc/yaz/server.html
|
||||
share/doc/yaz/server.invocation.html
|
||||
share/doc/yaz/server.main.html
|
||||
share/doc/yaz/soap.html
|
||||
share/doc/yaz/soap.http.html
|
||||
share/doc/yaz/soap.srw.html
|
||||
share/doc/yaz/soap.xml.html
|
||||
share/doc/yaz/tools.html
|
||||
share/doc/yaz/tools.nmem.html
|
||||
share/doc/yaz/tools.oid.html
|
||||
share/doc/yaz/yaz.html
|
||||
share/doc/yaz/yaz.pdf
|
||||
share/doc/yaz/zoom.events.html
|
||||
share/doc/yaz/zoom.html
|
||||
share/doc/yaz/zoom.options.html
|
||||
share/doc/yaz/zoom.query.html
|
||||
share/doc/yaz/zoom.records.html
|
||||
share/doc/yaz/zoom.resultsets.html
|
||||
share/doc/yaz/zoom.scan.html
|
||||
share/yaz/ill/ill.tcl
|
||||
share/yaz/ill/ill9702.asn
|
||||
share/yaz/ill/item-req.asn
|
||||
share/yaz/z39.50/charneg-3.asn
|
||||
share/yaz/z39.50/datetime.asn
|
||||
share/yaz/z39.50/esadmin.asn
|
||||
share/yaz/z39.50/esupdate.asn
|
||||
share/yaz/z39.50/mterm2.asn
|
||||
share/yaz/z39.50/univres.asn
|
||||
share/yaz/z39.50/z.tcl
|
||||
share/yaz/z39.50/z3950v3.asn
|
||||
@dirrm share/yaz/z39.50
|
||||
@dirrm share/yaz/ill
|
||||
@dirrm share/yaz
|
||||
@dirrm share/doc/yaz
|
||||
@dirrm include/yaz
|
5
net/yaz/distinfo
Normal file
5
net/yaz/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2003/05/16 12:17:26 dmcmahill Exp $
|
||||
|
||||
SHA1 (yaz-2.0.tar.gz) = 5ded060bf62f12a734e77f8123bd3d72b9dc971f
|
||||
Size (yaz-2.0.tar.gz) = 1047876 bytes
|
||||
SHA1 (patch-aa) = dac005456e824a99dba4fd3effc05ede0425c1cd
|
144
net/yaz/patches/patch-aa
Normal file
144
net/yaz/patches/patch-aa
Normal file
|
@ -0,0 +1,144 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2003/05/16 12:17:27 dmcmahill Exp $
|
||||
|
||||
These patches are needed to avoid unaligned accesses on 64 bit
|
||||
systems.
|
||||
|
||||
--- util/xmalloc.c.orig Mon Jan 6 08:20:28 2003
|
||||
+++ util/xmalloc.c
|
||||
@@ -23,9 +23,9 @@
|
||||
|
||||
#if TRACE_XMALLOC > 1
|
||||
|
||||
-static const unsigned char head[] = {44, 33, 22, 11};
|
||||
-static const unsigned char tail[] = {11, 22, 33, 44};
|
||||
-static const unsigned char freed[] = {11, 22, 33, 44};
|
||||
+static const unsigned char head[] = {88, 77, 66, 55, 44, 33, 22, 11};
|
||||
+static const unsigned char tail[] = {11, 22, 33, 44, 55, 66, 77, 88};
|
||||
+static const unsigned char freed[] = {11, 22, 33, 44, 55, 66, 77, 88};
|
||||
|
||||
struct dmalloc_info {
|
||||
int len;
|
||||
@@ -42,7 +42,7 @@ void *xmalloc_d(size_t nbytes, const cha
|
||||
char *res;
|
||||
struct dmalloc_info *dinfo;
|
||||
|
||||
- if (!(res = (char*) malloc(nbytes + sizeof(*dinfo)+8*sizeof(char))))
|
||||
+ if (!(res = (char*) malloc(nbytes + sizeof(*dinfo)+16*sizeof(char))))
|
||||
return 0;
|
||||
dinfo = (struct dmalloc_info *) res;
|
||||
strncpy (dinfo->file, file, sizeof(dinfo->file)-1);
|
||||
@@ -56,9 +56,9 @@ void *xmalloc_d(size_t nbytes, const cha
|
||||
dinfo->next->prev = dinfo;
|
||||
dmalloc_list = dinfo;
|
||||
|
||||
- memcpy(res + sizeof(*dinfo), head, 4*sizeof(char));
|
||||
- res += sizeof(*dinfo) + 4*sizeof(char);
|
||||
- memcpy(res + nbytes, tail, 4*sizeof(char));
|
||||
+ memcpy(res + sizeof(*dinfo), head, 8*sizeof(char));
|
||||
+ res += sizeof(*dinfo) + 8*sizeof(char);
|
||||
+ memcpy(res + nbytes, tail, 8*sizeof(char));
|
||||
return res;
|
||||
}
|
||||
|
||||
@@ -69,13 +69,13 @@ void xfree_d(void *ptr, const char *file
|
||||
if (!ptr)
|
||||
return;
|
||||
dinfo = (struct dmalloc_info *)
|
||||
- ((char*)ptr - 4*sizeof(char) - sizeof(*dinfo));
|
||||
- if (memcmp(head, (char*) ptr - 4*sizeof(char), 4*sizeof(char)))
|
||||
+ ((char*)ptr - 8*sizeof(char) - sizeof(*dinfo));
|
||||
+ if (memcmp(head, (char*) ptr - 8*sizeof(char), 8*sizeof(char)))
|
||||
{
|
||||
yaz_log(LOG_FATAL, "xfree_d bad head, %s:%d, %p", file, line, ptr);
|
||||
abort();
|
||||
}
|
||||
- if (memcmp((char*) ptr + dinfo->len, tail, 4*sizeof(char)))
|
||||
+ if (memcmp((char*) ptr + dinfo->len, tail, 8*sizeof(char)))
|
||||
{
|
||||
yaz_log(LOG_FATAL, "xfree_d bad tail, %s:%d, %p", file, line, ptr);
|
||||
abort();
|
||||
@@ -86,7 +86,7 @@ void xfree_d(void *ptr, const char *file
|
||||
dmalloc_list = dinfo->next;
|
||||
if (dinfo->next)
|
||||
dinfo->next->prev = dinfo->prev;
|
||||
- memcpy ((char*) ptr - 4*sizeof(char), freed, 4*sizeof(char));
|
||||
+ memcpy ((char*) ptr - 8*sizeof(char), freed, 8*sizeof(char));
|
||||
free(dinfo);
|
||||
return;
|
||||
}
|
||||
@@ -101,18 +101,18 @@ void *xrealloc_d(void *p, size_t nbytes,
|
||||
{
|
||||
if (!nbytes)
|
||||
return 0;
|
||||
- res = (char *) malloc(nbytes + sizeof(*dinfo) + 8*sizeof(char));
|
||||
+ res = (char *) malloc(nbytes + sizeof(*dinfo) + 16*sizeof(char));
|
||||
}
|
||||
else
|
||||
{
|
||||
- if (memcmp(head, ptr - 4*sizeof(char), 4*sizeof(char)))
|
||||
+ if (memcmp(head, ptr - 8*sizeof(char), 8*sizeof(char)))
|
||||
{
|
||||
yaz_log(LOG_FATAL, "xrealloc_d bad head, %s:%d, %p",
|
||||
file, line, ptr);
|
||||
abort();
|
||||
}
|
||||
- dinfo = (struct dmalloc_info *) (ptr-4*sizeof(char) - sizeof(*dinfo));
|
||||
- if (memcmp(ptr + dinfo->len, tail, 4*sizeof(char)))
|
||||
+ dinfo = (struct dmalloc_info *) (ptr-8*sizeof(char) - sizeof(*dinfo));
|
||||
+ if (memcmp(ptr + dinfo->len, tail, 8*sizeof(char)))
|
||||
{
|
||||
yaz_log(LOG_FATAL, "xrealloc_d bad tail, %s:%d, %p",
|
||||
file, line, ptr);
|
||||
@@ -131,7 +131,7 @@ void *xrealloc_d(void *p, size_t nbytes,
|
||||
return 0;
|
||||
}
|
||||
res = (char *)
|
||||
- realloc(dinfo, nbytes + sizeof(*dinfo) + 8*sizeof(char));
|
||||
+ realloc(dinfo, nbytes + sizeof(*dinfo) + 16*sizeof(char));
|
||||
}
|
||||
if (!res)
|
||||
return 0;
|
||||
@@ -147,9 +147,9 @@ void *xrealloc_d(void *p, size_t nbytes,
|
||||
dmalloc_list->prev = dinfo;
|
||||
dmalloc_list = dinfo;
|
||||
|
||||
- memcpy(res + sizeof(*dinfo), head, 4*sizeof(char));
|
||||
- res += sizeof(*dinfo) + 4*sizeof(char);
|
||||
- memcpy(res + nbytes, tail, 4*sizeof(char));
|
||||
+ memcpy(res + sizeof(*dinfo), head, 8*sizeof(char));
|
||||
+ res += sizeof(*dinfo) + 8*sizeof(char);
|
||||
+ memcpy(res + nbytes, tail, 8*sizeof(char));
|
||||
return res;
|
||||
}
|
||||
|
||||
@@ -159,7 +159,7 @@ void *xcalloc_d(size_t nmemb, size_t siz
|
||||
struct dmalloc_info *dinfo;
|
||||
size_t nbytes = nmemb * size;
|
||||
|
||||
- if (!(res = (char*) calloc(1, nbytes+sizeof(*dinfo)+8*sizeof(char))))
|
||||
+ if (!(res = (char*) calloc(1, nbytes+sizeof(*dinfo)+16*sizeof(char))))
|
||||
return 0;
|
||||
dinfo = (struct dmalloc_info *) res;
|
||||
strncpy (dinfo->file, file, sizeof(dinfo->file)-1);
|
||||
@@ -173,9 +173,9 @@ void *xcalloc_d(size_t nmemb, size_t siz
|
||||
dinfo->next->prev = dinfo;
|
||||
dmalloc_list = dinfo;
|
||||
|
||||
- memcpy(res + sizeof(*dinfo), head, 4*sizeof(char));
|
||||
- res += sizeof(*dinfo) + 4*sizeof(char);
|
||||
- memcpy(res + nbytes, tail, 4*sizeof(char));
|
||||
+ memcpy(res + sizeof(*dinfo), head, 8*sizeof(char));
|
||||
+ res += sizeof(*dinfo) + 8*sizeof(char);
|
||||
+ memcpy(res + nbytes, tail, 8*sizeof(char));
|
||||
return res;
|
||||
}
|
||||
|
||||
@@ -188,7 +188,7 @@ void xmalloc_trav_d(const char *file, in
|
||||
while (dinfo)
|
||||
{
|
||||
yaz_log (LOG_MALLOC, " %20s:%d p=%p size=%d", dinfo->file, dinfo->line,
|
||||
- ((char*) dinfo)+sizeof(*dinfo)+4*sizeof(char), dinfo->len);
|
||||
+ ((char*) dinfo)+sizeof(*dinfo)+8*sizeof(char), dinfo->len);
|
||||
size += dinfo->len;
|
||||
dinfo = dinfo->next;
|
||||
}
|
Loading…
Reference in a new issue