Initial import of manedit, a manpage editor and viewer, submitted by
Tomasz Luchowski in PR pkg/12019. The viewer/browser does not work for me -- it seems to be having trouble with my "mandesc" files -- but I guess some problems are expected with a "0.4e" release, and someone should tell the author how to spell "preferences"!
This commit is contained in:
parent
ff5a57cfcc
commit
f1f56ab89e
11 changed files with 223 additions and 0 deletions
41
editors/manedit/Makefile
Normal file
41
editors/manedit/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/01/21 18:18:04 fredb Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ${PKGNAME:S,manedit-,manedit,}
|
||||
PKGNAME= manedit-0.4e
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= ftp://fox.mit.edu/pub/xsw/
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= zuntum@eik.pl
|
||||
HOMEPAGE= http://wolfpack.twu.net/ManEdit/
|
||||
|
||||
DEPENDS+= gtk+-*:../../x11/gtk
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/manedit
|
||||
|
||||
post-patch:
|
||||
${SED} -e "s,@PREFIX@,${PREFIX},g" -e "s,@CC@,${CC},g" \
|
||||
-e "s,@CFLAGS@,${CFLAGS},g" < ${WRKSRC}/Makefile \
|
||||
> ${WRKSRC}/Makefile.done
|
||||
${MV} ${WRKSRC}/Makefile.done ${WRKSRC}/Makefile
|
||||
${SED} -e "s,@PREFIX@,${PREFIX},g" < ${WRKSRC}/manedit.1 \
|
||||
> ${WRKSRC}/manedit.1.done
|
||||
${MV} ${WRKSRC}/manedit.1.done ${WRKSRC}/manedit.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/manedit ${PREFIX}/bin
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/manedit \
|
||||
${PREFIX}/share/manedit/templates \
|
||||
${PREFIX}/share/manedit/icons
|
||||
${INSTALL_MAN} ${WRKSRC}/manedit.1 ${PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/help/manpage_writing_procedures \
|
||||
${PREFIX}/man/man7/manpage_writing_procedures.7
|
||||
${INSTALL_MAN} ${WRKSRC}/help/manpage_xml_referance \
|
||||
${PREFIX}/man/man7/manpage_xml_reference.7
|
||||
cd ${WRKSRC}/templates && ${INSTALL_DATA} api.mpt config.mpt \
|
||||
intro.mpt program.mpt ${PREFIX}/share/manedit/templates
|
||||
cd ${WRKSRC} && ${INSTALL_DATA} manedit.xpm \
|
||||
${PREFIX}/share/manedit/icons
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
editors/manedit/files/md5
Normal file
3
editors/manedit/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 2001/01/21 18:18:04 fredb Exp $
|
||||
|
||||
MD5 (manedit0.4e.tgz) = 10cdb4c7c81e6ddb7d4677333b1328b9
|
7
editors/manedit/files/patch-sum
Normal file
7
editors/manedit/files/patch-sum
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 2001/01/21 18:18:04 fredb Exp $
|
||||
|
||||
MD5 (patch-aa) = de297b8475290223408074b716c255f3
|
||||
MD5 (patch-ab) = badf577cb2a2679691235fc5d01e81a0
|
||||
MD5 (patch-ac) = a6a6bbc7e01f616cce0eadebc3071783
|
||||
MD5 (patch-ad) = 42b90356b02e8c5cbffb71e858d3b5e2
|
||||
MD5 (patch-ae) = 64260aa8eeeab084586f88aa18f7851c
|
12
editors/manedit/patches/patch-aa
Normal file
12
editors/manedit/patches/patch-aa
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/01/21 18:18:04 fredb Exp $
|
||||
|
||||
--- ../include/xsw_ctype.h.orig Sat Jan 20 12:39:31 2001
|
||||
+++ ../include/xsw_ctype.h
|
||||
@@ -4,7 +4,6 @@
|
||||
#if defined(__cplusplus) || defined(c_plusplus)
|
||||
|
||||
extern bool isblank(char c);
|
||||
-extern bool isblank(int c);
|
||||
|
||||
#else
|
||||
|
31
editors/manedit/patches/patch-ab
Normal file
31
editors/manedit/patches/patch-ab
Normal file
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2001/01/21 18:18:04 fredb Exp $
|
||||
|
||||
--- Makefile.orig Sat Jan 20 12:39:28 2001
|
||||
+++ Makefile
|
||||
@@ -18,7 +18,7 @@
|
||||
# You may modify any value as needed. Change only the ones you are
|
||||
# absolutly sure that requires modification.
|
||||
#
|
||||
-PREFIX = /usr
|
||||
+PREFIX = @PREFIX@
|
||||
|
||||
|
||||
# ########################################################################
|
||||
@@ -49,7 +49,7 @@
|
||||
# to debug the program.
|
||||
#
|
||||
#CFLAGS = `gtk-config --cflags` -g -efence -Wall
|
||||
-CFLAGS = `gtk-config --cflags` -O2 -Wall
|
||||
+CFLAGS = `gtk-config --cflags` @CFLAGS@
|
||||
|
||||
CPPFLAGS = -D__cplusplus -Dc_plusplus
|
||||
|
||||
@@ -95,7 +95,7 @@
|
||||
#
|
||||
include Makefile.srclist
|
||||
|
||||
-CC = gcc
|
||||
+CC = @CC@
|
||||
CPP = g++
|
||||
BIN = manedit
|
||||
OBJ_C = $(SRC_C:.c=.o)
|
36
editors/manedit/patches/patch-ac
Normal file
36
editors/manedit/patches/patch-ac
Normal file
|
@ -0,0 +1,36 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2001/01/21 18:18:04 fredb Exp $
|
||||
|
||||
--- manedit.1.orig Sat Jan 20 12:39:31 2001
|
||||
+++ manedit.1
|
||||
+@@ -50,16 +50,14 @@
|
||||
+ Output version information and exit.
|
||||
+ .LP
|
||||
+ Most other customizations can be performed in the
|
||||
+-preferances menu.
|
||||
++preferences menu.
|
||||
+ .SH "FILES"
|
||||
@@ -55,11 +55,9 @@
|
||||
.LP
|
||||
\fI$HOME/.maneditrc\fP
|
||||
.br
|
||||
-\fI/usr/share/manedit/\fP
|
||||
+\fI@PREFIX@/share/manedit/\fP
|
||||
.br
|
||||
-\fI/usr/share/manedit/help/\fP
|
||||
-.br
|
||||
-\fI/usr/share/manedit/templates/\fP
|
||||
+\fI@PREFIX@/share/manedit/templates/\fP
|
||||
.SH "ENVIRONMENT VARIABLES"
|
||||
.TP
|
||||
\fBHOME\fP
|
||||
@@ -84,5 +82,9 @@
|
||||
.LP
|
||||
WolfPack Entertainment \- http://wolfpack.twu.net/contacts.html
|
||||
.SH "SEE ALSO"
|
||||
-.LP
|
||||
+.LP
|
||||
ManEdit's home page at http://wolfpack.twu.net/ManEdit/
|
||||
+.LP
|
||||
+manpage_writing_procedures(7)
|
||||
+.br
|
||||
+manpage_xml_reference(7)
|
19
editors/manedit/patches/patch-ad
Normal file
19
editors/manedit/patches/patch-ad
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-ad,v 1.1.1.1 2001/01/21 18:18:04 fredb Exp $
|
||||
|
||||
--- help/manpage_xml_referance.orig Sat Jan 20 05:39:30 2001
|
||||
+++ help/manpage_xml_referance Sun Jan 21 11:28:54 2001
|
||||
@@ -1,6 +1,6 @@
|
||||
-.TH "ManPage XML Referance" "5" "Release 0.0.0" "WolfPack Entertainment" "File Formats"
|
||||
+.TH "ManPage XML Reference" "5" "Release 0.0.0" "WolfPack Entertainment" "File Formats"
|
||||
.SH "NAME"
|
||||
-\fBManPage XML Referance\fR \- Tags and symbolic representations list
|
||||
+\fBManPage XML Reference\fR \- Tags and symbolic representations list
|
||||
.SH "DESCRIPTION"
|
||||
.LP
|
||||
Contains a (mostly complete) list of UNIX Manual Page format
|
||||
@@ -87,4 +87,4 @@
|
||||
\fB>\fR
|
||||
Greater than (the > character).
|
||||
.SH "SEE ALSO"
|
||||
-manpage_writing_procedures(5)
|
||||
+manpage_writing_procedures(7)
|
54
editors/manedit/patches/patch-ae
Normal file
54
editors/manedit/patches/patch-ae
Normal file
|
@ -0,0 +1,54 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2001/01/21 18:18:04 fredb Exp $
|
||||
|
||||
--- help/manpage_writing_procedures.orig Sat Jan 20 05:39:30 2001
|
||||
+++ help/manpage_writing_procedures Sun Jan 21 11:29:24 2001
|
||||
@@ -120,7 +120,7 @@
|
||||
\fBSYMREP\fR).
|
||||
.LP
|
||||
For a list of tags and symbolic representations see
|
||||
-manpage_xml_referance(5).
|
||||
+manpage_xml_reference(7).
|
||||
.LP
|
||||
The following sections deal with using XML tags to create
|
||||
common styles and formats seen in most manual pages.
|
||||
@@ -162,7 +162,7 @@
|
||||
the right amount of line spacing.
|
||||
.LP
|
||||
However in XML you need to use XML tags to control line
|
||||
-spacing. To ensure that a sentance in a paragraph
|
||||
+spacing. To ensure that a sentence in a paragraph
|
||||
starts on a new line, you need to use the tag
|
||||
\fB<br>\fR. For instance:
|
||||
.LP
|
||||
@@ -176,13 +176,13 @@
|
||||
Create a section with the above text and click on the
|
||||
preview button. You will notice that after the
|
||||
\fB<br>\fR
|
||||
-the sentance will be placed on a new line.
|
||||
+the sentence will be placed on a new line.
|
||||
.LP
|
||||
One draw back is that multiple uses of \fB<br>\fR
|
||||
does not produce multiple lines. So incase you would have
|
||||
to ensure that there is an empty line between two
|
||||
-sentances, you would have to use \fB<LP>\fR.
|
||||
-That would effectivly separate the two sentances as two
|
||||
+sentences, you would have to use \fB<LP>\fR.
|
||||
+That would effectivly separate the two sentences as two
|
||||
paragraphs.
|
||||
.SH "STYLES"
|
||||
.LP
|
||||
@@ -273,7 +273,7 @@
|
||||
.LP
|
||||
Which would produce a \fB<\fR character.
|
||||
Complete list of symbolic representations
|
||||
-are in page_xml_referance(5).
|
||||
+are in page_xml_reference(7).
|
||||
.LP
|
||||
One last important symbolic representation to point out
|
||||
is the \fB&\fR character. Its symbolic representation
|
||||
@@ -281,4 +281,4 @@
|
||||
.LP
|
||||
\fB&\fR
|
||||
.SH "SEE ALSO"
|
||||
-manpage_xml_referance(5)
|
||||
+manpage_xml_reference(7)
|
1
editors/manedit/pkg/COMMENT
Normal file
1
editors/manedit/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
UNIX Manual (man, manpage) page editor, viewer, and browser for X11
|
6
editors/manedit/pkg/DESCR
Normal file
6
editors/manedit/pkg/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
The ManEdit UNIX Manual Page Editor is an editor specifically tailored
|
||||
for UNIX manual (man, manpage) pages. It has a preview viewer, it uses
|
||||
the manual page XML format for easy editing, and it comes with a tutorial
|
||||
and referance guide. It uses the GTK+ widget set and features syntax
|
||||
highlighting, a complete drag and drop system for easy viewing and
|
||||
editing, a crash recovery system, and sample manual page templates.
|
13
editors/manedit/pkg/PLIST
Normal file
13
editors/manedit/pkg/PLIST
Normal file
|
@ -0,0 +1,13 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2001/01/21 18:18:04 fredb Exp $
|
||||
bin/manedit
|
||||
man/man7/manpage_writing_procedures.7
|
||||
man/man7/manpage_xml_reference.7
|
||||
man/man1/manedit.1
|
||||
share/manedit/icons/manedit.xpm
|
||||
share/manedit/templates/api.mpt
|
||||
share/manedit/templates/config.mpt
|
||||
share/manedit/templates/intro.mpt
|
||||
share/manedit/templates/program.mpt
|
||||
@dirrm share/manedit/templates
|
||||
@dirrm share/manedit/icons
|
||||
@dirrm share/manedit
|
Loading…
Reference in a new issue