Updated libgpg-error to 1.22.

Noteworthy changes in version 1.22 (2016-04-25) [C18/A18/R0)
-----------------------------------------------

 * New functions and macros to to provide iconv(3) on Windows.

 * Support for LeakSanitizer with the gpgrt_annotate_leaked_object
   inline function.

 * Interface changes relative to the 1.21 release:
 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 GPG_ERR_DB_CORRUPTED             NEW.
 gpgrt_annotate_leaked_object     NEW inline func.
 GPGRT_ENABLE_W32_ICONV_MACROS    NEW.
 gpgrt_w32_iconv_open             NEW.
 gpgrt_w32_iconv_close            NEW.
 gpgrt_w32_iconv                  NEW.
This commit is contained in:
wiz 2016-05-05 11:34:49 +00:00
parent d295cafe34
commit f25810746b
3 changed files with 15 additions and 15 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.49 2015/12/13 21:24:54 wiz Exp $ # $NetBSD: Makefile,v 1.50 2016/05/05 11:34:49 wiz Exp $
DISTNAME= libgpg-error-1.21 DISTNAME= libgpg-error-1.22
CATEGORIES= security CATEGORIES= security
MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/libgpg-error/ \ MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/libgpg-error/ \
ftp://ftp.ring.gr.jp/pub/net/gnupg/libgpg-error/ \ ftp://ftp.ring.gr.jp/pub/net/gnupg/libgpg-error/ \

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.27 2015/12/13 21:24:54 wiz Exp $ $NetBSD: distinfo,v 1.28 2016/05/05 11:34:49 wiz Exp $
SHA1 (libgpg-error-1.21.tar.bz2) = ef1dfb2f8761f019091180596e9e638d8cc37513 SHA1 (libgpg-error-1.22.tar.bz2) = c40015ed88bf5f50fa58d02252d75cf20b858951
RMD160 (libgpg-error-1.21.tar.bz2) = 6c4d5eda0106ed0d932de4726a9ce7a49b7559ea RMD160 (libgpg-error-1.22.tar.bz2) = d89a2352e73b1116575f4ae8735138d9ec7b3be2
SHA512 (libgpg-error-1.21.tar.bz2) = 1bc2e27b9904cb66b091c4d15855d2d2fe5d88ed11917df628cd7865989a8a208b607e5d6c499a5d64a16d22b2310b7df6868fa5462cc30cd8fda80a2f8c8315 SHA512 (libgpg-error-1.22.tar.bz2) = 0e2bbbd1cf51e247921836642ebc0b52573565dde0f3c9df405d74ca148aafd9b6509ae782f8db93ef31425c88466c8a9d11c147aa65b4f21a1856af29f0b8db
Size (libgpg-error-1.21.tar.bz2) = 763186 bytes Size (libgpg-error-1.22.tar.bz2) = 777502 bytes
SHA1 (patch-src_estream.c) = 792929cebef6ba7860da89c70742b3cd28c9c92d SHA1 (patch-src_estream.c) = 6b7879019c23a7161a8f2d7e04377c523670327a
SHA1 (patch-src_gpg-error-config.in) = e22e99208192971f8c123d7ee9b22c5f615669e1 SHA1 (patch-src_gpg-error-config.in) = e22e99208192971f8c123d7ee9b22c5f615669e1

View file

@ -1,4 +1,4 @@
$NetBSD: patch-src_estream.c,v 1.2 2014/10/30 14:30:35 wiz Exp $ $NetBSD: patch-src_estream.c,v 1.3 2016/05/05 11:34:49 wiz Exp $
Don't use atexit(), since this library mey be dlopen()ed Don't use atexit(), since this library mey be dlopen()ed
and dlclose()d before exit() is called. and dlclose()d before exit() is called.
@ -7,17 +7,17 @@ Instead mark the do_deinit() function as a destructor.
https://bugs.g10code.com/gnupg/issue1749 https://bugs.g10code.com/gnupg/issue1749
--- src/estream.c.orig 2014-09-11 09:38:21.000000000 +0000 --- src/estream.c.orig 2016-04-05 13:44:10.000000000 +0000
+++ src/estream.c +++ src/estream.c
@@ -471,6 +471,7 @@ do_list_remove (estream_t stream, int wi @@ -529,6 +529,7 @@ do_list_remove (estream_t stream, int wi
/*
* The atexit handler for this estream module.
*/
+__attribute__((destructor,used)) +__attribute__((destructor,used))
static void static void
do_deinit (void) do_deinit (void)
{ {
@@ -503,7 +504,16 @@ _gpgrt_es_init (void) @@ -560,7 +561,16 @@ _gpgrt_es_init (void)
if (!initialized) if (!initialized)
{ {
initialized = 1; initialized = 1;