As this package is marked NOT-FOR-DRAGONFLY remove dragonfly patches
and pre-configure. Also remove MESSAGE_SUBST.
This commit is contained in:
parent
315419e0d6
commit
f25b10940e
4 changed files with 2 additions and 89 deletions
|
@ -1,4 +1,4 @@
|
||||||
# $NetBSD: Makefile,v 1.31 2012/03/15 06:45:26 sbd Exp $
|
# $NetBSD: Makefile,v 1.32 2012/03/15 06:52:07 sbd Exp $
|
||||||
|
|
||||||
DISTNAME= gcc-${GCC_VERSION}
|
DISTNAME= gcc-${GCC_VERSION}
|
||||||
PKGNAME= gcc44-${GCC_VERSION}
|
PKGNAME= gcc44-${GCC_VERSION}
|
||||||
|
@ -21,8 +21,6 @@ GCC_VERSION= 4.4.6
|
||||||
GCC_SUBPREFIX= gcc44
|
GCC_SUBPREFIX= gcc44
|
||||||
GCC_PREFIX= ${PREFIX}/${GCC_SUBPREFIX}
|
GCC_PREFIX= ${PREFIX}/${GCC_SUBPREFIX}
|
||||||
FILES_SUBST+= PKGNAME=${PKGNAME}
|
FILES_SUBST+= PKGNAME=${PKGNAME}
|
||||||
MESSAGE_SUBST+= GCC_PREFIX=${GCC_PREFIX}
|
|
||||||
|
|
||||||
|
|
||||||
# To avoid GNU surprises
|
# To avoid GNU surprises
|
||||||
CONFIG_SHELL= ${TOOLS_PATH.bash}
|
CONFIG_SHELL= ${TOOLS_PATH.bash}
|
||||||
|
@ -99,14 +97,6 @@ CFLAGS+= -I${BUILDLINK_DIR}/include
|
||||||
|
|
||||||
LIBS.SunOS+= -lgmp
|
LIBS.SunOS+= -lgmp
|
||||||
|
|
||||||
pre-configure:
|
|
||||||
.if ${OPSYS} == "DragonFly"
|
|
||||||
${CP} ${FILESDIR}/dragonfly.h ${WRKSRC}/gcc/config/dragonfly.h
|
|
||||||
${CP} ${FILESDIR}/dragonfly-spec.h ${WRKSRC}/gcc/config/dragonfly-spec.h
|
|
||||||
${CP} ${FILESDIR}/i386-dragonfly.h ${WRKSRC}/gcc/config/i386/dragonfly.h
|
|
||||||
${CP} ${FILESDIR}/i386-dragonfly64.h ${WRKSRC}/gcc/config/i386/dragonfly64.h
|
|
||||||
.endif
|
|
||||||
|
|
||||||
|
|
||||||
do-configure:
|
do-configure:
|
||||||
${MKDIR} ${WRKDIR}/obj
|
${MKDIR} ${WRKDIR}/obj
|
||||||
|
|
|
@ -1,10 +1,8 @@
|
||||||
$NetBSD: distinfo,v 1.10 2011/12/22 14:14:22 wiz Exp $
|
$NetBSD: distinfo,v 1.11 2012/03/15 06:52:07 sbd Exp $
|
||||||
|
|
||||||
SHA1 (gcc-4.4.6.tar.bz2) = fc5e6c60b03650f6508470c088440d3d9360adf9
|
SHA1 (gcc-4.4.6.tar.bz2) = fc5e6c60b03650f6508470c088440d3d9360adf9
|
||||||
RMD160 (gcc-4.4.6.tar.bz2) = b35f81ee9540cc4ad0d2f970643f8053f058feec
|
RMD160 (gcc-4.4.6.tar.bz2) = b35f81ee9540cc4ad0d2f970643f8053f058feec
|
||||||
Size (gcc-4.4.6.tar.bz2) = 63135296 bytes
|
Size (gcc-4.4.6.tar.bz2) = 63135296 bytes
|
||||||
SHA1 (patch-aa) = b90dbd935aa105b86a7dd0f3f5f76727bd2d55fb
|
|
||||||
SHA1 (patch-ab) = e254456a6da7090f7ba37d3b55a17be2dd157f88
|
|
||||||
SHA1 (patch-ac) = 5e4c05ac8cac376b2c4c33db90d3b309a11cedee
|
SHA1 (patch-ac) = 5e4c05ac8cac376b2c4c33db90d3b309a11cedee
|
||||||
SHA1 (patch-ad) = ea1f9e8b49bd4498812ef8d5f47baf8410794fd3
|
SHA1 (patch-ad) = ea1f9e8b49bd4498812ef8d5f47baf8410794fd3
|
||||||
SHA1 (patch-af) = 12f58f01e973f5684e8443ab402a70291bb6d621
|
SHA1 (patch-af) = 12f58f01e973f5684e8443ab402a70291bb6d621
|
||||||
|
|
|
@ -1,51 +0,0 @@
|
||||||
$NetBSD: patch-aa,v 1.2 2011/02/25 13:34:56 hans Exp $
|
|
||||||
|
|
||||||
--- gcc/config.gcc.orig 2009-04-17 13:58:41 +0200
|
|
||||||
+++ gcc/config.gcc
|
|
||||||
@@ -488,6 +488,33 @@ case ${target} in
|
|
||||||
default_use_cxa_atexit=yes;;
|
|
||||||
esac
|
|
||||||
;;
|
|
||||||
+*-*-dragonfly*)
|
|
||||||
+ gas=yes
|
|
||||||
+ gnu_ld=yes
|
|
||||||
+ extra_parts="crtbegin.o crtend.o crtbeginS.o crtendS.o"
|
|
||||||
+ case ${target} in
|
|
||||||
+ *-*-dragonfly1 | *-*-dragonfly[1].*)
|
|
||||||
+ tm_defines="${tm_defines} DFBSD_MAJOR=1" ;;
|
|
||||||
+ *-*-dragonfly2 | *-*-dragonfly[2].*)
|
|
||||||
+ tm_defines="${tm_defines} DFBSD_MAJOR=2" ;;
|
|
||||||
+ *-*-dragonfly3 | *-*-dragonfly[3].*)
|
|
||||||
+ tm_defines="${tm_defines} DFBSD_MAJOR=3" ;;
|
|
||||||
+ *-*-dragonfly4 | *-*-dragonfly[4].*)
|
|
||||||
+ tm_defines="${tm_defines} DFBSD_MAJOR=4" ;;
|
|
||||||
+ *)
|
|
||||||
+ echo 'Please update *-*-dragonfly* in gcc/config.gcc'
|
|
||||||
+ exit 1
|
|
||||||
+ ;;
|
|
||||||
+ esac
|
|
||||||
+ tmake_file="t-slibgcc-elf-ver t-dragonfly"
|
|
||||||
+ case ${enable_threads} in
|
|
||||||
+ "" | yes | posix)
|
|
||||||
+ thread_file='posix'
|
|
||||||
+ tmake_file="${tmake_file} t-dragonfly-thread"
|
|
||||||
+ ;;
|
|
||||||
+ esac
|
|
||||||
+ dfbsd_tm_file="${dfbsd_tm_file} dragonfly-spec.h dragonfly.h"
|
|
||||||
+ ;;
|
|
||||||
*-*-linux* | frv-*-*linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu | *-*-gnu* | *-*-kopensolaris*-gnu)
|
|
||||||
extra_parts="crtbegin.o crtbeginS.o crtbeginT.o crtend.o crtendS.o"
|
|
||||||
gas=yes
|
|
||||||
@@ -1053,6 +1080,12 @@ x86_64-*-freebsd*)
|
|
||||||
tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h ${fbsd_tm_file} i386/x86-64.h i386/freebsd.h i386/freebsd64.h"
|
|
||||||
tmake_file="${tmake_file} i386/t-crtstuff"
|
|
||||||
;;
|
|
||||||
+i[34567]86-*-dragonfly*)
|
|
||||||
+ tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h ${dfbsd_tm_file} i386/dragonfly.h"
|
|
||||||
+ ;;
|
|
||||||
+x86_64-*-dragonfly*)
|
|
||||||
+ tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h ${dfbsd_tm_file} i386/x86-64.h i386/dragonfly.h i386/dragonfly64.h"
|
|
||||||
+ ;;
|
|
||||||
i[34567]86-*-netbsdelf*)
|
|
||||||
tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h netbsd.h netbsd-elf.h i386/netbsd-elf.h"
|
|
||||||
;;
|
|
|
@ -1,24 +0,0 @@
|
||||||
$NetBSD: patch-ab,v 1.1.1.1 2009/09/18 11:24:50 dmcmahill Exp $
|
|
||||||
|
|
||||||
--- libgcc/config.host.orig 2009-04-17 13:58:41 +0200
|
|
||||||
+++ libgcc/config.host
|
|
||||||
@@ -149,6 +149,8 @@ case ${host} in
|
|
||||||
# machine-specific sections may refine and add to this
|
|
||||||
# configuration.
|
|
||||||
;;
|
|
||||||
+*-*-dragonfly*)
|
|
||||||
+ ;;
|
|
||||||
*-*-linux* | frv-*-*linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu | *-*-gnu*)
|
|
||||||
extra_parts="crtbegin.o crtbeginS.o crtbeginT.o crtend.o crtendS.o"
|
|
||||||
;;
|
|
||||||
@@ -281,6 +283,10 @@ i[34567]86-*-freebsd*)
|
|
||||||
;;
|
|
||||||
x86_64-*-freebsd*)
|
|
||||||
;;
|
|
||||||
+i[34567]86-*-dragonfly*)
|
|
||||||
+ ;;
|
|
||||||
+x86_64-*-dragonfly*)
|
|
||||||
+ ;;
|
|
||||||
i[34567]86-*-netbsdelf*)
|
|
||||||
;;
|
|
||||||
i[34567]86-*-netbsd*)
|
|
Loading…
Reference in a new issue