Don't hardcode /usr/X11R6 in the makefile - use ${X11BASE} instead.

Also, pass down ${_MOTIFBASE} from the package makefile during the
build, and use it in the Makefiles. Fixes PR 15277 from Hiramatsu
Yoshifumi, hiramatu@boreas.dti.ne.jp, albeit in a different way to
the fix in the PR.
This commit is contained in:
agc 2002-01-17 17:11:48 +00:00
parent bd9f7cc1ff
commit f25f6082c1
3 changed files with 11 additions and 7 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.20 2001/12/19 01:23:09 mjl Exp $
# $NetBSD: Makefile,v 1.21 2002/01/17 17:11:48 agc Exp $
VERS= 5.2
DISTNAME= nedit-${VERS}-src
@ -12,6 +12,7 @@ COMMENT= Motif based standard GUI style text editor
USE_BUILDLINK_ONLY= YES
ALL_TARGET= netbsd
MAKE_ENV+= _MOTIFBASE=${_MOTIFBASE}
WRKSRC= ${WRKDIR}/${PKGNAME}

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.4 2001/10/31 00:03:16 mjl Exp $
$NetBSD: distinfo,v 1.5 2002/01/17 17:11:49 agc Exp $
SHA1 (nedit-5.2-src.tar.gz) = 00327cb34f02318eb786d44051478dc367f65563
Size (nedit-5.2-src.tar.gz) = 768534 bytes
SHA1 (patch-aa) = 3e84aa03d60cf52a98a2c12053c045e8bc0cddeb
SHA1 (patch-aa) = 4edc5c9ffe57763d5c80e19e37d0c570f5d4be99
SHA1 (patch-ab) = 1d566822879aa6519bea91acb03cdba139edd250

View file

@ -1,12 +1,15 @@
$NetBSD: patch-aa,v 1.9 2001/10/31 00:03:16 mjl Exp $
$NetBSD: patch-aa,v 1.10 2002/01/17 17:11:49 agc Exp $
--- makefiles/Makefile.netbsd.orig Sat Aug 18 01:02:55 2001
+++ makefiles/Makefile.netbsd Wed Oct 31 00:18:05 2001
@@ -9,6 +9,6 @@
@@ -7,8 +7,8 @@
# To evaluate an alternative layout for the Replace/Find dialog, add
# -DREPLACE_SCOPE to the CFLAGS. See the README file for more information.
#
CFLAGS=-O -I/usr/X11R6/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD
-CFLAGS=-O -I/usr/X11R6/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD
+CFLAGS=-O -I${X11BASE}/include -I${_MOTIFBASE}/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD
ARFLAGS=-ur
-LIBS= -L/usr/X11R6/lib -lm -lXm -lXpm -lXext -lXt -lSM -lICE -lX11
+LIBS= ${LDFLAGS} ${MOTIFLIB} -L/usr/X11R6/lib -lm -lXpm -lXext -lXt -lSM -lICE -lX11
+LIBS= ${LDFLAGS} ${MOTIFLIB} -L${_MOTIFBASE}/lib -L${X11BASE}/lib -lm -lXpm -lXext -lXt -lSM -lICE -lX11
include Makefile.common