Pass CC down to configure script and make sure its used properly.

This fixes pkg/12797
This commit is contained in:
skrll 2001-05-03 13:22:50 +00:00
parent fb856da086
commit f282fbbfb9
2 changed files with 13 additions and 3 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.29 2001/02/16 15:22:34 wiz Exp $
# $NetBSD: Makefile,v 1.30 2001/05/03 13:22:50 skrll Exp $
DISTNAME= tiff-v3.5.5
PKGNAME= tiff-3.5.5
@ -18,6 +18,7 @@ DEPENDS+= jpeg-6b:../../graphics/jpeg
USE_LIBTOOL= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --noninteractive --site=${FILESDIR}
CONFIGURE_ENV+= CC="${CC}"
.include "../../mk/bsd.prefs.mk"

View file

@ -1,7 +1,16 @@
$NetBSD: patch-ad,v 1.6 2001/02/27 09:49:25 skrll Exp $
$NetBSD: patch-ad,v 1.7 2001/05/03 13:22:50 skrll Exp $
--- configure.orig Mon Mar 20 18:20:42 2000
+++ configure
+++ configure Thu May 3 14:15:41 2001
@@ -486,7 +486,7 @@
checkCompiler()
{
- compiler=$1
+ compiler="$*"
if isGNU $compiler; then
ISGCC=yes
else
@@ -512,7 +512,7 @@
$RM dummy dummy.o
capture $compiler -o dummy ${C_ANSI} dummy.c && {