Update upx to version 1.25. This addresses PR#29327.
Changes include: * INFO: http://upx.sourceforge.net is the permanent UPX home page * watcom/le: don't crash on files without relocations * win32/pe: stricter checks of some PE values * source code: much improved portability using ACC, the Automatic Compiler Configuration * source code: compile fixes for strict ISO C++ compilers * source code: compile fixes for Win64
This commit is contained in:
parent
2c9e7c0405
commit
f2bc41c677
4 changed files with 30 additions and 56 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.4 2004/03/30 06:44:53 uebayasi Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2005/02/10 15:51:38 ben Exp $
|
||||
|
||||
DISTNAME= upx-1.24-src
|
||||
DISTNAME= upx-1.25-src
|
||||
PKGNAME= ${DISTNAME:S/-src//}
|
||||
CATEGORIES= misc archivers
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=upx/}
|
||||
|
@ -9,16 +9,15 @@ MAINTAINER= fab@gnux.info
|
|||
HOMEPAGE= http://upx.sourceforge.net/
|
||||
COMMENT= Ultimate packer for executables
|
||||
|
||||
DEPENDS+= ucl>=1.01:../../devel/ucl
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
|
||||
|
||||
USE_GNU_TOOLS+= make
|
||||
USE_PERL5= build
|
||||
USE_BUILDLINK3= yes
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC}/src && ${GMAKE} PREFIX=${PREFIX} target=netbsd
|
||||
cd ${WRKSRC}/doc && ${GMAKE}
|
||||
cd ${WRKSRC}/src && ${MAKE_PROGRAM} PREFIX=${PREFIX} target=netbsd UCLDIR=${PREFIX} LDLIBDIRS=-L${PREFIX}/lib
|
||||
cd ${WRKSRC}/doc && ${MAKE_PROGRAM}
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/upx ${PREFIX}/bin
|
||||
|
@ -26,4 +25,5 @@ do-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/doc/upx.doc ${PREFIX}/share/doc/upx
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/upx.html ${PREFIX}/share/doc/upx
|
||||
|
||||
.include "../../devel/ucl/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2004/01/11 20:18:39 ben Exp $
|
||||
$NetBSD: distinfo,v 1.3 2005/02/10 15:51:38 ben Exp $
|
||||
|
||||
SHA1 (upx-1.24-src.tar.gz) = 81e9a8e9283045094b9c58439b1f537a04bc55fc
|
||||
Size (upx-1.24-src.tar.gz) = 222976 bytes
|
||||
SHA1 (patch-aa) = 720bdfd17a845be9953374fd832a7e92322a015a
|
||||
SHA1 (patch-ab) = 5e474b01e9e7f53e3870a033ddfee86d8c44ca27
|
||||
SHA1 (upx-1.25-src.tar.gz) = 7ce05370efe969832d841a73dd165e6a4292f9d4
|
||||
Size (upx-1.25-src.tar.gz) = 250849 bytes
|
||||
SHA1 (patch-aa) = cdd5c258c956148601cc6316854e02cc4d8d5c07
|
||||
|
|
|
@ -1,43 +1,31 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2004/01/07 15:12:59 ben Exp $
|
||||
--- ../upx-1.24/src/Makefile 2002-10-28 11:43:34.000000000 +0100
|
||||
+++ src/Makefile 2003-12-27 22:03:08.000000000 +0100
|
||||
@@ -187,6 +187,39 @@ LDFLAGS += $(LDLIBDIRS)
|
||||
$NetBSD: patch-aa,v 1.2 2005/02/10 15:51:38 ben Exp $
|
||||
|
||||
--- ../upx-1.25-orig/src/Makefile.bld 2004-06-24 20:35:14.000000000 +0200
|
||||
+++ src/Makefile.bld 2005-02-10 13:25:03.000000000 +0100
|
||||
@@ -144,6 +144,26 @@
|
||||
include $(srcdir)/Makedefs.gcc
|
||||
endif
|
||||
|
||||
|
||||
###
|
||||
+##
|
||||
+### NetBSD
|
||||
+###
|
||||
+
|
||||
+ifeq ($(target),netbsd)
|
||||
+override arch := $(shell uname -m | sed -e 's/^i[3456789]86$$/i386/')
|
||||
+DEFS += '-DUPX_CONFIG_H="config_h/linux.h"'
|
||||
+DEFS += -D_FILE_OFFSET_BITS=64 -DWITH_UCL=1
|
||||
+LDLIBS += -lucl
|
||||
+ifeq ($(arch),i386)
|
||||
+ CC += -march=i386 -mcpu=i586
|
||||
+endif
|
||||
+
|
||||
+ifeq (1,2) # checkergcc
|
||||
+ CC = checkergcc
|
||||
+ CXX = checkerg++
|
||||
+else
|
||||
+ifeq ($(target),netbsd)
|
||||
+include $(srcdir)/Makedefs.gcc
|
||||
+override arch := $(shell uname -m | sed -e 's/^i[3456789]86$$/i386/')
|
||||
+ifeq ($(arch),i386)
|
||||
+ CCARCH += -march=i386 -mcpu=i686
|
||||
+endif
|
||||
+DEFS += -D_FILE_OFFSET_BITS=64
|
||||
+##CFLAGS_WERROR = -Werror
|
||||
+ifeq ($(DEBUG),1)
|
||||
+ CFLAGS += -O0 -g
|
||||
+else
|
||||
+ ##LDFLAGS += -static
|
||||
+ STUBEDIT_EXE = objcopy -S -R .comment -R .note $@
|
||||
+ ifeq ($(arch),i386)
|
||||
+ STUBIFY_EXE = perl $(srcdir)/stub/scripts/brandelf.pl $@
|
||||
+ CHMOD_EXE = chmod 755 $@
|
||||
+ endif
|
||||
+endif
|
||||
+endif
|
||||
+LDFLAGS += -L$(PREFIX)/lib -Wl,-rpath=$(PREFIX)/lib
|
||||
+CFLAGS += -I$(PREFIX)/include
|
||||
+CC = g++
|
||||
+endif # netbsd
|
||||
+
|
||||
+###
|
||||
### Linux
|
||||
###
|
||||
+CHMOD_EXE = chmod 755 $@
|
||||
+endif # netbsd
|
||||
|
||||
###
|
||||
### linux - gcc
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2004/01/11 20:18:39 ben Exp $
|
||||
|
||||
--- src/conf.h.orig 2002-10-14 11:53:00.000000000 -0700
|
||||
+++ src/conf.h
|
||||
@@ -109,7 +109,7 @@
|
||||
# define UPX_E_OK UCL_E_OK
|
||||
# define UPX_E_ERROR UCL_E_ERROR
|
||||
# define UPX_E_OUT_OF_MEMORY UCL_E_OUT_OF_MEMORY
|
||||
-# define __UPX_ENTRY __UCL_ENTRY
|
||||
+# define __UPX_ENTRY __UCL_CDECL
|
||||
# endif
|
||||
#endif
|
||||
#if defined(WITH_NRV)
|
Loading…
Reference in a new issue