Updated math/ocaml-num to version 1.4.
Upstream changes are mostly minor, but DESTDIRS are now natively supported in the Makefile, so we can remove that patch.
This commit is contained in:
parent
d1d5746d73
commit
f323c54791
5 changed files with 12 additions and 29 deletions
|
@ -1,10 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.6 2021/03/08 08:13:03 jaapb Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2022/03/01 09:50:00 jaapb Exp $
|
||||
|
||||
GITHUB_PROJECT= num
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
DISTNAME= ${GITHUB_PROJECT}-1.1
|
||||
DISTNAME= ${GITHUB_PROJECT}-1.4
|
||||
PKGNAME= ocaml-${DISTNAME}
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=ocaml/}
|
||||
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2018/01/10 16:29:44 jaapb Exp $
|
||||
@comment $NetBSD: PLIST,v 1.2 2022/03/01 09:50:00 jaapb Exp $
|
||||
${PLIST.ocaml-opt}lib/ocaml/arith_flags.cmx
|
||||
lib/ocaml/arith_status.cmi
|
||||
lib/ocaml/arith_status.cmti
|
||||
${PLIST.ocaml-opt}lib/ocaml/arith_status.cmx
|
||||
|
@ -7,6 +8,7 @@ lib/ocaml/big_int.cmi
|
|||
lib/ocaml/big_int.cmti
|
||||
${PLIST.ocaml-opt}lib/ocaml/big_int.cmx
|
||||
lib/ocaml/big_int.mli
|
||||
${PLIST.ocaml-opt}lib/ocaml/int_misc.cmx
|
||||
lib/ocaml/libnums.a
|
||||
lib/ocaml/nat.cmi
|
||||
lib/ocaml/nat.cmti
|
||||
|
@ -25,7 +27,7 @@ lib/ocaml/ratio.cmti
|
|||
${PLIST.ocaml-opt}lib/ocaml/ratio.cmx
|
||||
lib/ocaml/ratio.mli
|
||||
${OCAML_SITELIB}/num-top/META
|
||||
${PLIST.ocaml-opt}${OCAML_SITELIB}/num-top/num_top.cma
|
||||
${OCAML_SITELIB}/num-top/num_top.cma
|
||||
${OCAML_SITELIB}/num-top/num_top.cmi
|
||||
${OCAML_SITELIB}/num-top/num_top_printers.cmi
|
||||
${OCAML_SITELIB}/num/META
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.3 2019/11/02 16:16:20 rillig Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.4 2022/03/01 09:50:00 jaapb Exp $
|
||||
|
||||
BUILDLINK_TREE+= ocaml-num
|
||||
|
||||
|
@ -6,7 +6,7 @@ BUILDLINK_TREE+= ocaml-num
|
|||
OCAML_NUM_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.ocaml-num+= ocaml-num>=1.1
|
||||
BUILDLINK_ABI_DEPENDS.ocaml-num+= ocaml-num>=1.1nb2
|
||||
BUILDLINK_ABI_DEPENDS.ocaml-num+= ocaml-num>=1.4
|
||||
BUILDLINK_PKGSRCDIR.ocaml-num?= ../../math/ocaml-num
|
||||
.endif # OCAML_NUM_BUILDLINK3_MK
|
||||
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.3 2021/10/26 10:55:50 nia Exp $
|
||||
$NetBSD: distinfo,v 1.4 2022/03/01 09:50:00 jaapb Exp $
|
||||
|
||||
BLAKE2s (num-1.1.tar.gz) = 6599e9c68c8b2dfb8aa3792cb6d459cb74d184532951274e455a5bceffe6c522
|
||||
SHA512 (num-1.1.tar.gz) = e7ee54e83eaab15ee879c5bb6deb0d76a3adf1ffd2cbd3f93cda63e7bc7b3a90313b94b4be078ecddaeee90a8a98a986d80c2fd6f1ad38faa35a318f77ec890e
|
||||
Size (num-1.1.tar.gz) = 65029 bytes
|
||||
SHA1 (patch-src_Makefile) = e122a2c207c5c8b9923bd72b309a5a382d99909d
|
||||
BLAKE2s (num-1.4.tar.gz) = e7ab3ea2666c00213cb8e327f1ca8526e796e1e0c9cca16601e733747f0e9673
|
||||
SHA512 (num-1.4.tar.gz) = 0cc9be8ad95704bb683b4bf6698bada1ee9a40dc05924b72adc7b969685c33eeb68ccf174cc09f6a228c48c18fe94af06f28bebc086a24973a066da620db8e6f
|
||||
Size (num-1.4.tar.gz) = 66327 bytes
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-src_Makefile,v 1.1 2018/01/10 16:29:44 jaapb Exp $
|
||||
|
||||
Use DESTDIR
|
||||
--- src/Makefile.orig 2017-10-13 16:43:54.000000000 +0000
|
||||
+++ src/Makefile
|
||||
@@ -84,9 +84,9 @@ TOINSTALL_STUBS=dllnums.$(SO)
|
||||
|
||||
install:
|
||||
$(OCAMLFIND) install num META
|
||||
- $(INSTALL_DATA) $(TOINSTALL) $(STDLIBDIR)
|
||||
+ $(INSTALL_DATA) $(TOINSTALL) ${DESTDIR}$(STDLIBDIR)
|
||||
ifeq "$(SUPPORTS_SHARED_LIBRARIES)" "true"
|
||||
- $(INSTALL_DLL) $(TOINSTALL_STUBS) $(STDLIBDIR)/stublibs
|
||||
+ $(INSTALL_DLL) $(TOINSTALL_STUBS) ${DESTDIR}$(STDLIBDIR)/stublibs
|
||||
endif
|
||||
|
||||
uninstall:
|
Loading…
Reference in a new issue