Deal with scandir prototype differences. Fixes pkg/52146
This commit is contained in:
parent
8a2d0743ad
commit
f3471eac12
3 changed files with 35 additions and 2 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.10 2017/01/12 05:49:54 skrll Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2017/04/16 19:25:25 skrll Exp $
|
||||
#
|
||||
|
||||
DISTNAME= userland-20170109
|
||||
PKGREVISION= 1
|
||||
PKGNAME= raspberrypi-${DISTNAME}
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=jaredmcneill/}
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.8 2017/01/12 05:49:54 skrll Exp $
|
||||
$NetBSD: distinfo,v 1.9 2017/04/16 19:25:25 skrll Exp $
|
||||
|
||||
SHA1 (userland-20170109-734d76b0675685e9ec9148694f2cc00f58e5ebc0.tar.gz) = 6d5db24f38e40a2aed866c8b96cd88074a4dc93b
|
||||
RMD160 (userland-20170109-734d76b0675685e9ec9148694f2cc00f58e5ebc0.tar.gz) = 0ac98329e36095fad45017d972eb0a14b7f3b30b
|
||||
SHA512 (userland-20170109-734d76b0675685e9ec9148694f2cc00f58e5ebc0.tar.gz) = 937591729ee19ee56722b354565163b07a23ba76d211c3bf5f340789e8fef334f18066448d59e4acd1147abfb7bd7c4c1a7fba6917a4072a59e2c17afd774e73
|
||||
Size (userland-20170109-734d76b0675685e9ec9148694f2cc00f58e5ebc0.tar.gz) = 32917687 bytes
|
||||
SHA1 (patch-host__applications_linux_apps_dtmerge_dtmerge.c) = 732dc54db48d43b97d558cd938617418bc0c3655
|
||||
SHA1 (patch-host__applications_linux_apps_dtoverlay_dtoverlay__main.c) = e6605a31f65b49b8993af3eff91aa523ae8acff6
|
||||
SHA1 (patch-host__applications_linux_apps_tvservice_tvservice.c) = 2cc304252c102d46603f6649eb959984e9d44b1f
|
||||
SHA1 (patch-interface_vchiq__arm_vchiq__lib.c) = a9535aa96ba3374f2a559899c6baff9ddc935f3f
|
||||
SHA1 (patch-interface_vcos_CMakeLists.txt) = f96c052af9c1d10f3f386efc1b5d0006559e4e67
|
||||
|
|
|
@ -0,0 +1,31 @@
|
|||
$NetBSD: patch-host__applications_linux_apps_dtoverlay_dtoverlay__main.c,v 1.3 2017/04/16 19:25:25 skrll Exp $
|
||||
|
||||
--- host_applications/linux/apps/dtoverlay/dtoverlay_main.c.orig 2017-01-07 08:24:37.000000000 +0000
|
||||
+++ host_applications/linux/apps/dtoverlay/dtoverlay_main.c
|
||||
@@ -36,6 +36,10 @@ SOFTWARE, EVEN IF ADVISED OF THE POSSIBI
|
||||
|
||||
#include <libfdt.h>
|
||||
|
||||
+#ifdef __NetBSD__
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
#include "dtoverlay.h"
|
||||
#include "utils.h"
|
||||
|
||||
@@ -1006,8 +1010,15 @@ int seq_filter(const struct dirent *de)
|
||||
return (sscanf(de->d_name, "%d_", &num) == 1);
|
||||
}
|
||||
|
||||
+#if defined (__NetBSD__) && __NetBSD_Version__-0 >= 799005100
|
||||
int seq_compare(const struct dirent **de1, const struct dirent **de2)
|
||||
{
|
||||
+#else
|
||||
+int seq_compare(const void *d1, const void *d2)
|
||||
+{
|
||||
+ const struct dirent * const *de1 = d1;
|
||||
+ const struct dirent * const *de2 = d2;
|
||||
+#endif
|
||||
int num1 = atoi((*de1)->d_name);
|
||||
int num2 = atoi((*de2)->d_name);
|
||||
if (num1 < num2)
|
Loading…
Reference in a new issue