spiff: Honour LDFLAGS. Should help the build on certain platforms.

While here, reduce amount of implicit-function-declaring.
This commit is contained in:
nia 2023-07-09 15:14:41 +00:00
parent 880958fe77
commit f37a0cebab
4 changed files with 35 additions and 6 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.8 2020/01/26 17:31:04 rillig Exp $
# $NetBSD: Makefile,v 1.9 2023/07/09 15:14:41 nia Exp $
#
DISTNAME= spiff-1.0
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.darwinsys.com/freeware/

View file

@ -1,12 +1,13 @@
$NetBSD: distinfo,v 1.11 2021/10/26 10:19:57 nia Exp $
$NetBSD: distinfo,v 1.12 2023/07/09 15:14:41 nia Exp $
BLAKE2s (spiff-1.0.tar.gz) = 1eefbd7dacba51cf114bcb279e2efff622e3eb92fe899c1690fb7aedbbb1d13a
SHA512 (spiff-1.0.tar.gz) = a93ff7a22644e67d548f31a3692d72242ead9a4b1ca69875b9cde748ea39a2c8d6a24eaac680fd02337290b87a10d0363111ef14ffca8eb02e36c83e0409b277
Size (spiff-1.0.tar.gz) = 48291 bytes
SHA1 (patch-aa) = 0a32ca2e2fd838cc21eca476111fe81a3f545181
SHA1 (patch-aa) = 426ec126bf8196f387fadb81fe8b3284751f9566
SHA1 (patch-ab) = 265a62ded94e73b42f8f46180613ff6e5de90399
SHA1 (patch-ac) = d88280626b3d1621377d38037a52e79e6e35bb1a
SHA1 (patch-ad) = 86d90bf42e1735f20fc8538522638f1b5af92d60
SHA1 (patch-ae) = a4d5f04fa69e775f3e39e60c93b764d0a6c0af7c
SHA1 (patch-af) = 5d922bcafe13e5f24347e78b9e1cd0859d295631
SHA1 (patch-line.c) = 3eb93ebdb9918799b7f532019f4dcb65dc4fa75c
SHA1 (patch-output.c) = ab59db490ca01e6983eebe830b7881a81bdd3590

View file

@ -1,4 +1,4 @@
$NetBSD: patch-aa,v 1.3 2012/06/18 03:39:00 dholland Exp $
$NetBSD: patch-aa,v 1.4 2023/07/09 15:14:41 nia Exp $
- configure for pkgsrc
- honor PKGMANDIR
@ -51,7 +51,7 @@ $NetBSD: patch-aa,v 1.3 2012/06/18 03:39:00 dholland Exp $
#
# 3) SELECTION OF WINDOW MANAGER AVAILABILITY
@@ -80,7 +80,7 @@ MANPAGE=spiff.1
@@ -80,12 +80,12 @@ MANPAGE=spiff.1
# disable this line iff you like being honked at.
DEFS = -DNOCHATTER
@ -60,6 +60,12 @@ $NetBSD: patch-aa,v 1.3 2012/06/18 03:39:00 dholland Exp $
default: spiff
spiff: $(OBJ)
- $(CC) $(CFLAGS) -o spiff $(OBJ) $(VISLIB) -l$(TLIB)
+ $(CC) $(LDFLAGS) -o spiff $(OBJ) $(VISLIB) -l$(TLIB)
spiff.o: spiff.c misc.h line.h token.h tol.h command.h edit.h parse.h compare.h flagdefs.h exact.h miller.h visual.h
@@ -145,5 +145,5 @@ cmd:
-$(CMD) $(CFILES) $(HFILES) $(OTHER) $(MANPAGE)
install:

View file

@ -0,0 +1,22 @@
$NetBSD: patch-output.c,v 1.1 2023/07/09 15:14:41 nia Exp $
Reduce implicit function declarations.
--- output.c.orig 1990-02-05 20:17:18.000000000 +0000
+++ output.c
@@ -12,6 +12,7 @@ static char rcsid[]= "$Header: output.c,
#endif
#include <stdio.h>
+#include <unistd.h>
#ifdef M_TERMINFO
#include <curses.h>
@@ -22,6 +23,7 @@ static char rcsid[]= "$Header: output.c,
#ifdef XENIX
#include <tcap.h>
#endif
+#include <termcap.h>
#endif
#include "misc.h"