Fix included (and installed) perl scripts to use the right interpreter.
While here, pull in a patch from CVS (which already is in 0.8.8) to make tunesbrowser be able to play aac files. Bump PKGREVISION to 2. Closes PR pkg/29653 by Antoine Reilles.
This commit is contained in:
parent
19aa3f4fa6
commit
f3b335e25a
3 changed files with 113 additions and 3 deletions
|
@ -1,12 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.20 2005/01/13 12:56:31 jmmv Exp $
|
||||
# $NetBSD: Makefile,v 1.21 2005/03/12 09:09:34 jmmv Exp $
|
||||
#
|
||||
|
||||
.include "Makefile.common"
|
||||
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
|
||||
COMMENT+= base plugins
|
||||
|
||||
USE_PERL5= run
|
||||
USE_X11= yes
|
||||
|
||||
PKGCONFIG_OVERRIDE+= pkgconfig/gstreamer-gconf.pc.in
|
||||
|
@ -25,5 +26,8 @@ CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc/gst-plugins
|
|||
|
||||
GCONF2_SCHEMAS= gstreamer-0.8.schemas
|
||||
|
||||
REPLACE_PERL+= tools/gst-launch-ext-m.m
|
||||
REPLACE_PERL+= tools/gst-visualise-m.m
|
||||
|
||||
.include "../../devel/GConf2/schemas.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.16 2005/02/24 11:24:02 agc Exp $
|
||||
$NetBSD: distinfo,v 1.17 2005/03/12 09:09:34 jmmv Exp $
|
||||
|
||||
SHA1 (gst-plugins-0.8.7.tar.bz2) = fbfb1a23ef805e58f5617649590d065440470628
|
||||
RMD160 (gst-plugins-0.8.7.tar.bz2) = faa220713f09824367795ad08bbce1f4293912a0
|
||||
Size (gst-plugins-0.8.7.tar.bz2) = 2134878 bytes
|
||||
SHA1 (patch-aa) = c9173d53f594236f114cb5356aca79f41e13240b
|
||||
SHA1 (patch-ab) = f7e6c495ebcddb49f9e01ff6de36ed11c6d98dd5
|
||||
SHA1 (patch-ac) = 31c3283a17d6e667e0296eb7bf102cc5213cf92f
|
||||
SHA1 (patch-ae) = d51997b93689753fa0a34eec21ac14dc22af7500
|
||||
|
|
105
multimedia/gst-plugins/patches/patch-ac
Normal file
105
multimedia/gst-plugins/patches/patch-ac
Normal file
|
@ -0,0 +1,105 @@
|
|||
$NetBSD: patch-ac,v 1.5 2005/03/12 09:09:34 jmmv Exp $
|
||||
|
||||
--- gst/qtdemux/qtdemux.c.orig 2004-12-23 13:42:49.000000000 +0100
|
||||
+++ gst/qtdemux/qtdemux.c 2005-03-11 16:47:54.000000000 +0100
|
||||
@@ -511,10 +511,11 @@
|
||||
|
||||
switch (GST_STATE_TRANSITION (element)) {
|
||||
case GST_STATE_NULL_TO_READY:
|
||||
- break;
|
||||
- case GST_STATE_READY_TO_PAUSED:
|
||||
qtdemux->bs = gst_bytestream_new (qtdemux->sinkpad);
|
||||
qtdemux->state = QTDEMUX_STATE_HEADER;
|
||||
+ GST_DEBUG("new bytestream");
|
||||
+ break;
|
||||
+ case GST_STATE_READY_TO_PAUSED:
|
||||
break;
|
||||
case GST_STATE_PAUSED_TO_PLAYING:
|
||||
break;
|
||||
@@ -524,9 +525,9 @@
|
||||
qtdemux->last_ts = GST_CLOCK_TIME_NONE;
|
||||
qtdemux->need_discont = FALSE;
|
||||
qtdemux->need_flush = FALSE;
|
||||
- gst_bytestream_destroy (qtdemux->bs);
|
||||
break;
|
||||
case GST_STATE_READY_TO_NULL:
|
||||
+ gst_bytestream_destroy (qtdemux->bs);
|
||||
break;
|
||||
default:
|
||||
break;
|
||||
@@ -614,6 +615,7 @@
|
||||
break;
|
||||
}
|
||||
} while (1);
|
||||
+ qtdemux->offset += length;
|
||||
|
||||
qtdemux_parse_moov (qtdemux, GST_BUFFER_DATA (moov), length);
|
||||
if (1) {
|
||||
@@ -632,11 +634,18 @@
|
||||
}
|
||||
ret = gst_bytestream_seek (qtdemux->bs, cur_offset + length,
|
||||
GST_SEEK_METHOD_SET);
|
||||
- if (!ret) {
|
||||
- g_warning ("seek failed");
|
||||
+ GST_DEBUG ("seek returned %d", ret);
|
||||
+ if (ret == FALSE) {
|
||||
+ length = cur_offset + length;
|
||||
+ cur_offset = qtdemux->offset;
|
||||
+ length -= cur_offset;
|
||||
+ if (gst_bytestream_flush (qtdemux->bs, length) == FALSE) {
|
||||
+ if (!gst_qtdemux_handle_sink_event (qtdemux)) {
|
||||
+ return;
|
||||
+ }
|
||||
+ }
|
||||
}
|
||||
qtdemux->offset = cur_offset + length;
|
||||
- GST_DEBUG ("seek returned %d", ret);
|
||||
break;
|
||||
}
|
||||
case QTDEMUX_STATE_SEEKING_EOS:
|
||||
@@ -685,8 +694,8 @@
|
||||
GST_DATA (gst_event_new (GST_EVENT_EOS)));
|
||||
}
|
||||
ret = gst_bytestream_seek (qtdemux->bs, 0, GST_SEEK_METHOD_END);
|
||||
- if (!ret) {
|
||||
- g_warning ("seek failed");
|
||||
+ if (ret == FALSE) {
|
||||
+ gst_bytestream_flush(qtdemux->bs, 0xffffffff);
|
||||
}
|
||||
GST_DEBUG ("seek returned %d", ret);
|
||||
|
||||
@@ -706,16 +715,23 @@
|
||||
|
||||
/* don't believe bytestream */
|
||||
//cur_offset = gst_bytestream_tell (qtdemux->bs);
|
||||
+ cur_offset = qtdemux->offset;
|
||||
|
||||
if (offset != cur_offset) {
|
||||
GST_DEBUG ("seeking to offset %d (currently at %d)", offset,
|
||||
cur_offset);
|
||||
ret = gst_bytestream_seek (qtdemux->bs, offset, GST_SEEK_METHOD_SET);
|
||||
- if (!ret) {
|
||||
- g_warning ("seek failed");
|
||||
+ GST_DEBUG ("seek returned %d", ret);
|
||||
+ if (ret == FALSE && offset > cur_offset) {
|
||||
+ if (gst_bytestream_flush (qtdemux->bs, offset - cur_offset) == FALSE) {
|
||||
+ if (!gst_qtdemux_handle_sink_event (qtdemux)) {
|
||||
+ return;
|
||||
+ }
|
||||
}
|
||||
+ }
|
||||
+ else if (ret == FALSE && offset < cur_offset)
|
||||
+ GST_ERROR("cannot flush backwards");
|
||||
qtdemux->offset = offset;
|
||||
- GST_DEBUG ("seek returned %d", ret);
|
||||
return;
|
||||
}
|
||||
|
||||
@@ -732,6 +748,7 @@
|
||||
break;
|
||||
}
|
||||
} while (TRUE);
|
||||
+ qtdemux->offset += size;
|
||||
|
||||
if (buf) {
|
||||
/* hum... FIXME changing framerate breaks horribly, better set
|
Loading…
Reference in a new issue