corewars: remove inline keyword

hopefully fixes NetBSD 9 build
This commit is contained in:
wiz 2022-12-24 14:24:34 +00:00
parent 19a71f9c06
commit f3b7d5cd9d
2 changed files with 17 additions and 1 deletions

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.7 2021/10/26 10:43:51 nia Exp $
$NetBSD: distinfo,v 1.8 2022/12/24 14:24:34 wiz Exp $
BLAKE2s (corewars-0.9.13.tar.gz) = 424ed84d33a26c31f44831556c8fa6688581b550502abeb607e427fd0c0e15ef
SHA512 (corewars-0.9.13.tar.gz) = fe4194ac5efa7612a06d80c1218740de17a6dae6228f5e603074ab296f4a195adc68c0d8db5bbc9588947a536a9cfc208b411b024163adfe1cda072d05dd6a71
Size (corewars-0.9.13.tar.gz) = 203874 bytes
SHA1 (patch-src_execute-cw.c) = 4c4a76cd4bed4b2bfb7e93a44c9df91f880c90e3

View File

@ -0,0 +1,15 @@
$NetBSD: patch-src_execute-cw.c,v 1.1 2022/12/24 14:24:34 wiz Exp $
Avoid inline to fix build on NetBSD 9.
--- src/execute-cw.c.orig 2000-03-30 20:21:34.000000000 +0000
+++ src/execute-cw.c
@@ -86,7 +86,7 @@ inline int get_value (struct cw_operand
}
}
-inline int get_reference (struct cw_operand *o, int i, struct cell **ref)
+int get_reference (struct cw_operand *o, int i, struct cell **ref)
{
int j;