wmii: remove some debug things, re-introduce @@ things
that got mangled via mkpatches, appease the pkglint gods
This commit is contained in:
parent
283e5820be
commit
f3e8ce02b8
4 changed files with 28 additions and 21 deletions
|
@ -1,15 +1,15 @@
|
|||
# $NetBSD: Makefile,v 1.33 2018/05/14 10:20:57 maya Exp $
|
||||
# $NetBSD: Makefile,v 1.34 2018/05/14 10:31:14 maya Exp $
|
||||
|
||||
PKGNAME= wmii-3.9.2
|
||||
DISTNAME= wmii+ixp-3.9.2
|
||||
PKGNAME= wmii-3.9.2
|
||||
CATEGORIES= wm
|
||||
MASTER_SITES= http://dl.suckless.org/wmii/
|
||||
EXTRACT_SUFX= .tbz
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://github.com/0intro/wmii
|
||||
COMMENT= Modular and keyboard-friendly window manager
|
||||
LICENSE= mit
|
||||
EXTRACT_SUFX= .tbz
|
||||
|
||||
DEPENDS+= dmenu>=3.7:../../x11/dmenu
|
||||
|
||||
|
@ -23,10 +23,10 @@ MAKE_ENV+= PKG_SYSCONFBASE=${PKG_SYSCONFBASE}
|
|||
MAKE_JOBS_SAFE= no
|
||||
|
||||
# see ${WRKSRC}/mk/wmii.mk
|
||||
CONFVERSION= 3.9.2
|
||||
CONFVERSION= ${PKGNAME:S/wmii-//}
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/wmii
|
||||
EGSUBDIR.top=
|
||||
EGSUBDIR.top= # empty
|
||||
EGFILES.top+= wmiirc welcome
|
||||
EGSUBDIR.pygmi= python/pygmi
|
||||
EGFILES.pygmi+= __init__.py event.py fs.py menu.py monitor.py
|
||||
|
@ -38,10 +38,9 @@ EGSUBDIR.python= python
|
|||
EGFILES.python+= wmiirc wmiirc.py
|
||||
EGSUBDIR.ruby= ruby
|
||||
EGFILES.ruby+= wmiirc config.rb config.yaml
|
||||
CONF_FILES_MODE= 0755
|
||||
CONF_FILES_MODE= 0644
|
||||
|
||||
.for subdir in top pygmi pyxp python ruby
|
||||
THING+= ${subdir}
|
||||
. for file in ${EGFILES.${subdir}}
|
||||
CONF_FILES+= ${EGDIR}/${EGSUBDIR.${subdir}}/${file} \
|
||||
${PKG_SYSCONFDIR}/wmii-${CONFVERSION}/${EGSUBDIR.${subdir}}${file}
|
||||
|
@ -51,7 +50,7 @@ CONF_FILES+= ${EGDIR}/${EGSUBDIR.${subdir}}/${file} \
|
|||
LDFLAGS.SunOS+= -lsocket -lnsl -liconv
|
||||
|
||||
SUBST_CLASSES+= vars
|
||||
SUBST_STAGE.vars= pre-build
|
||||
SUBST_STAGE.vars= post-patch
|
||||
SUBST_FILES.vars= util/compile
|
||||
SUBST_VARS.vars= EGREP SED SH AWK
|
||||
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.15 2018/05/14 10:20:57 maya Exp $
|
||||
$NetBSD: distinfo,v 1.16 2018/05/14 10:31:14 maya Exp $
|
||||
|
||||
SHA1 (wmii+ixp-3.9.2.tbz) = e85a2979a0bd0a1db7ed486fc709afe72bafd8b0
|
||||
RMD160 (wmii+ixp-3.9.2.tbz) = 8a401a5d0a033c0da254d15e7fe415ec40e7a332
|
||||
SHA512 (wmii+ixp-3.9.2.tbz) = c75d6d3f80e2b263c8d7b9eb6d0e700a1ad642209fc0984908e9399d22372c6c0572f47ab61881d5d56c4cc4eeb2914a545f6af1bbb936b65848764577d75761
|
||||
Size (wmii+ixp-3.9.2.tbz) = 432032 bytes
|
||||
SHA1 (patch-aa) = ba9598bf6d9313a800ee8de8588a6192c294e697
|
||||
SHA1 (patch-aa) = e8f5445fce699ba438753cefd4ec250018ce6985
|
||||
SHA1 (patch-ab) = cdb5ae1f02497852a5c965bdfb106e1b3a77853e
|
||||
SHA1 (patch-cmd_wmii_main.c) = 2e52a5861b197b9ffa8b7df83230e7bc74059256
|
||||
SHA1 (patch-util_compile) = 0474964a1e2491a28a17cc1f37c7a3cadd3b598a
|
||||
SHA1 (patch-util_compile) = 5b4815086c36789ad53c795ab26057b1066f5113
|
||||
|
|
|
@ -1,4 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.11 2018/05/14 10:20:57 maya Exp $
|
||||
$NetBSD: patch-aa,v 1.12 2018/05/14 10:31:14 maya Exp $
|
||||
|
||||
pkgsrc-friendly paths, don't force /usr/local PREFIX.
|
||||
|
||||
--- config.mk.orig 2010-06-10 07:24:04.000000000 +0000
|
||||
+++ config.mk
|
||||
|
|
|
@ -1,13 +1,19 @@
|
|||
$NetBSD: patch-util_compile,v 1.2 2018/05/14 10:20:57 maya Exp $
|
||||
$NetBSD: patch-util_compile,v 1.3 2018/05/14 10:31:14 maya Exp $
|
||||
|
||||
Allow substituing sh, bin, awk, egrep.
|
||||
|
||||
--- util/compile.orig 2010-06-10 07:24:04.000000000 +0000
|
||||
+++ util/compile
|
||||
@@ -4,7 +4,7 @@ CC=$1
|
||||
@@ -1,10 +1,10 @@
|
||||
-#!/bin/sh -f
|
||||
+#!@SH@ -f
|
||||
|
||||
CC=$1
|
||||
CFLAGS=$2; shift 2
|
||||
|
||||
outfile="$1"; shift
|
||||
-bin="$(echo $0 | sed 's,/[^/]*$,,')"
|
||||
+bin="$(echo $0 | /usr/bin/sed 's,/[^/]*$,,')"
|
||||
+bin="$(echo $0 | @SED@ 's,/[^/]*$,,')"
|
||||
|
||||
# Derived from Russ Cox's 9c in plan9port.
|
||||
|
||||
|
@ -16,7 +22,7 @@ $NetBSD: patch-util_compile,v 1.2 2018/05/14 10:20:57 maya Exp $
|
|||
[ $? -eq 0 ] || echo $CC -o $outfile $CFLAGS $@ >&2
|
||||
|
||||
-base=$(echo $BASE | sed 's/,/\\,/g')
|
||||
+base=$(echo $BASE | /usr/bin/sed 's/,/\\,/g')
|
||||
+base=$(echo $BASE | @SED@ 's/,/\\,/g')
|
||||
re='\([^[:space:]/]*\..:[0-9]\)'
|
||||
|
||||
undup() { # GCC is crap.
|
||||
|
@ -29,11 +35,11 @@ $NetBSD: patch-util_compile,v 1.2 2018/05/14 10:20:57 maya Exp $
|
|||
- sed 's/ .first use in this function.$//; s/\"\([^\"][^\"]*\)\", line \([0-9][0-9]*\)/\1:\2/g' |
|
||||
- awk '$1 == "warning:"{t=$2" "$1; sub(/^[^ ]+ [^ ]+ /, ""); $0 = t" "$0}; //' |
|
||||
- awk '{sub(/\[/, ": [", $1); print}' |
|
||||
+cat $xtmp | /usr/bin/sed "s,^$re,$base&,g; s,\([[:space:]]\)$re,\1$base\2,g" |
|
||||
+ /usr/bin/egrep -v ': error: .Each undeclared identifier|: error: for each function it appears|is dangerous, better use|is almost always misused|: In function |: At top level:|support .long long.|use of C99 long long|ISO C forbids conversion|warning:.*warn_unused_result' |
|
||||
+ /usr/bin/sed 's/ .first use in this function.$//; s/\"\([^\"][^\"]*\)\", line \([0-9][0-9]*\)/\1:\2/g' |
|
||||
+ /usr/bin/awk '$1 == "warning:"{t=$2" "$1; sub(/^[^ ]+ [^ ]+ /, ""); $0 = t" "$0}; //' |
|
||||
+ /usr/bin/awk '{sub(/\[/, ": [", $1); print}' |
|
||||
+cat $xtmp | @SED@ "s,^$re,$base&,g; s,\([[:space:]]\)$re,\1$base\2,g" |
|
||||
+ @EGREP@ -v ': error: .Each undeclared identifier|: error: for each function it appears|is dangerous, better use|is almost always misused|: In function |: At top level:|support .long long.|use of C99 long long|ISO C forbids conversion|warning:.*warn_unused_result' |
|
||||
+ @SED@ 's/ .first use in this function.$//; s/\"\([^\"][^\"]*\)\", line \([0-9][0-9]*\)/\1:\2/g' |
|
||||
+ @AWK@ '$1 == "warning:"{t=$2" "$1; sub(/^[^ ]+ [^ ]+ /, ""); $0 = t" "$0}; //' |
|
||||
+ @AWK@ '{sub(/\[/, ": [", $1); print}' |
|
||||
undup 1>&2
|
||||
|
||||
rm -f $xtmp
|
||||
|
|
Loading…
Reference in a new issue