Always install man pages. Bump revision.

This commit is contained in:
joerg 2020-08-18 01:01:56 +00:00
parent ae9af93395
commit f3f09799cf
4 changed files with 41 additions and 4 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.4 2020/02/16 20:40:14 adam Exp $
# $NetBSD: Makefile,v 1.5 2020/08/18 01:01:56 joerg Exp $
DISTNAME= odfpy-1.4.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= ${MASTER_SITE_PYPI:=o/odfpy/}
@ -17,10 +18,19 @@ USE_LANGUAGES= # none
PYSETUPTESTTARGET= pytest
SUBST_CLASSES+= man
SUBST_STAGE.man= pre-configure
SUBST_FILES.man= setup.py
SUBST_VARS.man= PKGMANDIR
post-install:
.for bin in csv2ods mailodf odf2mht odf2xhtml odf2xml odfimgimport \
odflint odfmeta odfoutline odfuserfield xml2odf
cd ${DESTDIR}${PREFIX}/bin && ${MV} ${bin} ${bin}-${PYVERSSUFFIX} || ${TRUE}
${MV} ${DESTDIR}${PREFIX}/bin/${bin} \
${DESTDIR}${PREFIX}/bin/${bin}-${PYVERSSUFFIX}
${MV} ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/${bin}.1 \
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/${bin}-${PYVERSSUFFIX}.1
.endfor
.include "../../lang/python/egg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2018/12/04 13:25:59 adam Exp $
@comment $NetBSD: PLIST,v 1.4 2020/08/18 01:01:56 joerg Exp $
bin/csv2ods-${PYVERSSUFFIX}
bin/mailodf-${PYVERSSUFFIX}
bin/odf2mht-${PYVERSSUFFIX}
@ -117,3 +117,14 @@ ${PYSITELIB}/odf/userfield.pyo
${PYSITELIB}/odf/xforms.py
${PYSITELIB}/odf/xforms.pyc
${PYSITELIB}/odf/xforms.pyo
man/man1/csv2ods-${PYVERSSUFFIX}.1
man/man1/mailodf-${PYVERSSUFFIX}.1
man/man1/odf2mht-${PYVERSSUFFIX}.1
man/man1/odf2xhtml-${PYVERSSUFFIX}.1
man/man1/odf2xml-${PYVERSSUFFIX}.1
man/man1/odfimgimport-${PYVERSSUFFIX}.1
man/man1/odflint-${PYVERSSUFFIX}.1
man/man1/odfmeta-${PYVERSSUFFIX}.1
man/man1/odfoutline-${PYVERSSUFFIX}.1
man/man1/odfuserfield-${PYVERSSUFFIX}.1
man/man1/xml2odf-${PYVERSSUFFIX}.1

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.4 2020/02/16 20:40:14 adam Exp $
$NetBSD: distinfo,v 1.5 2020/08/18 01:01:56 joerg Exp $
SHA1 (odfpy-1.4.1.tar.gz) = f0e8870e88957b9a9d541077fb9a8d703e0766f6
RMD160 (odfpy-1.4.1.tar.gz) = 70d9b9e69cd91c790002c331eb25f8dc88611846
SHA512 (odfpy-1.4.1.tar.gz) = 576b0eba9bba15d3682b1d0c33c585d02abb0cf9a11b783bc17d5e870ff779749d78d60b3b71d274e3195eed23ba687358d5df39e3fedec4b265b46a270f2fe1
Size (odfpy-1.4.1.tar.gz) = 717045 bytes
SHA1 (patch-setup.py) = e488589f283c0662dcac71f0de19bdae49bee92e

View file

@ -0,0 +1,15 @@
$NetBSD: patch-setup.py,v 1.1 2020/08/18 01:01:56 joerg Exp $
--- setup.py.orig 2020-08-18 00:55:43.861248992 +0000
+++ setup.py
@@ -23,8 +23,8 @@ from setuptools import setup
version = '1.4.1'
-if platform.system() in ('Linux','Unix'):
- man1pages = [('share/man/man1', [
+if True:
+ man1pages = [('@PKGMANDIR@/man1', [
'csv2ods/csv2ods.1',
'mailodf/mailodf.1',
'odf2xhtml/odf2xhtml.1',