update to freedv-1.1

This commit is contained in:
dbj 2016-01-19 04:03:21 +00:00
parent 82d76dfb46
commit f3f91f8fb4
5 changed files with 74 additions and 63 deletions

View file

@ -1,15 +1,10 @@
# $NetBSD: Makefile,v 1.6 2015/04/25 14:23:20 tnn Exp $
# $NetBSD: Makefile,v 1.7 2016/01/19 04:03:21 dbj Exp $
#
VERSION= 0.97.0.1696
PKGNAME= freedv-${VERSION}
DISTNAME= fdmdv2-${VERSION}
PKGREVISION= 2
WRKSRC= ${WRKDIR}/fdmdv2
DISTNAME= freedv-1.1
CATEGORIES= ham
# svn://svn.code.sf.net/p/freetel/code/fdmdv2
MASTER_SITES= ${MASTER_SITE_LOCAL}
EXTRACT_SUFX= .tgz
MASTER_SITES= http://files.freedv.org/freedv/
EXTRACT_SUFX= .tar.xz
MAINTAINER= dbj@NetBSD.org
HOMEPAGE= http://freedv.org/
@ -20,16 +15,11 @@ LICENSE= gnu-lgpl-v2.1
USE_TOOLS+= pkg-config
USE_LANGUAGES= c c++
CHECK_PORTABILITY_SKIP+= configure
USE_CMAKE= yes
CONFIGURE_DIRS= build
BUILD_DIRS=${CONFIGURE_DIRS}
CMAKE_ARG_PATH= ..
.include "fixbinconst.mk"
SUBST_STAGE.fixbinconst= pre-configure
SUBST_FILES.fixbinconst+= src/varicode_table.h
CMAKE_ARGS+= -DUSE_STATIC_CODEC2=FALSE
CMAKE_ARGS+= -DUSE_STATIC_SPEEXDSP=FALSE
.include "../../mk/bsd.prefs.mk"
@ -43,6 +33,7 @@ pre-configure:
.include "../../ham/codec2/buildlink3.mk"
.include "../../ham/hamlib/buildlink3.mk"
.include "../../audio/sox/buildlink3.mk"
.include "../../audio/speexdsp/buildlink3.mk"
.include "../../audio/portaudio-devel/buildlink3.mk"
.include "../../audio/libsamplerate/buildlink3.mk"
.include "../../x11/wxGTK30/buildlink3.mk"

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.3 2015/11/02 23:57:23 agc Exp $
$NetBSD: distinfo,v 1.4 2016/01/19 04:03:21 dbj Exp $
SHA1 (fdmdv2-0.97.0.1696.tgz) = c99311738ffb6960416dd261a11b08756827dc6e
RMD160 (fdmdv2-0.97.0.1696.tgz) = 122f630f7651607501c84a2109c92f989c04e519
SHA512 (fdmdv2-0.97.0.1696.tgz) = fa4c0324895bf7f31ae4036520aaa9da3aed7c819e672559f9c8b68ed12da49ad4b936bf0f78409408891ff2a90010f127566e1458d9e728ea54663a952a26e1
Size (fdmdv2-0.97.0.1696.tgz) = 1537981 bytes
SHA1 (freedv-1.1.tar.xz) = ec98a60e04c4eafb112793028468345d9f8aed55
RMD160 (freedv-1.1.tar.xz) = c2be5877a7a8865581aff8badb1bb6441f8fdc0b
SHA512 (freedv-1.1.tar.xz) = bd149f74ceae9c63b23c37d2e6d876238b9c1759d8bd1213675d3d0d2f817863e952129306ca37da9f41297b17a9f74d57cb807689ef051b3d94a8f8b52b5727
Size (freedv-1.1.tar.xz) = 424420 bytes
SHA1 (patch-src_CMakeLists.txt) = 6dc34dbc89394c92afbb435d8b06bd76603cc5d2
SHA1 (patch-src_sox__biquad.c) = b59975d6590cddacd3978759b254ce54894c1a7b

View file

@ -1,38 +0,0 @@
# $NetBSD: fixbinconst.mk,v 1.1 2015/01/27 08:19:22 dbj Exp $
# A hack to fix up single byte binary constants
SUBST_CLASSES+= fixbinconst
SUBST_SED.fixbinconst+= -e 's/0[bB]0000/0b0/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]0001/0b1/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]0010/0b2/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]0011/0b3/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]0100/0b4/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]0101/0b5/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]0110/0b6/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]0111/0b7/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]1000/0b8/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]1001/0b9/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]1010/0ba/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]1011/0bb/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]1100/0bc/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]1101/0bd/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]1110/0be/g'
SUBST_SED.fixbinconst+= -e 's/0[bB]1111/0bf/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)0000/0x\10/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)0001/0x\11/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)0010/0x\12/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)0011/0x\13/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)0100/0x\14/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)0101/0x\15/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)0110/0x\16/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)0111/0x\17/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)1000/0x\18/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)1001/0x\19/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)1010/0x\1a/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)1011/0x\1b/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)1100/0x\1c/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)1101/0x\1d/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)1110/0x\1e/g'
SUBST_SED.fixbinconst+= -e 's/0b\([0-9a-f]\)1111/0x\1f/g'
SUBST_MESSAGE.fixbinconst= Fixing unportable binary constants

View file

@ -0,0 +1,30 @@
$NetBSD: patch-src_CMakeLists.txt,v 1.1 2016/01/19 04:03:21 dbj Exp $
Disable building App bundle on MacOS. This isn't very useful
unless we have a native version wxWidgets, which we don't at the
moment.
--- src/CMakeLists.txt.orig 2015-08-30 10:27:14.000000000 +0000
+++ src/CMakeLists.txt
@@ -43,21 +43,3 @@ endif(FREEDV_STATIC_DEPS)
install(TARGETS freedv
RUNTIME DESTINATION bin)
-# Custom commands to build OSX images.
-if(APPLE)
- add_custom_command(
- TARGET freedv
- POST_BUILD
- COMMAND mkdir ARGS -p FreeDV.app/Contents/MacOS
- COMMAND mkdir ARGS -p FreeDV.app/Contents/Resources/English.lproj
- COMMAND cp ARGS ${CMAKE_CURRENT_SOURCE_DIR}/info.plist FreeDV.app/Contents
- COMMAND cp ARGS ${CMAKE_CURRENT_SOURCE_DIR}/freedv.icns FreeDV.app/Contents/Resources
- COMMAND echo ARGS -n "APPL????" > FreeDV.app/Contents/PkgInfo
- COMMAND cp ARGS freedv FreeDV.app/Contents/MacOS/FreeDV
- COMMAND dylibbundler ARGS -od -b -x FreeDV.app/Contents/MacOS/FreeDV -d FreeDV.app/Contents/libs -p @executable_path/../libs/
- COMMAND mkdir dist_tmp
- COMMAND cp -r FreeDV.app dist_tmp
- COMMAND hdiutil create -srcfolder dist_tmp/ -volname FreeDV -format UDZO ./FreeDV.dmg
- COMMAND rm -rf dist_tmp
- )
-endif(APPLE)

View file

@ -0,0 +1,26 @@
$NetBSD: patch-src_sox__biquad.c,v 1.1 2016/01/19 04:03:21 dbj Exp $
Avoid calling a sox internal function that is no longer
exported by the library.
--- src/sox_biquad.c.orig 2014-06-04 11:05:20.000000000 +0000
+++ src/sox_biquad.c
@@ -34,9 +34,6 @@
#define N_MAX 1024
-int lsx_biquad_flow(sox_effect_t * effp, const sox_sample_t *ibuf,
- sox_sample_t *obuf, size_t *isamp, size_t *osamp);
-
void sox_biquad_start(void)
{
int r = sox_init();
@@ -94,7 +91,7 @@ void sox_biquad_filter(void *sbq, short
for(i=0; i<n; i++)
ibuf[i] = SOX_SIGNED_16BIT_TO_SAMPLE(in[i], clips);
isamp = osamp = (unsigned int)n;
- lsx_biquad_flow(e, ibuf, obuf, &isamp, &osamp);
+ e->handler.flow(e, ibuf, obuf, &isamp, &osamp);
for(i=0; i<n; i++)
out[i] = SOX_SAMPLE_TO_SIGNED_16BIT(obuf[i], clips);
}