Update blender to version 2.45

pkgsrc changes:
use cmake rather than SCons to build.
DESTDIR support

2.45
The 2.45 is a bugfix release, to stabilize the 2.4x series.
No new feature have been added, but serious effort has been put in
tracking bugs and fixing them. Some performance issues have also been
addressed.

2.44
This release adds subsurface scattering, improved sculpting tools, ffmpeg
support for additional platforms, a number of animation tool improvements,
and a huge number of Python scripts and API enhancements.

2.43
This release features sculpting meshes that work as if they were clay,
render passes, retopology painting, multi-resolution meshes, texture map
and light map baking, support for multiple uv sets, fast 3D painting,
defocus blur node, multi-layer image read/write, painting in video
sequences, matte, key, and difference composite nodes, a number of
improved 3D animation tools such as proxy objects, walk cycles, simulation
tool improvements for fluid dynamics, hard body dynamics, and cloth and
softbody dynamics. There were also additional compositing and video
editing improvements.

2.42
This release is the result of work done for the Elephants Dream short
film. It includes major feature additions such as node based materials,
node based compositing, a renderer rewrite, improved UV tools, improved
character tools, an array modifier, and a host of other improvements.
This commit is contained in:
markd 2008-01-04 19:56:45 +00:00
parent 76eb6ee3dd
commit f3ff9a627f
9 changed files with 279 additions and 292 deletions

View file

@ -1,21 +1,20 @@
# $NetBSD: Makefile,v 1.58 2007/02/22 19:30:04 wiz Exp $
# $NetBSD: Makefile,v 1.59 2008/01/04 19:56:45 markd Exp $
DISTNAME= blender-2.41
PKGREVISION= 3
DISTNAME= blender-2.45
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.cs.umn.edu/pub/blender.org/source/ \
http://download.blender.org/source/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.blender.org/cms/Home.2.0.html
HOMEPAGE= http://www.blender.org/
COMMENT= Fully integrated 3D graphics creation suite
BUILD_DEPENDS+= scons>=0.96:../../devel/scons
WRKSRC= ${WRKDIR}/blender
USE_LIBTOOL= yes
USE_TOOLS+= gmake
USE_LANGUAGES= c c++
USE_CMAKE= yes
CMAKE_ARG_PATH= ..
CONFIGURE_DIRS= _build
PKG_DESTDIR_SUPPORT= user-destdir
LDFLAGS+= -lcrypto
@ -23,28 +22,37 @@ LDFLAGS+= -lcrypto
INSTALLATION_DIRS= bin
# remember to change the line number after an update
post-patch:
${MV} ${WRKSRC}/SConstruct ${WRKSRC}/SConstruct.orig
${AWK} '{print} NR == 62 {print "env.Append(LINKFLAGS = \"-Wl,-R${X11BASE}/lib,-R${LOCALBASE}/lib\")"}' ${WRKSRC}/SConstruct.orig > ${WRKSRC}/SConstruct
CMAKE_ARGS+= -DFREETYPE_INC=${BUILDLINK_PREFIX.freetype2}/include/freetype2
CMAKE_ARGS+= -DSDL_INCLUDE_DIR=${BUILDLINK_PREFIX.SDL}/include/SDL
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
ADD_C_INCLUDE_DIRS=${WRKDIR}/.buildlink/include ADD_C_LIB_DIRS=${WRKDIR}/.buildlink/lib \
${PREFIX}/bin/scons -C ${WRKSRC} prefix=${PREFIX}
CHECK_INTERPRETER_SKIP= share/blender/scripts/*.py share/blender/scripts/*/*.py
pre-configure:
${MKDIR} ${WRKSRC}/_build
WRKSRCBIN= ${WRKSRC}/_build/bin
post-build:
${CP} -f ${WRKSRCBIN}/blender ${WRKSRCBIN}/blender-bin
${SED} -e "s|__PREFIX__|${PREFIX}|g" files/blender > ${WRKSRCBIN}/blender
${CHMOD} +x ${WRKSRCBIN}/blender
${CHMOD} -x ${WRKSRCBIN}/.blender/scripts/*.py
${CHMOD} -x ${WRKSRCBIN}/.blender/scripts/*/*.py
do-install:
${CP} -f ${WRKSRC}/blender ${WRKSRC}/blender-bin
${SED} -e "s|__PREFIX__|${PREFIX}|g" files/blender > ${WRKDIR}/blender/bin/blender
${CHMOD} +x ${WRKDIR}/blender/bin/blender
${INSTALL_PROGRAM} ${WRKSRC}/blender-bin ${PREFIX}/bin
${INSTALL_DATA_DIR} ${PREFIX}/share/blender/scripts
${INSTALL_DATA} ${WRKSRC}/release/scripts/*.py \
${PREFIX}/share/blender/scripts
${INSTALL_DATA_DIR} ${PREFIX}/share/blender/scripts/bpymodules
${INSTALL_DATA} ${WRKSRC}/release/scripts/bpymodules/*.py \
${PREFIX}/share/blender/scripts/bpymodules
${INSTALL} ${WRKDIR}/blender/bin/blender ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRCBIN}/blender-bin ${DESTDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRCBIN}/blender ${DESTDIR}${PREFIX}/bin
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/blender
${CP} -R ${WRKSRCBIN}/.blender/scripts \
${DESTDIR}${PREFIX}/share/blender/
${CP} -R ${WRKSRCBIN}/.blender/locale \
${DESTDIR}${PREFIX}/share/blender/
${INSTALL_DATA} ${WRKSRCBIN}/.blender/.Blanguages \
${DESTDIR}${PREFIX}/share/blender
${INSTALL_DATA} ${WRKSRCBIN}/.blender/.bfont.ttf \
${DESTDIR}${PREFIX}/share/blender
${INSTALL_DATA} ${WRKSRCBIN}/BlenderQuickStart.pdf \
${DESTDIR}${PREFIX}/share/blender
.include "../../devel/SDL/buildlink3.mk"
.include "../../graphics/Mesa/buildlink3.mk"

View file

@ -1,105 +1,226 @@
@comment $NetBSD: PLIST,v 1.5 2006/02/10 20:34:25 adam Exp $
@comment $NetBSD: PLIST,v 1.6 2008/01/04 19:56:45 markd Exp $
bin/blender
bin/blender-bin
share/blender/scripts/3ds_export.py
share/blender/scripts/3ds_import.py
share/blender/scripts/Apply_def.py
share/blender/scripts/Axiscopy.py
share/blender/scripts/DirectX8Exporter.py
share/blender/scripts/DirectXExporter.py
share/blender/scripts/ac3d_export.py
share/blender/scripts/ac3d_import.py
share/blender/scripts/archimap.py
share/blender/scripts/armature_symetry.py
share/blender/scripts/bevel_center.py
share/blender/scripts/blender2cal3d.py
share/blender/scripts/blenderLipSynchro.py
share/blender/scripts/bpymodules/BPyBlender.py
share/blender/scripts/bpymodules/BPyMathutils.py
share/blender/scripts/bpymodules/BPyNMesh.py
share/blender/scripts/bpymodules/BPyRegistry.py
share/blender/scripts/bpymodules/ai2obj.py
share/blender/scripts/bpymodules/boxpack2d.py
share/blender/.bfont.ttf
share/blender/.Blanguages
share/blender/BlenderQuickStart.pdf
share/blender/locale/nl/LC_MESSAGES/blender.mo
share/blender/locale/pt_br/LC_MESSAGES/blender.mo
share/blender/locale/ja/LC_MESSAGES/blender.mo
share/blender/locale/cs/LC_MESSAGES/blender.mo
share/blender/locale/fr/LC_MESSAGES/blender.mo
share/blender/locale/pl/LC_MESSAGES/blender.mo
share/blender/locale/zh_cn/LC_MESSAGES/blender.mo
share/blender/locale/sr@Latn/LC_MESSAGES/blender.mo
share/blender/locale/ar/LC_MESSAGES/blender.mo
share/blender/locale/bg/LC_MESSAGES/blender.mo
share/blender/locale/ru/LC_MESSAGES/blender.mo
share/blender/locale/de/LC_MESSAGES/blender.mo
share/blender/locale/es/LC_MESSAGES/blender.mo
share/blender/locale/it/LC_MESSAGES/blender.mo
share/blender/locale/hr/LC_MESSAGES/blender.mo
share/blender/locale/sr/LC_MESSAGES/blender.mo
share/blender/locale/uk/LC_MESSAGES/blender.mo
share/blender/locale/fi/LC_MESSAGES/blender.mo
share/blender/locale/ro/LC_MESSAGES/blender.mo
share/blender/locale/hr_HR/LC_MESSAGES/blender.mo
share/blender/locale/ca/LC_MESSAGES/blender.mo
share/blender/locale/sv/LC_MESSAGES/blender.mo
share/blender/scripts/bpydata/config/readme.txt
share/blender/scripts/bpydata/readme.txt
share/blender/scripts/bpydata/KUlang.txt
share/blender/scripts/bpymodules/colladaImEx/cutils.py
share/blender/scripts/bpymodules/colladaImEx/__init__.py
share/blender/scripts/bpymodules/colladaImEx/xmlUtils.py
share/blender/scripts/bpymodules/colladaImEx/collada.py
share/blender/scripts/bpymodules/colladaImEx/logo.png
share/blender/scripts/bpymodules/colladaImEx/cstartup.py
share/blender/scripts/bpymodules/colladaImEx/helperObjects.py
share/blender/scripts/bpymodules/colladaImEx/translator.py
share/blender/scripts/bpymodules/BPyCurve.py
share/blender/scripts/bpymodules/defaultdoodads.py
share/blender/scripts/bpymodules/meshtools.py
share/blender/scripts/bpymodules/BPyWindow.py
share/blender/scripts/bpymodules/BPyMesh_redux.py
share/blender/scripts/bpymodules/BPyRender.py
share/blender/scripts/bpymodules/dxfReader.py
share/blender/scripts/bpymodules/BPyMessages.py
share/blender/scripts/bpymodules/BPyObject.py
share/blender/scripts/bpymodules/dxfColorMap.py
share/blender/scripts/bpymodules/eps2obj.py
share/blender/scripts/bpymodules/gimp2obj.py
share/blender/scripts/bpymodules/meshtools.py
share/blender/scripts/bpymodules/BPyBlender.py
share/blender/scripts/bpymodules/BPyMesh.py
share/blender/scripts/bpymodules/BPyMesh_octree.py
share/blender/scripts/bpymodules/BPySys.py
share/blender/scripts/bpymodules/mesh_gradient.py
share/blender/scripts/bpymodules/BPyAddMesh.py
share/blender/scripts/bpymodules/BPyNMesh.py
share/blender/scripts/bpymodules/ai2obj.py
share/blender/scripts/bpymodules/BPyRegistry.py
share/blender/scripts/bpymodules/BPyImage.py
share/blender/scripts/bpymodules/BPyArmature.py
share/blender/scripts/bpymodules/BPyMathutils.py
share/blender/scripts/bpymodules/svg2obj.py
share/blender/scripts/bvh2arm.py
share/blender/scripts/bvh_export.py
share/blender/scripts/bvh_import.py
share/blender/scripts/camera_changer.py
share/blender/scripts/collada_export.py
share/blender/scripts/collada_import.py
share/blender/scripts/config.py
share/blender/scripts/console.py
share/blender/scripts/discombobulator.py
share/blender/scripts/disp_paint.py
share/blender/scripts/doc_browser.py
share/blender/scripts/envelope_assignment.py
share/blender/scripts/envelope_symmetry.py
share/blender/scripts/fixfromarmature.py
share/blender/scripts/flt_export.py
share/blender/scripts/flt_filewalker.py
share/blender/scripts/flt_import.py
share/blender/scripts/help_browser.py
share/blender/scripts/help_getting_started.py
share/blender/scripts/help_manual.py
share/blender/scripts/help_py_reference.py
share/blender/scripts/help_release_notes.py
share/blender/scripts/help_tutorials.py
share/blender/scripts/help_web_blender.py
share/blender/scripts/help_web_devcomm.py
share/blender/scripts/help_web_eshop.py
share/blender/scripts/help_web_usercomm.py
share/blender/scripts/hotkeys.py
share/blender/scripts/kloputils.py
share/blender/scripts/knife.py
share/blender/scripts/lightwave_export.py
share/blender/scripts/lightwave_import.py
share/blender/scripts/md2_export.py
share/blender/scripts/md2_import.py
share/blender/scripts/mesh_bbrush_menu.py
share/blender/scripts/mesh_cleanup.py
share/blender/scripts/mesh_tri2quad.py
share/blender/scripts/mirror_bone_weights.py
share/blender/scripts/nendo_export.py
share/blender/scripts/nendo_import.py
share/blender/scripts/obdatacopier.py
share/blender/scripts/obj_export.py
share/blender/scripts/obj_import.py
share/blender/scripts/object_batch_name_edit.py
share/blender/scripts/off_export.py
share/blender/scripts/off_import.py
share/blender/scripts/paths_import.py
share/blender/scripts/ply_export.py
share/blender/scripts/ply_import.py
share/blender/scripts/radiosity_export.py
share/blender/scripts/radiosity_import.py
share/blender/scripts/raw_export.py
share/blender/scripts/raw_import.py
share/blender/scripts/renameobjectbyblock.py
share/blender/scripts/rvk1_torvk2.py
share/blender/scripts/save_theme.py
share/blender/scripts/sel_same.py
share/blender/scripts/skin.py
share/blender/scripts/blenderLipSynchro.py
share/blender/scripts/slp_import.py
share/blender/scripts/bvh_import.py
share/blender/scripts/3ds_import.py
share/blender/scripts/uv_from_adjacent.py
share/blender/scripts/object_batch_name_edit.py
share/blender/scripts/vertexpaint_gradient.py
share/blender/scripts/mesh_solidify.py
share/blender/scripts/widgetwizard.py
share/blender/scripts/vertexpaint_selfshadow_ao.py
share/blender/scripts/uv_seams_from_islands.py
share/blender/scripts/vrml97_export.py
share/blender/scripts/sysinfo.py
share/blender/scripts/tex2uvbaker.py
share/blender/scripts/truespace_export.py
share/blender/scripts/truespace_import.py
share/blender/scripts/weightpaint_envelope_assign.py
share/blender/scripts/ac3d_import.py
share/blender/scripts/help_manual.py
share/blender/scripts/uvcalc_follow_active_coords.py
share/blender/scripts/faceselect_same_weights.py
share/blender/scripts/mesh_poly_reduce.py
share/blender/scripts/collada_import.py
share/blender/scripts/mesh_skin.py
share/blender/scripts/weightpaint_copy.py
share/blender/scripts/help_getting_started.py
share/blender/scripts/image_billboard.py
share/blender/scripts/3ds_export.py
share/blender/scripts/export_map.py
share/blender/scripts/help_release_notes.py
share/blender/scripts/collada_export.py
share/blender/scripts/export-iv-0.1.py
share/blender/scripts/object_random_loc_sz_rot.py
share/blender/scripts/mesh_cleanup.py
share/blender/scripts/ac3d_export.py
share/blender/scripts/save_theme.py
share/blender/scripts/object_sel2dupgroup.py
share/blender/scripts/help_web_blender.py
share/blender/scripts/lightwave_import.py
share/blender/scripts/image_find_paths.py
share/blender/scripts/mesh_wire.py
share/blender/scripts/mesh_boneweight_copy.py
share/blender/scripts/object_drop.py
share/blender/scripts/weightpaint_gradient.py
share/blender/scripts/DirectX8Exporter.py
share/blender/scripts/ply_import.py
share/blender/scripts/object_apply_def.py
share/blender/scripts/vertexpaint_from_material.py
share/blender/scripts/import_mdd.py
share/blender/scripts/export_obj.py
share/blender/scripts/scripttemplate_mesh_edit.py
share/blender/scripts/help_web_eshop.py
share/blender/scripts/export_mdd.py
share/blender/scripts/DirectX8Importer.py
share/blender/scripts/object_cookie_cutter.py
share/blender/scripts/IDPropBrowser.py
share/blender/scripts/uvcalc_smart_project.py
share/blender/scripts/lightwave_export.py
share/blender/scripts/envelope_symmetry.py
share/blender/scripts/bevel_center.py
share/blender/scripts/weightpaint_clean.py
share/blender/scripts/xsi_export.py
share/blender/scripts/help_web_usercomm.py
share/blender/scripts/import_obj.py
share/blender/scripts/uvcopy.py
share/blender/scripts/rvk1_torvk2.py
share/blender/scripts/md2_import.py
share/blender/scripts/image_auto_layout.py
share/blender/scripts/camera_changer.py
share/blender/scripts/flt_export.py
share/blender/scripts/export_lightwave_motion.py
share/blender/scripts/export_fbx.py
share/blender/scripts/uvcalc_quad_clickproj.py
share/blender/scripts/ply_export.py
share/blender/scripts/Axiscopy.py
share/blender/scripts/raw_import.py
share/blender/scripts/off_export.py
share/blender/scripts/xfig_export.py
share/blender/scripts/object_find.py
share/blender/scripts/weightpaint_grow_shrink.py
share/blender/scripts/console.py
share/blender/scripts/uvcalc_lightmap.py
share/blender/scripts/animation_trajectory.py
share/blender/scripts/discombobulator.py
share/blender/scripts/armature_symmetry.py
share/blender/scripts/raw_export.py
share/blender/scripts/obdatacopier.py
share/blender/scripts/config.py
share/blender/scripts/renameobjectbyblock.py
share/blender/scripts/help_web_devcomm.py
share/blender/scripts/export_cal3d.py
share/blender/scripts/help_browser.py
share/blender/scripts/colladaExport14.py
share/blender/scripts/uvcalc_from_adjacent.py
share/blender/scripts/paths_import.py
share/blender/scripts/off_import.py
share/blender/scripts/import_dxf.py
share/blender/scripts/mesh_unfolder.py
share/blender/scripts/image_edit.py
share/blender/scripts/help_bpy_api.py
share/blender/scripts/flt_import.py
share/blender/scripts/weightpaint_normalize.py
share/blender/scripts/md2_export.py
share/blender/scripts/unweld.py
share/blender/scripts/uv_export.py
share/blender/scripts/uvpaint.py
share/blender/scripts/videoscape_export.py
share/blender/scripts/vrml97_export.py
share/blender/scripts/widgetwizard.py
share/blender/scripts/wings_export.py
share/blender/scripts/wings_import.py
share/blender/scripts/wrl2export.py
share/blender/scripts/colladaImport14.py
share/blender/scripts/mesh_mirror_tool.py
share/blender/scripts/mesh_edges2curves.py
share/blender/scripts/add_mesh_torus.py
share/blender/scripts/hotkeys.py
share/blender/scripts/scripttemplate_object_edit.py
share/blender/scripts/flt_filewalker.py
share/blender/scripts/help_tutorials.py
share/blender/scripts/x3d_export.py
share/blender/scripts/xfig_export.py
share/blender/scripts/xsi_export.py
@dirrm share/blender/scripts/bpymodules/colladaImEx
@dirrm share/blender/scripts/bpymodules
@dirrm share/blender/scripts/bpydata/config
@dirrm share/blender/scripts/bpydata
@dirrm share/blender/scripts
@dirrm share/blender/locale/zh_cn/LC_MESSAGES
@dirrm share/blender/locale/zh_cn
@dirrm share/blender/locale/uk/LC_MESSAGES
@dirrm share/blender/locale/uk
@dirrm share/blender/locale/sv/LC_MESSAGES
@dirrm share/blender/locale/sv
@dirrm share/blender/locale/sr@Latn/LC_MESSAGES
@dirrm share/blender/locale/sr@Latn
@dirrm share/blender/locale/sr/LC_MESSAGES
@dirrm share/blender/locale/sr
@dirrm share/blender/locale/ru/LC_MESSAGES
@dirrm share/blender/locale/ru
@dirrm share/blender/locale/ro/LC_MESSAGES
@dirrm share/blender/locale/ro
@dirrm share/blender/locale/pt_br/LC_MESSAGES
@dirrm share/blender/locale/pt_br
@dirrm share/blender/locale/pl/LC_MESSAGES
@dirrm share/blender/locale/pl
@dirrm share/blender/locale/nl/LC_MESSAGES
@dirrm share/blender/locale/nl
@dirrm share/blender/locale/ja/LC_MESSAGES
@dirrm share/blender/locale/ja
@dirrm share/blender/locale/it/LC_MESSAGES
@dirrm share/blender/locale/it
@dirrm share/blender/locale/hr_HR/LC_MESSAGES
@dirrm share/blender/locale/hr_HR
@dirrm share/blender/locale/hr/LC_MESSAGES
@dirrm share/blender/locale/hr
@dirrm share/blender/locale/fr/LC_MESSAGES
@dirrm share/blender/locale/fr
@dirrm share/blender/locale/fi/LC_MESSAGES
@dirrm share/blender/locale/fi
@dirrm share/blender/locale/es/LC_MESSAGES
@dirrm share/blender/locale/es
@dirrm share/blender/locale/de/LC_MESSAGES
@dirrm share/blender/locale/de
@dirrm share/blender/locale/cs/LC_MESSAGES
@dirrm share/blender/locale/cs
@dirrm share/blender/locale/ca/LC_MESSAGES
@dirrm share/blender/locale/ca
@dirrm share/blender/locale/bg/LC_MESSAGES
@dirrm share/blender/locale/bg
@dirrm share/blender/locale/ar/LC_MESSAGES
@dirrm share/blender/locale/ar
@dirrm share/blender/locale
@dirrm share/blender

View file

@ -1,12 +1,10 @@
$NetBSD: distinfo,v 1.22 2007/08/08 17:39:09 joerg Exp $
$NetBSD: distinfo,v 1.23 2008/01/04 19:56:45 markd Exp $
SHA1 (blender-2.41.tar.gz) = 839dfece3b6efbf10694ac535d88e3745c3253ec
RMD160 (blender-2.41.tar.gz) = 7857eac2acda18ee24db4bb147bcf780025e2c12
Size (blender-2.41.tar.gz) = 9464385 bytes
SHA1 (patch-aa) = 21dd95ff4ab51bb9b1084f28e4e080ca38421bce
SHA1 (blender-2.45.tar.gz) = ff66ec5f0129fd04a2ba5c063627ef13033c0598
RMD160 (blender-2.45.tar.gz) = fd39b59de0f4d770fe26ce39d51356e98b1ec8ea
Size (blender-2.45.tar.gz) = 14226829 bytes
SHA1 (patch-ab) = 7f5b4966bd08333f5d726cf9b6d7c2300e62d711
SHA1 (patch-ac) = dcfa14519404915a69bd626c8a5a6029d2535ca2
SHA1 (patch-ae) = 9f8c84495eaa793dd04182f1ad871975083d1bb2
SHA1 (patch-af) = d8fad42c6b304651d36ac20e69f3cbe66f018a86
SHA1 (patch-ag) = cfbd34b0f9c01c044808e3fb6c07de76abbefccb
SHA1 (patch-ad) = cfec8537593071381687df1f37906a6f28eb45cf
SHA1 (patch-ah) = b45f534b4c5850da13e9b421f73e33c8d079696f
SHA1 (patch-ai) = 8909e9d698b9370bb756b81c41812a05790da419

View file

@ -1,14 +0,0 @@
$NetBSD: patch-aa,v 1.5 2006/02/12 21:52:19 joerg Exp $
--- intern/ghost/intern/GHOST_SystemCarbon.cpp.orig 2006-02-12 22:17:07.000000000 +0100
+++ intern/ghost/intern/GHOST_SystemCarbon.cpp
@@ -527,7 +527,8 @@ static char g_firstFileBuf[512];
extern "C" int GHOST_HACK_getFirstFile(char buf[512]) {
if (g_hasFirstFile) {
- strcpy(buf, g_firstFileBuf);
+ strncpy(buf, g_firstFileBuf, sizeof(buf) - 1);
+ buf[sizeof(buf) - 1] = '\0';
return 1;
} else {
return 0;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.3 2008/01/04 19:56:45 markd Exp $
--- extern/bFTGL/src/FTVectoriser.cpp.orig 2007-12-05 02:15:19.000000000 +1300
+++ extern/bFTGL/src/FTVectoriser.cpp
@@ -7,7 +7,7 @@
#ifdef __APPLE_CC__
typedef GLvoid (*GLUTesselatorFunction)(...);
-#elif defined( __mips ) || defined( __linux__ ) || defined( __FreeBSD__ ) || defined( __OpenBSD__ ) || defined( __sun ) || defined (__CYGWIN__)
+#elif defined( __mips ) || defined( __linux__ ) || defined( __FreeBSD__ ) || defined( __OpenBSD__ ) || defined( __sun ) || defined (__CYGWIN__) || defined( __NetBSD__ )
typedef GLvoid (*GLUTesselatorFunction)();
#elif defined ( WIN32)
typedef GLvoid (CALLBACK *GLUTesselatorFunction)( );

View file

@ -1,126 +0,0 @@
$NetBSD: patch-ae,v 1.5 2006/02/23 20:15:22 joerg Exp $
--- SConstruct.orig 2006-01-22 23:46:29.000000000 +0100
+++ SConstruct
@@ -38,7 +38,7 @@ else:
playername = 'blenderplayer$PROGSUFFIX'
# Build directory.
-# root_build_dir = '..' + os.sep + 'build' + os.sep + sys.platform + os.sep
+root_build_dir = '..' + os.sep + 'build' + os.sep + sys.platform + os.sep
bs_config.parseOpts()
@@ -61,7 +61,102 @@ sdl_env = Environment (ENV = os.environ)
freetype_env = Environment (ENV = os.environ)
env = Environment (ENV = os.environ)
-if sys.platform == 'linux2' or sys.platform == 'linux-i386':
+# pkgsrc patch
+#
+sys.platform = 'pkgsrc'
+if sys.platform == 'pkgsrc':
+ print "Building for pkgsrc systems"
+ use_international = 'false'
+ use_gameengine = 'true'
+ use_openal = 'false'
+ use_fmod = 'false'
+ use_quicktime = 'false'
+ use_sumo = 'true'
+ use_ode = 'false'
+ use_bullet = 'true'
+ use_buildinfo = 'true'
+ use_fluidsim = 'true'
+ build_blender_dynamic = 'true'
+ build_blender_static = 'false'
+ build_blender_player = 'false'
+ build_blender_plugin = 'false'
+ release_flags = string.split(os.environ[ 'CFLAGS' ])
+ debug_flags = ['-O2', '-g']
+ extra_flags = ['-pipe', '-fPIC', '-funsigned-char']
+ cxxflags = []
+ defines = []
+ warn_flags = ['-Wall','-W']
+ window_system = 'X11'
+ platform_libs = ['m', 'stdc++', 'util']
+ platform_libpath = []
+ platform_linkflags = string.split(os.environ['PTHREAD_LDFLAGS']) + string.split(os.environ['PTHREAD_LIBS'])
+ extra_includes = []
+ z_lib = ['z']
+ z_libpath = []
+ z_include = []
+ # png library information
+ png_lib = ['png']
+ png_libpath = os.environ[ 'ADD_C_LIB_DIRS' ].split(",")
+ png_include = os.environ[ 'ADD_C_INCLUDE_DIRS' ].split(",")
+ # jpeg library information
+ jpeg_lib = ['jpeg']
+ jpeg_libpath = os.environ[ 'ADD_C_LIB_DIRS' ].split(",")
+ jpeg_include = os.environ[ 'ADD_C_INCLUDE_DIRS' ].split(",")
+ # tiff library information
+ tiff_lib = ['tiff']
+ tiff_libpath = os.environ[ 'ADD_C_LIB_DIRS' ].split(",")
+ tiff_include = os.environ[ 'ADD_C_INCLUDE_DIRS' ].split(",")
+ # OpenGL library information
+ opengl_lib = ['GL', 'GLU']
+ opengl_libpath = os.environ[ 'ADD_C_LIB_DIRS' ].split(",")
+ opengl_include = os.environ[ 'ADD_C_INCLUDE_DIRS' ].split(",")
+ opengl_static = ['libGL.a', 'libGLU.a']
+ # SDL library information
+ sdl_env.ParseConfig ('sdl-config --cflags --libs')
+ sdl_cflags = sdl_env.Dictionary()['CCFLAGS']
+ sdl_include = sdl_env.Dictionary()['CPPPATH']
+ sdl_libpath = sdl_env.Dictionary()['LIBPATH']
+ sdl_lib = sdl_env.Dictionary()['LIBS']
+ # SOLID library information
+ solid_lib = [] # TODO
+ solid_libpath = [] # TODO
+ solid_include = ['#extern/solid']
+ qhull_lib = [] # TODO
+ qhull_libpath = [] # TODO
+ qhull_include = ['#extern/qhull/include']
+ # Bullet library information
+ bullet_lib = []
+ bullet_libpath = []
+ bullet_include = ['#extern/bullet','#extern/bullet/LinearMath','#extern/bullet/Bullet','#extern/bullet/BulletDynamics']
+ # ODE library information
+ ode_lib = ['ode']
+ ode_libpath = os.environ[ 'ADD_C_LIB_DIRS' ].split(",")
+ ode_include = os.environ[ 'ADD_C_INCLUDE_DIRS' ].split(",")
+ # Python library information
+ python_lib = ['python%d.%d' % sys.version_info[0:2]]
+ python_libpath = [sysconfig.get_python_lib (0, 1) + '/config']
+ python_include = [sysconfig.get_python_inc ()]
+ python_linkflags = Split (sysconfig.get_config_var('LINKFORSHARED'))
+ # International support information
+ ftgl_lib = ['ftgl']
+ ftgl_libpath = ['#../lib/linux-glibc2.2.5-i386/ftgl/lib']
+ ftgl_include = ['#../lib/linux-glibc2.2.5-i386/ftgl/include']
+ freetype_env.ParseConfig('pkg-config --cflags --libs freetype2')
+ freetype_lib = freetype_env.Dictionary()['LIBS']
+ freetype_libpath = freetype_env.Dictionary()['LIBPATH']
+ freetype_include = freetype_env.Dictionary()['CPPPATH']
+ gettext_lib = []
+ gettext_libpath = []
+ gettext_include = []
+ # OpenAL library information
+ openal_lib = ['openal']
+ openal_libpath = []
+ openal_include = []
+
+elif sys.platform=='freebsd4' or sys.platform=='freebsd5':
+ print "Building for FreeBSD"
+
+elif sys.platform == 'linux2' or sys.platform == 'linux-i386':
use_international = 'true'
use_gameengine = 'true'
use_openal = 'true'
@@ -561,7 +656,7 @@ elif string.find (sys.platform, 'irix')
use_openal = 'false'
use_fmod = 'false'
use_quicktime = 'false'
- use_sumo = 'false'
+ use_sumo = 'true'
use_ode = 'false'
use_bullet = 'false'
use_buildinfo = 'false'

View file

@ -1,13 +0,0 @@
$NetBSD: patch-af,v 1.4 2006/02/23 20:15:22 joerg Exp $
--- extern/bullet/BulletDynamics/ConstraintSolver/OdeConstraintSolver.cpp.orig 2006-02-10 20:35:26.000000000 +0100
+++ extern/bullet/BulletDynamics/ConstraintSolver/OdeConstraintSolver.cpp
@@ -36,7 +36,7 @@
#if defined (WIN32)
#include <malloc.h>
#else
-#if defined (__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
#include <stdlib.h>
#else
#include <alloca.h>

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ag,v 1.4 2006/02/23 20:15:22 joerg Exp $
--- extern/bullet/BulletDynamics/ConstraintSolver/SorLcp.cpp.orig 2006-02-10 20:42:45.000000000 +0100
+++ extern/bullet/BulletDynamics/ConstraintSolver/SorLcp.cpp
@@ -42,7 +42,7 @@
#if defined (WIN32)
#include <malloc.h>
#else
-#if defined (__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
#include <stdlib.h>
#else
#include <alloca.h>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ai,v 1.1 2008/01/04 19:56:46 markd Exp $
--- CMakeLists.txt.orig 2007-12-07 15:07:16.000000000 +1300
+++ CMakeLists.txt
@@ -133,6 +133,8 @@ IF(UNIX)
)
IF(INTL_LIBRARY AND ICONV_LIBRARY)
SET(GETTEXT_LIB ${INTL_LIBRARY} ${ICONV_LIBRARY})
+ ELSEIF(INTL_LIBRARY)
+ SET(GETTEXT_LIB ${INTL_LIBRARY})
ENDIF(INTL_LIBRARY AND ICONV_LIBRARY)
FIND_PATH(FREETYPE_INC