radare2: Update to 5.1.1
pkgsrc changes: - Remove no longer needed patches: applied upstream - Use PRINT_PLIST_AWK so print-PLIST will generate proper PLIST Changes: 5.1.1 ----- This is a minor bug fix release after 5.1.0 was out. But as usual it comes with some new features! Contents are mainly bug fixes and behaviour and abi compat should be fine 5.0.0, this is, all the built packages for 5.1.x will work. - New: * UDS Search: new `/cu' command search for UDS tables, code taken from binbloom * Color2g graph nodes * Visual Gameboy 2bpp Pixmaps: visual mode can be used to search for 2bpp bitmaps usually embedded in Gameboy roms * Encoding charsets * Reverse Shell: new `=r' command to get access to a shell on a machine under NAT or firewall - Other Improvements * Analysis * Allow to analyze bigger functions by reducing the stackframe usage and using anal.depth better * Reclassify some AVR instructions away from SWI * Assembler * Improve .fill and rasm2 -hh with documented directives * Refactor and cleanup the z80 assembler * bin * Faster mach0 and dyldcache parsers * Fix iCj for mach0 * build * Fix a credentials downgrade problem in Install.sh * Introduce w32 and w64 in the CI * Add Windows ZIP in the CI (#18310) * Assign radare2 binr target * Support statically linking system OpenSSL * Define PYC_ROOT and WASM_ROOT (#18290) * shell * Add print, println, and placeholder for printf and printfln
This commit is contained in:
parent
219d7bc6c8
commit
f422ca1860
6 changed files with 17 additions and 64 deletions
|
@ -1,6 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.28 2021/01/26 14:25:00 kamil Exp $
|
||||
# $NetBSD: Makefile,v 1.29 2021/03/21 13:16:47 leot Exp $
|
||||
|
||||
DISTNAME= radare2-5.1.0
|
||||
DISTNAME= radare2-5.1.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=radareorg/}
|
||||
|
||||
|
@ -20,8 +20,12 @@ USE_TOOLS+= gmake patch pkg-config perl
|
|||
# node
|
||||
CHECK_INTERPRETER_SKIP+= share/radare2/${PKGVERSION_NOREV}/www/m/fonts/iconjar-map.js
|
||||
|
||||
#PLIST_SUBST+= R2VERSION=${PKGVERSION_NOREV}-git # trunk revision
|
||||
PLIST_SUBST+= R2VERSION=${PKGVERSION_NOREV} # release revision
|
||||
#R2VERSION= ${PKGVERSION_NOREV}-git # trunk revision
|
||||
R2VERSION= ${PKGVERSION_NOREV} # release version
|
||||
|
||||
PLIST_SUBST+= R2VERSION=${R2VERSION}
|
||||
|
||||
PRINT_PLIST_AWK+= { gsub(/${R2VERSION}/, "$${R2VERSION}") }
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.8 2021/01/26 14:25:00 kamil Exp $
|
||||
@comment $NetBSD: PLIST,v 1.9 2021/03/21 13:16:47 leot Exp $
|
||||
bin/r2
|
||||
bin/r2agent
|
||||
bin/r2p
|
||||
|
@ -128,6 +128,7 @@ include/libr/sdb/config.h
|
|||
include/libr/sdb/dict.h
|
||||
include/libr/sdb/ht_inc.h
|
||||
include/libr/sdb/ht_pp.h
|
||||
include/libr/sdb/ht_pu.h
|
||||
include/libr/sdb/ht_up.h
|
||||
include/libr/sdb/ht_uu.h
|
||||
include/libr/sdb/ls.h
|
||||
|
@ -651,8 +652,10 @@ share/radare2/${R2VERSION}/www/m/app.js
|
|||
share/radare2/${R2VERSION}/www/m/disasmNavProvider.js
|
||||
share/radare2/${R2VERSION}/www/m/disasmProvider.js
|
||||
share/radare2/${R2VERSION}/www/m/hexchunkProvider.js
|
||||
share/radare2/${R2VERSION}/www/m/images/apple-touch-icon.png
|
||||
share/radare2/${R2VERSION}/www/m/images/icon.png
|
||||
share/radare2/${R2VERSION}/www/m/images/rlogo256.png
|
||||
share/radare2/${R2VERSION}/www/m/images/touch/chrome-touch-icon-192x192.png
|
||||
share/radare2/${R2VERSION}/www/m/images/user.jpg
|
||||
share/radare2/${R2VERSION}/www/m/index.html
|
||||
share/radare2/${R2VERSION}/www/m/legacy.js
|
||||
|
|
|
@ -1,10 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.11 2021/01/26 14:25:00 kamil Exp $
|
||||
$NetBSD: distinfo,v 1.12 2021/03/21 13:16:47 leot Exp $
|
||||
|
||||
SHA1 (radare2-5.1.0.tar.gz) = b40c2fad2cf3030e517cba56b71cdac319ffa79d
|
||||
RMD160 (radare2-5.1.0.tar.gz) = 5e244dd387ff4c48c7a9c3b57193aad48cc9be66
|
||||
SHA512 (radare2-5.1.0.tar.gz) = f973aeeb4d3a1e9eaf889a14bba4d54568dc2527d1160c7d999a7b2c870270cec7dc11a0eed12ae8f1d0aeacf63f14a92c7ca99f44e38573a6ce2276a08180f1
|
||||
Size (radare2-5.1.0.tar.gz) = 7908690 bytes
|
||||
SHA1 (patch-libr_anal_p_pyc.mk) = d3e590ca6debf89971e915f081592d906a685d49
|
||||
SHA1 (patch-libr_anal_p_wasm.mk) = 65e88fe77213602888f4b8ee9bf7750feae5f93f
|
||||
SHA1 (patch-libr_debug_Makefile) = 8e903f00bf2678392bcea47ecceaa5ec0d019966
|
||||
SHA1 (radare2-5.1.1.tar.gz) = 2689cc0b990bca3ae895e75c2bb98558128638b4
|
||||
RMD160 (radare2-5.1.1.tar.gz) = 9e6954a98edbcd2d3130a3201badf62a89442fab
|
||||
SHA512 (radare2-5.1.1.tar.gz) = b6728bb59788804f5442d5eec8141f62c3b51f589955589b310733b3aeb28beedb969af540649f454dad96710231df384e389d8b4a1d55627d8370e4d3da454f
|
||||
Size (radare2-5.1.1.tar.gz) = 7920840 bytes
|
||||
SHA1 (patch-sys_ios-sdk.sh) = 3f50b49e75dea1ac02f6d2ce8c556c77276e51d6
|
||||
|
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-libr_anal_p_pyc.mk,v 1.1 2021/01/26 14:25:00 kamil Exp $
|
||||
|
||||
Avoid passing empty -I.
|
||||
|
||||
Merged upstream:
|
||||
https://github.com/radareorg/radare2/commit/de01f2d7db0508d16b0c43703bed9de3b9a78708
|
||||
|
||||
--- libr/anal/p/pyc.mk.orig 2021-01-25 14:41:12.000000000 +0000
|
||||
+++ libr/anal/p/pyc.mk
|
||||
@@ -35,6 +35,7 @@ STATIC_OBJ+=${OBJ_PYC}
|
||||
TARGET_PYC=anal_pyc.$(EXT_SO)
|
||||
|
||||
ALL_TARGETS+=${TARGET_PYC}
|
||||
+PYC_ROOT=../asm/arch/pyc
|
||||
CFLAGS+=-I$(PYC_ROOT)
|
||||
|
||||
${TARGET_PYC}: ${OBJ_PYC}
|
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-libr_anal_p_wasm.mk,v 1.2 2021/01/26 14:25:00 kamil Exp $
|
||||
|
||||
* Do not pass empty -I to CC/cwrappers. Avoid "Missing argument for -I".
|
||||
|
||||
Merged upstream:
|
||||
https://github.com/radareorg/radare2/commit/de01f2d7db0508d16b0c43703bed9de3b9a78708
|
||||
|
||||
--- libr/anal/p/wasm.mk.orig 2019-02-19 12:35:24.000000000 +0000
|
||||
+++ libr/anal/p/wasm.mk
|
||||
@@ -1,5 +1,5 @@
|
||||
OBJ_WASM=anal_wasm.o
|
||||
-CFLAGS+=-I$(WASM_ROOT)
|
||||
+#CFLAGS+=-I$(WASM_ROOT)
|
||||
|
||||
STATIC_OBJ+=${OBJ_WASM}
|
||||
TARGET_WASM=anal_wasm.${EXT_SO}
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-libr_debug_Makefile,v 1.3 2021/01/26 14:25:00 kamil Exp $
|
||||
|
||||
* Avoid overwriting LDFLAGS
|
||||
|
||||
Merged upstream:
|
||||
https://github.com/radareorg/radare2/commit/73bb7fdd66d5b3c8abebd8fae281f4f75446b9ec
|
||||
|
||||
--- libr/debug/Makefile.orig 2019-06-24 12:09:20.000000000 +0000
|
||||
+++ libr/debug/Makefile
|
||||
@@ -6,7 +6,7 @@ DEPS+=r_socket
|
||||
CFLAGS+=-DR2_PLUGIN_INCORE
|
||||
|
||||
ifeq ($(OSTYPE),bsd)
|
||||
-LDFLAGS=-lkvm
|
||||
+LDFLAGS+=-lkvm
|
||||
endif
|
||||
|
||||
foo:
|
Loading…
Reference in a new issue