Update to 3.10.21, and fix build on current (statvfs lossage).

Changes since 3.10.20:
        *  arj_arcv.c, arj_file.c, arj_proc.c, arj_user.c, arjtypes.c,
           environ.c, externs.c, externs.h, makefile:
           Merged with the remaining part of TCO fixes to make up for 3.10.21
        *  defines.h, encode.c, environ.c, environ.h, fmemcmp.asm, misc.c,
           rearj.c: Resync with TCO to close any outstanding bugs
        *  arj.c: Rudimentary Borland code caused the filenames in argv[] to
           be mishandled under Win32
        *  register.c: REGISTER might fail due to _fput_* changes
This commit is contained in:
wiz 2004-07-27 13:03:39 +00:00
parent 8c8c89684e
commit f44073a32e
3 changed files with 9 additions and 10 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.10 2004/07/10 17:39:50 salo Exp $
# $NetBSD: Makefile,v 1.11 2004/07/27 13:03:39 wiz Exp $
# FreeBSD Id: ports/archivers/arj/Makefile,v 1.2 2002/09/17 05:17:29 ijliao Exp
DISTNAME= arj-3.10.20
PKGREVISION= 1
DISTNAME= arj-3.10.21
CATEGORIES= archivers
MASTER_SITES= http://testcase.newmail.ru/files/

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.5 2004/07/10 17:39:50 salo Exp $
$NetBSD: distinfo,v 1.6 2004/07/27 13:03:39 wiz Exp $
SHA1 (arj-3.10.20.tar.gz) = ce818c8127d11efac469c65a9f65572be7e07a5a
Size (arj-3.10.20.tar.gz) = 428054 bytes
SHA1 (patch-aa) = 627dfb018aad8c624c5c88e4f4fdb39bee159b36
SHA1 (arj-3.10.21.tar.gz) = 3599001a762655688dcd1663e100f2d6ebec8227
Size (arj-3.10.21.tar.gz) = 430807 bytes
SHA1 (patch-aa) = d9d1d7970a00286451a8fcf56e27cd86182e8a99
SHA1 (patch-ab) = c588776f9b8e2331471be07e6acd3b873af84fbc
SHA1 (patch-ac) = 4e557fa98bc92e033d11e2e9a8e34127275f7f72

View file

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.4 2004/04/27 17:16:28 tv Exp $
$NetBSD: patch-aa,v 1.5 2004/07/27 13:03:39 wiz Exp $
--- environ.c.orig Sat Apr 17 09:19:40 2004
--- environ.c.orig 2004-06-18 18:19:36.000000000 +0200
+++ environ.c
@@ -61,7 +61,7 @@
#elif defined(__FreeBSD__)||defined(__NetBSD__)
@ -16,7 +16,7 @@ $NetBSD: patch-aa,v 1.4 2004/04/27 17:16:28 tv Exp $
return((LONG_MAX/(spclu*bps)<fclu)?LONG_MAX:spclu*bps*fclu);
#elif TARGET==UNIX
- #if defined(__QNXNTO__)||defined(__sco__)||defined(SUNOS)
+ #if defined(__QNXNTO__)||defined(__sco__)||defined(SUNOS)||defined(__INTERIX)
+ #if defined(__QNXNTO__)||defined(__sco__)||defined(SUNOS)||defined(__INTERIX)||(defined(__NetBSD__) && (__NetBSD_Version__ > 200030000))
struct statvfs vfs;
if(statvfs(name, &vfs)==-1)